source: projects/specs/trunk/t/texlive-common/texlive-common-vl.spec @ 2503

Revision 2503, 4.8 KB checked in by munepi, 13 years ago (diff)

updated texlive packages: supported VinePlus?/5, more; improved some %%post scripts

Line 
1## -*- coding: utf-8-unix -*-
2%bcond_with firstbuild
3
4%if %{?_dist_release} == "vl6"
5Provides:    jadetex
6Obsoletes:   jadetex tetex dvipdfmx xdvik xdvik-motif
7%endif
8%if %{?_dist_release} == "vl5"
9Provides:    jadetex
10Conflicts:   tetex dvipdfmx xdvik xdvik-motif jvf
11%endif
12Obsoletes:   tetex-latex tetex-afm tetex-type1 tetex-devel
13Obsoletes:   pTeX pLaTeX2e pLaTeX2e_Macros dvipsk
14Obsoletes:   dvipdfm texmacro-aps
15Obsoletes:   makejvf <= 1.1a
16Conflicts:   task-texmacro-phys < 1.1
17
18%define tex_destdir     %{_datadir}
19%define texmf           %{tex_destdir}/texmf
20%define texlive_src     %{tex_destdir}/texlive-sources
21%define build_tex_destdir       %{buildroot}%{tex_destdir}
22%define build_texmf     %{buildroot}%{texmf}
23
24%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
25%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
26%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
27## NOTE: For only texlive-common, if %exec_fmtutil fails,
28## we show the STDERR of %exec_fmtutil.
29%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null
30%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
31%define vartexfonts %{_var}/lib/texmf
32
33%define __find_provides %{nil}
34%define __find_requires %{nil}
35%define __perl_provides %{nil}
36%define __perl_requires %{nil}
37
38Autoreq: 0
39
40Summary: Common base for all TeX Live packages
41Summary(ja): TeX Live パッケージの共通ベース
42Name: texlive-common
43Version: 2009
44Release: 3%{?_dist_release}
45License: distributable
46Group: Applications/Publishing
47URL: http://www.tug.org/texlive/
48
49Requires(pre): texlive-collection-basic = %{version}
50Requires(pre): texlive-collection-latex = %{version}
51Requires(pre): texlive-collection-latexrecommended = %{version}
52Requires(pre): texlive-collection-fontsrecommended = %{version}
53
54#### $ pdftex -ini  -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini
55## dehypht-x-2009-06-19.tex
56Requires(pre): texlive-collection-langgerman = %{version}
57## catkoi
58Requires(pre): texlive-collection-langcyrillic = %{version}
59
60#### $ xetex -ini  -jobname=xelatex -progname=xelatex -etex xelatex.ini
61## unicode-letters
62Requires(pre): texlive-collection-xetex = %{version}
63
64BuildArch:      noarch
65Buildroot:    %{_tmppath}/%{name}-%{version}-root
66
67Vendor:       Project Vine
68Distribution: Vine Linux
69Packager:     munepi
70
71
72%description
73The TeX Live software distribution offers a complete TeX system for a
74variety of Unix, Macintosh, Windows and other platforms. It
75encompasses programs for editing, typesetting, previewing and printing
76of TeX documents in many different languages, and a large collection
77of TeX macros and font libraries.
78
79The distribution includes extensive general documentation about TeX,
80as well as the documentation for the included software packages.
81
82This package is a virtual package
83to provide a common base for all TeX Live packages.
84
85
86%description -l ja
87TeX Live ソフトウェアディストリビューションは、
88さまざまな Unix, Macintosh, Windows、および
89他のプラットホームに対して完全な TeX システムを提供します。
90多くの異なった言語を含む TeX ドキュメントの
91編集、組版、閲覧、印刷するためのプログラム、
92そして、TeX マクロやフォントライブラリの大きなコレクションを
93同梱しています。
94
95このディストリビューションは
96同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
97TeX に関するたくさんの一般的なドキュメントを含んでいます。
98
99このパッケージは TeX Live パッケージの共通ベースを
100提供ための仮想パッケージです。
101
102
103%files
104
105
106%post
107%{exec_texhash}
108echo -n "    "
109echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
110rm -f %{texmf}/updmap.lock
111echo -n "    "
112echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
113
114exit 0
115
116
117# %postun
118# %{exec_texhash}
119# echo -n "    "
120# echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
121# echo -n "    "
122# echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
123
124exit 0
125
126
127%changelog
128* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
129- added to remove %%{texmf}/updmap.lock in %%post
130  - When texlive-common is installed, this lock generating
131    texlive-collection-* leaves.
132- dropped %%postun
133- added some comments for the definition of %%exec_fmtutil
134
135* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
136- changed Requires: -> Requires(pre): for all requirements
137- merged dependencies of Provides:/Obsoletes: tags from texlive-vl.spec
138
139* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
140- TeX Live 2009
Note: See TracBrowser for help on using the repository browser.