source: projects/specs/trunk/t/texlive-collection-langitalian/texlive-collection-langitalian-vl.spec @ 1533

Revision 1533, 6.3 KB checked in by munepi, 14 years ago (diff)

NEW texlive and its related packages: replacement of teTeX

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec.sh 2009-1:
3## tlpdb2rpmspec.sh collection-basic
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Italian
28Summary(ja): TeX Live: Italian
29Name: texlive-collection-langitalian
30Version: 2009
31Release: 1%{?_dist_release}
32License: LPPL, LGPLv2+
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37Requires: texlive-collection-basic = %{version}
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Italian:
61
62
63This package contains the following CTAN packages:
64frontespizio: Create a frontispiece for Italian theses.
65hyphen-italian: Hyphenation patterns for the Italian language.
66itnumpar: Spell numbers in words (Italian).
67
68%description -l ja
69TeX Live ソフトウェアディストリビューションは、
70さまざまな Unix, Macintosh, Windows、および
71他のプラットホームに対して完全な TeX システムを提供します。
72多くの異なった言語を含む TeX ドキュメントの
73編集、組版、閲覧、印刷するためのプログラム、
74そして、TeX マクロやフォントライブラリの大きなコレクションを
75同梱しています。
76
77このディストリビューションは
78同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
79TeX に関するたくさんの一般的なドキュメントを含んでいます。
80
81このパッケージは以下のようなパッケージ集です。
82Italian:
83
84
85このパッケージは以下の CTAN パッケージを含んでいます:
86frontespizio: Create a frontispiece for Italian theses.
87hyphen-italian: Hyphenation patterns for the Italian language.
88itnumpar: Spell numbers in words (Italian).
89
90%package doc
91Summary: TeX Live: Documentation files of %{name}
92Group: Applications/Publishing
93Requires: %{name} = %{version}-%{release}
94
95%description doc
96This package contains documentation files of %{name}.
97
98%prep
99
100%build
101
102%install
103[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
104
105PREF=%{buildroot}%{tex_destdir}
106
107manifest=(
108texmf-dist/doc/latex/frontespizio/README
109texmf-dist/doc/latex/frontespizio/examplea.tex
110texmf-dist/doc/latex/frontespizio/exampleb.tex
111texmf-dist/doc/latex/frontespizio/examplec.tex
112texmf-dist/doc/latex/frontespizio/frontespizio.pdf
113texmf-dist/doc/latex/frontespizio/makedoc.sh
114texmf-dist/source/latex/frontespizio/frontespizio.dtx
115texmf-dist/source/latex/frontespizio/frontespizio.ins
116texmf-dist/tex/latex/frontespizio/frontespizio.sty
117texmf-dist/doc/latex/itnumpar/README
118texmf-dist/doc/latex/itnumpar/itnumpar.pdf
119texmf-dist/source/latex/itnumpar/itnumpar.dtx
120texmf-dist/source/latex/itnumpar/itnumpar.ins
121texmf-dist/tex/latex/itnumpar/itnumpar.sty
122)
123
124%__mkdir_p ${PREF}/texmf-dist
125for i in "${manifest[@]}"; do
126    %__install -D %{texlive_src}/$i ${PREF}/$i
127done
128
129## info
130%__rm -f %{buildroot}%{_infodir}/dir
131%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
132
133## man
134## man t1* files are provided by t1utils
135for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
136    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
137done
138
139## man some files are provided by psutils
140for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
141    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
142done
143
144## remove asymptote directries, which provides asymptote package
145find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
146# find %{buildroot} -name "Makefile" | xargs %__rm -f
147
148# ## remove xindy
149# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
150
151# ## remove tex4ht
152# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
153
154## remove unpackaging files
155find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
156find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
157
158## Files list
159find %{buildroot} -type f -or -type l | \
160    %__sed -e "s|%{buildroot}||g" > filelist.full
161
162find %{buildroot}%{texmf}-dist -type d | \
163    %__sed -e "s|^%{buildroot}|%dir |" \
164           -e "s|$|/|"             >> filelist.full
165
166## subpackages
167grep "/texmf-dist/doc/" filelist.full > filelist.doc
168cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
169%__mv -f filelist.tmp filelist.full
170
171%clean
172%__rm -rf %{buildroot}
173
174%post
175%{exec_texhash}
176
177echo -n "    "
178echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
179
180exit 0
181
182
183%postun
184if [ "$1" = 0 ]; then
185    %{exec_texhash}
186
187fi
188
189exit 0
190
191%files -f filelist.full
192%defattr(-,root,root)
193
194%files -f filelist.doc doc
195%defattr(-,root,root)
196
197%changelog
198* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
199- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langitalian
Note: See TracBrowser for help on using the repository browser.