source: projects/specs/trunk/t/texlive-collection-langitalian/texlive-collection-langitalian-vl.spec @ 1974

Revision 1974, 6.9 KB checked in by munepi, 14 years ago (diff)

updated all texlive-collection packages: generated by tlpdb2rpmspec 2009-2; removed arch dependent binaries (for rpm-4.8.1); fixed perl path (for rpm-4.8.1); improved updmap process in %%post and %%postun

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2009-2:
3## tlpdb2rpmspec collection-langitalian
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Italian
28Summary(ja): TeX Live: Italian
29Name: texlive-collection-langitalian
30Version: 2009
31Release: 2%{?_dist_release}
32License: LPPL, LGPLv2+
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37Requires: texlive-collection-basic = %{version}
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Italian:
61
62
63This package contains the following CTAN packages:
64frontespizio: Create a frontispiece for Italian theses.
65hyphen-italian: Hyphenation patterns for the Italian language.
66itnumpar: Spell numbers in words (Italian).
67
68%description -l ja
69TeX Live ソフトウェアディストリビューションは、
70さまざまな Unix, Macintosh, Windows、および
71他のプラットホームに対して完全な TeX システムを提供します。
72多くの異なった言語を含む TeX ドキュメントの
73編集、組版、閲覧、印刷するためのプログラム、
74そして、TeX マクロやフォントライブラリの大きなコレクションを
75同梱しています。
76
77このディストリビューションは
78同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
79TeX に関するたくさんの一般的なドキュメントを含んでいます。
80
81このパッケージは以下のようなパッケージ集です。
82Italian:
83
84
85このパッケージは以下の CTAN パッケージを含んでいます:
86frontespizio: Create a frontispiece for Italian theses.
87hyphen-italian: Hyphenation patterns for the Italian language.
88itnumpar: Spell numbers in words (Italian).
89
90%package doc
91Summary: TeX Live: Documentation files of %{name}
92Group: Applications/Publishing
93Requires: %{name} = %{version}-%{release}
94
95%description doc
96This package contains documentation files of %{name}.
97
98%prep
99
100%build
101
102%install
103[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
104
105PREF=%{buildroot}%{tex_destdir}
106
107manifest=(
108texmf-dist/doc/latex/frontespizio/README
109texmf-dist/doc/latex/frontespizio/examplea.tex
110texmf-dist/doc/latex/frontespizio/exampleb.tex
111texmf-dist/doc/latex/frontespizio/examplec.tex
112texmf-dist/doc/latex/frontespizio/frontespizio.pdf
113texmf-dist/doc/latex/frontespizio/makedoc.sh
114texmf-dist/source/latex/frontespizio/frontespizio.dtx
115texmf-dist/source/latex/frontespizio/frontespizio.ins
116texmf-dist/tex/latex/frontespizio/frontespizio.sty
117texmf-dist/doc/latex/itnumpar/README
118texmf-dist/doc/latex/itnumpar/itnumpar.pdf
119texmf-dist/source/latex/itnumpar/itnumpar.dtx
120texmf-dist/source/latex/itnumpar/itnumpar.ins
121texmf-dist/tex/latex/itnumpar/itnumpar.sty
122)
123
124%__mkdir_p ${PREF}/texmf-dist
125for i in "${manifest[@]}"; do
126    %__install -D %{texlive_src}/$i ${PREF}/$i
127done
128
129## info
130%__rm -f %{buildroot}%{_infodir}/dir
131%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
132
133## man
134## man t1* files are provided by t1utils
135for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
136    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
137done
138
139## man some files are provided by psutils
140for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
141    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
142done
143
144## fix perl path
145for i in source/metapost/expressg/expressg.dtx          doc/metapost/expressg/n2mpsprl.prl          doc/latex/songbook/contrib/crd2sb/crd2sb; do
146    [ -f %{build_texmf}-dist/${i} ] &&         %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
147done
148
149## remove asymptote directries, which provides asymptote package
150find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
151# find %{buildroot} -name "Makefile" | xargs %__rm -f
152
153# ## remove xindy
154# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
155
156# ## remove tex4ht
157# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
158
159## remove arch dependent binaries
160%__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
161
162## remove unpackaging files
163find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
164find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
165
166## Files list
167find %{buildroot} -type f -or -type l | \
168    %__sed -e "s|%{buildroot}||g" > filelist.full
169
170find %{buildroot}%{texmf}-dist -type d | \
171    %__sed -e "s|^%{buildroot}|%dir |" \
172           -e "s|$|/|"             >> filelist.full
173
174## subpackages
175grep "/texmf-dist/doc/" filelist.full > filelist.doc
176cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
177%__mv -f filelist.tmp filelist.full
178
179%clean
180%__rm -rf %{buildroot}
181
182%post
183%{exec_texhash}
184
185echo -n "    "
186echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
187
188exit 0
189
190
191%postun
192if [ "$1" = 0 ]; then
193    %{exec_texhash}
194
195fi
196
197exit 0
198
199%files -f filelist.full
200%defattr(-,root,root)
201
202%files -f filelist.doc doc
203%defattr(-,root,root)
204
205%changelog
206* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
207- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-langitalian
208- removed arch dependent binaries (texlive-collection-latexextra)
209- fixed perl path
210- improved updmap process in %%post and %%postun
211
212* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
213- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langitalian
Note: See TracBrowser for help on using the repository browser.