source: projects/specs/trunk/t/texlive-collection-langhebrew/texlive-collection-langhebrew-vl.spec @ 1533

Revision 1533, 6.8 KB checked in by munepi, 14 years ago (diff)

NEW texlive and its related packages: replacement of teTeX

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec.sh 2009-1:
3## tlpdb2rpmspec.sh collection-basic
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Hebrew
28Summary(ja): TeX Live: Hebrew
29Name: texlive-collection-langhebrew
30Version: 2009
31Release: 1%{?_dist_release}
32License: LPPL
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37Requires: texlive-collection-basic = %{version}
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Hebrew:
61Support for typesetting Hebrew.
62
63This package contains the following CTAN packages:
64cjhebrew: Typeset Hebrew with LaTeX.
65
66%description -l ja
67TeX Live ソフトウェアディストリビューションは、
68さまざまな Unix, Macintosh, Windows、および
69他のプラットホームに対して完全な TeX システムを提供します。
70多くの異なった言語を含む TeX ドキュメントの
71編集、組版、閲覧、印刷するためのプログラム、
72そして、TeX マクロやフォントライブラリの大きなコレクションを
73同梱しています。
74
75このディストリビューションは
76同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
77TeX に関するたくさんの一般的なドキュメントを含んでいます。
78
79このパッケージは以下のようなパッケージ集です。
80Hebrew:
81Support for typesetting Hebrew.
82
83このパッケージは以下の CTAN パッケージを含んでいます:
84cjhebrew: Typeset Hebrew with LaTeX.
85
86%package doc
87Summary: TeX Live: Documentation files of %{name}
88Group: Applications/Publishing
89Requires: %{name} = %{version}-%{release}
90
91%description doc
92This package contains documentation files of %{name}.
93
94%prep
95
96%build
97
98%install
99[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
100
101PREF=%{buildroot}%{tex_destdir}
102
103manifest=(
104texmf-dist/doc/fonts/cjhebrew/cjhebtst.tex
105texmf-dist/doc/fonts/cjhebrew/manual.pdf
106texmf-dist/fonts/afm/public/cjhebrew/cjheblsm.afm
107texmf-dist/fonts/afm/public/cjhebrew/cjhebltx.afm
108texmf-dist/fonts/enc/dvips/cjhebrew/cjhebltx.enc
109texmf-dist/fonts/map/dvips/cjhebrew/cjhebrew.map
110texmf-dist/fonts/tfm/public/cjhebrew/cjhblsm.tfm
111texmf-dist/fonts/tfm/public/cjhebrew/cjhbltx.tfm
112texmf-dist/fonts/tfm/public/cjhebrew/cjheblsm.tfm
113texmf-dist/fonts/tfm/public/cjhebrew/cjhebltx.tfm
114texmf-dist/fonts/tfm/public/cjhebrew/rcjhblsm.tfm
115texmf-dist/fonts/tfm/public/cjhebrew/rcjhbltx.tfm
116texmf-dist/fonts/type1/public/cjhebrew/cjheblsm.pfb
117texmf-dist/fonts/type1/public/cjhebrew/cjhebltx.pfb
118texmf-dist/fonts/vf/public/cjhebrew/cjhblsm.vf
119texmf-dist/fonts/vf/public/cjhebrew/cjhbltx.vf
120texmf-dist/tex/latex/cjhebrew/cjhebrew.sty
121)
122
123%__mkdir_p ${PREF}/texmf-dist
124for i in "${manifest[@]}"; do
125    %__install -D %{texlive_src}/$i ${PREF}/$i
126done
127
128## info
129%__rm -f %{buildroot}%{_infodir}/dir
130%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
131
132## man
133## man t1* files are provided by t1utils
134for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
135    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
136done
137
138## man some files are provided by psutils
139for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
140    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
141done
142
143## remove asymptote directries, which provides asymptote package
144find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
145# find %{buildroot} -name "Makefile" | xargs %__rm -f
146
147# ## remove xindy
148# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
149
150# ## remove tex4ht
151# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
152
153## remove unpackaging files
154find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
155find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
156
157## Files list
158find %{buildroot} -type f -or -type l | \
159    %__sed -e "s|%{buildroot}||g" > filelist.full
160
161find %{buildroot}%{texmf}-dist -type d | \
162    %__sed -e "s|^%{buildroot}|%dir |" \
163           -e "s|$|/|"             >> filelist.full
164
165## subpackages
166grep "/texmf-dist/doc/" filelist.full > filelist.doc
167cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
168%__mv -f filelist.tmp filelist.full
169
170%clean
171%__rm -rf %{buildroot}
172
173%post
174%{exec_texhash}
175
176[ -f %{texmf}/web2c/updmap.cfg ] || exit 0
177
178    %{exec_updmap} --listmaps 2>/dev/null | egrep -q "^#! Map cjhebrew.map" && \
179        echo -n "    " && \
180        echo -n "Running updmap: enable cjhebrew.map ... " && \
181        %{exec_updmap} --enable Map cjhebrew.map >/dev/null 2>&1 && \
182        echo "done."
183
184exit 0
185
186
187%postun
188if [ "$1" = 0 ]; then
189    %{exec_texhash}
190
191    [ -f %{texmf}/web2c/updmap.cfg ] || exit 0
192
193    %{exec_updmap} --listmaps 2>/dev/null | egrep -q "^Map cjhebrew.map" && \
194        echo -n "    " && \
195        echo -n "Running updmap: disable cjhebrew.map ... " && \
196        %{exec_updmap} --disable cjhebrew.map >/dev/null 2>&1 && \
197        echo "done."
198
199fi
200
201exit 0
202
203%files -f filelist.full
204%defattr(-,root,root)
205
206%files -f filelist.doc doc
207%defattr(-,root,root)
208
209%changelog
210* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
211- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langhebrew
Note: See TracBrowser for help on using the repository browser.