source: projects/specs/trunk/t/texinfo/texinfo-vl.spec @ 883

Revision 883, 12.2 KB checked in by owa, 14 years ago (diff)

updated lilypond and old libs

Line 
1%define      extraver   a
2
3%define      _infodir   /usr/share/info
4
5Summary:     Tools needed to create Texinfo format documentation files.
6Summary(ja): Texinfo ドキュメントを作成する為に使うツール群
7
8Name:        texinfo
9Version:     4.13
10Release:     1%{?_dist_release}
11License:     GPL
12Group:       Applications/Publishing
13URL:         http://www.gnu.org/software/texinfo/
14#Source0:     ftp://ftp.gnu.org/gnu/texinfo/texinfo-%{version}%{?extraver:%extraver}.tar.bz2
15Source0:     ftp://ftp.gnu.org/gnu/texinfo/texinfo-%{version}.tar.gz
16Source1:     info-dir
17Patch1:      texinfo-fix.patch
18Patch3:      texinfo-4.3-zlib.patch
19Prereq:      install-info
20Prefix:      %{_prefix}
21Buildroot:   %{_tmppath}/%{name}-%{version}-root
22BuildRequires: autoconf libtool ncurses-devel zlib-devel
23
24
25# Redifine this to "dir" in the info directory isn't compressed
26
27%define __spec_install_post /usr/lib/rpm/brp-strip \; /usr/lib/rpm/brp-strip-comment-note \; rm -f
28
29
30%description
31Texinfo is a documentation system that can produce both online
32information and printed output from a single source file. The GNU
33Project uses the Texinfo file format for most of its documentation.
34
35Install texinfo if you want a documentation system for producing both
36online and print documentation from the same source file and/or if you
37are going to write documentation for the GNU Project.
38
39%description -l ja
40Texinfo は,単一ソースファイルから,オンラインドキュメントと
41印刷用ファイルを出力することの出来るドキュメントシステムです.
42GNU Project では,殆どのドキュメントでこの Texinfo フォーマットを
43採用しています.
44
45単一ソースファイルからオンラインドキュメントと印刷用ファイルを出力
46したい場合,あるいは GNU Project 用にドキュメントを書こうと思っている
47場合は,この texinfo をインストールして下さい.
48
49
50%package -n info
51Summary:     A stand-alone TTY-based reader for GNU texinfo documentation.
52Summary(ja): TTY ベースのスタンドアロン GNU texinfo ドキュメントリーダ
53Group:       System Environment/Base
54# By making info prereq bash, other packages which have triggers based on
55# info don't run those triggers until bash is in place as well. This is an
56# ugly method of doing it (triggers which fire on set intersection would
57# be better), but it's the best we can do for now. Talk to Erik before
58# removing this.
59Prereq: bash install-info
60Requires: install-info
61
62%description -n info
63The GNU project uses the texinfo file format for much of its
64documentation. The info package provides a standalone TTY-based
65browser program for viewing texinfo files.
66
67%description -n info -l ja
68GNU Project では殆どのドキュメントに texinfo 形式を採用しています.
69この info パッケージには texinfo ファイルを読む TTY ベースの
70ブラウザプログラムが収められています.
71
72
73%package -n install-info
74Summary:     info file installer
75Summary(ja): info ファイルのインストーラー
76Group:       System Environment/Base
77Conflicts: info < 4.0b-3vl2
78
79%description -n install-info
80info file installer.
81
82%description -n install-info -l ja
83info ファイルのインストーラーです.
84
85%prep
86%setup -q
87#%%patch1 -p1
88#%patch3 -p1 -b .zlib
89
90
91%build
92
93%configure --mandir=%{_mandir} --infodir=%{_infodir}
94make %{?_smp_mflags}
95
96make -C util LIBS=%{_libdir}/libz.a
97
98
99%install
100rm -rf ${RPM_BUILD_ROOT}
101mkdir -p ${RPM_BUILD_ROOT}/{etc,sbin}
102
103%makeinstall
104
105( cd ${RPM_BUILD_ROOT}
106  gzip -n -9f .%{_infodir}/*info*
107  gzip -n -9f .%{_mandir}/*/*
108  install -m644 ${RPM_SOURCE_DIR}/info-dir ./etc/info-dir
109  ln -sf /etc/info-dir ${RPM_BUILD_ROOT}%{_infodir}/dir
110  for i in makeinfo texindex info install-info ; do
111    strip .%{_bindir}/$i
112  done
113  mv -f .%{_bindir}/install-info ./sbin
114)
115
116%find_lang %name
117
118
119%clean
120rm -rf ${RPM_BUILD_ROOT}
121
122
123%post
124/sbin/install-info %{_infodir}/texinfo.gz %{_infodir}/dir
125
126
127%preun
128if [ $1 = 0 ]; then
129    /sbin/install-info --delete %{_infodir}/texinfo.gz %{_infodir}/dir
130fi
131
132
133%post -n info
134/sbin/install-info %{_infodir}/info-stnd.info.gz %{_infodir}/dir
135
136
137%preun -n info
138if [ $1 = 0 ]; then
139    /sbin/install-info --delete %{_infodir}/info-stnd.info.gz %{_infodir}/dir
140fi
141
142
143%files -f %{name}.lang
144%defattr(-,root,root)
145%doc AUTHORS ChangeLog INSTALL INTRODUCTION NEWS README TODO
146%{_bindir}/makeinfo
147%{_bindir}/pdftexi2dvi
148%{_bindir}/texindex
149%{_bindir}/texi2dvi
150%{_bindir}/texi2pdf
151%{_datadir}/texinfo
152%{_infodir}/texinfo*
153%{_mandir}/man1/makeinfo.1*
154%{_mandir}/man1/pdftexi2dvi.1*
155%{_mandir}/man1/texindex.1*
156%{_mandir}/man1/texi2dvi.1*
157%{_mandir}/man1/texi2pdf.1*
158%{_mandir}/man5/texinfo.5*
159
160
161%files -n info
162%defattr(-,root,root)
163#%config(missingok) /etc/X11/applnk/Utilities/info.desktop
164#%config(noreplace) %verify(not md5 size mtime) /etc/info-dir
165#%config(noreplace) %{_infodir}/dir
166%doc info/README
167%{_bindir}/info
168%{_bindir}/infokey
169%{_infodir}/info.info*
170%{_infodir}/info-stnd.info*
171%{_mandir}/man1/info.1*
172%{_mandir}/man1/infokey.1*
173%{_mandir}/man5/info.5*
174
175
176%files -n install-info
177%defattr(-,root,root)
178%config(noreplace) %verify(not md5 size mtime) /etc/info-dir
179%config(noreplace) %{_infodir}/dir
180%{_syssbindir}/install-info
181%{_mandir}/man1/install-info.1*
182
183
184%changelog
185* Wed Apr 21 2010 Shu KONNO <owa@bg.wakwak.com> 4.13-1
186- new upstream release, and rebuilt with new environment
187- dropt Patch3: texinfo-4.3-zlib.patch
188
189* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.8-1vl5
190- applied new versioning policy, spec in utf-8
191
192* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.8-0vl1
193- new upstream release (4.8a)
194- move /etc/info-dir, %%{_infodir}/dir to install-info package
195- add URL
196- not apply patch1
197
198* Thu Mar 09 2006 Shu KONNO <owa@bg.wakwak.com> 4.7-0vl2
199- rebuilt for x86_64 architecture support
200
201* Thu Jul 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7-0vl1
202- new upstream release
203
204* Sat Dec 20 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.2-5vl1
205- updated to 4.2 based on 4.2-5
206
207  * Mon Sep  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-5
208  - Fix crash w/ MALLOC_CHECK_ == 2 (#72831)
209  * Tue Jul  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-4
210  - Add infokey (#67728)
211  * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
212  - automated rebuild
213  * Thu May 23 2002 Tim Powers <timp@redhat.com>
214  - automated rebuild
215  * Tue Apr 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
216  - 4.2
217
218* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.1-1vl4
219- rebuild
220
221* Fri Nov 29 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.1-1vl3
222- /usr/info -> /usr/share/info (defined on the first line of this spec)
223  (rpm-4.0.4-18vl11 and later will define so, though)
224
225* Sun Mar 17 2002 Satoshi MACHINO <machino@vinelinux.org> 4.1-1vl2
226- rewrote changelog at 4.0b-3vl4 (fixed typo)
227- rebuild
228
229* Sat Mar 16 2002 Satoshi MACHINO <machino@vinelinux.org> 4.1-1vl1
230- updated texinfo-4.1
231- fixed broken changelog ;P
232
233* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 4.0b-3vl4
234- updated on zlib (security Fix.)
235
236* Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0b-3vl3
237  - just rebuild with new release number.
238    * Mon Feb 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0b-3vl2
239    - Oops the spec was in Shift-JIS. Fixed.
240
241* Mon Feb 11 2002 akira yamada <akira@vinelinux.org> 4.0b-3vl2
242- %{_syssbindir}/install-info is separated from info package.
243- added autoconf, libtool, ncurses-devel, zlib-devel to BuildRequires.
244
245* Mon Jan 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0b-3vl1
246- based on 4.0b-3 from Rawhide and built for Vine Linux
247- added Japanese summary and description
248- fixed rpm macros
249
250* Tue Aug  7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.0b-3
251- Don't create the desktop file - we don't install it anyway.
252
253* Sat Jul 21 2001 Tim Powers <timp@redhat.com>
254- remove the info viewer from the menus, it's cluttering things
255
256* Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
257- 4.0b
258
259* Tue Apr 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.0a-1
260- Update to 4.0a, the patch looks sane
261
262* Fri Feb 23 2001 Trond Eivind Glomsr <teg@redhat.com>
263- langify
264- don't create desktop file in spec file
265
266* Tue Jan 23 2001 Preston Brown <pbrown@redhat.com>
267- danish translation added
268
269* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
270- Rebuild to get rid of 0777 dirs
271
272* Wed Nov  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
273- Fix recognition of .?o extensions in texi2dvi, Bug #20498
274
275* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
276- FHS packaging (64bit systems need to use %%_libdir not /usr/lib).
277
278* Sat Aug 19 2000 Trond Eivind Glomsr <teg@redhat.com>
279- really do it - #16120
280
281* Mon Aug 14 2000 Helge Deller <hdeller@redhat.com>
282- gzip man-pages, #16120
283
284* Mon Aug  7 2000 Tim Waugh <twaugh@redhat.com>
285- List man-pages in %%files.
286
287* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
288- Add Swedish and German translations to desktop file, Bug #15366
289
290* Thu Aug  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
291- mark /etc/info-dir %%verify(not md5 size mime), Bug #14826
292
293* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
294- automatic rebuild
295
296* Wed Jun 28 2000 Bill Nottingham <notting@redhat.com>
297- fix build wackiness with info page compressing
298
299* Fri Jun 16 2000 Bill Nottingham <notting@redhat.com>
300- fix info-dir symlink
301
302* Thu May 18 2000 Preston Brown <pbrown@redhat.com>
303- use FHS paths for info.
304
305* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
306- rebuild with current ncurses
307
308* Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
309- wmconfig -> desktop
310
311* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
312- fix descriptions
313
314* Wed Jan 26 2000 Bernhard Rosenkraenzer <bero@redhat.com>
315- move info-stnd.info* to the info package, /sbin/install-info it
316  in %post (Bug #6632)
317
318* Thu Jan 13 2000 Jeff Johnson <jbj@redhat.com>
319- recompile to eliminate ncurses foul-up.
320
321* Tue Nov  9 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
322- 4.0
323- handle RPM_OPT_FLAGS
324
325* Tue Sep 07 1999 Cristian Gafton <gafton@redhat.com>
326- import version 3.12h into 6.1 tree from HJLu
327
328* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
329- auto rebuild in the new build environment (release 4)
330
331* Wed Mar 17 1999 Erik Troan <ewt@redhat.com>
332- hacked to use zlib to get rid of the requirement on gzip
333
334* Wed Mar 17 1999 Matt Wilson <msw@redhat.com>
335- install-info prerequires gzip
336
337* Thu Mar 11 1999 Cristian Gafton <gafton@redhat.com>
338- version 3.12f
339- make /usr/info/dir to be a %config(noreplace)
340* Wed Nov 25 1998 Jeff Johnson <jbj@redhat.com>
341- rebuild to fix docdir perms.
342
343* Thu Sep 24 1998 Cristian Gafton <gafton@redhat.com>
344- fix allocation problems in install-info
345
346* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
347- /sbin/install-info should not depend on /usr/lib/libz.so.1 -- statically
348  link with /usr/lib/libz.a.
349
350* Fri Aug 07 1998 Erik Troan <ewt@redhat.com>
351- added a prereq of bash to the info package -- see the comment for a
352  description of why that was done
353
354* Tue Jun 09 1998 Prospector System <bugs@redhat.com>
355- translations modified for de
356
357* Tue Jun  9 1998 Jeff Johnson <jbj@redhat.com>
358- add %attr to permit non-root build.
359
360* Thu May 07 1998 Prospector System <bugs@redhat.com>
361- translations modified for de, fr, tr
362
363* Sun Apr 12 1998 Cristian Gafton <gafton@redhat.com>
364- added %clean
365- manhattan build
366
367* Wed Mar 04 1998 Cristian Gafton <gafton@redhat.com>
368- upgraded to version 3.12
369- added buildroot
370
371* Sun Nov 09 1997 Donnie Barnes <djb@redhat.com>
372- moved /usr/info/dir to /etc/info-dir and made /usr/info/dir a
373  symlink to /etc/info-dir.
374
375* Wed Oct 29 1997 Donnie Barnes <djb@redhat.com>
376- added wmconfig entry for info
377
378* Wed Oct 01 1997 Donnie Barnes <djb@redhat.com>
379- stripped /sbin/install-info
380
381* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
382- added info-dir to filelist
383
384* Sun Sep 14 1997 Erik Troan <ewt@redhat.com>
385- added patch from sopwith to let install-info understand gzip'ed info files
386- use skeletal dir file from texinfo tarball (w/ bash entry to reduce
387  dependency chain) instead (and install-info command everywhere else)
388- patches install-info to handle .gz names correctly
389
390* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
391- built against glibc
392
393* Tue Feb 25 1997 Erik Troan <ewt@redhat.com>
394- patched install-info.c for glibc.
395- added /usr/bin/install-info to the filelist
396
397* Tue Feb 18 1997 Michael Fulbright <msf@redhat.com>
398- upgraded to version 3.9.
Note: See TracBrowser for help on using the repository browser.