source: projects/specs/trunk/t/texinfo/texinfo-vl.spec @ 12335

Revision 12335, 13.6 KB checked in by tomop, 4 years ago (diff)

updated 14 packages

chkconfig-1.3.61-3

diffutils-3.7-1

findutils-4.7.0-1

libmpc-1.1.0-1

libuser-0.62-1

libutempter-1.1.6-2

mpfr-4.0.2-1

mpfr3-3.1.6-1

psmisc-23.2-1

sed-4.8-1

shadow-utils-4.8-1

tcsh-6.22.02-1

texinfo-6.7-1

usermode-1.109-2

Line 
1%bcond_without  test
2
3%define      extraver   a
4
5%define      _infodir   /usr/share/info
6
7Summary:     Tools needed to create Texinfo format documentation files.
8Summary(ja): Texinfo ドキュメントを作成する為に使うツール群
9
10Name:        texinfo
11Version:     6.7
12Release:     1%{?_dist_release}
13Group:       Applications/Publishing
14
15Vendor:      Project Vine
16Distribution: Vine Linux
17Packager:    daisuke
18
19License:     GPLv3+
20URL:         https://www.gnu.org/software/texinfo/
21Source0:     https://ftp.gnu.org/gnu/texinfo/texinfo-%{version}.tar.xz
22Source1:     info-dir
23
24Patch0: texinfo-4.12-zlib.patch
25# Patch1: this is needed just for koji/mock, all tests pass fine in local build
26Patch1: texinfo-6.0-disable-failing-info-test.patch
27# Patch2: rhbz#1348671, because of OSTree
28Patch2: texinfo-6.1-install-info-use-create-tmp-then-rename-pattern.patch
29# Patch3: we need to fix template fix-info-dir generates
30Patch3: info-6.5-sync-fix-info-dir.patch
31# Patch4: rhbz#1592433, bug in fix-info-dir --delete
32Patch4: texinfo-6.5-fix-info-dir.patch
33# Patch5: fixes issues detected by static analysis
34Patch5: texinfo-6.5-covscan-fixes.patch
35
36Requires(post): install-info
37Requires(preun): install-info
38Prefix:      %{_prefix}
39Buildroot:   %{_tmppath}/%{name}-%{version}-root
40BuildRequires: autoconf libtool ncurses-devel zlib-devel help2man
41
42# Texinfo perl packages are not installed in default perl library dirs
43%global __provides_exclude ^perl\\(.*Texinfo.*\\)$
44%global __requires_exclude ^perl\\(.*Texinfo.*\\)$
45
46# Redifine this to "dir" in the info directory isn't compressed
47
48%define __spec_install_post /usr/lib/rpm/brp-strip \; /usr/lib/rpm/brp-strip-comment-note \; rm -f
49
50
51%description
52Texinfo is a documentation system that can produce both online
53information and printed output from a single source file. The GNU
54Project uses the Texinfo file format for most of its documentation.
55
56Install texinfo if you want a documentation system for producing both
57online and print documentation from the same source file and/or if you
58are going to write documentation for the GNU Project.
59
60%description -l ja
61Texinfo は,単一ソースファイルから,オンラインドキュメントと
62印刷用ファイルを出力することの出来るドキュメントシステムです.
63GNU Project では,殆どのドキュメントでこの Texinfo フォーマットを
64採用しています.
65
66単一ソースファイルからオンラインドキュメントと印刷用ファイルを出力
67したい場合,あるいは GNU Project 用にドキュメントを書こうと思っている
68場合は,この texinfo をインストールして下さい.
69
70
71%package -n info
72Summary:     A stand-alone TTY-based reader for GNU texinfo documentation.
73Summary(ja): TTY ベースのスタンドアロン GNU texinfo ドキュメントリーダ
74Group:       System Environment/Base
75# By making info prereq bash, other packages which have triggers based on
76# info don't run those triggers until bash is in place as well. This is an
77# ugly method of doing it (triggers which fire on set intersection would
78# be better), but it's the best we can do for now. Talk to Erik before
79# removing this.
80Requires(pre): bash install-info
81Requires: install-info
82
83%description -n info
84The GNU project uses the texinfo file format for much of its
85documentation. The info package provides a standalone TTY-based
86browser program for viewing texinfo files.
87
88%description -n info -l ja
89GNU Project では殆どのドキュメントに texinfo 形式を採用しています.
90この info パッケージには texinfo ファイルを読む TTY ベースの
91ブラウザプログラムが収められています.
92
93
94%package -n install-info
95Summary:     info file installer
96Summary(ja): info ファイルのインストーラー
97Group:       System Environment/Base
98Conflicts: info < 4.0b-3vl2
99Requires: gzip, bzip2
100
101%description -n install-info
102info file installer.
103
104%description -n install-info -l ja
105info ファイルのインストーラーです.
106
107%prep
108%autosetup -p1
109
110%build
111
112%configure \
113        --mandir=%{_mandir} \
114        --infodir=%{_infodir} \
115        --enable-perl-xs=no
116make %{?_smp_mflags}
117
118make -C util LIBS=%{_libdir}/libz.a
119
120
121%install
122rm -rf %{buildroot}
123mkdir -p %{buildroot}/{etc,sbin}
124
125%makeinstall
126
127( cd %{buildroot}
128  gzip -n -9f .%{_infodir}/*info*
129  gzip -n -9f .%{_mandir}/*/*
130  install -m644 ${RPM_SOURCE_DIR}/info-dir ./etc/info-dir
131  ln -sf /etc/info-dir %{buildroot}%{_infodir}/dir
132  mv -f .%{_bindir}/install-info ./sbin
133)
134
135%find_lang %name
136%find_lang %{name}_document
137
138
139%if %{with test}
140%check
141export ALL_TESTS=yes
142%make_build check
143%endif
144
145%clean
146rm -rf %{buildroot}
147
148
149%post
150/sbin/install-info %{_infodir}/texinfo.info.gz %{_infodir}/dir
151
152
153%preun
154if [ $1 = 0 ]; then
155    /sbin/install-info --delete %{_infodir}/texinfo.info.gz %{_infodir}/dir
156fi
157
158
159%post -n info
160/sbin/install-info %{_infodir}/info-stnd.info.gz %{_infodir}/dir
161
162
163%preun -n info
164if [ $1 = 0 ]; then
165    /sbin/install-info --delete %{_infodir}/info-stnd.info.gz %{_infodir}/dir
166fi
167
168
169%files -f %{name}.lang -f %{name}_document.lang
170%defattr(-,root,root)
171%license COPYING
172%doc AUTHORS ChangeLog NEWS README TODO
173%{_bindir}/makeinfo
174%{_bindir}/pdftexi2dvi
175%{_bindir}/pod2texi
176%{_bindir}/texi2any
177%{_bindir}/texi2dvi
178%{_bindir}/texi2pdf
179%{_bindir}/texindex
180%{_datadir}/texinfo
181%{_infodir}/texinfo*
182#dir %{_libdir}/texinfo
183#{_libdir}/texinfo/*
184%{_mandir}/man1/makeinfo.1*
185%{_mandir}/man1/pdftexi2dvi.1*
186%{_mandir}/man1/pod2texi.1.gz
187%{_mandir}/man1/texi2any.1.gz
188%{_mandir}/man1/texi2dvi.1*
189%{_mandir}/man1/texi2pdf.1*
190%{_mandir}/man1/texindex.1*
191%{_mandir}/man5/texinfo.5*
192   
193
194%files -n info
195%defattr(-,root,root)
196#%config(missingok) /etc/X11/applnk/Utilities/info.desktop
197#%config(noreplace) %verify(not md5 size mtime) /etc/info-dir
198#%config(noreplace) %{_infodir}/dir
199%license COPYING
200%doc info/README
201%{_bindir}/info
202#{_bindir}/infokey
203#{_infodir}/info.info*
204%{_infodir}/info-stnd.info*
205%{_mandir}/man1/info.1*
206#{_mandir}/man1/infokey.1*
207%{_mandir}/man5/info.5*
208
209
210%files -n install-info
211%defattr(-,root,root)
212%license COPYING
213%config(noreplace) %verify(not md5 size mtime) /etc/info-dir
214%config(noreplace) %{_infodir}/dir
215%{_syssbindir}/install-info
216%{_mandir}/man1/install-info.1*
217
218
219%changelog
220* Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.7-1
221- new upstream release.
222
223* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.13a-2
224- rebuild with VineSeed environment
225
226* Sun Apr 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.13a-1
227- update to 4.13a
228- add patch2-6 from upstream
229- add BR: help2man
230
231* Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.13-2
232- add R: gzip, bzip2 into install-info to fix making vbootstrap env.
233- change tag Prereq -> Req(pre)
234
235* Wed Apr 21 2010 Shu KONNO <owa@bg.wakwak.com> 4.13-1
236- new upstream release, and rebuilt with new environment
237- dropt Patch3: texinfo-4.3-zlib.patch
238
239* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.8-1vl5
240- applied new versioning policy, spec in utf-8
241
242* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.8-0vl1
243- new upstream release (4.8a)
244- move /etc/info-dir, %%{_infodir}/dir to install-info package
245- add URL
246- not apply patch1
247
248* Thu Mar 09 2006 Shu KONNO <owa@bg.wakwak.com> 4.7-0vl2
249- rebuilt for x86_64 architecture support
250
251* Thu Jul 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7-0vl1
252- new upstream release
253
254* Sat Dec 20 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.2-5vl1
255- updated to 4.2 based on 4.2-5
256
257  * Mon Sep  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-5
258  - Fix crash w/ MALLOC_CHECK_ == 2 (#72831)
259  * Tue Jul  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-4
260  - Add infokey (#67728)
261  * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
262  - automated rebuild
263  * Thu May 23 2002 Tim Powers <timp@redhat.com>
264  - automated rebuild
265  * Tue Apr 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
266  - 4.2
267
268* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.1-1vl4
269- rebuild
270
271* Fri Nov 29 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.1-1vl3
272- /usr/info -> /usr/share/info (defined on the first line of this spec)
273  (rpm-4.0.4-18vl11 and later will define so, though)
274
275* Sun Mar 17 2002 Satoshi MACHINO <machino@vinelinux.org> 4.1-1vl2
276- rewrote changelog at 4.0b-3vl4 (fixed typo)
277- rebuild
278
279* Sat Mar 16 2002 Satoshi MACHINO <machino@vinelinux.org> 4.1-1vl1
280- updated texinfo-4.1
281- fixed broken changelog ;P
282
283* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 4.0b-3vl4
284- updated on zlib (security Fix.)
285
286* Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0b-3vl3
287  - just rebuild with new release number.
288    * Mon Feb 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0b-3vl2
289    - Oops the spec was in Shift-JIS. Fixed.
290
291* Mon Feb 11 2002 akira yamada <akira@vinelinux.org> 4.0b-3vl2
292- %{_syssbindir}/install-info is separated from info package.
293- added autoconf, libtool, ncurses-devel, zlib-devel to BuildRequires.
294
295* Mon Jan 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0b-3vl1
296- based on 4.0b-3 from Rawhide and built for Vine Linux
297- added Japanese summary and description
298- fixed rpm macros
299
300* Tue Aug  7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.0b-3
301- Don't create the desktop file - we don't install it anyway.
302
303* Sat Jul 21 2001 Tim Powers <timp@redhat.com>
304- remove the info viewer from the menus, it's cluttering things
305
306* Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
307- 4.0b
308
309* Tue Apr 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.0a-1
310- Update to 4.0a, the patch looks sane
311
312* Fri Feb 23 2001 Trond Eivind Glomsr <teg@redhat.com>
313- langify
314- don't create desktop file in spec file
315
316* Tue Jan 23 2001 Preston Brown <pbrown@redhat.com>
317- danish translation added
318
319* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
320- Rebuild to get rid of 0777 dirs
321
322* Wed Nov  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
323- Fix recognition of .?o extensions in texi2dvi, Bug #20498
324
325* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
326- FHS packaging (64bit systems need to use %%_libdir not /usr/lib).
327
328* Sat Aug 19 2000 Trond Eivind Glomsr <teg@redhat.com>
329- really do it - #16120
330
331* Mon Aug 14 2000 Helge Deller <hdeller@redhat.com>
332- gzip man-pages, #16120
333
334* Mon Aug  7 2000 Tim Waugh <twaugh@redhat.com>
335- List man-pages in %%files.
336
337* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
338- Add Swedish and German translations to desktop file, Bug #15366
339
340* Thu Aug  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
341- mark /etc/info-dir %%verify(not md5 size mime), Bug #14826
342
343* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
344- automatic rebuild
345
346* Wed Jun 28 2000 Bill Nottingham <notting@redhat.com>
347- fix build wackiness with info page compressing
348
349* Fri Jun 16 2000 Bill Nottingham <notting@redhat.com>
350- fix info-dir symlink
351
352* Thu May 18 2000 Preston Brown <pbrown@redhat.com>
353- use FHS paths for info.
354
355* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
356- rebuild with current ncurses
357
358* Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
359- wmconfig -> desktop
360
361* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
362- fix descriptions
363
364* Wed Jan 26 2000 Bernhard Rosenkraenzer <bero@redhat.com>
365- move info-stnd.info* to the info package, /sbin/install-info it
366  in %post (Bug #6632)
367
368* Thu Jan 13 2000 Jeff Johnson <jbj@redhat.com>
369- recompile to eliminate ncurses foul-up.
370
371* Tue Nov  9 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
372- 4.0
373- handle RPM_OPT_FLAGS
374
375* Tue Sep 07 1999 Cristian Gafton <gafton@redhat.com>
376- import version 3.12h into 6.1 tree from HJLu
377
378* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
379- auto rebuild in the new build environment (release 4)
380
381* Wed Mar 17 1999 Erik Troan <ewt@redhat.com>
382- hacked to use zlib to get rid of the requirement on gzip
383
384* Wed Mar 17 1999 Matt Wilson <msw@redhat.com>
385- install-info prerequires gzip
386
387* Thu Mar 11 1999 Cristian Gafton <gafton@redhat.com>
388- version 3.12f
389- make /usr/info/dir to be a %config(noreplace)
390* Wed Nov 25 1998 Jeff Johnson <jbj@redhat.com>
391- rebuild to fix docdir perms.
392
393* Thu Sep 24 1998 Cristian Gafton <gafton@redhat.com>
394- fix allocation problems in install-info
395
396* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
397- /sbin/install-info should not depend on /usr/lib/libz.so.1 -- statically
398  link with /usr/lib/libz.a.
399
400* Fri Aug 07 1998 Erik Troan <ewt@redhat.com>
401- added a prereq of bash to the info package -- see the comment for a
402  description of why that was done
403
404* Tue Jun 09 1998 Prospector System <bugs@redhat.com>
405- translations modified for de
406
407* Tue Jun  9 1998 Jeff Johnson <jbj@redhat.com>
408- add %attr to permit non-root build.
409
410* Thu May 07 1998 Prospector System <bugs@redhat.com>
411- translations modified for de, fr, tr
412
413* Sun Apr 12 1998 Cristian Gafton <gafton@redhat.com>
414- added %clean
415- manhattan build
416
417* Wed Mar 04 1998 Cristian Gafton <gafton@redhat.com>
418- upgraded to version 3.12
419- added buildroot
420
421* Sun Nov 09 1997 Donnie Barnes <djb@redhat.com>
422- moved /usr/info/dir to /etc/info-dir and made /usr/info/dir a
423  symlink to /etc/info-dir.
424
425* Wed Oct 29 1997 Donnie Barnes <djb@redhat.com>
426- added wmconfig entry for info
427
428* Wed Oct 01 1997 Donnie Barnes <djb@redhat.com>
429- stripped /sbin/install-info
430
431* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
432- added info-dir to filelist
433
434* Sun Sep 14 1997 Erik Troan <ewt@redhat.com>
435- added patch from sopwith to let install-info understand gzip'ed info files
436- use skeletal dir file from texinfo tarball (w/ bash entry to reduce
437  dependency chain) instead (and install-info command everywhere else)
438- patches install-info to handle .gz names correctly
439
440* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
441- built against glibc
442
443* Tue Feb 25 1997 Erik Troan <ewt@redhat.com>
444- patched install-info.c for glibc.
445- added /usr/bin/install-info to the filelist
446
447* Tue Feb 18 1997 Michael Fulbright <msf@redhat.com>
448- upgraded to version 3.9.
Note: See TracBrowser for help on using the repository browser.