source: projects/specs/trunk/t/texinfo/texinfo-vl.spec @ 521

Revision 521, 11.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define      extraver   a
2
3%define      _infodir   /usr/share/info
4
5Summary:     Tools needed to create Texinfo format documentation files.
6Summary(ja): Texinfo ドキュメントを作成する為に使うツール群
7
8Name:        texinfo
9Version:     4.8
10Release:     1%{?_dist_release}
11License:     GPL
12Group:       Applications/Publishing
13URL:         http://www.gnu.org/software/texinfo/
14Source0:     ftp://ftp.gnu.org/gnu/texinfo/texinfo-%{version}%{?extraver:%extraver}.tar.bz2
15Source1:     info-dir
16Patch1:      texinfo-fix.patch
17Patch3:      texinfo-4.3-zlib.patch
18Prereq:      install-info
19Prefix:      %{_prefix}
20Buildroot:   %{_tmppath}/%{name}-%{version}-root
21BuildRequires: autoconf libtool ncurses-devel zlib-devel
22
23
24# Redifine this to "dir" in the info directory isn't compressed
25
26%define __spec_install_post /usr/lib/rpm/brp-strip \; /usr/lib/rpm/brp-strip-comment-note \; rm -f
27
28
29%description
30Texinfo is a documentation system that can produce both online
31information and printed output from a single source file. The GNU
32Project uses the Texinfo file format for most of its documentation.
33
34Install texinfo if you want a documentation system for producing both
35online and print documentation from the same source file and/or if you
36are going to write documentation for the GNU Project.
37
38%description -l ja
39Texinfo は,単一ソースファイルから,オンラインドキュメントと
40印刷用ファイルを出力することの出来るドキュメントシステムです.
41GNU Project では,殆どのドキュメントでこの Texinfo フォーマットを
42採用しています.
43
44単一ソースファイルからオンラインドキュメントと印刷用ファイルを出力
45したい場合,あるいは GNU Project 用にドキュメントを書こうと思っている
46場合は,この texinfo をインストールして下さい.
47
48
49%package -n info
50Summary:     A stand-alone TTY-based reader for GNU texinfo documentation.
51Summary(ja): TTY ベースのスタンドアロン GNU texinfo ドキュメントリーダ
52Group:       System Environment/Base
53# By making info prereq bash, other packages which have triggers based on
54# info don't run those triggers until bash is in place as well. This is an
55# ugly method of doing it (triggers which fire on set intersection would
56# be better), but it's the best we can do for now. Talk to Erik before
57# removing this.
58Prereq: bash install-info
59Requires: install-info
60
61%description -n info
62The GNU project uses the texinfo file format for much of its
63documentation. The info package provides a standalone TTY-based
64browser program for viewing texinfo files.
65
66%description -n info -l ja
67GNU Project では殆どのドキュメントに texinfo 形式を採用しています.
68この info パッケージには texinfo ファイルを読む TTY ベースの
69ブラウザプログラムが収められています.
70
71
72%package -n install-info
73Summary:     info file installer
74Summary(ja): info ファイルのインストーラー
75Group:       System Environment/Base
76Conflicts: info < 4.0b-3vl2
77
78%description -n install-info
79info file installer.
80
81%description -n install-info -l ja
82info ファイルのインストーラーです.
83
84%prep
85%setup -q
86#%%patch1 -p1
87%patch3 -p1 -b .zlib
88
89
90%build
91
92%configure --mandir=%{_mandir} --infodir=%{_infodir}
93make %{?_smp_mflags}
94
95make -C util LIBS=%{_libdir}/libz.a
96
97
98%install
99rm -rf ${RPM_BUILD_ROOT}
100mkdir -p ${RPM_BUILD_ROOT}/{etc,sbin}
101
102%makeinstall
103
104( cd ${RPM_BUILD_ROOT}
105  gzip -n -9f .%{_infodir}/*info*
106  gzip -n -9f .%{_mandir}/*/*
107  install -m644 ${RPM_SOURCE_DIR}/info-dir ./etc/info-dir
108  ln -sf /etc/info-dir ${RPM_BUILD_ROOT}%{_infodir}/dir
109  for i in makeinfo texindex info install-info ; do
110    strip .%{_bindir}/$i
111  done
112  mv -f .%{_bindir}/install-info ./sbin
113)
114
115%find_lang %name
116
117
118%clean
119rm -rf ${RPM_BUILD_ROOT}
120
121
122%post
123/sbin/install-info %{_infodir}/texinfo.gz %{_infodir}/dir
124
125
126%preun
127if [ $1 = 0 ]; then
128    /sbin/install-info --delete %{_infodir}/texinfo.gz %{_infodir}/dir
129fi
130
131
132%post -n info
133/sbin/install-info %{_infodir}/info-stnd.info.gz %{_infodir}/dir
134
135
136%preun -n info
137if [ $1 = 0 ]; then
138    /sbin/install-info --delete %{_infodir}/info-stnd.info.gz %{_infodir}/dir
139fi
140
141
142%files -f %{name}.lang
143%defattr(-,root,root)
144%doc AUTHORS ChangeLog INSTALL INTRODUCTION NEWS README TODO
145%{_bindir}/makeinfo
146%{_bindir}/texindex
147%{_bindir}/texi2dvi
148%{_datadir}/texinfo
149%{_infodir}/texinfo*
150%{_mandir}/man1/makeinfo.1*
151%{_mandir}/man1/texindex.1*
152%{_mandir}/man1/texi2dvi.1*
153%{_mandir}/man5/texinfo.5*
154
155
156%files -n info
157%defattr(-,root,root)
158#%config(missingok) /etc/X11/applnk/Utilities/info.desktop
159#%config(noreplace) %verify(not md5 size mtime) /etc/info-dir
160#%config(noreplace) %{_infodir}/dir
161%doc info/README
162%{_bindir}/info
163%{_bindir}/infokey
164%{_infodir}/info.info*
165%{_infodir}/info-stnd.info*
166%{_mandir}/man1/info.1*
167%{_mandir}/man1/infokey.1*
168%{_mandir}/man5/info.5*
169
170
171%files -n install-info
172%defattr(-,root,root)
173%config(noreplace) %verify(not md5 size mtime) /etc/info-dir
174%config(noreplace) %{_infodir}/dir
175%{_syssbindir}/install-info
176%{_mandir}/man1/install-info.1*
177
178
179%changelog
180* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.8-1vl5
181- applied new versioning policy, spec in utf-8
182
183* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.8-0vl1
184- new upstream release (4.8a)
185- move /etc/info-dir, %%{_infodir}/dir to install-info package
186- add URL
187- not apply patch1
188
189* Thu Mar 09 2006 Shu KONNO <owa@bg.wakwak.com> 4.7-0vl2
190- rebuilt for x86_64 architecture support
191
192* Thu Jul 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7-0vl1
193- new upstream release
194
195* Sat Dec 20 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.2-5vl1
196- updated to 4.2 based on 4.2-5
197
198  * Mon Sep  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-5
199  - Fix crash w/ MALLOC_CHECK_ == 2 (#72831)
200  * Tue Jul  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-4
201  - Add infokey (#67728)
202  * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
203  - automated rebuild
204  * Thu May 23 2002 Tim Powers <timp@redhat.com>
205  - automated rebuild
206  * Tue Apr 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
207  - 4.2
208
209* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.1-1vl4
210- rebuild
211
212* Fri Nov 29 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.1-1vl3
213- /usr/info -> /usr/share/info (defined on the first line of this spec)
214  (rpm-4.0.4-18vl11 and later will define so, though)
215
216* Sun Mar 17 2002 Satoshi MACHINO <machino@vinelinux.org> 4.1-1vl2
217- rewrote changelog at 4.0b-3vl4 (fixed typo)
218- rebuild
219
220* Sat Mar 16 2002 Satoshi MACHINO <machino@vinelinux.org> 4.1-1vl1
221- updated texinfo-4.1
222- fixed broken changelog ;P
223
224* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 4.0b-3vl4
225- updated on zlib (security Fix.)
226
227* Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0b-3vl3
228  - just rebuild with new release number.
229    * Mon Feb 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0b-3vl2
230    - Oops the spec was in Shift-JIS. Fixed.
231
232* Mon Feb 11 2002 akira yamada <akira@vinelinux.org> 4.0b-3vl2
233- %{_syssbindir}/install-info is separated from info package.
234- added autoconf, libtool, ncurses-devel, zlib-devel to BuildRequires.
235
236* Mon Jan 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0b-3vl1
237- based on 4.0b-3 from Rawhide and built for Vine Linux
238- added Japanese summary and description
239- fixed rpm macros
240
241* Tue Aug  7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.0b-3
242- Don't create the desktop file - we don't install it anyway.
243
244* Sat Jul 21 2001 Tim Powers <timp@redhat.com>
245- remove the info viewer from the menus, it's cluttering things
246
247* Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
248- 4.0b
249
250* Tue Apr 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.0a-1
251- Update to 4.0a, the patch looks sane
252
253* Fri Feb 23 2001 Trond Eivind Glomsr <teg@redhat.com>
254- langify
255- don't create desktop file in spec file
256
257* Tue Jan 23 2001 Preston Brown <pbrown@redhat.com>
258- danish translation added
259
260* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
261- Rebuild to get rid of 0777 dirs
262
263* Wed Nov  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
264- Fix recognition of .?o extensions in texi2dvi, Bug #20498
265
266* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
267- FHS packaging (64bit systems need to use %%_libdir not /usr/lib).
268
269* Sat Aug 19 2000 Trond Eivind Glomsr <teg@redhat.com>
270- really do it - #16120
271
272* Mon Aug 14 2000 Helge Deller <hdeller@redhat.com>
273- gzip man-pages, #16120
274
275* Mon Aug  7 2000 Tim Waugh <twaugh@redhat.com>
276- List man-pages in %%files.
277
278* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
279- Add Swedish and German translations to desktop file, Bug #15366
280
281* Thu Aug  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
282- mark /etc/info-dir %%verify(not md5 size mime), Bug #14826
283
284* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
285- automatic rebuild
286
287* Wed Jun 28 2000 Bill Nottingham <notting@redhat.com>
288- fix build wackiness with info page compressing
289
290* Fri Jun 16 2000 Bill Nottingham <notting@redhat.com>
291- fix info-dir symlink
292
293* Thu May 18 2000 Preston Brown <pbrown@redhat.com>
294- use FHS paths for info.
295
296* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
297- rebuild with current ncurses
298
299* Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
300- wmconfig -> desktop
301
302* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
303- fix descriptions
304
305* Wed Jan 26 2000 Bernhard Rosenkraenzer <bero@redhat.com>
306- move info-stnd.info* to the info package, /sbin/install-info it
307  in %post (Bug #6632)
308
309* Thu Jan 13 2000 Jeff Johnson <jbj@redhat.com>
310- recompile to eliminate ncurses foul-up.
311
312* Tue Nov  9 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
313- 4.0
314- handle RPM_OPT_FLAGS
315
316* Tue Sep 07 1999 Cristian Gafton <gafton@redhat.com>
317- import version 3.12h into 6.1 tree from HJLu
318
319* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
320- auto rebuild in the new build environment (release 4)
321
322* Wed Mar 17 1999 Erik Troan <ewt@redhat.com>
323- hacked to use zlib to get rid of the requirement on gzip
324
325* Wed Mar 17 1999 Matt Wilson <msw@redhat.com>
326- install-info prerequires gzip
327
328* Thu Mar 11 1999 Cristian Gafton <gafton@redhat.com>
329- version 3.12f
330- make /usr/info/dir to be a %config(noreplace)
331* Wed Nov 25 1998 Jeff Johnson <jbj@redhat.com>
332- rebuild to fix docdir perms.
333
334* Thu Sep 24 1998 Cristian Gafton <gafton@redhat.com>
335- fix allocation problems in install-info
336
337* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
338- /sbin/install-info should not depend on /usr/lib/libz.so.1 -- statically
339  link with /usr/lib/libz.a.
340
341* Fri Aug 07 1998 Erik Troan <ewt@redhat.com>
342- added a prereq of bash to the info package -- see the comment for a
343  description of why that was done
344
345* Tue Jun 09 1998 Prospector System <bugs@redhat.com>
346- translations modified for de
347
348* Tue Jun  9 1998 Jeff Johnson <jbj@redhat.com>
349- add %attr to permit non-root build.
350
351* Thu May 07 1998 Prospector System <bugs@redhat.com>
352- translations modified for de, fr, tr
353
354* Sun Apr 12 1998 Cristian Gafton <gafton@redhat.com>
355- added %clean
356- manhattan build
357
358* Wed Mar 04 1998 Cristian Gafton <gafton@redhat.com>
359- upgraded to version 3.12
360- added buildroot
361
362* Sun Nov 09 1997 Donnie Barnes <djb@redhat.com>
363- moved /usr/info/dir to /etc/info-dir and made /usr/info/dir a
364  symlink to /etc/info-dir.
365
366* Wed Oct 29 1997 Donnie Barnes <djb@redhat.com>
367- added wmconfig entry for info
368
369* Wed Oct 01 1997 Donnie Barnes <djb@redhat.com>
370- stripped /sbin/install-info
371
372* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
373- added info-dir to filelist
374
375* Sun Sep 14 1997 Erik Troan <ewt@redhat.com>
376- added patch from sopwith to let install-info understand gzip'ed info files
377- use skeletal dir file from texinfo tarball (w/ bash entry to reduce
378  dependency chain) instead (and install-info command everywhere else)
379- patches install-info to handle .gz names correctly
380
381* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
382- built against glibc
383
384* Tue Feb 25 1997 Erik Troan <ewt@redhat.com>
385- patched install-info.c for glibc.
386- added /usr/bin/install-info to the filelist
387
388* Tue Feb 18 1997 Michael Fulbright <msf@redhat.com>
389- upgraded to version 3.9.
Note: See TracBrowser for help on using the repository browser.