source: projects/specs/trunk/t/texinfo/texinfo-vl.spec @ 979

Revision 979, 12.4 KB checked in by iwamoto, 14 years ago (diff)

add BR: gzip, bzip2 for fix making vbuilder env.

Line 
1%define      extraver   a
2
3%define      _infodir   /usr/share/info
4
5Summary:     Tools needed to create Texinfo format documentation files.
6Summary(ja): Texinfo ドキュメントを作成する為に使うツール群
7
8Name:        texinfo
9Version:     4.13
10Release:     2%{?_dist_release}
11License:     GPL
12Group:       Applications/Publishing
13URL:         http://www.gnu.org/software/texinfo/
14#Source0:     ftp://ftp.gnu.org/gnu/texinfo/texinfo-%{version}%{?extraver:%extraver}.tar.bz2
15Source0:     ftp://ftp.gnu.org/gnu/texinfo/texinfo-%{version}.tar.gz
16Source1:     info-dir
17Patch1:      texinfo-fix.patch
18Patch3:      texinfo-4.3-zlib.patch
19Requires(pre): install-info
20Prefix:      %{_prefix}
21Buildroot:   %{_tmppath}/%{name}-%{version}-root
22BuildRequires: autoconf libtool ncurses-devel zlib-devel
23
24
25# Redifine this to "dir" in the info directory isn't compressed
26
27%define __spec_install_post /usr/lib/rpm/brp-strip \; /usr/lib/rpm/brp-strip-comment-note \; rm -f
28
29
30%description
31Texinfo is a documentation system that can produce both online
32information and printed output from a single source file. The GNU
33Project uses the Texinfo file format for most of its documentation.
34
35Install texinfo if you want a documentation system for producing both
36online and print documentation from the same source file and/or if you
37are going to write documentation for the GNU Project.
38
39%description -l ja
40Texinfo は,単一ソースファイルから,オンラインドキュメントと
41印刷用ファイルを出力することの出来るドキュメントシステムです.
42GNU Project では,殆どのドキュメントでこの Texinfo フォーマットを
43採用しています.
44
45単一ソースファイルからオンラインドキュメントと印刷用ファイルを出力
46したい場合,あるいは GNU Project 用にドキュメントを書こうと思っている
47場合は,この texinfo をインストールして下さい.
48
49
50%package -n info
51Summary:     A stand-alone TTY-based reader for GNU texinfo documentation.
52Summary(ja): TTY ベースのスタンドアロン GNU texinfo ドキュメントリーダ
53Group:       System Environment/Base
54# By making info prereq bash, other packages which have triggers based on
55# info don't run those triggers until bash is in place as well. This is an
56# ugly method of doing it (triggers which fire on set intersection would
57# be better), but it's the best we can do for now. Talk to Erik before
58# removing this.
59Requires(pre): bash install-info
60Requires: install-info
61
62%description -n info
63The GNU project uses the texinfo file format for much of its
64documentation. The info package provides a standalone TTY-based
65browser program for viewing texinfo files.
66
67%description -n info -l ja
68GNU Project では殆どのドキュメントに texinfo 形式を採用しています.
69この info パッケージには texinfo ファイルを読む TTY ベースの
70ブラウザプログラムが収められています.
71
72
73%package -n install-info
74Summary:     info file installer
75Summary(ja): info ファイルのインストーラー
76Group:       System Environment/Base
77Conflicts: info < 4.0b-3vl2
78Requires: gzip, bzip2
79
80%description -n install-info
81info file installer.
82
83%description -n install-info -l ja
84info ファイルのインストーラーです.
85
86%prep
87%setup -q
88#%%patch1 -p1
89#%patch3 -p1 -b .zlib
90
91
92%build
93
94%configure --mandir=%{_mandir} --infodir=%{_infodir}
95make %{?_smp_mflags}
96
97make -C util LIBS=%{_libdir}/libz.a
98
99
100%install
101rm -rf ${RPM_BUILD_ROOT}
102mkdir -p ${RPM_BUILD_ROOT}/{etc,sbin}
103
104%makeinstall
105
106( cd ${RPM_BUILD_ROOT}
107  gzip -n -9f .%{_infodir}/*info*
108  gzip -n -9f .%{_mandir}/*/*
109  install -m644 ${RPM_SOURCE_DIR}/info-dir ./etc/info-dir
110  ln -sf /etc/info-dir ${RPM_BUILD_ROOT}%{_infodir}/dir
111  for i in makeinfo texindex info install-info ; do
112    strip .%{_bindir}/$i
113  done
114  mv -f .%{_bindir}/install-info ./sbin
115)
116
117%find_lang %name
118
119
120%clean
121rm -rf ${RPM_BUILD_ROOT}
122
123
124%post
125/sbin/install-info %{_infodir}/texinfo.gz %{_infodir}/dir
126
127
128%preun
129if [ $1 = 0 ]; then
130    /sbin/install-info --delete %{_infodir}/texinfo.gz %{_infodir}/dir
131fi
132
133
134%post -n info
135/sbin/install-info %{_infodir}/info-stnd.info.gz %{_infodir}/dir
136
137
138%preun -n info
139if [ $1 = 0 ]; then
140    /sbin/install-info --delete %{_infodir}/info-stnd.info.gz %{_infodir}/dir
141fi
142
143
144%files -f %{name}.lang
145%defattr(-,root,root)
146%doc AUTHORS ChangeLog INSTALL INTRODUCTION NEWS README TODO
147%{_bindir}/makeinfo
148%{_bindir}/pdftexi2dvi
149%{_bindir}/texindex
150%{_bindir}/texi2dvi
151%{_bindir}/texi2pdf
152%{_datadir}/texinfo
153%{_infodir}/texinfo*
154%{_mandir}/man1/makeinfo.1*
155%{_mandir}/man1/pdftexi2dvi.1*
156%{_mandir}/man1/texindex.1*
157%{_mandir}/man1/texi2dvi.1*
158%{_mandir}/man1/texi2pdf.1*
159%{_mandir}/man5/texinfo.5*
160
161
162%files -n info
163%defattr(-,root,root)
164#%config(missingok) /etc/X11/applnk/Utilities/info.desktop
165#%config(noreplace) %verify(not md5 size mtime) /etc/info-dir
166#%config(noreplace) %{_infodir}/dir
167%doc info/README
168%{_bindir}/info
169%{_bindir}/infokey
170%{_infodir}/info.info*
171%{_infodir}/info-stnd.info*
172%{_mandir}/man1/info.1*
173%{_mandir}/man1/infokey.1*
174%{_mandir}/man5/info.5*
175
176
177%files -n install-info
178%defattr(-,root,root)
179%config(noreplace) %verify(not md5 size mtime) /etc/info-dir
180%config(noreplace) %{_infodir}/dir
181%{_syssbindir}/install-info
182%{_mandir}/man1/install-info.1*
183
184
185%changelog
186* Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.13-2
187- add R: gzip, bzip2 into install-info to fix making vbootstrap env.
188- change tag Prereq -> Req(pre)
189
190* Wed Apr 21 2010 Shu KONNO <owa@bg.wakwak.com> 4.13-1
191- new upstream release, and rebuilt with new environment
192- dropt Patch3: texinfo-4.3-zlib.patch
193
194* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.8-1vl5
195- applied new versioning policy, spec in utf-8
196
197* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.8-0vl1
198- new upstream release (4.8a)
199- move /etc/info-dir, %%{_infodir}/dir to install-info package
200- add URL
201- not apply patch1
202
203* Thu Mar 09 2006 Shu KONNO <owa@bg.wakwak.com> 4.7-0vl2
204- rebuilt for x86_64 architecture support
205
206* Thu Jul 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7-0vl1
207- new upstream release
208
209* Sat Dec 20 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.2-5vl1
210- updated to 4.2 based on 4.2-5
211
212  * Mon Sep  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-5
213  - Fix crash w/ MALLOC_CHECK_ == 2 (#72831)
214  * Tue Jul  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-4
215  - Add infokey (#67728)
216  * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
217  - automated rebuild
218  * Thu May 23 2002 Tim Powers <timp@redhat.com>
219  - automated rebuild
220  * Tue Apr 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
221  - 4.2
222
223* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.1-1vl4
224- rebuild
225
226* Fri Nov 29 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.1-1vl3
227- /usr/info -> /usr/share/info (defined on the first line of this spec)
228  (rpm-4.0.4-18vl11 and later will define so, though)
229
230* Sun Mar 17 2002 Satoshi MACHINO <machino@vinelinux.org> 4.1-1vl2
231- rewrote changelog at 4.0b-3vl4 (fixed typo)
232- rebuild
233
234* Sat Mar 16 2002 Satoshi MACHINO <machino@vinelinux.org> 4.1-1vl1
235- updated texinfo-4.1
236- fixed broken changelog ;P
237
238* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 4.0b-3vl4
239- updated on zlib (security Fix.)
240
241* Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0b-3vl3
242  - just rebuild with new release number.
243    * Mon Feb 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0b-3vl2
244    - Oops the spec was in Shift-JIS. Fixed.
245
246* Mon Feb 11 2002 akira yamada <akira@vinelinux.org> 4.0b-3vl2
247- %{_syssbindir}/install-info is separated from info package.
248- added autoconf, libtool, ncurses-devel, zlib-devel to BuildRequires.
249
250* Mon Jan 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0b-3vl1
251- based on 4.0b-3 from Rawhide and built for Vine Linux
252- added Japanese summary and description
253- fixed rpm macros
254
255* Tue Aug  7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.0b-3
256- Don't create the desktop file - we don't install it anyway.
257
258* Sat Jul 21 2001 Tim Powers <timp@redhat.com>
259- remove the info viewer from the menus, it's cluttering things
260
261* Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
262- 4.0b
263
264* Tue Apr 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.0a-1
265- Update to 4.0a, the patch looks sane
266
267* Fri Feb 23 2001 Trond Eivind Glomsr <teg@redhat.com>
268- langify
269- don't create desktop file in spec file
270
271* Tue Jan 23 2001 Preston Brown <pbrown@redhat.com>
272- danish translation added
273
274* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
275- Rebuild to get rid of 0777 dirs
276
277* Wed Nov  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
278- Fix recognition of .?o extensions in texi2dvi, Bug #20498
279
280* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
281- FHS packaging (64bit systems need to use %%_libdir not /usr/lib).
282
283* Sat Aug 19 2000 Trond Eivind Glomsr <teg@redhat.com>
284- really do it - #16120
285
286* Mon Aug 14 2000 Helge Deller <hdeller@redhat.com>
287- gzip man-pages, #16120
288
289* Mon Aug  7 2000 Tim Waugh <twaugh@redhat.com>
290- List man-pages in %%files.
291
292* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
293- Add Swedish and German translations to desktop file, Bug #15366
294
295* Thu Aug  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
296- mark /etc/info-dir %%verify(not md5 size mime), Bug #14826
297
298* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
299- automatic rebuild
300
301* Wed Jun 28 2000 Bill Nottingham <notting@redhat.com>
302- fix build wackiness with info page compressing
303
304* Fri Jun 16 2000 Bill Nottingham <notting@redhat.com>
305- fix info-dir symlink
306
307* Thu May 18 2000 Preston Brown <pbrown@redhat.com>
308- use FHS paths for info.
309
310* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
311- rebuild with current ncurses
312
313* Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
314- wmconfig -> desktop
315
316* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
317- fix descriptions
318
319* Wed Jan 26 2000 Bernhard Rosenkraenzer <bero@redhat.com>
320- move info-stnd.info* to the info package, /sbin/install-info it
321  in %post (Bug #6632)
322
323* Thu Jan 13 2000 Jeff Johnson <jbj@redhat.com>
324- recompile to eliminate ncurses foul-up.
325
326* Tue Nov  9 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
327- 4.0
328- handle RPM_OPT_FLAGS
329
330* Tue Sep 07 1999 Cristian Gafton <gafton@redhat.com>
331- import version 3.12h into 6.1 tree from HJLu
332
333* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
334- auto rebuild in the new build environment (release 4)
335
336* Wed Mar 17 1999 Erik Troan <ewt@redhat.com>
337- hacked to use zlib to get rid of the requirement on gzip
338
339* Wed Mar 17 1999 Matt Wilson <msw@redhat.com>
340- install-info prerequires gzip
341
342* Thu Mar 11 1999 Cristian Gafton <gafton@redhat.com>
343- version 3.12f
344- make /usr/info/dir to be a %config(noreplace)
345* Wed Nov 25 1998 Jeff Johnson <jbj@redhat.com>
346- rebuild to fix docdir perms.
347
348* Thu Sep 24 1998 Cristian Gafton <gafton@redhat.com>
349- fix allocation problems in install-info
350
351* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
352- /sbin/install-info should not depend on /usr/lib/libz.so.1 -- statically
353  link with /usr/lib/libz.a.
354
355* Fri Aug 07 1998 Erik Troan <ewt@redhat.com>
356- added a prereq of bash to the info package -- see the comment for a
357  description of why that was done
358
359* Tue Jun 09 1998 Prospector System <bugs@redhat.com>
360- translations modified for de
361
362* Tue Jun  9 1998 Jeff Johnson <jbj@redhat.com>
363- add %attr to permit non-root build.
364
365* Thu May 07 1998 Prospector System <bugs@redhat.com>
366- translations modified for de, fr, tr
367
368* Sun Apr 12 1998 Cristian Gafton <gafton@redhat.com>
369- added %clean
370- manhattan build
371
372* Wed Mar 04 1998 Cristian Gafton <gafton@redhat.com>
373- upgraded to version 3.12
374- added buildroot
375
376* Sun Nov 09 1997 Donnie Barnes <djb@redhat.com>
377- moved /usr/info/dir to /etc/info-dir and made /usr/info/dir a
378  symlink to /etc/info-dir.
379
380* Wed Oct 29 1997 Donnie Barnes <djb@redhat.com>
381- added wmconfig entry for info
382
383* Wed Oct 01 1997 Donnie Barnes <djb@redhat.com>
384- stripped /sbin/install-info
385
386* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
387- added info-dir to filelist
388
389* Sun Sep 14 1997 Erik Troan <ewt@redhat.com>
390- added patch from sopwith to let install-info understand gzip'ed info files
391- use skeletal dir file from texinfo tarball (w/ bash entry to reduce
392  dependency chain) instead (and install-info command everywhere else)
393- patches install-info to handle .gz names correctly
394
395* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
396- built against glibc
397
398* Tue Feb 25 1997 Erik Troan <ewt@redhat.com>
399- patched install-info.c for glibc.
400- added /usr/bin/install-info to the filelist
401
402* Tue Feb 18 1997 Michael Fulbright <msf@redhat.com>
403- upgraded to version 3.9.
Note: See TracBrowser for help on using the repository browser.