source: projects/specs/trunk/t/telnet/telnet-vl.spec @ 521

Revision 521, 8.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define telnet_version 0.17
2
3Summary: The client program for the telnet remote login protocol.
4Summary(ja): リモートログインプロトコル telnet のクライアントプログラム
5Name: telnet
6Version: %{telnet_version}.x
7Release: 31%{?_dist_release}
8License: BSD
9Group: Applications/Internet
10Source0: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-telnet-%{telnet_version}.tar.gz
11Source2: telnet-client.tar.gz
12Source3: telnet-xinetd
13Source4: telnet.wmconfig
14Patch1: telnet-client-cvs.patch
15Patch5: telnetd-0.17.diff
16Patch6: telnet-0.17-env.patch
17Patch7: telnet-0.17-issue.patch
18Patch8: telnet-0.17-sa-01-49.patch
19Patch9: telnet-0.17-env-5x.patch
20Patch10: telnet-0.17-pek.patch
21Patch11: telnet-0.17-8bit.patch
22Patch12: telnet-0.17-argv.patch
23Patch13: telnet-0.17-conf.patch
24Patch50: telnet-0.17-CAN-2005-468_469.patch
25BuildPreReq: ncurses-devel
26Buildroot: %{_tmppath}/%{name}-%{version}-root
27
28%description
29Telnet is a popular protocol for logging into remote systems over the
30Internet.  The telnet package provides a command line telnet client.
31
32Install the telnet package if you want to telnet to remote machines.
33
34This version has support for IPv6.
35
36%description -l ja
37Telnet はインターネット越しにリモートシステムへログインするための非常に
38ポピュラーなプロトコルです。telnet パッケージは telnet のコマンドライン
39クライアントを提供しています。
40
41リモートマシンへ telnet したい場合は telnet パッケージをインストールして
42ください。
43
44このバージョンは IPv6 をサポートしています。
45
46%package server
47Summary: The server program for the telnet remote login protocol.
48Summary(ja): リモートログインプロトコル telnet サーバトプログラム
49Requires: xinetd
50Group: System Environment/Daemons
51
52%description server
53Telnet is a popular protocol for logging into remote systems over the
54Internet.  The telnet-server package  a telnet daemon, which will
55support remote logins into the host machine.  The telnet daemon is
56enabled by default.  You may disable the telnet daemon by editing
57/etc/xinet.d/telnet
58
59Install the telnet-server package if you want to support remote logins
60to your own machine.
61
62%description -l ja server
63Telnet はインターネット越しにリモートシステムへログインするための非常に
64ポピュラーなプロトコルです。telnet-server パッケージにはホストマシンにリ
65モートログインの機能を提供する telnet デーモンが含まれています。
66xinetd または inetd の設定を編集することで telnet デーモンを停止すること
67ができます。
68
69あなたのマシンに外部から telnet でリモートログインできるようにするために
70は telnet-server パッケージをインストールしてください。
71
72%prep
73%setup -q -n netkit-telnet-%{telnet_version}
74
75mv telnet telnet-NETKIT
76%setup -T -D -q -a 2 -n netkit-telnet-%{telnet_version}
77
78%patch1 -p0 -b .cvs
79%patch5 -p0 -b .fix
80%patch6 -p1 -b .env
81%patch10 -p0 -b .pek
82%patch7 -p1 -b .issue
83%patch8 -p1 -b .sa-01-49
84%patch11 -p1 -b .8bit
85%patch12 -p1 -b .argv
86%patch13 -p1 -b .confverb
87
88%patch50  -p1 -b .CAN-2005-468_469
89
90%build
91sh configure --with-c-compiler=gcc
92perl -pi -e '
93    s,^CC=.*$,CC=cc,;
94    s,-O2,\$(RPM_OPT_FLAGS),;
95    s,^BINDIR=.*$,BINDIR=%{_bindir},;
96    s,^MANDIR=.*$,MANDIR=%{_mandir},;
97    s,^SBINDIR=.*$,SBINDIR=%{_sbindir},;
98    ' MCONFIG
99
100make
101
102%install
103rm -rf ${RPM_BUILD_ROOT}
104mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
105mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
106mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
107mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man5
108mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
109
110make INSTALLROOT=${RPM_BUILD_ROOT} install
111
112mkdir -p ${RPM_BUILD_ROOT}/etc/xinetd.d
113install -m644 %SOURCE3 ${RPM_BUILD_ROOT}/etc/xinetd.d/telnet
114
115%clean
116rm -rf ${RPM_BUILD_ROOT}
117
118%files
119%defattr(-,root,root)
120%{_bindir}/telnet
121%{_mandir}/man1/telnet.1*
122
123%{!?b5x:%files server}
124%defattr(-,root,root)
125%config(noreplace) /etc/xinetd.d/telnet
126%{_sbindir}/in.telnetd
127%{_mandir}/man5/issue.net.5*
128%{_mandir}/man8/in.telnetd.8*
129%{_mandir}/man8/telnetd.8*
130
131%changelog
132* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.x-31
133- Requires: xinetd instead of inetd
134
135* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 0.17.x-30vl5
136- applied new versioning policy, spec in utf-8
137
138* Thu Jul 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17.x-30vl2
139- rebuilt for VineSeed
140
141* Fri Apr 01 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.17.x-30vl1.1
142- added a security patch for CAN-2005-0468 and CAN-2005-0469 from Fedora.
143
144* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.x-30vl1
145- import patches from Fedora package
146- add Japanese summaries and desctiptions.
147- add xinetd config files.
148- remove old applnk files.
149
150* Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.6x-23vl1
151- merged with redhat package (patch10 for errata)
152
153* Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
154- 0.17.6x-18vl1: from RedHat updates
155
156* Tue Jul 31 2001 Harald Hoyer <harald@redhat.de>
157- fixed security issues (#50335)
158- patched the patches to fit the 5x version
159- one world -> one spec file for all versions ;)
160
161* Sat Jul 21 2001 Tim Powers <timp@redhat.com>
162- no applnk file, it's clutrtering the menus
163
164* Wed Jul 17 2001 Bill Nottingham <notting@redhat.com>
165- apply the patch, duh (and fix it while we're here)
166
167* Tue Jul 10 2001 Bill Nottingham <notting@redhat.com>
168- make /etc/issue.net parsing match the various gettys
169
170* Mon Jun 18 2001 Harald Hoyer <harald@redhat.de>
171- merged Jakubs and Pekka's patches
172
173* Wed Apr  4 2001 Jakub Jelinek <jakub@redhat.com>
174- don't let configure to guess compiler, it can pick up egcs
175
176* Fri Mar  9 2001 Pekka Savola <pekkas@netcore.fi>
177- update to 0.17
178- apply latest changes from CVS to telnet client, enable IPv6
179- BuildPreReq ncurses-devel
180
181* Mon Jan 22 2001 Helge Deller <hdeller@redhat.com>
182- added swedish & german translation to .desktop-file (#15332)
183
184* Sat Dec 30 2000 Nalin Dahyabhai <nalin@redhat.com>
185- mark the xinetd config file as config(noreplace)
186
187* Fri Dec 01 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
188- make sure the server is turned off by default
189
190* Tue Jul 18 2000 Bill Nottingham <notting@redhat.com>
191- add description & default to xinetd file
192
193* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
194- automatic rebuild
195
196* Mon Jun 19 2000 Jeff Johnson <jbj@redhat.com>
197- FHS packaging.
198- update to 0.17-pre20000412.
199
200* Tue May 23 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
201- moved the xinet entry to the server
202
203* Mon May 22 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
204- add an entry to /etc/xinetd.d
205
206* Tue May 16 2000 Jeff Johnson <jbj@redhat.com>
207- permit telnet queries only for exported variables.
208
209* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
210- 0.17
211
212* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
213- rebuild for sparc baud rates > 38400.
214
215* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
216- fix description
217
218* Mon Feb 07 2000 Preston Brown <pbrown@redhat.com>
219- wmconfig gone
220
221* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
222- man pages are compressed
223- fix description
224
225* Tue Jan  4 2000 Bill Nottingham <notting@redhat.com>
226- split client and server
227
228* Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com>
229- update to 0.16.
230
231* Sun Oct 10 1999 Matt Wilson <msw@redhat.com>
232- corrected the Terminal setting of the .desktop (needs to be 'true' not '1')
233
234* Sat Sep 24 1999 Preston Brown <pbrown@redhat.com>
235- red hat .desktop entry
236
237* Sat Aug 21 1999 Jeff Johnson <jbj@redhat.com>
238- rebuild for 6.1.
239
240* Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
241- don't trust random TERM variables in telnetd (#4560)
242
243* Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
244- fix (#3098).
245
246* Thu May 27 1999 Antti Andreimann <Antti.Andreimann@mail.ee>
247- fixed the problem with escape character (it could not be disabled)
248- changed the spec file to use %setup macro for unpacking telnet-client
249
250* Thu Apr 15 1999 Jeff Johnson <jbj@redhat.com>
251- use glibc utmp routines.
252
253* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
254- fix the fix (wrong way memcpy).
255
256* Wed Apr  7 1999 Jeff Johnson <jbj@redhat.com>
257- fix "telnet localhost" bus error on sparc64 (alpha?).
258
259* Tue Apr  6 1999 Jeff Johnson <jbj@redhat.com>
260- use OpenBSD telnet client (and fix minor core dump with .telnetrc #247)
261
262* Thu Mar 25 1999 Erik Troan <ewt@redhat.com>
263- use openpty in telnetd
264
265* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
266- auto rebuild in the new build environment (release 22)
267
268* Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
269- compile for 6.0.
270
271* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
272- translations modified for de, fr, tr
273
274* Fri Apr 24 1998 Cristian Gafton <gafton@redhat.com>
275- compile C++ code using egcs
276
277* Tue Apr 14 1998 Erik Troan <ewt@redhat.com>
278- built against new ncurses
279
280* Wed Oct 29 1997 Donnie Barnes <djb@redhat.com>
281- added wmconfig entry
282
283* Tue Jul 15 1997 Erik Troan <ewt@redhat.com>
284- initial build
Note: See TracBrowser for help on using the repository browser.