source: projects/specs/trunk/t/telnet/telnet-vl.spec @ 8738

Revision 8738, 10.5 KB checked in by kudoh, 10 years ago (diff)

new up stream release & rebuilt

Line 
1%define telnet_version 0.17
2
3Summary: The client program for the telnet remote login protocol.
4Summary(ja): リモートログインプロトコル telnet のクライアントプログラム
5Name: telnet
6Version: %{telnet_version}.x
7Release: 33%{?_dist_release}
8
9License: BSD
10Group: Applications/Internet
11URL: http://web.archive.org/web/20070819111735/www.hcs.harvard.edu/~dholland/computers/old-netkit.html
12
13Source0: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-telnet-%{telnet_version}.tar.gz
14Source2: telnet-client.tar.gz
15Source3: telnet-xinetd
16Source4: telnet.wmconfig
17Patch1: telnet-client-cvs.patch
18Patch5: telnetd-0.17.diff
19Patch6: telnet-0.17-env.patch
20Patch7: telnet-0.17-issue.patch
21Patch8: telnet-0.17-sa-01-49.patch
22Patch9: telnet-0.17-env-5x.patch
23Patch10: telnet-0.17-pek.patch
24Patch11: telnet-0.17-8bit.patch
25Patch12: telnet-0.17-argv.patch
26Patch13: telnet-0.17-conf.patch
27Patch14: telnet-0.17-cleanup_race.patch
28Patch15: telnetd-0.17-pty_read.patch
29Patch16: telnet-0.17-CAN-2005-468_469.patch
30Patch18: telnet-gethostbyname.patch
31Patch19: netkit-telnet-0.17-ipv6.diff
32Patch20: netkit-telnet-0.17-nodns.patch
33Patch21: telnet-0.17-errno_test_sys_bsd.patch
34Patch22: netkit-telnet-0.17-reallynodns.patch
35
36Buildroot: %{_tmppath}/%{name}-%{version}-root
37BuildRequires: ncurses-devel
38
39%description
40Telnet is a popular protocol for logging into remote systems over the
41Internet.  The telnet package provides a command line telnet client.
42
43Install the telnet package if you want to telnet to remote machines.
44
45This version has support for IPv6.
46
47%description -l ja
48Telnet はインターネット越しにリモートシステムへログインするための非常に
49ポピュラーなプロトコルです。telnet パッケージは telnet のコマンドライン
50クライアントを提供しています。
51
52リモートマシンへ telnet したい場合は telnet パッケージをインストールして
53ください。
54
55このバージョンは IPv6 をサポートしています。
56
57%package server
58Summary: The server program for the telnet remote login protocol.
59Summary(ja): リモートログインプロトコル telnet サーバトプログラム
60Requires: xinetd
61Group: System Environment/Daemons
62
63%description server
64Telnet is a popular protocol for logging into remote systems over the
65Internet.  The telnet-server package  a telnet daemon, which will
66support remote logins into the host machine.  The telnet daemon is
67enabled by default.  You may disable the telnet daemon by editing
68/etc/xinet.d/telnet
69
70Install the telnet-server package if you want to support remote logins
71to your own machine.
72
73%description -l ja server
74Telnet はインターネット越しにリモートシステムへログインするための非常に
75ポピュラーなプロトコルです。telnet-server パッケージにはホストマシンにリ
76モートログインの機能を提供する telnet デーモンが含まれています。
77xinetd または inetd の設定を編集することで telnet デーモンを停止すること
78ができます。
79
80あなたのマシンに外部から telnet でリモートログインできるようにするために
81は telnet-server パッケージをインストールしてください。
82
83%prep
84%setup -q -n netkit-telnet-%{telnet_version}
85
86mv telnet telnet-NETKIT
87%setup -T -D -q -a 2 -n netkit-telnet-%{telnet_version}
88
89%patch1 -p0 -b .cvs
90%patch5 -p0 -b .fix
91%patch6 -p1 -b .env
92%patch10 -p0 -b .pek
93%patch7 -p1 -b .issue
94%patch8 -p1 -b .sa-01-49
95%patch11 -p1 -b .8bit
96%patch12 -p1 -b .argv
97%patch13 -p1 -b .confverb
98%patch14 -p1 -b .cleanup_race
99%patch15 -p0 -b .pty_read
100%patch16 -p1 -b .CAN-2005-468_469
101#%patch17 -p1 -b .linemode
102%patch18 -p1 -b .gethost
103%patch19 -p1 -b .gethost2
104%patch20 -p1 -b .nodns
105%patch21 -p1 -b .errnosysbsd
106%patch22 -p1 -b .reallynodns
107
108%build
109sh configure --with-c-compiler=gcc
110perl -pi -e '
111    s,^CC=.*$,CC=cc,;
112    s,-O2,\$(RPM_OPT_FLAGS),;
113    s,^BINDIR=.*$,BINDIR=%{_bindir},;
114    s,^MANDIR=.*$,MANDIR=%{_mandir},;
115    s,^SBINDIR=.*$,SBINDIR=%{_sbindir},;
116    ' MCONFIG
117
118make
119
120%install
121rm -rf ${RPM_BUILD_ROOT}
122mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
123mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
124mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
125mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man5
126mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
127
128make INSTALLROOT=${RPM_BUILD_ROOT} install
129
130mkdir -p ${RPM_BUILD_ROOT}/etc/xinetd.d
131install -m644 %SOURCE3 ${RPM_BUILD_ROOT}/etc/xinetd.d/telnet
132
133%clean
134rm -rf ${RPM_BUILD_ROOT}
135
136%files
137%defattr(-,root,root)
138%doc README
139%{_bindir}/telnet
140%{_mandir}/man1/telnet.1*
141
142%{!?b5x:%files server}
143%defattr(-,root,root)
144%config(noreplace) /etc/xinetd.d/telnet
145%{_sbindir}/in.telnetd
146%{_mandir}/man5/issue.net.5*
147%{_mandir}/man8/in.telnetd.8*
148%{_mandir}/man8/telnetd.8*
149
150%changelog
151* Sat Jul 05 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.17.x-33
152- rebuilt current environment
153
154* Sun Apr 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17.x-32
155- rebuilt with current VineSeed
156- used BuildRequires instead of BuildPrereq
157- added Patch 14, 15, 18-22 from Fedora
158  * Wed Sep 02 2009 Adam Tkac <atkac redhat com> 1:0.17-45
159  - add new option -N to disable DNS lookups (#490242)
160  * Tue Sep 25 2007 Adam Tkac <atkac redhat com> 1:0.17-41
161  - rebased "nodns" patch with patch from Bryn M. Reeves
162  * Fri Jul 14 2006 Harald Hoyer <harald@redhat.com> - 1:0.17-37
163  - added netkit-telnet-0.17-ipv6.diff from Marek Grác,
164    which adds IPv6 support to telnetd
165  * Mon May 08 2006 Harald Hoyer <harald@redhat.com> - 1:0.17-36
166  - patch to remove gethostbyname() (bug #190296)
167  * Fri Jan 21 2005 Harald Hoyer <harald@redhat.com> - 1:0.17-33
168  - added patch telnetd-0.17-pty_read.patch, which fixes 145636
169  * Thu Jan 13 2005 Jason Vas Dias <jvdias@redhat.com> - 1:0.17-31
170  - bug 143929 / 145004 : fix race condition in telnetd on wtmp lock
171  - when cleanup() is entered from main process and in signal
172  - handler
173
174* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.x-31
175- Requires: xinetd instead of inetd
176
177* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 0.17.x-30vl5
178- applied new versioning policy, spec in utf-8
179
180* Thu Jul 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17.x-30vl2
181- rebuilt for VineSeed
182
183* Fri Apr 01 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.17.x-30vl1.1
184- added a security patch for CAN-2005-0468 and CAN-2005-0469 from Fedora.
185
186* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.x-30vl1
187- import patches from Fedora package
188- add Japanese summaries and desctiptions.
189- add xinetd config files.
190- remove old applnk files.
191
192* Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.6x-23vl1
193- merged with redhat package (patch10 for errata)
194
195* Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
196- 0.17.6x-18vl1: from RedHat updates
197
198* Tue Jul 31 2001 Harald Hoyer <harald@redhat.de>
199- fixed security issues (#50335)
200- patched the patches to fit the 5x version
201- one world -> one spec file for all versions ;)
202
203* Sat Jul 21 2001 Tim Powers <timp@redhat.com>
204- no applnk file, it's clutrtering the menus
205
206* Wed Jul 17 2001 Bill Nottingham <notting@redhat.com>
207- apply the patch, duh (and fix it while we're here)
208
209* Tue Jul 10 2001 Bill Nottingham <notting@redhat.com>
210- make /etc/issue.net parsing match the various gettys
211
212* Mon Jun 18 2001 Harald Hoyer <harald@redhat.de>
213- merged Jakubs and Pekka's patches
214
215* Wed Apr  4 2001 Jakub Jelinek <jakub@redhat.com>
216- don't let configure to guess compiler, it can pick up egcs
217
218* Fri Mar  9 2001 Pekka Savola <pekkas@netcore.fi>
219- update to 0.17
220- apply latest changes from CVS to telnet client, enable IPv6
221- BuildPreReq ncurses-devel
222
223* Mon Jan 22 2001 Helge Deller <hdeller@redhat.com>
224- added swedish & german translation to .desktop-file (#15332)
225
226* Sat Dec 30 2000 Nalin Dahyabhai <nalin@redhat.com>
227- mark the xinetd config file as config(noreplace)
228
229* Fri Dec 01 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
230- make sure the server is turned off by default
231
232* Tue Jul 18 2000 Bill Nottingham <notting@redhat.com>
233- add description & default to xinetd file
234
235* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
236- automatic rebuild
237
238* Mon Jun 19 2000 Jeff Johnson <jbj@redhat.com>
239- FHS packaging.
240- update to 0.17-pre20000412.
241
242* Tue May 23 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
243- moved the xinet entry to the server
244
245* Mon May 22 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
246- add an entry to /etc/xinetd.d
247
248* Tue May 16 2000 Jeff Johnson <jbj@redhat.com>
249- permit telnet queries only for exported variables.
250
251* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
252- 0.17
253
254* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
255- rebuild for sparc baud rates > 38400.
256
257* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
258- fix description
259
260* Mon Feb 07 2000 Preston Brown <pbrown@redhat.com>
261- wmconfig gone
262
263* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
264- man pages are compressed
265- fix description
266
267* Tue Jan  4 2000 Bill Nottingham <notting@redhat.com>
268- split client and server
269
270* Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com>
271- update to 0.16.
272
273* Sun Oct 10 1999 Matt Wilson <msw@redhat.com>
274- corrected the Terminal setting of the .desktop (needs to be 'true' not '1')
275
276* Sat Sep 24 1999 Preston Brown <pbrown@redhat.com>
277- red hat .desktop entry
278
279* Sat Aug 21 1999 Jeff Johnson <jbj@redhat.com>
280- rebuild for 6.1.
281
282* Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
283- don't trust random TERM variables in telnetd (#4560)
284
285* Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
286- fix (#3098).
287
288* Thu May 27 1999 Antti Andreimann <Antti.Andreimann@mail.ee>
289- fixed the problem with escape character (it could not be disabled)
290- changed the spec file to use %setup macro for unpacking telnet-client
291
292* Thu Apr 15 1999 Jeff Johnson <jbj@redhat.com>
293- use glibc utmp routines.
294
295* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
296- fix the fix (wrong way memcpy).
297
298* Wed Apr  7 1999 Jeff Johnson <jbj@redhat.com>
299- fix "telnet localhost" bus error on sparc64 (alpha?).
300
301* Tue Apr  6 1999 Jeff Johnson <jbj@redhat.com>
302- use OpenBSD telnet client (and fix minor core dump with .telnetrc #247)
303
304* Thu Mar 25 1999 Erik Troan <ewt@redhat.com>
305- use openpty in telnetd
306
307* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
308- auto rebuild in the new build environment (release 22)
309
310* Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
311- compile for 6.0.
312
313* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
314- translations modified for de, fr, tr
315
316* Fri Apr 24 1998 Cristian Gafton <gafton@redhat.com>
317- compile C++ code using egcs
318
319* Tue Apr 14 1998 Erik Troan <ewt@redhat.com>
320- built against new ncurses
321
322* Wed Oct 29 1997 Donnie Barnes <djb@redhat.com>
323- added wmconfig entry
324
325* Tue Jul 15 1997 Erik Troan <ewt@redhat.com>
326- initial build
Note: See TracBrowser for help on using the repository browser.