source: projects/specs/trunk/t/tcsh/tcsh-vl.spec @ 521

Revision 521, 7.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _bindir /bin
2
3Summary: An enhanced version of csh, the C shell
4Summary(ja): csh, Cシェルの進化バージョン
5Name: tcsh
6Version: 6.16
7Release: 1%{?_dist_release}
8License: BSD
9URL: http://www.tcsh.org/
10Group: System Environment/Shells
11
12Source: ftp://ftp.astron.com/pub/tcsh/%{name}-%{version}.00.tar.gz
13Patch1: tcsh-6.15.00-closem.patch
14Patch2: tcsh-6.14.00-tinfo.patch
15Patch3: tcsh-6.14.00-unprintable.patch
16Patch4: tcsh-6.15.00-hist-sub.patch
17Patch6: tcsh-6.15.00-ca-color.patch
18Patch7: tcsh-6.14.00-set.patch
19Patch8: tcsh-6.14.00-syntax.patch
20Patch9: tcsh-6.13.00-memoryuse.patch
21Patch11: tcsh-6.14.00-order.patch
22Patch12: tcsh-6.15.00-wide-str.patch
23Patch13: tcsh-6.15.00-rs-color.patch
24
25Provides: csh = %{version}
26Requires(post): grep
27Requires(postun): coreutils, grep
28
29Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
30BuildRequires: autoconf, automake, ncurses-devel, gettext-devel
31
32%description
33Tcsh is an enhanced but completely compatible version of csh, the C
34shell.  Tcsh is a command language interpreter which can be used both
35as an interactive login shell and as a shell script command processor.
36Tcsh includes a command line editor, programmable word completion,
37spelling correction, a history mechanism, job control and a C language
38like syntax.
39
40%description -l ja
41tcsh は、バークレイ版 UNIX の C シェル csh と完全に互換性があり、
42さらに機能強化したシェルです。対話的なログインシェル、またシェルス
43クリプトのコマンドプロセッサの両方の用途で使われるコマンドインタプ
44リタです。
45tcsh には、コマンド行編集機能や、プログラム可能な単語の補完機能、
46スペル訂正、履歴、ジョブ制御、C 言語風の文法等が含まれます。
47
48%prep
49%setup -q -n %{name}-%{version}.00
50%patch1 -p1 -b .closem
51%patch2 -p1 -b .tinfo
52%patch3 -p1 -b .unprintable
53%patch4 -p1 -b .hist-sub
54%patch6 -p1 -b .ca-color
55%patch7 -p1 -b .set
56%patch8 -p1 -b .syntax
57%patch9 -p1 -b .memoryuse
58%patch11 -p1 -b .order
59%patch12 -p1 -b .wide-str
60%patch13 -p1 -b .rs-color
61
62for i in Fixes WishList; do
63 iconv -f iso-8859-1 -t utf-8 "$i" > "${i}_" && \
64 touch -r "$i" "${i}_" && \
65 mv "${i}_" "$i"
66done
67
68%build
69# For tcsh-6.14.00-tinfo.patch
70autoreconf
71%configure --without-hesiod
72make %{?_smp_mflags} all
73make %{?_smp_mflags} -C nls catalogs
74
75%install
76rm -rf $RPM_BUILD_ROOT
77mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1 ${RPM_BUILD_ROOT}%{_bindir}
78install -p -m 755 tcsh ${RPM_BUILD_ROOT}%{_bindir}/tcsh
79install -p -m 644 tcsh.man ${RPM_BUILD_ROOT}%{_mandir}/man1/tcsh.1
80ln -sf tcsh ${RPM_BUILD_ROOT}%{_bindir}/csh
81ln -sf tcsh.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/csh.1
82
83while read lang language ; do
84        dest=${RPM_BUILD_ROOT}%{_datadir}/locale/$lang/LC_MESSAGES
85        if test -f tcsh.$language.cat ; then
86                mkdir -p $dest
87                install -p -m 644 tcsh.$language.cat $dest/tcsh
88                echo "%lang($lang) %{_datadir}/locale/$lang/LC_MESSAGES/tcsh"
89        fi
90done > tcsh.lang << _EOF
91de german
92el greek
93en C
94es spanish
95et et
96fi finnish
97fr french
98it italian
99ja ja
100pl pl
101ru russian
102uk ukrainian
103_EOF
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post
109if [ ! -f /etc/shells ]; then
110 echo "%{_bindir}/tcsh" >> /etc/shells
111 echo "%{_bindir}/csh"  >> /etc/shells
112else
113 grep -q '^%{_bindir}/tcsh$' /etc/shells || \
114 echo "%{_bindir}/tcsh" >> /etc/shells
115 grep -q '^%{_bindir}/csh$'  /etc/shells || \
116 echo "%{_bindir}/csh"  >> /etc/shells
117fi
118
119%postun
120if [ ! -x %{_bindir}/tcsh ]; then
121 grep -v '^%{_bindir}/tcsh$'  /etc/shells | \
122 grep -v '^%{_bindir}/csh$' > /etc/shells.rpm && \
123 mv /etc/shells.rpm /etc/shells
124fi
125
126%files -f tcsh.lang
127%defattr(-,root,root,-)
128%doc BUGS FAQ Fixes NewThings WishList complete.tcsh
129%{_bindir}/tcsh
130%{_bindir}/csh
131%{_mandir}/man1/*.1*
132
133%changelog
134* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 6.16-1
135- new upstream release
136- resync with 6.16-1(fc12)
137- drop vine patch
138
139* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 6.12-1vl5
140- applied new versioning policy, spec in utf-8
141
142* Wed Oct 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 6.12-0vl6
143- added patch11 from fedora
144  * Thu Mar 23 2006 Miloslav Trmac <mitr@redhat.com> - 6.14-8
145  - Backport a patch to ignore LS_COLOR codes introduced in newer coreutils
146    (#186037)
147- added japanese description
148
149* Thu Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.12-0vl5
150- added patch from fedora
151  * Tue Feb 10 2004 Nalin Dahyabhai <nalin@redhat.com> 6.12-7
152  - remove declaration of setpgrp() which conflicts with libc's (#115185)
153
154  * Fri Nov 21 2003 Nalin Dahyabhai <nalin@redhat.com> 6.12-6
155  - add missing buildprereqs on groff, libtermcap-devel (#110599)
156
157* Mon Oct 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.12-0vl4
158- rebuild with new toolchains
159- s/Copyright/License/
160- fix spec file to build correctly (based on Rawhide spec file)
161
162* Tue Aug 06 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.12-0vl3
163- "Re"-changed the way of fixing check locale from Patch8 to Patch9
164  on ppc strlen() can not deal with 'short' variables
165
166* Sat Aug 03 2002 Satoshi MACHINO <machino@vinelinux.org> 6.12-0vl2
167- fixed changelog
168
169* Thu Jul 25 2002 K. Nagasaka <nagasaka@math.tsukuba.ac.jp> 6.12-0vl1
170- update
171
172* Sun Apr 28 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.11-0vl4
173- change limit.patch
174
175* Fri Apr 26 2002 Kosaku Nagasaka <nagasaka@math.tsukuba.ac.jp> 6.11-0vl3
176- fixed limit by Patch10
177
178* Sun Jan 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.11-0vl2
179- changed the way of fixing check locale from Patch8 to Patch9
180  on ppc strlen() can not deal with 'short' variables
181
182* Mon Jan 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.11-0vl1
183- update
184
185* Thu Dec 28 2001 Satoshi MACHINO <machino@vinelinux.org> 6.10.02-0vl2
186- fixed check locale
187        - merged some patches from RHL-7.2
188
189* Thu Aug 09 2001 <sagami@vinelinux.org>
190- 6.10.02-0vl1
191
192* Sun Jan  7 2001 Jun Nishii <jun@vinelinux.org>
193- 6.10-1vl2
194- build with gcc
195
196* Mon Dec 11 2000 Yasuhide OOMORI <dasen@icntv.ne.jp>
197- syncronized release tcsh based on a securty fix for RH6.2.
198
199* Thu Nov 30 2000 Nalin Dahyabhai <nalin@redhat.com>
200- update to 6.10.00 to fix here-script vulnerability
201
202* Wed Sep 18 2000 Adrian Havill <havill@redhat.com>
203- fix catalog locale dirname for Japanese
204
205* Thu Jun 15 2000 Jeff Johnson <jbj@redhat.com>
206- FHS packaging.
207- add locale support (#10345).
208
209* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
210- rebuild for sparc baud rates > 38400.
211
212* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
213- rebuild to fix dependencies
214
215* Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
216- append entries to spanking new /etc/shells.
217
218* Mon Jan 10 2000 Jeff Johnson <jbj@redhat.com>
219- update to 6.09.
220- fix strcoll oddness (#6000, #6244, #6398).
221
222* Sat Sep 25 1999 Michael K. Johnson <johnsonm@redhat.com>
223- fix $shell by using --bindir
224
225* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
226- auto rebuild in the new build environment (release 5)
227
228* Wed Feb 24 1999 Cristian Gafton <gafton@redhat.com>
229- patch for using PATH_MAX instead of some silly internal #defines for
230  variables that handle filenames.
231
232* Fri Nov  6 1998 Jeff Johnson <jbj@redhat.com>
233- update to 6.08.00.
234
235* Fri Oct 02 1998 Cristian Gafton <gafton@redhat.com>
236- upgraded to 6.07.09 from the freebsd
237- security fix
238
239* Wed Aug  5 1998 Jeff Johnson <jbj@redhat.com>
240- use -ltermcap so that /bin/tcsh can be used in single user mode w/o /usr.
241- update url's
242
243* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
244- translations modified for de, fr, tr
245
246* Thu Oct 21 1997 Cristian Gafton <gafton@redhat.com>
247- updated to 6.07; added BuildRoot
248- cleaned up the spec file; fixed source url
249
250* Wed Sep 03 1997 Erik Troan <ewt@redhat.com>
251- added termios hacks for new glibc
252- added /bin/csh to file list
253
254* Fri Jun 13 1997 Erik Troan <ewt@redhat.com>
255- built against glibc
256
257* Fri Feb 07 1997 Erik Troan <ewt@redhat.com>
258 - Provides csh, adds and removes /bin/csh from /etc/shells if csh package
259isn't installed.
Note: See TracBrowser for help on using the repository browser.