source: projects/specs/trunk/t/tcsh/tcsh-vl.spec @ 12335

Revision 12335, 11.0 KB checked in by tomop, 4 years ago (diff)

updated 14 packages

chkconfig-1.3.61-3

diffutils-3.7-1

findutils-4.7.0-1

libmpc-1.1.0-1

libuser-0.62-1

libutempter-1.1.6-2

mpfr-4.0.2-1

mpfr3-3.1.6-1

psmisc-23.2-1

sed-4.8-1

shadow-utils-4.8-1

tcsh-6.22.02-1

texinfo-6.7-1

usermode-1.109-2

Line 
1%define _bindir /bin
2
3Summary: An enhanced version of csh, the C shell
4Summary(ja): csh, Cシェルの進化バージョン
5Name: tcsh
6Version: 6.22.02
7Release: 1%{?_dist_release}
8License: BSD
9URL: http://www.tcsh.org/
10Group: System Environment/Shells
11
12Source: https://astron.com/pub/tcsh/%{name}-%{version}.tar.gz
13# NOTE: 'autosetup' macro (below) uses 'git' for applying the patches:
14#       ->> All the patches should be provided in 'git format-patch' format.
15#       ->> Auxiliary repository will be created during 'fedpkg prep', you
16#           can see all the applied patches there via 'git log'.
17
18# Upstream patches -- official upstream patches released by upstream since the
19# ----------------    last rebase that are necessary for any reason:
20Patch001: tcsh-6.22.02-avoid-gcc-to-fail.patch
21
22
23# Downstream patches -- these should be always included when doing rebase:
24# ------------------
25Patch100: tcsh-6.20.00-manpage-memoryuse.patch
26
27Provides: csh = %{version}
28Requires(post): grep
29Requires(postun): coreutils, grep
30
31Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
32BuildRequires: autoconf, automake, ncurses-devel, gettext-devel, git
33
34%description
35Tcsh is an enhanced but completely compatible version of csh, the C
36shell.  Tcsh is a command language interpreter which can be used both
37as an interactive login shell and as a shell script command processor.
38Tcsh includes a command line editor, programmable word completion,
39spelling correction, a history mechanism, job control and a C language
40like syntax.
41
42%description -l ja
43tcsh は、バークレイ版 UNIX の C シェル csh と完全に互換性があり、
44さらに機能強化したシェルです。対話的なログインシェル、またシェルス
45クリプトのコマンドプロセッサの両方の用途で使われるコマンドインタプ
46リタです。
47tcsh には、コマンド行編集機能や、プログラム可能な単語の補完機能、
48スペル訂正、履歴、ジョブ制御、C 言語風の文法等が含まれます。
49
50
51%prep
52%autosetup -N -S git
53
54# NOTE: If more files needs to be converted, add them here:
55for file in Fixes; do
56  iconv -f iso-8859-1 -t utf-8 "$file" > "${file}.converted" && \
57  touch -r "$file" "${file}.converted" && \
58  mv "${file}.converted" "$file"
59done
60
61# Also, rename the Copyright so we comply with more generally accepted name:
62mv Copyright COPYING
63
64# Amend the converted files to the initial commit, and patch the source code:
65git add --all --force
66git commit --all --amend --no-edit > /dev/null
67%autopatch -p1
68
69
70%build
71# For tcsh-6.14.00-tinfo.patch
72autoreconf
73%configure --without-hesiod
74make %{?_smp_mflags} all
75make %{?_smp_mflags} -C nls catalogs
76
77
78%install
79rm -rf $RPM_BUILD_ROOT
80mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1 ${RPM_BUILD_ROOT}%{_bindir}
81install -p -m 755 tcsh ${RPM_BUILD_ROOT}%{_bindir}/tcsh
82install -p -m 644 tcsh.man ${RPM_BUILD_ROOT}%{_mandir}/man1/tcsh.1
83ln -sf tcsh ${RPM_BUILD_ROOT}%{_bindir}/csh
84ln -sf tcsh.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/csh.1
85
86while read lang language ; do
87        dest=${RPM_BUILD_ROOT}%{_datadir}/locale/$lang/LC_MESSAGES
88        if test -f tcsh.$language.cat ; then
89                mkdir -p $dest
90                install -p -m 644 tcsh.$language.cat $dest/tcsh
91                echo "%lang($lang) %{_datadir}/locale/$lang/LC_MESSAGES/tcsh"
92        fi
93done > tcsh.lang << _EOF
94de german
95el greek
96en C
97es spanish
98et et
99fi finnish
100fr french
101it italian
102ja ja
103pl pl
104ru russian
105uk ukrainian
106_EOF
107
108
109%check
110%make_build check
111
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%post
117if [ ! -f /etc/shells ]; then
118 echo "%{_bindir}/tcsh" >> /etc/shells
119 echo "%{_bindir}/csh"  >> /etc/shells
120else
121 grep -q '^%{_bindir}/tcsh$' /etc/shells || \
122 echo "%{_bindir}/tcsh" >> /etc/shells
123 grep -q '^%{_bindir}/csh$'  /etc/shells || \
124 echo "%{_bindir}/csh"  >> /etc/shells
125fi
126
127%postun
128if [ ! -x %{_bindir}/tcsh ]; then
129 grep -v '^%{_bindir}/tcsh$'  /etc/shells | \
130 grep -v '^%{_bindir}/csh$' > /etc/shells.rpm && \
131 mv /etc/shells.rpm /etc/shells
132fi
133
134%files -f tcsh.lang
135%defattr(-,root,root,-)
136%doc BUGS FAQ Fixes NewThings WishList complete.tcsh
137%{_bindir}/tcsh
138%{_bindir}/csh
139%{_mandir}/man1/*.1*
140
141%changelog
142* Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.22.02
143- new upstream release.
144
145* Sun Jul 20 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.18.01-1
146- update to 6.18.01
147
148* Sun Jun 12 2011 IWAI, Masaharu <iwai@alib.jp> 6.17-1
149- new upstream release
150- drop wide str patch (Patch12): upstream fixed
151- update ca-color patch (Patch6) from Fedora tcsh-6.17-15
152- update syntax patch (Patch8) from Fedora tcsh-6.17-15
153- update rs-color patch from Fedora tcsh-6.17-15
154- resync with Fedora tcsh-6.17-15
155 - change patch number Patch13 -> Patch12
156 - add Patch13..24
157  * Thu Mar 24 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-15
158  - Avoid infinite loop pendjob()-xprintf() when stdout is closed
159    Resolves: #690356
160 
161  * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.17-14
162  - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
163 
164  * Fri Jan 28 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-13
165  - Modify verbose patch to match with upstream (don't print on history -S)
166    Resolves: #672810
167 
168  * Wed Jan 26 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-12
169  - Fix error message on exit
170    Resolves: #672810
171 
172  * Mon Jan 24 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-11
173  - Don't set $REMOTEHOST on the local machine
174    Resolves: #669176
175  - Don't print history in verbose mode
176    Resolves: #583075, #658171
177  - Don't allow illegal variable names to be set
178    Resolves: #436901
179  - Revert "Fix incorrect $status value of pipelined commands"
180 
181  * Tue Dec 21 2010 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-10
182  - Make wait builtin command interruptible
183    Resolves: #440465
184  - Fix incorrect $status value of pipelined commands
185    Resolves: #638955 (Patch by Tomas Smetana <tsmetana@redhat.com>)
186 
187  * Wed Oct  6 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-9
188  - Remove fork when tcsh processes backquotes
189 
190  * Wed Apr 14 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-8
191  - Fix testsuite
192 
193  * Mon Mar  1 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-7
194  - Ship README file
195 
196  * Tue Dec 15 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-6
197  - Fix tcsh obeys printexitvalue for back-ticks
198 
199  * Wed Nov  4 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-5
200  - Fix few globbing problems
201 
202  * Mon Oct 19 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-4
203  - Fix tcsh globbing causing bad automount
204  - Fix truncated history file after network crash
205 
206  * Wed Aug 26 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-3
207  - Add new colorls variable
208    Resolves: #518808
209 
210  * Sun Jul 26 2009 Fedora Release Engineering <releng@lists.fedoraproject.org> - 6.17-2
211  - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
212 
213  * Mon Jul 20 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-1
214  - Update to tcsh-6.17.00
215
216* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.16-2
217- rebuilt with current VineSeed
218
219* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 6.16-1
220- new upstream release
221- resync with 6.16-1(fc12)
222- drop vine patch
223
224* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 6.12-1vl5
225- applied new versioning policy, spec in utf-8
226
227* Wed Oct 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 6.12-0vl6
228- added patch11 from fedora
229  * Thu Mar 23 2006 Miloslav Trmac <mitr@redhat.com> - 6.14-8
230  - Backport a patch to ignore LS_COLOR codes introduced in newer coreutils
231    (#186037)
232- added japanese description
233
234* Fri Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.12-0vl5
235- added patch from fedora
236  * Tue Feb 10 2004 Nalin Dahyabhai <nalin@redhat.com> 6.12-7
237  - remove declaration of setpgrp() which conflicts with libc's (#115185)
238
239  * Fri Nov 21 2003 Nalin Dahyabhai <nalin@redhat.com> 6.12-6
240  - add missing buildprereqs on groff, libtermcap-devel (#110599)
241
242* Mon Oct 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.12-0vl4
243- rebuild with new toolchains
244- s/Copyright/License/
245- fix spec file to build correctly (based on Rawhide spec file)
246
247* Tue Aug 06 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.12-0vl3
248- "Re"-changed the way of fixing check locale from Patch8 to Patch9
249  on ppc strlen() can not deal with 'short' variables
250
251* Sat Aug 03 2002 Satoshi MACHINO <machino@vinelinux.org> 6.12-0vl2
252- fixed changelog
253
254* Thu Jul 25 2002 K. Nagasaka <nagasaka@math.tsukuba.ac.jp> 6.12-0vl1
255- update
256
257* Sun Apr 28 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.11-0vl4
258- change limit.patch
259
260* Fri Apr 26 2002 Kosaku Nagasaka <nagasaka@math.tsukuba.ac.jp> 6.11-0vl3
261- fixed limit by Patch10
262
263* Sun Jan 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.11-0vl2
264- changed the way of fixing check locale from Patch8 to Patch9
265  on ppc strlen() can not deal with 'short' variables
266
267* Mon Jan 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.11-0vl1
268- update
269
270* Fri Dec 28 2001 Satoshi MACHINO <machino@vinelinux.org> 6.10.02-0vl2
271- fixed check locale
272        - merged some patches from RHL-7.2
273
274* Thu Aug 09 2001 <sagami@vinelinux.org>
275- 6.10.02-0vl1
276
277* Sun Jan  7 2001 Jun Nishii <jun@vinelinux.org>
278- 6.10-1vl2
279- build with gcc
280
281* Mon Dec 11 2000 Yasuhide OOMORI <dasen@icntv.ne.jp>
282- syncronized release tcsh based on a securty fix for RH6.2.
283
284* Thu Nov 30 2000 Nalin Dahyabhai <nalin@redhat.com>
285- update to 6.10.00 to fix here-script vulnerability
286
287* Mon Sep 18 2000 Adrian Havill <havill@redhat.com>
288- fix catalog locale dirname for Japanese
289
290* Thu Jun 15 2000 Jeff Johnson <jbj@redhat.com>
291- FHS packaging.
292- add locale support (#10345).
293
294* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
295- rebuild for sparc baud rates > 38400.
296
297* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
298- rebuild to fix dependencies
299
300* Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
301- append entries to spanking new /etc/shells.
302
303* Mon Jan 10 2000 Jeff Johnson <jbj@redhat.com>
304- update to 6.09.
305- fix strcoll oddness (#6000, #6244, #6398).
306
307* Sat Sep 25 1999 Michael K. Johnson <johnsonm@redhat.com>
308- fix $shell by using --bindir
309
310* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
311- auto rebuild in the new build environment (release 5)
312
313* Wed Feb 24 1999 Cristian Gafton <gafton@redhat.com>
314- patch for using PATH_MAX instead of some silly internal #defines for
315  variables that handle filenames.
316
317* Fri Nov  6 1998 Jeff Johnson <jbj@redhat.com>
318- update to 6.08.00.
319
320* Fri Oct 02 1998 Cristian Gafton <gafton@redhat.com>
321- upgraded to 6.07.09 from the freebsd
322- security fix
323
324* Wed Aug  5 1998 Jeff Johnson <jbj@redhat.com>
325- use -ltermcap so that /bin/tcsh can be used in single user mode w/o /usr.
326- update url's
327
328* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
329- translations modified for de, fr, tr
330
331* Tue Oct 21 1997 Cristian Gafton <gafton@redhat.com>
332- updated to 6.07; added BuildRoot
333- cleaned up the spec file; fixed source url
334
335* Wed Sep 03 1997 Erik Troan <ewt@redhat.com>
336- added termios hacks for new glibc
337- added /bin/csh to file list
338
339* Fri Jun 13 1997 Erik Troan <ewt@redhat.com>
340- built against glibc
341
342* Fri Feb 07 1997 Erik Troan <ewt@redhat.com>
343 - Provides csh, adds and removes /bin/csh from /etc/shells if csh package
344isn't installed.
Note: See TracBrowser for help on using the repository browser.