source: projects/specs/trunk/t/tcsh/tcsh-vl.spec @ 8847

Revision 8847, 11.1 KB checked in by daisuke, 10 years ago (diff)

tcsh: update to 6.18.01

Line 
1%define _bindir /bin
2
3Summary: An enhanced version of csh, the C shell
4Summary(ja): csh, Cシェルの進化バージョン
5Name: tcsh
6Version: 6.18.01
7Release: 1%{?_dist_release}
8License: BSD
9URL: http://www.tcsh.org/
10Group: System Environment/Shells
11
12Source: ftp://ftp.astron.com/pub/tcsh/%{name}-%{version}.tar.gz
13Patch1: tcsh-6.15.00-closem.patch
14Patch2: tcsh-6.14.00-tinfo.patch
15Patch3: tcsh-6.14.00-unprintable.patch
16Patch4: tcsh-6.15.00-hist-sub.patch
17Patch8: tcsh-6.14.00-syntax.patch
18Patch9: tcsh-6.13.00-memoryuse.patch
19Patch11: tcsh-6.14.00-order.patch
20# Proposed upstream - http://github.com/tcsh-org/tcsh/pull/1
21Patch28: tcsh-6.17.00-manpage-spelling.patch
22# Proposed upstream - http://github.com/tcsh-org/tcsh/pull/2
23Patch31: tcsh-6.18.00-history-file-locking.patch
24Patch33: tcsh-6.18.00-history-merge.patch
25Patch34: tcsh-6.18.01-repeated-words-man.patch
26# Proposed upstream - http://mx.gw.com/pipermail/tcsh-bugs/2013-April/000833.html
27Patch35: tcsh-6.18.01-elf-interpreter.patch
28Patch36: tcsh-6.18.01-posix-exit-status-value.patch
29Patch37: tcsh-6.18.01-reverse-history-handling-in-loops.patch
30
31Provides: csh = %{version}
32Requires(post): grep
33Requires(postun): coreutils, grep
34
35Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
36BuildRequires: autoconf, automake, ncurses-devel, gettext-devel
37
38%description
39Tcsh is an enhanced but completely compatible version of csh, the C
40shell.  Tcsh is a command language interpreter which can be used both
41as an interactive login shell and as a shell script command processor.
42Tcsh includes a command line editor, programmable word completion,
43spelling correction, a history mechanism, job control and a C language
44like syntax.
45
46%description -l ja
47tcsh は、バークレイ版 UNIX の C シェル csh と完全に互換性があり、
48さらに機能強化したシェルです。対話的なログインシェル、またシェルス
49クリプトのコマンドプロセッサの両方の用途で使われるコマンドインタプ
50リタです。
51tcsh には、コマンド行編集機能や、プログラム可能な単語の補完機能、
52スペル訂正、履歴、ジョブ制御、C 言語風の文法等が含まれます。
53
54%prep
55%setup -q
56%patch1 -p1 -b .closem
57%patch2 -p1 -b .tinfo
58%patch3 -p1 -b .unprintable
59%patch4 -p1 -b .hist-sub
60%patch8 -p1 -b .syntax
61%patch9 -p1 -b .memoryuse
62%patch11 -p1 -b .order
63%patch28 -p1 -b .manpage-spelling
64%patch31 -p1 -b .history-file-locking
65%patch33 -p1 -b .history-merge
66%patch34 -p1 -b .repeated-words-man
67%patch35 -p1 -b .elf-interpreter
68%patch36 -p1 -b .posix-exit-status-value
69%patch37 -p1 -b .reverse-history-handling-in-loops
70
71for i in Fixes WishList; do
72 iconv -f iso-8859-1 -t utf-8 "$i" > "${i}_" && \
73 touch -r "$i" "${i}_" && \
74 mv "${i}_" "$i"
75done
76
77%build
78# For tcsh-6.14.00-tinfo.patch
79autoreconf
80%configure --without-hesiod
81make %{?_smp_mflags} all
82make %{?_smp_mflags} -C nls catalogs
83
84%install
85rm -rf $RPM_BUILD_ROOT
86mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1 ${RPM_BUILD_ROOT}%{_bindir}
87install -p -m 755 tcsh ${RPM_BUILD_ROOT}%{_bindir}/tcsh
88install -p -m 644 tcsh.man ${RPM_BUILD_ROOT}%{_mandir}/man1/tcsh.1
89ln -sf tcsh ${RPM_BUILD_ROOT}%{_bindir}/csh
90ln -sf tcsh.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/csh.1
91
92while read lang language ; do
93        dest=${RPM_BUILD_ROOT}%{_datadir}/locale/$lang/LC_MESSAGES
94        if test -f tcsh.$language.cat ; then
95                mkdir -p $dest
96                install -p -m 644 tcsh.$language.cat $dest/tcsh
97                echo "%lang($lang) %{_datadir}/locale/$lang/LC_MESSAGES/tcsh"
98        fi
99done > tcsh.lang << _EOF
100de german
101el greek
102en C
103es spanish
104et et
105fi finnish
106fr french
107it italian
108ja ja
109pl pl
110ru russian
111uk ukrainian
112_EOF
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post
118if [ ! -f /etc/shells ]; then
119 echo "%{_bindir}/tcsh" >> /etc/shells
120 echo "%{_bindir}/csh"  >> /etc/shells
121else
122 grep -q '^%{_bindir}/tcsh$' /etc/shells || \
123 echo "%{_bindir}/tcsh" >> /etc/shells
124 grep -q '^%{_bindir}/csh$'  /etc/shells || \
125 echo "%{_bindir}/csh"  >> /etc/shells
126fi
127
128%postun
129if [ ! -x %{_bindir}/tcsh ]; then
130 grep -v '^%{_bindir}/tcsh$'  /etc/shells | \
131 grep -v '^%{_bindir}/csh$' > /etc/shells.rpm && \
132 mv /etc/shells.rpm /etc/shells
133fi
134
135%files -f tcsh.lang
136%defattr(-,root,root,-)
137%doc BUGS FAQ Fixes NewThings WishList complete.tcsh
138%{_bindir}/tcsh
139%{_bindir}/csh
140%{_mandir}/man1/*.1*
141
142%changelog
143* Sun Jul 20 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.18.01-1
144- update to 6.18.01
145
146* Sun Jun 12 2011 IWAI, Masaharu <iwai@alib.jp> 6.17-1
147- new upstream release
148- drop wide str patch (Patch12): upstream fixed
149- update ca-color patch (Patch6) from Fedora tcsh-6.17-15
150- update syntax patch (Patch8) from Fedora tcsh-6.17-15
151- update rs-color patch from Fedora tcsh-6.17-15
152- resync with Fedora tcsh-6.17-15
153 - change patch number Patch13 -> Patch12
154 - add Patch13..24
155  * Thu Mar 24 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-15
156  - Avoid infinite loop pendjob()-xprintf() when stdout is closed
157    Resolves: #690356
158 
159  * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.17-14
160  - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
161 
162  * Fri Jan 28 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-13
163  - Modify verbose patch to match with upstream (don't print on history -S)
164    Resolves: #672810
165 
166  * Wed Jan 26 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-12
167  - Fix error message on exit
168    Resolves: #672810
169 
170  * Mon Jan 24 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-11
171  - Don't set $REMOTEHOST on the local machine
172    Resolves: #669176
173  - Don't print history in verbose mode
174    Resolves: #583075, #658171
175  - Don't allow illegal variable names to be set
176    Resolves: #436901
177  - Revert "Fix incorrect $status value of pipelined commands"
178 
179  * Tue Dec 21 2010 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-10
180  - Make wait builtin command interruptible
181    Resolves: #440465
182  - Fix incorrect $status value of pipelined commands
183    Resolves: #638955 (Patch by Tomas Smetana <tsmetana@redhat.com>)
184 
185  * Wed Oct  6 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-9
186  - Remove fork when tcsh processes backquotes
187 
188  * Wed Apr 14 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-8
189  - Fix testsuite
190 
191  * Mon Mar  1 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-7
192  - Ship README file
193 
194  * Tue Dec 15 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-6
195  - Fix tcsh obeys printexitvalue for back-ticks
196 
197  * Wed Nov  4 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-5
198  - Fix few globbing problems
199 
200  * Mon Oct 19 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-4
201  - Fix tcsh globbing causing bad automount
202  - Fix truncated history file after network crash
203 
204  * Wed Aug 26 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-3
205  - Add new colorls variable
206    Resolves: #518808
207 
208  * Sun Jul 26 2009 Fedora Release Engineering <releng@lists.fedoraproject.org> - 6.17-2
209  - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
210 
211  * Mon Jul 20 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-1
212  - Update to tcsh-6.17.00
213
214* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.16-2
215- rebuilt with current VineSeed
216
217* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 6.16-1
218- new upstream release
219- resync with 6.16-1(fc12)
220- drop vine patch
221
222* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 6.12-1vl5
223- applied new versioning policy, spec in utf-8
224
225* Wed Oct 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 6.12-0vl6
226- added patch11 from fedora
227  * Thu Mar 23 2006 Miloslav Trmac <mitr@redhat.com> - 6.14-8
228  - Backport a patch to ignore LS_COLOR codes introduced in newer coreutils
229    (#186037)
230- added japanese description
231
232* Thu Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.12-0vl5
233- added patch from fedora
234  * Tue Feb 10 2004 Nalin Dahyabhai <nalin@redhat.com> 6.12-7
235  - remove declaration of setpgrp() which conflicts with libc's (#115185)
236
237  * Fri Nov 21 2003 Nalin Dahyabhai <nalin@redhat.com> 6.12-6
238  - add missing buildprereqs on groff, libtermcap-devel (#110599)
239
240* Mon Oct 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.12-0vl4
241- rebuild with new toolchains
242- s/Copyright/License/
243- fix spec file to build correctly (based on Rawhide spec file)
244
245* Tue Aug 06 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.12-0vl3
246- "Re"-changed the way of fixing check locale from Patch8 to Patch9
247  on ppc strlen() can not deal with 'short' variables
248
249* Sat Aug 03 2002 Satoshi MACHINO <machino@vinelinux.org> 6.12-0vl2
250- fixed changelog
251
252* Thu Jul 25 2002 K. Nagasaka <nagasaka@math.tsukuba.ac.jp> 6.12-0vl1
253- update
254
255* Sun Apr 28 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.11-0vl4
256- change limit.patch
257
258* Fri Apr 26 2002 Kosaku Nagasaka <nagasaka@math.tsukuba.ac.jp> 6.11-0vl3
259- fixed limit by Patch10
260
261* Sun Jan 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.11-0vl2
262- changed the way of fixing check locale from Patch8 to Patch9
263  on ppc strlen() can not deal with 'short' variables
264
265* Mon Jan 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 6.11-0vl1
266- update
267
268* Thu Dec 28 2001 Satoshi MACHINO <machino@vinelinux.org> 6.10.02-0vl2
269- fixed check locale
270        - merged some patches from RHL-7.2
271
272* Thu Aug 09 2001 <sagami@vinelinux.org>
273- 6.10.02-0vl1
274
275* Sun Jan  7 2001 Jun Nishii <jun@vinelinux.org>
276- 6.10-1vl2
277- build with gcc
278
279* Mon Dec 11 2000 Yasuhide OOMORI <dasen@icntv.ne.jp>
280- syncronized release tcsh based on a securty fix for RH6.2.
281
282* Thu Nov 30 2000 Nalin Dahyabhai <nalin@redhat.com>
283- update to 6.10.00 to fix here-script vulnerability
284
285* Wed Sep 18 2000 Adrian Havill <havill@redhat.com>
286- fix catalog locale dirname for Japanese
287
288* Thu Jun 15 2000 Jeff Johnson <jbj@redhat.com>
289- FHS packaging.
290- add locale support (#10345).
291
292* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
293- rebuild for sparc baud rates > 38400.
294
295* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
296- rebuild to fix dependencies
297
298* Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
299- append entries to spanking new /etc/shells.
300
301* Mon Jan 10 2000 Jeff Johnson <jbj@redhat.com>
302- update to 6.09.
303- fix strcoll oddness (#6000, #6244, #6398).
304
305* Sat Sep 25 1999 Michael K. Johnson <johnsonm@redhat.com>
306- fix $shell by using --bindir
307
308* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
309- auto rebuild in the new build environment (release 5)
310
311* Wed Feb 24 1999 Cristian Gafton <gafton@redhat.com>
312- patch for using PATH_MAX instead of some silly internal #defines for
313  variables that handle filenames.
314
315* Fri Nov  6 1998 Jeff Johnson <jbj@redhat.com>
316- update to 6.08.00.
317
318* Fri Oct 02 1998 Cristian Gafton <gafton@redhat.com>
319- upgraded to 6.07.09 from the freebsd
320- security fix
321
322* Wed Aug  5 1998 Jeff Johnson <jbj@redhat.com>
323- use -ltermcap so that /bin/tcsh can be used in single user mode w/o /usr.
324- update url's
325
326* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
327- translations modified for de, fr, tr
328
329* Thu Oct 21 1997 Cristian Gafton <gafton@redhat.com>
330- updated to 6.07; added BuildRoot
331- cleaned up the spec file; fixed source url
332
333* Wed Sep 03 1997 Erik Troan <ewt@redhat.com>
334- added termios hacks for new glibc
335- added /bin/csh to file list
336
337* Fri Jun 13 1997 Erik Troan <ewt@redhat.com>
338- built against glibc
339
340* Fri Feb 07 1997 Erik Troan <ewt@redhat.com>
341 - Provides csh, adds and removes /bin/csh from /etc/shells if csh package
342isn't installed.
Note: See TracBrowser for help on using the repository browser.