source: projects/specs/trunk/t/tcpdump/tcpdump-vl.spec @ 8191

Revision 8191, 16.2 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define tcpdump_ver     4.5.1
2%define libpcap_ver     1.5.3
3
4Summary: A network traffic monitoring tool.
5Summary(ja): ネットワークのトラフィックをモニタするツール
6Name: tcpdump
7Version: %{tcpdump_ver}
8%define tcpdump_dir     tcpdump-%{tcpdump_ver}
9%define tcpslice_dir    tcpslice
10Release: 1%{?_dist_release}
11Epoch: 1
12
13Group: Applications/System
14# XXX epoch is necessary to obsolete tcpdump-3.4a5
15License: BSD
16URL: http://www.tcpdump.org/
17
18Source0: http://www.tcpdump.org/release/tcpdump-%{tcpdump_ver}.tar.gz
19Source4: tcpslice-CVS.20010207.tar.gz
20
21Patch5: tcpdump-3.6.2-tcpslice-time.patch
22Patch10: tcpdump-4.1.1-portnumbers.patch
23Patch15: tcpdump-3.6.2-ip6opts.patch
24Patch16: tcpdump-3.8.1-sctp.patch
25Patch17: tcpdump-3.7.2-sctpdef.patch
26Patch19: tcpdump-3.8.2-rsvp-dos.patch
27Patch21: tcpdump-3.8.2-isis-dos.patch
28Patch22: tcpdump-3.9.1-ethbuf.patch
29
30Patch70: tcpslice-CVS.20010207-bpf.patch
31
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33BuildRequires: glibc-kernheaders >= 2.2.0
34BuildRequires: openssl-devel
35BuildRequires: libpcap-devel >= %{libpcap_ver}
36BuildRequires: autoconf, automake
37# Requires: kernel >= 2.2.0
38# Requires: libpcap >= %{libpcap_ver}
39
40
41Vendor: Project Vine
42Distribution: Vine Linux
43Packager: daisuke, shaolin
44
45
46%description
47Tcpdump is a command-line tool for monitoring network traffic.
48Tcpdump can capture and display the packet headers on a particular
49network interface or on all interfaces. Tcpdump can display all of the
50packet headers, or just the ones that match particular criteria.
51
52Install tcpdump if you need a program to monitor network traffic.
53
54%description -l ja
55tcpdump はネットワークのトラフィックをモニタする、コマンドライン
56ベースのツールです。tcpdump はあるネットワークインターフェイス
57もしくは全てのネットワークインターフェイス上のパケットのヘッダを
58キャプチャして表示することができます。tcpdump は全てのパケットの
59ヘッダを表示することもできますし、ある規則に合致するものだけを
60表示することもできます。
61
62ネットワークのトラフィックをモニタする必要がある場合、tcpdump を
63インストールしてください。
64
65
66%prep
67%setup -q -c -a 4
68
69%patch5 -p1 -b .tcpslicetime
70
71pushd %tcpdump_dir
72%patch10 -p1 -b .portnumbers
73%patch15 -p1 -b .ip6opts
74%patch16 -p1 -b .sctp
75%patch17 -p1 -b .sctpdef
76%patch19 -p1 -b .rsvp-dos
77%patch21 -p1 -b .isis-dos
78#patch22 -p1 -b .ethbuf
79popd
80
81pushd tcpslice
82%patch70 -p1 -b .bpf
83popd
84
85%build
86pushd %tcpslice_dir
87%configure
88make
89popd
90
91pushd %tcpdump_dir
92%define optflags $RPM_OPT_FLAGS -DIP_MAX_MEMBERSHIPS=20
93%configure --enable-ipv6
94%undefine optflags
95
96DEFS="-g -D_U_=\"\" -DHAVE_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
97%ifarch alpha sparc sparc64
98DEFS="$DEFS -DHAVE_ETHER_HOSTTON=1 -DLBL_ALIGN=1 -DHAVE_ETHER_NTOA=1"
99%endif
100%ifarch sparc sparc64
101DEFS="$DEFS -DWORDS_BIGENDIAN"
102%endif
103
104make DEFS="$DEFS"
105popd
106
107%install
108rm -rf %{buildroot}
109mkdir -p %{buildroot}%{_libdir}
110mkdir -p %{buildroot}%{_mandir}/man{3,8}
111mkdir -p %{buildroot}%{_sbindir}
112
113pushd %tcpslice_dir
114install -m755 -s tcpslice %{buildroot}%{_sbindir}
115install -m644 tcpslice.1 %{buildroot}%{_mandir}/man8/tcpslice.8
116popd
117
118pushd %tcpdump_dir
119install -m755 -s tcpdump %{buildroot}%{_sbindir}
120install -m644 tcpdump.1 %{buildroot}%{_mandir}/man8/tcpdump.8
121popd
122
123
124%clean
125rm -rf %{buildroot}
126
127
128%files
129%defattr(-,root,root)
130%doc %{name}-%{version}/README.md
131%doc %{name}-%{version}/CHANGES
132%doc %{name}-%{version}/LICENSE
133%{_sbindir}/tcpdump
134%{_sbindir}/tcpslice
135%{_mandir}/man8/tcpslice.8*
136%{_mandir}/man8/tcpdump.8*
137
138
139%changelog
140* Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:4.5.1-1
141- new upstream release
142
143* Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:4.3.0-1
144- new upstream release
145
146* Thu Mar 22 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1:4.1.1-4
147- rebuild
148
149* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:4.1.1-3
150- rebuild with openssl-1.0.0c
151
152* Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:4.1.1-2
153- removed pcap header direction
154- added URL tag
155
156* Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:4.1.1-1
157- new upstream release
158- updated Patch10
159- built with new toolchain
160
161* Sat Apr 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:4.0.0-2
162- spec in UTF-8
163- added BuildRequires: libpcap-devel instead of libpcap
164- changed Group to Applications/System
165
166* Thu Oct 30 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1:4.0.0-1
167- new upstream release with libpcap 1.0.0
168
169* Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:3.9.8-2
170- built again with libpcap-0.9.8 for sure this time
171
172* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.8-1vl5
173- new upstream release
174
175* Sat Sep  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.7-0vl1
176- new upstream release
177
178* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.6-0vl1
179- new upstream release
180
181* Mon May 21 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:3.9.3-0vl3
182- rebuilt with new toolchain
183
184* Fri Aug 26 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.3-0vl2
185- dropped --with-user option
186
187* Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.3-0vl1
188- new upstream release
189- some patches are imported from fedora package
190- build with libpcap 0.9.3
191- changed BuildRequire kernel-headers to glibc-kernheaders
192
193* Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.8.3-0vl1
194- new upstream release
195- some patches are imported from fedora package
196
197* Sat Oct 11 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.7.2-0vl1
198- updated to 3.7.2
199- fixed patches based on Redhat Rawhide
200- rebuild with libpcap-0.7.2
201- s/Copyright/License/
202
203* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.7.1-0vl2
204- split out libpcap, Requires: libpcap
205
206* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.7.1-0vl1
207- update to new upstream release tcpdump 3.7.1, arpwatch 0.7.1
208- drop unneeded patches
209- use autoconf213, automake14
210- split out arpwatch
211
212* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl2
213- add patch16 to fix  print_bgp security bug
214  - errata 20030221-3
215
216* Wed Jun 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl1
217- merged with 3.6.2-13
218- fix buffer overflow for errata
219  * Thu May 16 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-13
220  - added official 3.6.3 fix
221  - fixed 6.2 compat #63113
222  * Wed Jan 23 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-12
223  - tcpdump-3.6.2-snaplen.patch added to fix #55145
224  * Tue Dec 18 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-10
225  - took old purge patch for filters
226  - fixed #54225,#58346
227  - drop root by default #49635
228  - fixed #54593
229  - fixed #57711
230
231* Thu Oct 25 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
232- 3.6.2-9vl1
233- used PRM macros
234- changed File Name to Package Name in Prereq tag
235- marged 3.6.2-9 (RedHat7.2)
236
237  * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
238  - 3.4-19vl2
239  - use better macros
240 
241  * Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
242  - add libpcap-0.4-guy-gerald.patch to fix the timeout problem (by Ethereal)
243  - add Japanese summarys and descriptions
244  - modify spec file to build as a normal user
245 
246  * Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
247  - Compile shared libpcap with -fPIC (Bug #6342)
248 
249  * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
250  - fix descriptions
251  - man pages are compressed
252 
253  * Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
254  - remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
255  - upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
256  - add getprotobyname lookup (#6725).
257  - getservbyname port lookup appears functional (#7569).
258  - remove uid 2090 backdoor (sorry Dave) (#7116).
259 
260  * Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
261  - fox the pcap.h header
262 
263  * Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
264  - prevent segfault on obscure spoofed ip header (#4634).
265 
266  * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
267  - add defattr to arpwatch (#4591).
268 
269  * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
270  - initscript munging
271
272  * Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
273  - add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
274 
275  * Tue Aug  3 1999 Jeff Johnson <jbj@redhat.com>
276  - include A. Kuznetsov's patches to libpcap/tcpdump.
277  - added arpsnmp to package (#3258).
278  - arp2ethers written for different of awk (#4326).
279
280  * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
281  - auto rebuild in the new build environment (release 10)
282
283  * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
284  - strip binaries.
285 
286  * Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
287  - autoconf fixes for arm
288
289  * Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
290  - libpcap description typo.
291
292  * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
293  - fix arpwatch summary line.
294 
295  * Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
296  - enable arpwatch
297 
298  * Mon Aug  3 1998 Jeff Johnson <jbj@redhat.com>
299  - separate package for libpcap.
300  - update tcpdump to 3.4, libpcap to 0.4.
301  - added arpwatch (but disabled for now)
302 
303  * Thu May 07 1998 Prospector System <bugs@redhat.com>
304  - translations modified for de, fr, tr
305 
306  * Sat May  2 1998 Alan Cox <alan@rehat.com>
307  - Added the SACK printing fix so you can dump Linux 2.1+.
308 
309  * Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
310  - updated to release 3.4a5
311  - uses a buildroot and %attr
312 
313  * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
314  - built against glibc
315
316* Fri Aug 31 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-9
317- took better fix for #52654 from tcpdump cvs
318
319* Thu Aug 30 2001 Harald Hoyer <harald@redhat.de> 11:3.6.2-8
320- fixed #52654
321
322* Thu Jul 19 2001 Harald Hoyer <harald@redhat.de> 10:3.6.2-7
323- added shared library to libpcap (#47174)
324- afs printing security patch (#49294)
325
326* Wed Jun 20 2001 Harald Hoyer <harald@redhat.de>
327- use initgroups, instead of setgroups
328
329* Mon Jun 18 2001 Harald Hoyer <harald@redhat.de>
330- added dropgroup patches (#44563)
331
332* Mon May 07 2001 Harald Hoyer <harald@redhat.de>
333- switched to Pekka's tcpdump-3.6.2 package
334- incremented epoch
335
336* Sat Apr 14 2001 Pekka Savola <pekkas@netcore.fi>
337- fix building of tcpslice on glibc 2.2.2 (time.h)
338- disable /etc/init.d requirement and fix %post scripts in arpwatch
339
340* Wed Feb 14 2001 Harald Hoyer <harald@redhat.de>
341- glibc sys/time -> time include patch
342
343* Wed Feb  7 2001 Trond Eivind Glomsr <teg@redhat.com>
344- Add space to this check
345
346* Wed Feb 07 2001 Harald Hoyer <harald@redhat.com>
347- added check for presence of /etc/sysconfig/arpwatch (#23172)
348
349* Wed Feb  7 2001 Pekka Savola <pekkas@netcore.fi>
350- update to 3.6.2, 0.6.2 and new CVS of tcpslice.
351- i18n'ize arpwatch init script
352
353* Fri Feb  2 2001 Trond Eivind Glomsr <teg@redhat.com>
354- i18nize initscript
355
356* Mon Jan 29 2001 Harald Hoyer <harald@redhat.com>
357- fixed EINTR stopping for e.g. SIGSTOP. (#22008)
358- added -u option for tcpdump (#20231)
359- new arpwatch version (#23172)
360- added "all" and "one" interface for -i (#20907)
361- added arpwatch sysconfig (#23172)
362
363* Mon Jan 22 2001 Harald Hoyer <harald@redhat.com>
364- more (potential) overflows in libpcap. #21373
365- documentation fix for #20906
366
367* Sun Jan 14 2001 Pekka Savola <pekkas@netcore.fi>
368- use --enable-ipv6
369- Add two patches from CVS to enhance 802.2 printing, and more importantly,
370  to be able to specify 'no stp'
371
372* Sat Jan 13 2001 Pekka Savola <pekkas@netcore.fi>
373- Make SMB printing output a lot more quiet unless in verbose mode.
374- Make -n resolve port/protocol numbers but not hostnames, -nn for no
375  resolving at all
376- Separate droproot patch from a more generic man/usage fix one
377- Add non-promiscuous mode -by default patch, but don't apply it by default
378
379* Thu Jan 11 2001 Pekka Savola <pekkas@netcore.fi>
380- Update to tcpdump 3.6.1 and libpcap 0.6.1 releases.
381
382* Mon Jan  8 2001 Pekka Savola <pekkas@netcore.fi>
383- Update to 20010108 CVS, disable some upstreamed patches.
384- Change some additional .1 pages to .8.
385- Add droproot patch, some --usage and man page fixes.
386
387* Mon Jan  1 2001 Pekka Savola <pekkas@netcore.fi>
388- Initial packaging with latest tcpdump.org CVS tcpdump-3.6 and libpcap-0.6.
389- add earlier print-domain.c, the latest is segfaulting
390- don't unnecesessarily include snprintf.o, it didn't compile with gcc 2.96 anyway
391- don't use savestr, require openssl, tweak tweak tweak
392- add tcpslice, patch it a bit for egcs detection
393
394* Sun Dec 31 2000 Pekka Savola <pekkas@netcore.fi>
395- tcpdump: spice up the manpage about interfaces
396- tcpdump: add 'all' and 'any' keywords to -i, saner default behaviour.
397- upgrade arpwatch to 2.1a10
398
399* Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
400- more (potential) overflows in libpcap.
401
402* Sun Nov 12 2000 Jeff Johnson <jbj@redhat.com>
403- eliminate still more buffer overflows (from FreeBSD) (#20069).
404
405* Thu Nov  2 2000 Jeff Johnson <jbj@redhat.com>
406- eliminate more buffer overflows (from FreeBSD) (#20069).
407- 802.1q ether type incorrect (#19850).
408- add -u flag to drop arpwatch privs (#19696).
409
410* Sun Oct 15 2000 Jeff Johnson <jbj@redhat.com>
411- updated ethercodes.dat
412
413* Thu Oct 12 2000 Jeff Johnson <jbj@redhat.com>
414- fix arpwatch tmp race (#18943).
415
416* Fri Aug 11 2000 Bill Nottingham <notting@redhat.com>
417- fix condrestart
418
419* Fri Aug 11 2000 Jeff Johnson <jbj@redhat.com>
420- correct arpsnmp man pages (#15442).
421- don't print harmless ENOPROTOOPT message (#13518).
422
423* Fri Aug  4 2000 Jeff Johnson <jbj@redhat.com>
424- rebuild with final kernel headers (#13518).
425
426* Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
427- add STP patch (#14112).
428
429* Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
430- source /etc/init.d/functions
431- back out /etc/init.d/arpwatch, place file in /etc/rc.d
432- move initscript to /etc/init.d
433- changed initscript to use start() and stop() functions
434- added condrestart to init script
435- added %%post %%preun %%postun scripts to register arpwatch script
436- added Prereq: for all things needed in post/preun/postun
437
438* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
439- automatic rebuild
440
441* Tue Jul 11 2000 Jeff Johnson <jbj@redhat.com>
442- updated man page and help (pekkas@netcore.fi) (#10739 et al).
443
444* Sun Jun 18 2000 Jeff Johnson <jbj@redhat/com>
445- FHS packaging.
446
447* Tue May  9 2000 Bill Nottingham <notting@redhat.com>
448- minor tweaks for ia64 (prototypes)
449
450* Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
451- Compile shared libpcap with -fPIC (Bug #6342)
452
453* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
454- fix descriptions
455- man pages are compressed
456
457* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
458- remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
459- upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
460- add getprotobyname lookup (#6725).
461- getservbyname port lookup appears functional (#7569).
462- remove uid 2090 backdoor (sorry Dave) (#7116).
463
464* Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
465- fox the pcap.h header
466
467* Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
468- prevent segfault on obscure spoofed ip header (#4634).
469
470* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
471- add defattr to arpwatch (#4591).
472
473* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
474- initscript munging
475
476* Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
477- add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
478
479* Tue Aug  3 1999 Jeff Johnson <jbj@redhat.com>
480- include A. Kuznetsov's patches to libpcap/tcpdump.
481- added arpsnmp to package (#3258).
482- arp2ethers written for different of awk (#4326).
483
484* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
485- auto rebuild in the new build environment (release 10)
486
487* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
488- strip binaries.
489
490* Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
491- autoconf fixes for arm
492
493* Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
494- libpcap description typo.
495
496* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
497- fix arpwatch summary line.
498
499* Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
500- enable arpwatch
501
502* Mon Aug  3 1998 Jeff Johnson <jbj@redhat.com>
503- separate package for libpcap.
504- update tcpdump to 3.4, libpcap to 0.4.
505- added arpwatch (but disabled for now)
506
507* Thu May 07 1998 Prospector System <bugs@redhat.com>
508- translations modified for de, fr, tr
509
510* Sat May  2 1998 Alan Cox <alan@rehat.com>
511- Added the SACK printing fix so you can dump Linux 2.1+.
512
513* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
514- updated to release 3.4a5
515- uses a buildroot and %attr
516
517* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
518- built against glibc
Note: See TracBrowser for help on using the repository browser.