source: projects/specs/trunk/t/tcpdump/tcpdump-vl.spec @ 9432

Revision 9432, 16.1 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%define tcpdump_ver     4.7.3
2%define libpcap_ver     1.7.2
3
4Summary: A network traffic monitoring tool.
5Summary(ja): ネットワークのトラフィックをモニタするツール
6Name: tcpdump
7Version: %{tcpdump_ver}
8%define tcpdump_dir     tcpdump-%{tcpdump_ver}
9%define tcpslice_dir    tcpslice
10Release: 1%{?_dist_release}
11Epoch: 1
12
13Group: Applications/System
14# XXX epoch is necessary to obsolete tcpdump-3.4a5
15License: BSD
16URL: http://www.tcpdump.org/
17
18Source0: http://www.tcpdump.org/release/tcpdump-%{tcpdump_ver}.tar.gz
19Source4: tcpslice-CVS.20010207.tar.gz
20
21Patch5: tcpdump-3.6.2-tcpslice-time.patch
22Patch10: tcpdump-4.7.3-portnumbers.patch
23Patch15: tcpdump-3.6.2-ip6opts.patch
24Patch19: tcpdump-3.8.2-rsvp-dos.patch
25Patch21: tcpdump-4.7.3-isis-dos.patch
26
27Patch70: tcpslice-CVS.20010207-bpf.patch
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30BuildRequires: glibc-kernheaders >= 2.2.0
31BuildRequires: openssl-devel
32BuildRequires: libpcap-devel >= %{libpcap_ver}
33BuildRequires: autoconf, automake
34
35
36Vendor: Project Vine
37Distribution: Vine Linux
38Packager: daisuke, shaolin, Takemikaduchi
39
40
41%description
42Tcpdump is a command-line tool for monitoring network traffic.
43Tcpdump can capture and display the packet headers on a particular
44network interface or on all interfaces. Tcpdump can display all of the
45packet headers, or just the ones that match particular criteria.
46
47Install tcpdump if you need a program to monitor network traffic.
48
49%description -l ja
50tcpdump はネットワークのトラフィックをモニタする、コマンドライン
51ベースのツールです。tcpdump はあるネットワークインターフェイス
52もしくは全てのネットワークインターフェイス上のパケットのヘッダを
53キャプチャして表示することができます。tcpdump は全てのパケットの
54ヘッダを表示することもできますし、ある規則に合致するものだけを
55表示することもできます。
56
57ネットワークのトラフィックをモニタする必要がある場合、tcpdump を
58インストールしてください。
59
60
61%prep
62%setup -q -c -a 4
63
64%patch5 -p1 -b .tcpslicetime
65
66pushd %tcpdump_dir
67%patch10 -p1 -b .portnumbers
68%patch15 -p1 -b .ip6opts
69%patch19 -p1 -b .rsvp-dos
70%patch21 -p1 -b .isis-dos
71popd
72
73pushd tcpslice
74%patch70 -p1 -b .bpf
75popd
76
77%build
78pushd %tcpslice_dir
79%configure
80make
81popd
82
83pushd %tcpdump_dir
84%define optflags $RPM_OPT_FLAGS -DIP_MAX_MEMBERSHIPS=20
85%configure --enable-ipv6
86%undefine optflags
87
88DEFS="-g -D_U_=\"\" -DHAVE_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
89%ifarch alpha sparc sparc64
90DEFS="$DEFS -DHAVE_ETHER_HOSTTON=1 -DLBL_ALIGN=1 -DHAVE_ETHER_NTOA=1"
91%endif
92%ifarch sparc sparc64
93DEFS="$DEFS -DWORDS_BIGENDIAN"
94%endif
95
96make DEFS="$DEFS"
97popd
98
99%install
100rm -rf %{buildroot}
101mkdir -p %{buildroot}%{_libdir}
102mkdir -p %{buildroot}%{_mandir}/man{3,8}
103mkdir -p %{buildroot}%{_sbindir}
104
105pushd %tcpslice_dir
106install -m755 -s tcpslice %{buildroot}%{_sbindir}
107install -m644 tcpslice.1 %{buildroot}%{_mandir}/man8/tcpslice.8
108popd
109
110pushd %tcpdump_dir
111install -m755 -s tcpdump %{buildroot}%{_sbindir}
112install -m644 tcpdump.1 %{buildroot}%{_mandir}/man8/tcpdump.8
113popd
114
115
116%clean
117rm -rf %{buildroot}
118
119
120%files
121%defattr(-,root,root)
122%doc %{name}-%{version}/README.md
123%doc %{name}-%{version}/CHANGES
124%doc %{name}-%{version}/LICENSE
125%{_sbindir}/tcpdump
126%{_sbindir}/tcpslice
127%{_mandir}/man8/tcpslice.8*
128%{_mandir}/man8/tcpdump.8*
129
130
131%changelog
132* Sun Mar 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:4.7.3-1
133- new upstream release
134- update Patch10 (tcpdump-4.7.3-portnumbers.patch)
135- update Patch21 (tcpdump-4.7.3-isis-dos.patch)
136- remove Patch16,17,22
137
138* Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:4.5.1-1
139- new upstream release
140
141* Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:4.3.0-1
142- new upstream release
143
144* Thu Mar 22 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1:4.1.1-4
145- rebuild
146
147* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:4.1.1-3
148- rebuild with openssl-1.0.0c
149
150* Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:4.1.1-2
151- removed pcap header direction
152- added URL tag
153
154* Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:4.1.1-1
155- new upstream release
156- updated Patch10
157- built with new toolchain
158
159* Sat Apr 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:4.0.0-2
160- spec in UTF-8
161- added BuildRequires: libpcap-devel instead of libpcap
162- changed Group to Applications/System
163
164* Thu Oct 30 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1:4.0.0-1
165- new upstream release with libpcap 1.0.0
166
167* Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:3.9.8-2
168- built again with libpcap-0.9.8 for sure this time
169
170* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.8-1vl5
171- new upstream release
172
173* Sat Sep  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.7-0vl1
174- new upstream release
175
176* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.6-0vl1
177- new upstream release
178
179* Mon May 21 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:3.9.3-0vl3
180- rebuilt with new toolchain
181
182* Fri Aug 26 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.3-0vl2
183- dropped --with-user option
184
185* Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.3-0vl1
186- new upstream release
187- some patches are imported from fedora package
188- build with libpcap 0.9.3
189- changed BuildRequire kernel-headers to glibc-kernheaders
190
191* Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.8.3-0vl1
192- new upstream release
193- some patches are imported from fedora package
194
195* Sat Oct 11 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.7.2-0vl1
196- updated to 3.7.2
197- fixed patches based on Redhat Rawhide
198- rebuild with libpcap-0.7.2
199- s/Copyright/License/
200
201* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.7.1-0vl2
202- split out libpcap, Requires: libpcap
203
204* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.7.1-0vl1
205- update to new upstream release tcpdump 3.7.1, arpwatch 0.7.1
206- drop unneeded patches
207- use autoconf213, automake14
208- split out arpwatch
209
210* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl2
211- add patch16 to fix  print_bgp security bug
212  - errata 20030221-3
213
214* Wed Jun 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl1
215- merged with 3.6.2-13
216- fix buffer overflow for errata
217  * Thu May 16 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-13
218  - added official 3.6.3 fix
219  - fixed 6.2 compat #63113
220  * Wed Jan 23 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-12
221  - tcpdump-3.6.2-snaplen.patch added to fix #55145
222  * Tue Dec 18 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-10
223  - took old purge patch for filters
224  - fixed #54225,#58346
225  - drop root by default #49635
226  - fixed #54593
227  - fixed #57711
228
229* Thu Oct 25 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
230- 3.6.2-9vl1
231- used PRM macros
232- changed File Name to Package Name in Prereq tag
233- marged 3.6.2-9 (RedHat7.2)
234
235  * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
236  - 3.4-19vl2
237  - use better macros
238 
239  * Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
240  - add libpcap-0.4-guy-gerald.patch to fix the timeout problem (by Ethereal)
241  - add Japanese summarys and descriptions
242  - modify spec file to build as a normal user
243 
244  * Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
245  - Compile shared libpcap with -fPIC (Bug #6342)
246 
247  * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
248  - fix descriptions
249  - man pages are compressed
250 
251  * Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
252  - remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
253  - upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
254  - add getprotobyname lookup (#6725).
255  - getservbyname port lookup appears functional (#7569).
256  - remove uid 2090 backdoor (sorry Dave) (#7116).
257 
258  * Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
259  - fox the pcap.h header
260 
261  * Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
262  - prevent segfault on obscure spoofed ip header (#4634).
263 
264  * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
265  - add defattr to arpwatch (#4591).
266 
267  * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
268  - initscript munging
269
270  * Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
271  - add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
272 
273  * Tue Aug  3 1999 Jeff Johnson <jbj@redhat.com>
274  - include A. Kuznetsov's patches to libpcap/tcpdump.
275  - added arpsnmp to package (#3258).
276  - arp2ethers written for different of awk (#4326).
277
278  * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
279  - auto rebuild in the new build environment (release 10)
280
281  * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
282  - strip binaries.
283 
284  * Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
285  - autoconf fixes for arm
286
287  * Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
288  - libpcap description typo.
289
290  * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
291  - fix arpwatch summary line.
292 
293  * Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
294  - enable arpwatch
295 
296  * Mon Aug  3 1998 Jeff Johnson <jbj@redhat.com>
297  - separate package for libpcap.
298  - update tcpdump to 3.4, libpcap to 0.4.
299  - added arpwatch (but disabled for now)
300 
301  * Thu May 07 1998 Prospector System <bugs@redhat.com>
302  - translations modified for de, fr, tr
303 
304  * Sat May  2 1998 Alan Cox <alan@rehat.com>
305  - Added the SACK printing fix so you can dump Linux 2.1+.
306 
307  * Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
308  - updated to release 3.4a5
309  - uses a buildroot and %attr
310 
311  * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
312  - built against glibc
313
314* Fri Aug 31 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-9
315- took better fix for #52654 from tcpdump cvs
316
317* Thu Aug 30 2001 Harald Hoyer <harald@redhat.de> 11:3.6.2-8
318- fixed #52654
319
320* Thu Jul 19 2001 Harald Hoyer <harald@redhat.de> 10:3.6.2-7
321- added shared library to libpcap (#47174)
322- afs printing security patch (#49294)
323
324* Wed Jun 20 2001 Harald Hoyer <harald@redhat.de>
325- use initgroups, instead of setgroups
326
327* Mon Jun 18 2001 Harald Hoyer <harald@redhat.de>
328- added dropgroup patches (#44563)
329
330* Mon May 07 2001 Harald Hoyer <harald@redhat.de>
331- switched to Pekka's tcpdump-3.6.2 package
332- incremented epoch
333
334* Sat Apr 14 2001 Pekka Savola <pekkas@netcore.fi>
335- fix building of tcpslice on glibc 2.2.2 (time.h)
336- disable /etc/init.d requirement and fix %post scripts in arpwatch
337
338* Wed Feb 14 2001 Harald Hoyer <harald@redhat.de>
339- glibc sys/time -> time include patch
340
341* Wed Feb  7 2001 Trond Eivind Glomsr <teg@redhat.com>
342- Add space to this check
343
344* Wed Feb 07 2001 Harald Hoyer <harald@redhat.com>
345- added check for presence of /etc/sysconfig/arpwatch (#23172)
346
347* Wed Feb  7 2001 Pekka Savola <pekkas@netcore.fi>
348- update to 3.6.2, 0.6.2 and new CVS of tcpslice.
349- i18n'ize arpwatch init script
350
351* Fri Feb  2 2001 Trond Eivind Glomsr <teg@redhat.com>
352- i18nize initscript
353
354* Mon Jan 29 2001 Harald Hoyer <harald@redhat.com>
355- fixed EINTR stopping for e.g. SIGSTOP. (#22008)
356- added -u option for tcpdump (#20231)
357- new arpwatch version (#23172)
358- added "all" and "one" interface for -i (#20907)
359- added arpwatch sysconfig (#23172)
360
361* Mon Jan 22 2001 Harald Hoyer <harald@redhat.com>
362- more (potential) overflows in libpcap. #21373
363- documentation fix for #20906
364
365* Sun Jan 14 2001 Pekka Savola <pekkas@netcore.fi>
366- use --enable-ipv6
367- Add two patches from CVS to enhance 802.2 printing, and more importantly,
368  to be able to specify 'no stp'
369
370* Sat Jan 13 2001 Pekka Savola <pekkas@netcore.fi>
371- Make SMB printing output a lot more quiet unless in verbose mode.
372- Make -n resolve port/protocol numbers but not hostnames, -nn for no
373  resolving at all
374- Separate droproot patch from a more generic man/usage fix one
375- Add non-promiscuous mode -by default patch, but don't apply it by default
376
377* Thu Jan 11 2001 Pekka Savola <pekkas@netcore.fi>
378- Update to tcpdump 3.6.1 and libpcap 0.6.1 releases.
379
380* Mon Jan  8 2001 Pekka Savola <pekkas@netcore.fi>
381- Update to 20010108 CVS, disable some upstreamed patches.
382- Change some additional .1 pages to .8.
383- Add droproot patch, some --usage and man page fixes.
384
385* Mon Jan  1 2001 Pekka Savola <pekkas@netcore.fi>
386- Initial packaging with latest tcpdump.org CVS tcpdump-3.6 and libpcap-0.6.
387- add earlier print-domain.c, the latest is segfaulting
388- don't unnecesessarily include snprintf.o, it didn't compile with gcc 2.96 anyway
389- don't use savestr, require openssl, tweak tweak tweak
390- add tcpslice, patch it a bit for egcs detection
391
392* Sun Dec 31 2000 Pekka Savola <pekkas@netcore.fi>
393- tcpdump: spice up the manpage about interfaces
394- tcpdump: add 'all' and 'any' keywords to -i, saner default behaviour.
395- upgrade arpwatch to 2.1a10
396
397* Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
398- more (potential) overflows in libpcap.
399
400* Sun Nov 12 2000 Jeff Johnson <jbj@redhat.com>
401- eliminate still more buffer overflows (from FreeBSD) (#20069).
402
403* Thu Nov  2 2000 Jeff Johnson <jbj@redhat.com>
404- eliminate more buffer overflows (from FreeBSD) (#20069).
405- 802.1q ether type incorrect (#19850).
406- add -u flag to drop arpwatch privs (#19696).
407
408* Sun Oct 15 2000 Jeff Johnson <jbj@redhat.com>
409- updated ethercodes.dat
410
411* Thu Oct 12 2000 Jeff Johnson <jbj@redhat.com>
412- fix arpwatch tmp race (#18943).
413
414* Fri Aug 11 2000 Bill Nottingham <notting@redhat.com>
415- fix condrestart
416
417* Fri Aug 11 2000 Jeff Johnson <jbj@redhat.com>
418- correct arpsnmp man pages (#15442).
419- don't print harmless ENOPROTOOPT message (#13518).
420
421* Fri Aug  4 2000 Jeff Johnson <jbj@redhat.com>
422- rebuild with final kernel headers (#13518).
423
424* Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
425- add STP patch (#14112).
426
427* Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
428- source /etc/init.d/functions
429- back out /etc/init.d/arpwatch, place file in /etc/rc.d
430- move initscript to /etc/init.d
431- changed initscript to use start() and stop() functions
432- added condrestart to init script
433- added %%post %%preun %%postun scripts to register arpwatch script
434- added Prereq: for all things needed in post/preun/postun
435
436* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
437- automatic rebuild
438
439* Tue Jul 11 2000 Jeff Johnson <jbj@redhat.com>
440- updated man page and help (pekkas@netcore.fi) (#10739 et al).
441
442* Sun Jun 18 2000 Jeff Johnson <jbj@redhat/com>
443- FHS packaging.
444
445* Tue May  9 2000 Bill Nottingham <notting@redhat.com>
446- minor tweaks for ia64 (prototypes)
447
448* Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
449- Compile shared libpcap with -fPIC (Bug #6342)
450
451* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
452- fix descriptions
453- man pages are compressed
454
455* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
456- remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
457- upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
458- add getprotobyname lookup (#6725).
459- getservbyname port lookup appears functional (#7569).
460- remove uid 2090 backdoor (sorry Dave) (#7116).
461
462* Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
463- fox the pcap.h header
464
465* Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
466- prevent segfault on obscure spoofed ip header (#4634).
467
468* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
469- add defattr to arpwatch (#4591).
470
471* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
472- initscript munging
473
474* Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
475- add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
476
477* Tue Aug  3 1999 Jeff Johnson <jbj@redhat.com>
478- include A. Kuznetsov's patches to libpcap/tcpdump.
479- added arpsnmp to package (#3258).
480- arp2ethers written for different of awk (#4326).
481
482* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
483- auto rebuild in the new build environment (release 10)
484
485* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
486- strip binaries.
487
488* Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
489- autoconf fixes for arm
490
491* Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
492- libpcap description typo.
493
494* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
495- fix arpwatch summary line.
496
497* Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
498- enable arpwatch
499
500* Mon Aug  3 1998 Jeff Johnson <jbj@redhat.com>
501- separate package for libpcap.
502- update tcpdump to 3.4, libpcap to 0.4.
503- added arpwatch (but disabled for now)
504
505* Thu May 07 1998 Prospector System <bugs@redhat.com>
506- translations modified for de, fr, tr
507
508* Sat May  2 1998 Alan Cox <alan@rehat.com>
509- Added the SACK printing fix so you can dump Linux 2.1+.
510
511* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
512- updated to release 3.4a5
513- uses a buildroot and %attr
514
515* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
516- built against glibc
Note: See TracBrowser for help on using the repository browser.