source: projects/specs/trunk/t/tcp_wrappers/tcp_wrappers-vl.spec @ 521

Revision 521, 9.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define LIB_MAJOR 0
3%define LIB_MINOR 7
4%define LIB_REL 6
5
6Summary:     A security tool which acts as a wrapper for TCP daemons.
7Summary(ja): TCP デーモンのラッパとして働くセキュリティツール
8Name: tcp_wrappers
9Version: 7.6
10Release: 37%{?_dist_release}
11License: BSD
12Group: System Environment/Daemons
13Source: ftp://ftp.porcupine.org/pub/security/tcp_wrappers_7.6.tar.gz
14Patch0: tcpw7.2-config.patch
15Patch1: tcpw7.2-setenv.patch
16Patch2: tcpw7.6-netgroup.patch
17Patch3: tcp_wrappers-7.6-bug11881.patch
18Patch4: tcp_wrappers-7.6-bug17795.patch
19Patch5: tcp_wrappers-7.6-bug17847.patch
20Patch6: tcp_wrappers-7.6-fixgethostbyname.patch
21Patch7: tcp_wrappers-7.6-docu.patch
22Patch8: tcp_wrappers-7.6-casesens.patch
23Patch9: tcp_wrappers.usagi-ipv6.patch
24Patch10: tcp_wrappers.ume-ipv6.patch
25Patch11: tcp_wrappers-7.6-shared.patch
26Patch12: tcp_wrappers-7.6-sig.patch
27Patch13: tcp_wrappers-7.6-strerror.patch
28Patch14: tcp_wrappers-7.6-ldflags.patch
29Patch15: tcp_wrappers-7.6-fix_sig-bug141110.patch
30Patch16: tcp_wrappers-7.6-162412.patch
31Patch17: tcp_wrappers-7.6-220015.patch
32Patch18: tcp_wrappers-7.6-restore_sigalarm.patch
33Patch19: tcp_wrappers-7.6-siglongjmp.patch
34Patch20: tcp_wrappers-7.6-sigchld.patch
35Patch21: tcp_wrappers-7.6-196326.patch
36Patch22: tcp_wrappers_7.6-249430.patch
37
38# required by sin_scope_id in ipv6 patch
39BuildRequires: glibc-devel >= 2.2               
40BuildRoot: %{_tmppath}/%{name}-%{version}-root
41
42
43%description
44The tcp_wrappers package provides small daemon programs which can
45monitor and filter incoming requests for systat, finger, FTP, telnet,
46rlogin, rsh, exec, tftp, talk and other network services.
47
48Install the tcp_wrappers program if you need a security tool for
49filtering incoming network services requests.
50
51%description -l ja
52tcp_wrapper パッケージには小さなデーモンプログラムが収められており,
53systat, finger, FTP, telnet, rlogin, rsh, exec, tftp, talk, その他
54様々なネットワークサービスに対する外部からの要求を監視し,フィルタリング
55することが出来ます.
56
57ネットワークサービスに対する外部からのリクエストをフィルタリング
58出来るセキュリティツールが必要ならば tcp_wrappers パッケージを
59インストールして下さい.
60
61
62## to build compat32 for x86_64 architecture support
63%package -n compat32-%{name}
64Summary:     A security tool which acts as a wrapper for TCP daemons.
65Summary(ja): TCP デーモンのラッパとして働くセキュリティツール
66Group: System Environment/Daemons
67
68%description -n compat32-%{name}
69The tcp_wrappers package provides small daemon programs which can
70monitor and filter incoming requests for systat, finger, FTP, telnet,
71rlogin, rsh, exec, tftp, talk and other network services.
72
73Install the tcp_wrappers program if you need a security tool for
74filtering incoming network services requests.
75
76
77%prep
78%setup -q -n tcp_wrappers_7.6
79%patch0 -p1 -b .config
80%patch1 -p1 -b .setenv
81%patch2 -p1 -b .netgroup
82%patch3 -p1 -b .bug11881
83%patch4 -p1 -b .bug17795
84%patch5 -p1 -b .bug17847
85%patch6 -p1 -b .fixgethostbyname
86%patch7 -p1 -b .docu
87%patch8 -p1 -b .man
88%patch9 -p1 -b .usagi-ipv6
89%patch10 -p1 -b .ume-ipv6
90%patch11 -p1 -b .shared
91%patch12 -p1 -b .sig
92%patch13 -p1 -b .strerror
93%patch14 -p1 -b .cflags
94%patch15 -p1 -b .fix_sig
95%patch16 -p1 -b .162412
96%patch17 -p1 -b .220015
97%patch18 -p1 -b .restore_sigalarm
98%patch19 -p1 -b .siglongjmp
99%patch20 -p1 -b .sigchld
100%patch21 -p1 -b .196326
101%patch22 -p1 -b .249430
102
103# Disable static library creation by default.
104%define with_static 0
105
106%build
107make RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC -DPIC -D_REENTRANT -DHAVE_STRERROR" \
108     LDFLAGS="-pie" MAJOR=%{LIB_MAJOR} MINOR=%{LIB_MINOR} REL=%{LIB_REL} linux
109
110%install
111[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
112mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
113mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
114mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man{3,5,8}
115mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
116
117cp hosts_access.3 ${RPM_BUILD_ROOT}%{_mandir}/man3
118cp hosts_access.5 hosts_options.5 ${RPM_BUILD_ROOT}%{_mandir}/man5
119cp tcpd.8 tcpdchk.8 tcpdmatch.8 ${RPM_BUILD_ROOT}%{_mandir}/man8
120ln -sf hosts_access.5 ${RPM_BUILD_ROOT}%{_mandir}/man5/hosts.allow.5
121ln -sf hosts_access.5 ${RPM_BUILD_ROOT}%{_mandir}/man5/hosts.deny.5
122%if %{with_static}
123cp -a libwrap.a ${RPM_BUILD_ROOT}%{_libdir}
124%endif
125cp -a libwrap.so* ${RPM_BUILD_ROOT}%{_libdir}
126install -p -m644 tcpd.h ${RPM_BUILD_ROOT}%{_includedir}
127install -m755 safe_finger ${RPM_BUILD_ROOT}%{_sbindir}
128install -m711 tcpd ${RPM_BUILD_ROOT}%{_sbindir}
129install -m755 try-from ${RPM_BUILD_ROOT}%{_sbindir}
130
131## XXX remove utilities that expect /etc/inetd.conf (#16059).
132##install -m755 tcpdchk ${RPM_BUILD_ROOT}%{_sbindir}
133##install -m755 tcpdmatch ${RPM_BUILD_ROOT}%{_sbindir}
134#rm -f ${RPM_BUILD_ROOT}%{_mandir}/man8/tcpdmatch.*
135#rm -f ${RPM_BUILD_ROOT}%{_mandir}/man8/tcpdchk.*
136
137## keep tcpdchk and tcpdmatch included here
138## until xinetd is introduced for Vine Linux....
139##
140install -m755 tcpdchk $RPM_BUILD_ROOT%{_sbindir}
141install -m755 tcpdmatch $RPM_BUILD_ROOT%{_sbindir}
142
143%post -p /sbin/ldconfig
144%postun -p /sbin/ldconfig
145
146%post -n compat32-%{name} -p /sbin/ldconfig
147%postun -n compat32-%{name} -p /sbin/ldconfig
148
149%clean
150[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
151
152%files
153%defattr(-,root,root)
154%doc BLURB CHANGES README* DISCLAIMER Banners.Makefile
155%{_mandir}/man[358]/*
156%{_includedir}/*
157%if %{with_static}
158%{_libdir}/*.a
159%endif
160%{_libdir}/*.so
161%{_libdir}/*.so.*
162%{_sbindir}/*
163
164%if %{build_compat32}
165%files -n compat32-%{name}
166%defattr(-,root,root)
167%if %{with_static}
168%{_libdir}/*.a
169%endif
170%{_libdir}/*.so
171%{_libdir}/*.so.*
172%endif
173
174%changelog
175* Fri Feb 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-37
176- s/BuildPrereq/BuildRequires/
177- added Patch14-22 from FC
178  * Wed Jul 25 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-49
179  - fix for a.b.c.d/255.255.255.255 - fixes #249430
180  * Thu Jun 28 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-48
181  - compare localhost and localhost.localdomain as the same
182  * Wed Jun 06 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-47
183  - fix the hostname resolving patch for x86_64
184  * Fri May 25 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-45
185  - unblock and catch SIGCHLD from spawned shell commands, fixes #112975
186  * Mon Apr 16 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-44
187  - added restore_sigalarm and siglongjmp patches from Debian, fixes #205129
188  * Fri Mar 09 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-43
189  - resolve hostnames in hosts.{allow,deny}, should fix a bunch of issues with
190    IPv4/6
191  * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 7.6-40
192  - fixed uninitialized fp in function inet_cfg (#162412)
193  * Fri May  6 2005 Thomas Woerner <twoerner@redhat.com> 7.6-39
194  - fixed sig patch (#141110). Thanks to Nikita Shulga for the patch
195
196* Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 7.6-36
197- removed unnecessary %%if %{build_compat32} statements
198- removed the static library libwrap.a by default
199
200* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.6-35
201- new versioning policy
202- spec in UTF-8
203
204* Fri Feb 17 2006 Shu KONNO <owa@bg.wakwak.com> 7.6-34vl3
205- added compat32-* packages for x86_64 architecture support
206- fixed tcp_wrappers-7.6-shared.patch (which changed gcc to $CC)
207
208* Wed Nov 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 7.6-34vl2
209- new upstream release
210- add libwrap.so* to %%files
211
212* Fri Jul  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-34vl1
213- based on 7.6-34 from Rawhide, applied some patches
214- rebuild with new toolchains
215- s/Copyright/License/
216
217* Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
218- 7.6-17vl0
219- based on 7.6-17 from Rawhide
220- added Japanese summary and description
221- keep tcpdmatch and tcpchk still until xinetd is introduced for Vine
222  (if so in the future, these two program should be removed again...)
223
224* Sat Dec 30 2000 Jeff Johnson <jbj@redhat.com>
225- permit hosts.{allow,deny} to be assembled from included components (#17795).
226- permit '*' and '?' wildcard matches on hostnames (#17847).
227
228* Sun Nov 19 2000 Bill Nottingham <notting@redhat.com>
229- ia64 needs -fPIC too
230
231* Mon Aug 14 2000 Jeff Johnson <jbj@redhat.com>
232- remove utilities that expect /etc/inetd.conf (#16059).
233
234* Thu Jul 27 2000 Jeff Johnson <jbj@redhat.com>
235- security hardening (#11881).
236
237* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
238- automatic rebuild
239
240* Tue Jun  6 2000 Jeff Johnson <jbj@redhat.com>
241- FHS packaging.
242
243* Tue May 16 2000 Chris Evans <chris@ferret.lmh.ox.ac.uk>
244- Make tcpd mode -rwx--x--x as a security hardening measure
245
246* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
247- compress man pages.
248
249* Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
250- add netgroup support (#3940).
251
252* Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
253- compile on sparc with -fPIC.
254
255* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
256- auto rebuild in the new build environment (release 7)
257
258* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
259- build for glibc 2.1
260
261* Sat Aug 22 1998 Jeff Johnson <jbj@redhat.com>
262- close setenv bug (problem #690)
263- spec file cleanup
264
265* Thu Jun 25 1998 Alan Cox <alan@redhat.com>
266- Erp where did the Dec 05 patch escape to
267
268* Thu May 07 1998 Prospector System <bugs@redhat.com>
269- translations modified for de, fr, tr
270
271* Fri Dec 05 1997 Erik Troan <ewt@redhat.com>
272- don't build setenv.o module -- it just breaks things
273
274* Wed Oct 29 1997 Marc Ewing <marc@redhat.com>
275- upgrade to 7.6
276
277* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
278- built against glibc
279
280* Mon Mar 03 1997 Erik Troan <ewt@redhat.com>
281- Upgraded to version 7.5
282- Uses a build root
Note: See TracBrowser for help on using the repository browser.