source: projects/specs/trunk/t/tcp_wrappers/tcp_wrappers-vl.spec @ 8751

Revision 8751, 10.0 KB checked in by tomop, 10 years ago (diff)

tcp_wrappers-7.6-40

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define LIB_MAJOR 0
3%define LIB_MINOR 7
4%define LIB_REL 6
5
6Summary:     A security tool which acts as a wrapper for TCP daemons.
7Summary(ja): TCP デーモンのラッパとして働くセキュリティツール
8Name: tcp_wrappers
9Version: 7.6
10Release: 40%{?_dist_release}
11License: BSD
12Group: System Environment/Daemons
13Source: ftp://ftp.porcupine.org/pub/security/tcp_wrappers_7.6.tar.gz
14Patch0: tcpw7.2-config.patch
15Patch1: tcpw7.2-setenv.patch
16Patch2: tcpw7.6-netgroup.patch
17Patch3: tcp_wrappers-7.6-bug11881.patch
18Patch4: tcp_wrappers-7.6-bug17795.patch
19Patch5: tcp_wrappers-7.6-bug17847.patch
20Patch6: tcp_wrappers-7.6-fixgethostbyname.patch
21Patch7: tcp_wrappers-7.6-docu.patch
22Patch8: tcp_wrappers-7.6-casesens.patch
23Patch9: tcp_wrappers.usagi-ipv6.patch
24Patch10: tcp_wrappers.ume-ipv6.patch
25Patch11: tcp_wrappers-7.6-shared.patch
26Patch12: tcp_wrappers-7.6-sig.patch
27Patch13: tcp_wrappers-7.6-strerror.patch
28Patch14: tcp_wrappers-7.6-ldflags.patch
29Patch15: tcp_wrappers-7.6-fix_sig-bug141110.patch
30Patch16: tcp_wrappers-7.6-162412.patch
31Patch17: tcp_wrappers-7.6-220015.patch
32Patch18: tcp_wrappers-7.6-restore_sigalarm.patch
33Patch19: tcp_wrappers-7.6-siglongjmp.patch
34Patch20: tcp_wrappers-7.6-sigchld.patch
35Patch21: tcp_wrappers-7.6-196326.patch
36Patch22: tcp_wrappers_7.6-249430.patch
37Patch23: tcp_wrappers-7.6-aclexec.patch
38Patch24: tcp_wrappers-7.6-fix-multidef.patch
39
40# required by sin_scope_id in ipv6 patch
41BuildRequires: glibc-devel >= 2.2               
42BuildRoot: %{_tmppath}/%{name}-%{version}-root
43
44
45%description
46The tcp_wrappers package provides small daemon programs which can
47monitor and filter incoming requests for systat, finger, FTP, telnet,
48rlogin, rsh, exec, tftp, talk and other network services.
49
50Install the tcp_wrappers program if you need a security tool for
51filtering incoming network services requests.
52
53%description -l ja
54tcp_wrapper パッケージには小さなデーモンプログラムが収められており,
55systat, finger, FTP, telnet, rlogin, rsh, exec, tftp, talk, その他
56様々なネットワークサービスに対する外部からの要求を監視し,フィルタリング
57することが出来ます.
58
59ネットワークサービスに対する外部からのリクエストをフィルタリング
60出来るセキュリティツールが必要ならば tcp_wrappers パッケージを
61インストールして下さい.
62
63
64## to build compat32 for x86_64 architecture support
65%package -n compat32-%{name}
66Summary:     A security tool which acts as a wrapper for TCP daemons.
67Summary(ja): TCP デーモンのラッパとして働くセキュリティツール
68Group: System Environment/Daemons
69
70%description -n compat32-%{name}
71The tcp_wrappers package provides small daemon programs which can
72monitor and filter incoming requests for systat, finger, FTP, telnet,
73rlogin, rsh, exec, tftp, talk and other network services.
74
75Install the tcp_wrappers program if you need a security tool for
76filtering incoming network services requests.
77
78
79%prep
80%setup -q -n tcp_wrappers_7.6
81%patch0 -p1 -b .config
82%patch1 -p1 -b .setenv
83%patch2 -p1 -b .netgroup
84%patch3 -p1 -b .bug11881
85%patch4 -p1 -b .bug17795
86%patch5 -p1 -b .bug17847
87%patch6 -p1 -b .fixgethostbyname
88%patch7 -p1 -b .docu
89%patch8 -p1 -b .man
90%patch9 -p1 -b .usagi-ipv6
91%patch10 -p1 -b .ume-ipv6
92%patch11 -p1 -b .shared
93%patch12 -p1 -b .sig
94%patch13 -p1 -b .strerror
95%patch14 -p1 -b .cflags
96%patch15 -p1 -b .fix_sig
97%patch16 -p1 -b .162412
98%patch17 -p1 -b .220015
99%patch18 -p1 -b .restore_sigalarm
100%patch19 -p1 -b .siglongjmp
101%patch20 -p1 -b .sigchld
102%patch21 -p1 -b .196326
103%patch22 -p1 -b .249430
104%patch23 -p1 -b .aclexec
105%patch24 -p1 -b .multidef
106
107# Disable static library creation by default.
108%define with_static 0
109
110%build
111make RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC -DPIC -D_REENTRANT -DHAVE_STRERROR -DACLEXEC" \
112     LDFLAGS="-pie" MAJOR=%{LIB_MAJOR} MINOR=%{LIB_MINOR} REL=%{LIB_REL} linux
113
114%install
115[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
116mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
117mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
118mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man{3,5,8}
119mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
120
121cp hosts_access.3 ${RPM_BUILD_ROOT}%{_mandir}/man3
122cp hosts_access.5 hosts_options.5 ${RPM_BUILD_ROOT}%{_mandir}/man5
123cp tcpd.8 tcpdchk.8 tcpdmatch.8 ${RPM_BUILD_ROOT}%{_mandir}/man8
124ln -sf hosts_access.5 ${RPM_BUILD_ROOT}%{_mandir}/man5/hosts.allow.5
125ln -sf hosts_access.5 ${RPM_BUILD_ROOT}%{_mandir}/man5/hosts.deny.5
126%if %{with_static}
127cp -a libwrap.a ${RPM_BUILD_ROOT}%{_libdir}
128%endif
129cp -a libwrap.so* ${RPM_BUILD_ROOT}%{_libdir}
130install -p -m644 tcpd.h ${RPM_BUILD_ROOT}%{_includedir}
131install -m755 safe_finger ${RPM_BUILD_ROOT}%{_sbindir}
132install -m711 tcpd ${RPM_BUILD_ROOT}%{_sbindir}
133install -m755 try-from ${RPM_BUILD_ROOT}%{_sbindir}
134
135## XXX remove utilities that expect /etc/inetd.conf (#16059).
136##install -m755 tcpdchk ${RPM_BUILD_ROOT}%{_sbindir}
137##install -m755 tcpdmatch ${RPM_BUILD_ROOT}%{_sbindir}
138#rm -f ${RPM_BUILD_ROOT}%{_mandir}/man8/tcpdmatch.*
139#rm -f ${RPM_BUILD_ROOT}%{_mandir}/man8/tcpdchk.*
140
141## keep tcpdchk and tcpdmatch included here
142## until xinetd is introduced for Vine Linux....
143##
144install -m755 tcpdchk $RPM_BUILD_ROOT%{_sbindir}
145install -m755 tcpdmatch $RPM_BUILD_ROOT%{_sbindir}
146
147%post -p /sbin/ldconfig
148%postun -p /sbin/ldconfig
149
150%post -n compat32-%{name} -p /sbin/ldconfig
151%postun -n compat32-%{name} -p /sbin/ldconfig
152
153%clean
154[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
155
156%files
157%defattr(-,root,root)
158%doc BLURB CHANGES README* DISCLAIMER Banners.Makefile
159%{_mandir}/man[358]/*
160%{_includedir}/*
161%if %{with_static}
162%{_libdir}/*.a
163%endif
164%{_libdir}/*.so
165%{_libdir}/*.so.*
166%{_sbindir}/*
167
168%if %{build_compat32}
169%files -n compat32-%{name}
170%defattr(-,root,root)
171%if %{with_static}
172%{_libdir}/*.a
173%endif
174%{_libdir}/*.so
175%{_libdir}/*.so.*
176%endif
177
178%changelog
179* Mon Jul  7 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.6-40
180- rebuilt with current environment.
181
182* Tue Aug 07 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.6-39
183- added Patch23 from debian (aclexec support).
184- added Patch24 (fix multiple definition).
185
186* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 7.6-38
187- rebuilt with rpm-4.8.1-3
188
189* Fri Feb 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-37
190- s/BuildPrereq/BuildRequires/
191- added Patch14-22 from FC
192  * Wed Jul 25 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-49
193  - fix for a.b.c.d/255.255.255.255 - fixes #249430
194  * Thu Jun 28 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-48
195  - compare localhost and localhost.localdomain as the same
196  * Wed Jun 06 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-47
197  - fix the hostname resolving patch for x86_64
198  * Fri May 25 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-45
199  - unblock and catch SIGCHLD from spawned shell commands, fixes #112975
200  * Mon Apr 16 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-44
201  - added restore_sigalarm and siglongjmp patches from Debian, fixes #205129
202  * Fri Mar 09 2007 Tomas Janousek <tjanouse@redhat.com> - 7.6-43
203  - resolve hostnames in hosts.{allow,deny}, should fix a bunch of issues with
204    IPv4/6
205  * Tue Jan 24 2006 Thomas Woerner <twoerner@redhat.com> 7.6-40
206  - fixed uninitialized fp in function inet_cfg (#162412)
207  * Fri May  6 2005 Thomas Woerner <twoerner@redhat.com> 7.6-39
208  - fixed sig patch (#141110). Thanks to Nikita Shulga for the patch
209
210* Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 7.6-36
211- removed unnecessary %%if %{build_compat32} statements
212- removed the static library libwrap.a by default
213
214* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.6-35
215- new versioning policy
216- spec in UTF-8
217
218* Fri Feb 17 2006 Shu KONNO <owa@bg.wakwak.com> 7.6-34vl3
219- added compat32-* packages for x86_64 architecture support
220- fixed tcp_wrappers-7.6-shared.patch (which changed gcc to $CC)
221
222* Wed Nov 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 7.6-34vl2
223- new upstream release
224- add libwrap.so* to %%files
225
226* Fri Jul  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-34vl1
227- based on 7.6-34 from Rawhide, applied some patches
228- rebuild with new toolchains
229- s/Copyright/License/
230
231* Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
232- 7.6-17vl0
233- based on 7.6-17 from Rawhide
234- added Japanese summary and description
235- keep tcpdmatch and tcpchk still until xinetd is introduced for Vine
236  (if so in the future, these two program should be removed again...)
237
238* Sat Dec 30 2000 Jeff Johnson <jbj@redhat.com>
239- permit hosts.{allow,deny} to be assembled from included components (#17795).
240- permit '*' and '?' wildcard matches on hostnames (#17847).
241
242* Sun Nov 19 2000 Bill Nottingham <notting@redhat.com>
243- ia64 needs -fPIC too
244
245* Mon Aug 14 2000 Jeff Johnson <jbj@redhat.com>
246- remove utilities that expect /etc/inetd.conf (#16059).
247
248* Thu Jul 27 2000 Jeff Johnson <jbj@redhat.com>
249- security hardening (#11881).
250
251* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
252- automatic rebuild
253
254* Tue Jun  6 2000 Jeff Johnson <jbj@redhat.com>
255- FHS packaging.
256
257* Tue May 16 2000 Chris Evans <chris@ferret.lmh.ox.ac.uk>
258- Make tcpd mode -rwx--x--x as a security hardening measure
259
260* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
261- compress man pages.
262
263* Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
264- add netgroup support (#3940).
265
266* Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
267- compile on sparc with -fPIC.
268
269* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
270- auto rebuild in the new build environment (release 7)
271
272* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
273- build for glibc 2.1
274
275* Sat Aug 22 1998 Jeff Johnson <jbj@redhat.com>
276- close setenv bug (problem #690)
277- spec file cleanup
278
279* Thu Jun 25 1998 Alan Cox <alan@redhat.com>
280- Erp where did the Dec 05 patch escape to
281
282* Thu May 07 1998 Prospector System <bugs@redhat.com>
283- translations modified for de, fr, tr
284
285* Fri Dec 05 1997 Erik Troan <ewt@redhat.com>
286- don't build setenv.o module -- it just breaks things
287
288* Wed Oct 29 1997 Marc Ewing <marc@redhat.com>
289- upgrade to 7.6
290
291* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
292- built against glibc
293
294* Mon Mar 03 1997 Erik Troan <ewt@redhat.com>
295- Upgraded to version 7.5
296- Uses a build root
Note: See TracBrowser for help on using the repository browser.