source: projects/specs/trunk/t/tcl/tcl-vl.spec @ 8186

Revision 8186, 10.1 KB checked in by kenta, 10 years ago (diff)
  • tcl
    • rebuilt
Line 
1%define majorver 8.5
2%define minorver 15
3%define version %{majorver}.%{minorver}
4%define htmlver %{majorver}.15
5
6%{!?sdt:%define sdt 0}
7
8Summary: A Tcl/Tk development environment: tcl
9Summary(ja): Tcl/Tk 開発環境: tcl
10Name: tcl
11Version: %{version}
12Release: 2%{?_dist_release}
13Group: Development/Languages
14License: TCL
15URL:     http://tcl.sourceforge.net/
16
17Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
18Source1: http://prdownloads.sourceforge.net/tcl/%{name}%{htmlver}-html.tar.gz
19# patches from Red Hat Enterprise Linux tcl-8.5.7-6.el6
20Patch100: tcl-8.5.1-autopath.patch
21Patch101: tcl-8.5.15-conf.patch
22Patch102: tcl-8.5.0-hidden.patch
23
24Buildroot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: libtool, util-linux, perl, gdbm, autoconf, imake
26%if %sdt
27BuildRequires: systemtap-sdt-devel
28%endif
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34Tcl is a simple scripting language designed to be embedded into
35other applications.  Tcl is designed to be used with Tk, a widget
36set, which is provided in the tk package.  This package also includes
37tclsh, a simple example of a Tcl application.
38
39%description -l ja
40Tcl は様々なアプリケーションの実行を行うための、簡単なスクリプ
41ト言語です。Tclはウィジッド・セットであるTkとともに用いるように
42デザインしています。このパッケージにはTclの簡単な例として、tclsh
43も含んでいます。
44
45
46%prep
47%setup -n %{name}%{version} -q -a 1
48mv tcl%{htmlver}/html .
49
50%patch100 -p1 -b .autopath
51%patch101 -p1 -b .conf
52%patch102 -p1 -b .hidden
53
54%build
55pushd unix
56autoconf
57%configure \
58%if %sdt
59--enable-dtrace \
60%endif
61--disable-threads \
62--enable-symbols \
63--enable-shared
64
65make %{?_smp_mflags} TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
66
67
68%install
69rm -rf $RPM_BUILD_ROOT
70make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
71
72ln -s tclsh%{majorver} $RPM_BUILD_ROOT%{_bindir}/tclsh
73
74# for linking with -lib%{name}
75ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
76
77mkdir -p $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}
78
79# postgresql and maybe other packages too need tclConfig.sh
80# paths don't look at /usr/lib for efficiency, so we symlink into tcl8.5 for now
81ln -s %{_libdir}/%{name}Config.sh $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}/%{name}Config.sh
82
83mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic,unix}
84find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
85( cd $RPM_BUILD_ROOT/%{_includedir}
86        for i in *.h ; do
87                [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
88        done
89)
90
91# remove buildroot traces
92sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
93rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tclAppInit.c
94rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/ldAix
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%post -p /sbin/ldconfig
100
101%postun -p /sbin/ldconfig
102
103%files
104%defattr(-,root,root,-)
105%doc html/*
106%{_bindir}/tclsh*
107%{_datadir}/tcl%{majorver}
108%{_libdir}/libtcl%{majorver}.so
109%{_libdir}/tclConfig.sh
110%{_libdir}/tcl%{majorver}/tclConfig.sh
111%{_mandir}/man1/*
112%{_includedir}/*
113%{_datadir}/%{name}8
114%{_libdir}/libtclstub%{majorver}.a
115%{_libdir}/libtcl.so
116%{_mandir}/man3/*
117%{_mandir}/mann/*
118
119%changelog
120* Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 8.5.15-2
121- rebuilt with the current environment
122
123* Tue Oct 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.5.15-1
124- update to 8.5.15
125- update Patch101 (tcl-8.5.15-conf.patch)
126- remove Patch103 (tcl-8.5.7-sigabrt.patch)
127
128* Fri Jan  4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
129- update to 8.5.7: sync Red Hat Enterprise Linux 6 tcl-8.5.7-6.el6
130- update License: TCL
131- drop obsolete patches
132 - tclm4-soname patch (Patch1)
133 - lib-perm patch (Patch2)
134 - configure patch (Patch3)
135 - no rpath patch (Patch4)
136 - init lib64 patch (Patch10)
137- add some patches from RHEL tcl-8.5.7-6.el6
138 - autopath patch (Patch100)
139 - conf patch (Patch101)
140 - hidden patch (Patch102)
141 - sigabrt patch (Patch103)
142- update build and install section: sync RHEL tcl-8.5.7-6.el6
143- add BR: systemtap-sdt-devel: default disable
144
145* Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
146- added imake to BR:.
147
148* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
149- rebuilt with rpm-4.8.1-3
150
151* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
152- rebuilt with new environment
153- updated Patch3: tcl8.4.16-configure.patch
154
155* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
156- new upstream release
157
158* Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.4.18-2
159- spec in UTF-8
160- configure with disabled threads. See:
161  https://bugzilla.redhat.com/show_bug.cgi?id=443246
162  http://groups.google.com/group/comp.lang.tcl/msg/ce6a1324bada8db0
163
164* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
165- rebuild with new environment
166
167* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
168- updated tcl to 8.4.18
169- updated tcl-html to 8.4.18
170
171* Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
172- updated tcl to 8.4.16
173- updated tcl-html to 8.4.16
174- dropt Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
175- added Patch3: tcl8.4.16-configure.patch
176
177* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
178- updated tcl to 8.4.15
179- updated tcl-html to 8.4.15
180- dropt Patch1: tcl-8.3.5-tclm4-soname.patch
181- added Patch10: tcl-8.4.15-init.lib64.patch
182- rebuilt with new toolchain
183
184* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
185- updated tcl to 8.4.13
186- updated tcl-html to 8.4.13
187
188* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
189- updated tcl to 8.4.12
190- updated patch4
191
192* Sat Aug 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.4.11-0vl1
193- updated tcl to 8.4.11
194- updated Patch4
195
196* Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
197- updated tcl to 8.4.6
198
199* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
200- merged with fedora
201  * Mon Dec  1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-3
202  - removed rpath (patch 4)
203
204  * Fri Nov 28 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-2
205  - put private header files under generic and unix subdirs
206  - include real generic/tclPort.h not just a symlink to tclUnixPort.h
207  - add tclMath.h to %{_includedir}/tcl-private/generic for building tk
208
209  * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
210  - new package split out from tcltk
211  - update to tcl 8.4.5 (#88429)
212    - drop tcl-8.3.3-heiierarchy.patch, tcl-8.3.3-dlopen.patch
213      and tcl8.3.5-koi8-u.enc-88806.patch
214  - include private include headers under %{_includedir}/tcl-private
215  - filtered changelog for tcl
216  - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
217
218* Sat Mar 29 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
219- update based on BitWalk's tcltk-8.4.2-83bw
220
221* Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
222- split source package.
223
224* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
225- expand some macros.. (FIXME)
226
227* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
228- use %configure macros
229- add Patch 47,50
230
231* Thu May 31 2001 <sagami@vinelinux.org>
232- 8.0.5_jp-10
233- unexpand old %%{configure}, new one causes build failure
234- fixed missing libtkx.so libtclx.so symlink in /usr/lib
235- install manpages into %%{_mandir} and mode 644
236
237* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
238- 8.0.5_jp-9
239- modified %install section to handle compressed man pages
240- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
241
242* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
243- changed default fonts
244
245* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
246- added defattr
247
248* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
249- added some symlinks, such as libtcl8.0.so.
250- obsoletes version number using _jp, now 8.0.5-31vl1
251
252* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
253- Apply Tcl/Tk 8.0 Japanese Patch 1.7
254
255* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
256- fix tclX symlinks.
257- compile on systems where SIGPWR == SIGLOST.
258
259* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
260- update tcl/tk to 8.0.5.
261- avoid "containing" in Tix (#2332).
262
263* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
264- use /usr/bin/write in kibitz (#1320).
265- use cirrus.sprl.umich.edu in weather (#1926).
266
267* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
268- auto rebuild in the new build environment (release 28)
269
270* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
271- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
272
273* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
274- expect does unaligned access on alpha (#989)
275- upgrade tcl/tk/tclX to 8.0.4
276- upgrade expect to 5.28.
277- add itcl 3.0.1
278
279* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
280- call libtoolize to allow building on the arm
281- build for glibc 2.1
282- strip binaries
283
284* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
285- update tcl/tk/tclX to 8.0.3, expect is updated also.
286
287* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
288- expect: mkpasswd needs delay before sending password (problem #576)
289
290* Thu May 07 1998 Prospector System <bugs@redhat.com>
291- translations modified for de, fr, tr
292
293* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
294- fixed expect binaries exec permissions
295
296* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
297- updated to Tix 4.1.0.006
298- updated version numbers of tcl/tk to relflect includsion of p2
299
300* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
301- updated tcl/tk to patch level 2
302- updated tclX to 8.0.2
303
304* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
305- fixed filelist for tix... replacing path to the expect binary in scripts
306  was leaving junk files around.
307
308* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
309- added patch to remove libieee test in configure.in for tcl and tk.
310  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
311  solution for all systems
312- fixed src urls
313
314* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
315- removed version numbers from descriptions
316
317* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
318- updated to tcl/tk 8.0 and related versions of packages
319
320* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
321- built against glibc
322- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.