source: projects/specs/trunk/t/tcl/tcl-vl.spec @ 521

Revision 521, 8.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define majorver 8.4
2%define minorver 19
3%define version %{majorver}.%{minorver}
4%define htmlver %{majorver}.18
5
6Summary: A Tcl/Tk development environment: tcl
7Summary(ja): Tcl/Tk 開発環境: tcl
8Name: tcl
9Version: %{version}
10Release: 1%{?_dist_release}
11Group: Development/Languages
12License: BSD
13URL:     http://tcl.sourceforge.net/
14
15Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
16Source1: http://prdownloads.sourceforge.net/tcl/%{name}%{htmlver}-html.tar.gz
17Patch1: tcl-8.3.5-tclm4-soname.patch
18Patch2: tcl-8.4.5-lib-perm.patch
19#Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
20Patch3: tcl8.4.16-configure.patch
21Patch4: tcl-8.4.12-no_rpath.patch
22Patch10: tcl-8.4.15-init.lib64.patch
23
24Buildroot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: libtool, util-linux, perl, gdbm, autoconf
26
27%description
28Tcl is a simple scripting language designed to be embedded into
29other applications.  Tcl is designed to be used with Tk, a widget
30set, which is provided in the tk package.  This package also includes
31tclsh, a simple example of a Tcl application.
32
33%description -l ja
34Tcl は様々なアプリケーションの実行を行うための、簡単なスクリプ
35ト言語です。Tclはウィジッド・セットであるTkとともに用いるように
36デザインしています。このパッケージにはTclの簡単な例として、tclsh
37も含んでいます。
38
39
40%prep
41#%setup -n %{name}%{version} -q -b1
42%setup -n %{name}%{version} -q -a 1
43mv tcl%{htmlver}/html .
44
45# define DT SONAME in shared lib
46# %patch1 -p1 -b .soname
47%patch2 -p1 -b .ro-lib
48%patch3 -p1 -b .pkgpath
49%patch4 -p1 -b .no_rpath
50# patch1 touches tcl.m4, and patch3 touches configure.in
51%ifarch x86_64
52%patch10 -p1 -b .init.lib64
53%endif
54
55cd unix
56#autoconf-2.13
57autoconf
58
59%build
60cd unix
61%configure \
62        --enable-shared --disable-threads --enable-langinfo --enable-64bit
63make %{?_smp_mflags} TCL_LIBRARY=%{_datadir}/tcl%{majorver}
64
65
66%install
67rm -rf $RPM_BUILD_ROOT
68make install -C unix INSTALL_ROOT=%{buildroot} TCL_LIBRARY=%{_datadir}/tcl%{majorver}
69
70ln -s tclsh%{majorver} %{buildroot}%{_bindir}/tclsh
71
72# for linking with -ltcl
73ln -s libtcl%{majorver}.so %{buildroot}%{_libdir}/libtcl.so
74
75mkdirhier %buildroot/%{_includedir}/tcl-private/{generic,unix}
76cp -p generic/tcl{Int,IntDecls,IntPlatDecls,Math,Port}.h %buildroot/%{_includedir}/tcl-private/generic
77cp -p unix/tclUnixPort.h %buildroot/%{_includedir}/tcl-private/unix
78
79# Fix up the include files.
80install -m 644 generic/tclRegexp.h $RPM_BUILD_ROOT%{_includedir}
81cp generic/*.h $RPM_BUILD_ROOT%{_includedir}/tcl-private/generic
82cp unix/*.h $RPM_BUILD_ROOT%{_includedir}/tcl-private/unix
83
84
85# remove buildroot traces
86perl -pi -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/tcl-private|" %buildroot/%{_libdir}/tclConfig.sh
87
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96%files
97%defattr(-,root,root,-)
98%doc html/*
99%{_bindir}/tclsh*
100%{_datadir}/tcl%{majorver}
101%{_libdir}/libtcl%{majorver}.so
102%{_libdir}/tclConfig.sh
103%{_mandir}/man1/*
104%{_includedir}/*
105%{_libdir}/libtclstub%{majorver}.a
106%{_libdir}/libtcl.so
107%{_mandir}/man3/*
108%{_mandir}/mann/*
109
110%changelog
111* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
112- new upstream release
113
114* Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.4.18-2
115- spec in UTF-8
116- configure with disabled threads. See:
117  https://bugzilla.redhat.com/show_bug.cgi?id=443246
118  http://groups.google.com/group/comp.lang.tcl/msg/ce6a1324bada8db0
119
120* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
121- rebuild with new environment
122
123* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
124- updated tcl to 8.4.18
125- updated tcl-html to 8.4.18
126
127* Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
128- updated tcl to 8.4.16
129- updated tcl-html to 8.4.16
130- dropt Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
131- added Patch3: tcl8.4.16-configure.patch
132
133* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
134- updated tcl to 8.4.15
135- updated tcl-html to 8.4.15
136- dropt Patch1: tcl-8.3.5-tclm4-soname.patch
137- added Patch10: tcl-8.4.15-init.lib64.patch
138- rebuilt with new toolchain
139
140* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
141- updated tcl to 8.4.13
142- updated tcl-html to 8.4.13
143
144* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
145- updated tcl to 8.4.12
146- updated patch4
147
148* Sat Aug 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.4.11-0vl1
149- updated tcl to 8.4.11
150- updated Patch4
151
152* Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
153- updated tcl to 8.4.6
154
155* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
156- merged with fedora
157  * Mon Dec  1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-3
158  - removed rpath (patch 4)
159
160  * Fri Nov 28 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-2
161  - put private header files under generic and unix subdirs
162  - include real generic/tclPort.h not just a symlink to tclUnixPort.h
163  - add tclMath.h to %{_includedir}/tcl-private/generic for building tk
164
165  * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
166  - new package split out from tcltk
167  - update to tcl 8.4.5 (#88429)
168    - drop tcl-8.3.3-heiierarchy.patch, tcl-8.3.3-dlopen.patch
169      and tcl8.3.5-koi8-u.enc-88806.patch
170  - include private include headers under %{_includedir}/tcl-private
171  - filtered changelog for tcl
172  - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
173
174* Sat Mar 29 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
175- update based on BitWalk's tcltk-8.4.2-83bw
176
177* Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
178- split source package.
179
180* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
181- expand some macros.. (FIXME)
182
183* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
184- use %configure macros
185- add Patch 47,50
186
187* Thu May 31 2001 <sagami@vinelinux.org>
188- 8.0.5_jp-10
189- unexpand old %%{configure}, new one causes build failure
190- fixed missing libtkx.so libtclx.so symlink in /usr/lib
191- install manpages into %%{_mandir} and mode 644
192
193* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
194- 8.0.5_jp-9
195- modified %install section to handle compressed man pages
196- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
197
198* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
199- changed default fonts
200
201* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
202- added defattr
203
204* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
205- added some symlinks, such as libtcl8.0.so.
206- obsoletes version number using _jp, now 8.0.5-31vl1
207
208* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
209- Apply Tcl/Tk 8.0 Japanese Patch 1.7
210
211* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
212- fix tclX symlinks.
213- compile on systems where SIGPWR == SIGLOST.
214
215* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
216- update tcl/tk to 8.0.5.
217- avoid "containing" in Tix (#2332).
218
219* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
220- use /usr/bin/write in kibitz (#1320).
221- use cirrus.sprl.umich.edu in weather (#1926).
222
223* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
224- auto rebuild in the new build environment (release 28)
225
226* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
227- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
228
229* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
230- expect does unaligned access on alpha (#989)
231- upgrade tcl/tk/tclX to 8.0.4
232- upgrade expect to 5.28.
233- add itcl 3.0.1
234
235* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
236- call libtoolize to allow building on the arm
237- build for glibc 2.1
238- strip binaries
239
240* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
241- update tcl/tk/tclX to 8.0.3, expect is updated also.
242
243* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
244- expect: mkpasswd needs delay before sending password (problem #576)
245
246* Thu May 07 1998 Prospector System <bugs@redhat.com>
247- translations modified for de, fr, tr
248
249* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
250- fixed expect binaries exec permissions
251
252* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
253- updated to Tix 4.1.0.006
254- updated version numbers of tcl/tk to relflect includsion of p2
255
256* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
257- updated tcl/tk to patch level 2
258- updated tclX to 8.0.2
259
260* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
261- fixed filelist for tix... replacing path to the expect binary in scripts
262  was leaving junk files around.
263
264* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
265- added patch to remove libieee test in configure.in for tcl and tk.
266  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
267  solution for all systems
268- fixed src urls
269
270* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
271- removed version numbers from descriptions
272
273* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
274- updated to tcl/tk 8.0 and related versions of packages
275
276* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
277- built against glibc
278- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.