source: projects/specs/trunk/t/tcl/tcl-vl.spec @ 7288

Revision 7288, 9.9 KB checked in by iwaim, 11 years ago (diff)

tcl 8.5.7-1

Line 
1%define majorver 8.5
2%define minorver 7
3%define version %{majorver}.%{minorver}
4%define htmlver %{majorver}.7
5
6%{!?sdt:%define sdt 0}
7
8Summary: A Tcl/Tk development environment: tcl
9Summary(ja): Tcl/Tk 開発環境: tcl
10Name: tcl
11Version: %{version}
12Release: 1%{?_dist_release}
13Group: Development/Languages
14License: TCL
15URL:     http://tcl.sourceforge.net/
16
17Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
18Source1: http://prdownloads.sourceforge.net/tcl/%{name}%{htmlver}-html.tar.gz
19# patches from Red Hat Enterprise Linux tcl-8.5.7-6.el6
20Patch100: tcl-8.5.1-autopath.patch
21Patch101: tcl-8.5.0-conf.patch
22Patch102: tcl-8.5.0-hidden.patch
23Patch103: tcl-8.5.7-sigabrt.patch
24
25Buildroot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: libtool, util-linux, perl, gdbm, autoconf, imake
27%if %sdt
28BuildRequires: systemtap-sdt-devel
29%endif
30
31Vendor: Project Vine
32Distribution: Vine Linux
33
34%description
35Tcl is a simple scripting language designed to be embedded into
36other applications.  Tcl is designed to be used with Tk, a widget
37set, which is provided in the tk package.  This package also includes
38tclsh, a simple example of a Tcl application.
39
40%description -l ja
41Tcl は様々なアプリケーションの実行を行うための、簡単なスクリプ
42ト言語です。Tclはウィジッド・セットであるTkとともに用いるように
43デザインしています。このパッケージにはTclの簡単な例として、tclsh
44も含んでいます。
45
46
47%prep
48%setup -n %{name}%{version} -q -a 1
49mv tcl%{htmlver}/html .
50
51%patch100 -p1 -b .autopath
52%patch101 -p1 -b .conf
53%patch102 -p1 -b .hidden
54%patch103 -p1 -b .sigabrt
55
56%build
57pushd unix
58autoconf
59%configure \
60%if %sdt
61--enable-dtrace \
62%endif
63--disable-threads \
64--enable-symbols \
65--enable-shared
66
67make %{?_smp_mflags} TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
68
69
70%install
71rm -rf $RPM_BUILD_ROOT
72make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
73
74ln -s tclsh%{majorver} $RPM_BUILD_ROOT%{_bindir}/tclsh
75
76# for linking with -lib%{name}
77ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
78
79mkdir -p $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}
80
81# postgresql and maybe other packages too need tclConfig.sh
82# paths don't look at /usr/lib for efficiency, so we symlink into tcl8.5 for now
83ln -s %{_libdir}/%{name}Config.sh $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}/%{name}Config.sh
84
85mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic,unix}
86find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
87( cd $RPM_BUILD_ROOT/%{_includedir}
88        for i in *.h ; do
89                [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
90        done
91)
92
93# remove buildroot traces
94sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
95rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tclAppInit.c
96rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/ldAix
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%post -p /sbin/ldconfig
102
103%postun -p /sbin/ldconfig
104
105%files
106%defattr(-,root,root,-)
107%doc html/*
108%{_bindir}/tclsh*
109%{_datadir}/tcl%{majorver}
110%{_libdir}/libtcl%{majorver}.so
111%{_libdir}/tclConfig.sh
112%{_libdir}/tcl%{majorver}/tclConfig.sh
113%{_mandir}/man1/*
114%{_includedir}/*
115%{_datadir}/%{name}8
116%{_libdir}/libtclstub%{majorver}.a
117%{_libdir}/libtcl.so
118%{_mandir}/man3/*
119%{_mandir}/mann/*
120
121%changelog
122* Fri Jan  4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
123- update to 8.5.7: sync Red Hat Enterprise Linux 6 tcl-8.5.7-6.el6
124- update License: TCL
125- drop obsolete patches
126 - tclm4-soname patch (Patch1)
127 - lib-perm patch (Patch2)
128 - configure patch (Patch3)
129 - no rpath patch (Patch4)
130 - init lib64 patch (Patch10)
131- add some patches from RHEL tcl-8.5.7-6.el6
132 - autopath patch (Patch100)
133 - conf patch (Patch101)
134 - hidden patch (Patch102)
135 - sigabrt patch (Patch103)
136- update build and install section: sync RHEL tcl-8.5.7-6.el6
137- add BR: systemtap-sdt-devel: default disable
138
139* Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
140- added imake to BR:.
141
142* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
143- rebuilt with rpm-4.8.1-3
144
145* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
146- rebuilt with new environment
147- updated Patch3: tcl8.4.16-configure.patch
148
149* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
150- new upstream release
151
152* Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.4.18-2
153- spec in UTF-8
154- configure with disabled threads. See:
155  https://bugzilla.redhat.com/show_bug.cgi?id=443246
156  http://groups.google.com/group/comp.lang.tcl/msg/ce6a1324bada8db0
157
158* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
159- rebuild with new environment
160
161* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
162- updated tcl to 8.4.18
163- updated tcl-html to 8.4.18
164
165* Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
166- updated tcl to 8.4.16
167- updated tcl-html to 8.4.16
168- dropt Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
169- added Patch3: tcl8.4.16-configure.patch
170
171* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
172- updated tcl to 8.4.15
173- updated tcl-html to 8.4.15
174- dropt Patch1: tcl-8.3.5-tclm4-soname.patch
175- added Patch10: tcl-8.4.15-init.lib64.patch
176- rebuilt with new toolchain
177
178* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
179- updated tcl to 8.4.13
180- updated tcl-html to 8.4.13
181
182* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
183- updated tcl to 8.4.12
184- updated patch4
185
186* Sat Aug 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.4.11-0vl1
187- updated tcl to 8.4.11
188- updated Patch4
189
190* Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
191- updated tcl to 8.4.6
192
193* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
194- merged with fedora
195  * Mon Dec  1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-3
196  - removed rpath (patch 4)
197
198  * Fri Nov 28 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-2
199  - put private header files under generic and unix subdirs
200  - include real generic/tclPort.h not just a symlink to tclUnixPort.h
201  - add tclMath.h to %{_includedir}/tcl-private/generic for building tk
202
203  * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
204  - new package split out from tcltk
205  - update to tcl 8.4.5 (#88429)
206    - drop tcl-8.3.3-heiierarchy.patch, tcl-8.3.3-dlopen.patch
207      and tcl8.3.5-koi8-u.enc-88806.patch
208  - include private include headers under %{_includedir}/tcl-private
209  - filtered changelog for tcl
210  - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
211
212* Sat Mar 29 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
213- update based on BitWalk's tcltk-8.4.2-83bw
214
215* Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
216- split source package.
217
218* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
219- expand some macros.. (FIXME)
220
221* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
222- use %configure macros
223- add Patch 47,50
224
225* Thu May 31 2001 <sagami@vinelinux.org>
226- 8.0.5_jp-10
227- unexpand old %%{configure}, new one causes build failure
228- fixed missing libtkx.so libtclx.so symlink in /usr/lib
229- install manpages into %%{_mandir} and mode 644
230
231* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
232- 8.0.5_jp-9
233- modified %install section to handle compressed man pages
234- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
235
236* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
237- changed default fonts
238
239* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
240- added defattr
241
242* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
243- added some symlinks, such as libtcl8.0.so.
244- obsoletes version number using _jp, now 8.0.5-31vl1
245
246* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
247- Apply Tcl/Tk 8.0 Japanese Patch 1.7
248
249* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
250- fix tclX symlinks.
251- compile on systems where SIGPWR == SIGLOST.
252
253* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
254- update tcl/tk to 8.0.5.
255- avoid "containing" in Tix (#2332).
256
257* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
258- use /usr/bin/write in kibitz (#1320).
259- use cirrus.sprl.umich.edu in weather (#1926).
260
261* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
262- auto rebuild in the new build environment (release 28)
263
264* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
265- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
266
267* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
268- expect does unaligned access on alpha (#989)
269- upgrade tcl/tk/tclX to 8.0.4
270- upgrade expect to 5.28.
271- add itcl 3.0.1
272
273* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
274- call libtoolize to allow building on the arm
275- build for glibc 2.1
276- strip binaries
277
278* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
279- update tcl/tk/tclX to 8.0.3, expect is updated also.
280
281* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
282- expect: mkpasswd needs delay before sending password (problem #576)
283
284* Thu May 07 1998 Prospector System <bugs@redhat.com>
285- translations modified for de, fr, tr
286
287* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
288- fixed expect binaries exec permissions
289
290* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
291- updated to Tix 4.1.0.006
292- updated version numbers of tcl/tk to relflect includsion of p2
293
294* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
295- updated tcl/tk to patch level 2
296- updated tclX to 8.0.2
297
298* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
299- fixed filelist for tix... replacing path to the expect binary in scripts
300  was leaving junk files around.
301
302* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
303- added patch to remove libieee test in configure.in for tcl and tk.
304  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
305  solution for all systems
306- fixed src urls
307
308* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
309- removed version numbers from descriptions
310
311* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
312- updated to tcl/tk 8.0 and related versions of packages
313
314* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
315- built against glibc
316- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.