source: projects/specs/trunk/t/tcl/tcl-vl.spec @ 3506

Revision 3506, 9.0 KB checked in by owa, 13 years ago (diff)

rebuild main

Line 
1%define majorver 8.4
2%define minorver 19
3%define version %{majorver}.%{minorver}
4%define htmlver %{majorver}.18
5
6Summary: A Tcl/Tk development environment: tcl
7Summary(ja): Tcl/Tk 開発環境: tcl
8Name: tcl
9Version: %{version}
10Release: 3%{?_dist_release}
11Group: Development/Languages
12License: BSD
13URL:     http://tcl.sourceforge.net/
14
15Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
16Source1: http://prdownloads.sourceforge.net/tcl/%{name}%{htmlver}-html.tar.gz
17Patch1: tcl-8.3.5-tclm4-soname.patch
18Patch2: tcl-8.4.5-lib-perm.patch
19#Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
20Patch3: tcl8.4.16-configure.patch
21Patch4: tcl-8.4.12-no_rpath.patch
22Patch10: tcl-8.4.15-init.lib64.patch
23
24Buildroot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: libtool, util-linux, perl, gdbm, autoconf
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30%description
31Tcl is a simple scripting language designed to be embedded into
32other applications.  Tcl is designed to be used with Tk, a widget
33set, which is provided in the tk package.  This package also includes
34tclsh, a simple example of a Tcl application.
35
36%description -l ja
37Tcl は様々なアプリケーションの実行を行うための、簡単なスクリプ
38ト言語です。Tclはウィジッド・セットであるTkとともに用いるように
39デザインしています。このパッケージにはTclの簡単な例として、tclsh
40も含んでいます。
41
42
43%prep
44#%setup -n %{name}%{version} -q -b1
45%setup -n %{name}%{version} -q -a 1
46mv tcl%{htmlver}/html .
47
48# define DT SONAME in shared lib
49# %patch1 -p1 -b .soname
50%patch2 -p1 -b .ro-lib
51%patch3 -p1 -b .pkgpath
52%patch4 -p1 -b .no_rpath
53# patch1 touches tcl.m4, and patch3 touches configure.in
54%ifarch x86_64
55%patch10 -p1 -b .init.lib64
56%endif
57
58cd unix
59#autoconf-2.13
60autoconf
61
62%build
63cd unix
64%configure \
65        --enable-shared --disable-threads --enable-langinfo --enable-64bit
66make %{?_smp_mflags} TCL_LIBRARY=%{_datadir}/tcl%{majorver}
67
68
69%install
70rm -rf $RPM_BUILD_ROOT
71make install -C unix INSTALL_ROOT=%{buildroot} TCL_LIBRARY=%{_datadir}/tcl%{majorver}
72
73ln -s tclsh%{majorver} %{buildroot}%{_bindir}/tclsh
74
75# for linking with -ltcl
76ln -s libtcl%{majorver}.so %{buildroot}%{_libdir}/libtcl.so
77
78mkdirhier %buildroot/%{_includedir}/tcl-private/{generic,unix}
79cp -p generic/tcl{Int,IntDecls,IntPlatDecls,Math,Port}.h %buildroot/%{_includedir}/tcl-private/generic
80cp -p unix/tclUnixPort.h %buildroot/%{_includedir}/tcl-private/unix
81
82# Fix up the include files.
83install -m 644 generic/tclRegexp.h $RPM_BUILD_ROOT%{_includedir}
84cp generic/*.h $RPM_BUILD_ROOT%{_includedir}/tcl-private/generic
85cp unix/*.h $RPM_BUILD_ROOT%{_includedir}/tcl-private/unix
86
87
88# remove buildroot traces
89perl -pi -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/tcl-private|" %buildroot/%{_libdir}/tclConfig.sh
90
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%post -p /sbin/ldconfig
96
97%postun -p /sbin/ldconfig
98
99%files
100%defattr(-,root,root,-)
101%doc html/*
102%{_bindir}/tclsh*
103%{_datadir}/tcl%{majorver}
104%{_libdir}/libtcl%{majorver}.so
105%{_libdir}/tclConfig.sh
106%{_mandir}/man1/*
107%{_includedir}/*
108%{_libdir}/libtclstub%{majorver}.a
109%{_libdir}/libtcl.so
110%{_mandir}/man3/*
111%{_mandir}/mann/*
112
113%changelog
114* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
115- rebuilt with rpm-4.8.1-3
116
117* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
118- rebuilt with new environment
119- updated Patch3: tcl8.4.16-configure.patch
120
121* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
122- new upstream release
123
124* Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.4.18-2
125- spec in UTF-8
126- configure with disabled threads. See:
127  https://bugzilla.redhat.com/show_bug.cgi?id=443246
128  http://groups.google.com/group/comp.lang.tcl/msg/ce6a1324bada8db0
129
130* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
131- rebuild with new environment
132
133* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
134- updated tcl to 8.4.18
135- updated tcl-html to 8.4.18
136
137* Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
138- updated tcl to 8.4.16
139- updated tcl-html to 8.4.16
140- dropt Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
141- added Patch3: tcl8.4.16-configure.patch
142
143* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
144- updated tcl to 8.4.15
145- updated tcl-html to 8.4.15
146- dropt Patch1: tcl-8.3.5-tclm4-soname.patch
147- added Patch10: tcl-8.4.15-init.lib64.patch
148- rebuilt with new toolchain
149
150* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
151- updated tcl to 8.4.13
152- updated tcl-html to 8.4.13
153
154* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
155- updated tcl to 8.4.12
156- updated patch4
157
158* Sat Aug 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.4.11-0vl1
159- updated tcl to 8.4.11
160- updated Patch4
161
162* Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
163- updated tcl to 8.4.6
164
165* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
166- merged with fedora
167  * Mon Dec  1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-3
168  - removed rpath (patch 4)
169
170  * Fri Nov 28 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-2
171  - put private header files under generic and unix subdirs
172  - include real generic/tclPort.h not just a symlink to tclUnixPort.h
173  - add tclMath.h to %{_includedir}/tcl-private/generic for building tk
174
175  * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
176  - new package split out from tcltk
177  - update to tcl 8.4.5 (#88429)
178    - drop tcl-8.3.3-heiierarchy.patch, tcl-8.3.3-dlopen.patch
179      and tcl8.3.5-koi8-u.enc-88806.patch
180  - include private include headers under %{_includedir}/tcl-private
181  - filtered changelog for tcl
182  - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
183
184* Sat Mar 29 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
185- update based on BitWalk's tcltk-8.4.2-83bw
186
187* Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
188- split source package.
189
190* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
191- expand some macros.. (FIXME)
192
193* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
194- use %configure macros
195- add Patch 47,50
196
197* Thu May 31 2001 <sagami@vinelinux.org>
198- 8.0.5_jp-10
199- unexpand old %%{configure}, new one causes build failure
200- fixed missing libtkx.so libtclx.so symlink in /usr/lib
201- install manpages into %%{_mandir} and mode 644
202
203* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
204- 8.0.5_jp-9
205- modified %install section to handle compressed man pages
206- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
207
208* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
209- changed default fonts
210
211* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
212- added defattr
213
214* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
215- added some symlinks, such as libtcl8.0.so.
216- obsoletes version number using _jp, now 8.0.5-31vl1
217
218* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
219- Apply Tcl/Tk 8.0 Japanese Patch 1.7
220
221* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
222- fix tclX symlinks.
223- compile on systems where SIGPWR == SIGLOST.
224
225* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
226- update tcl/tk to 8.0.5.
227- avoid "containing" in Tix (#2332).
228
229* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
230- use /usr/bin/write in kibitz (#1320).
231- use cirrus.sprl.umich.edu in weather (#1926).
232
233* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
234- auto rebuild in the new build environment (release 28)
235
236* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
237- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
238
239* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
240- expect does unaligned access on alpha (#989)
241- upgrade tcl/tk/tclX to 8.0.4
242- upgrade expect to 5.28.
243- add itcl 3.0.1
244
245* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
246- call libtoolize to allow building on the arm
247- build for glibc 2.1
248- strip binaries
249
250* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
251- update tcl/tk/tclX to 8.0.3, expect is updated also.
252
253* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
254- expect: mkpasswd needs delay before sending password (problem #576)
255
256* Thu May 07 1998 Prospector System <bugs@redhat.com>
257- translations modified for de, fr, tr
258
259* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
260- fixed expect binaries exec permissions
261
262* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
263- updated to Tix 4.1.0.006
264- updated version numbers of tcl/tk to relflect includsion of p2
265
266* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
267- updated tcl/tk to patch level 2
268- updated tclX to 8.0.2
269
270* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
271- fixed filelist for tix... replacing path to the expect binary in scripts
272  was leaving junk files around.
273
274* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
275- added patch to remove libieee test in configure.in for tcl and tk.
276  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
277  solution for all systems
278- fixed src urls
279
280* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
281- removed version numbers from descriptions
282
283* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
284- updated to tcl/tk 8.0 and related versions of packages
285
286* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
287- built against glibc
288- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.