source: projects/specs/trunk/t/tar/tar-vl.spec @ 9264

Revision 9264, 11.7 KB checked in by kudoh, 9 years ago (diff)

new upstream release

Line 
1Summary: A GNU file archiving program.
2Summary(ja): GNU ファイルアーカイブプログラム
3Name: tar
4Version: 1.28
5Release: 1%{?_dist_release}
6License: GPLv3+
7Group: Applications/Archiving
8Source: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.xz
9Patch0: tar-1.13.18-manpage.patch
10Patch8: tar-1.20-loneZeroWarning.patch
11Patch10: tar-1.15.1-gcc4.patch
12
13#Fix extracting sparse files to a filesystem like vfat,
14#when ftruncate may fail to grow the size of a file.(#179507)
15Patch11: tar-1.15.1-vfatTruncate.patch
16#change inclusion defaults of tar to "--wildcards --anchored
17#--wildcards-match-slash" for compatibility reasons (#206841)
18Patch12: tar-1.17-wildcards.patch
19
20# Fix for bad cooperation of -C and -u options.
21# ~> #688567
22# ~> http://lists.gnu.org/archive/html/bug-tar/2012-02/msg00007.html
23# ~> still downstream
24Patch15: tar-1.26-update-with-change-directory.patch
25
26# adhoc but useful patch for z option accepts bzip2ed tarball.
27Patch100: tar-1.13.6-barterly.patch
28Patch110: tar-1.22-rtapelib-overflow.patch
29
30BuildRequires: autoconf texinfo gettext
31
32Requires(post,postun): install-info
33Buildroot: %{_tmppath}/%{name}-%{version}-root
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39The GNU tar program saves many files together in one archive and can
40restore individual files (or all of the files) from that archive. Tar
41can also be used to add supplemental files to an archive and to update
42or list files in the archive. Tar includes multivolume support,
43automatic archive compression/decompression, the ability to perform
44remote archives, and the ability to perform incremental and full
45backups.
46
47If you want to use tar for remote backups, you also need to install
48the rmt package.
49
50
51%description -l ja
52GNU tar プログラムは多くのファイルを一つのファイルにまとめたりアーカイブ
53から個々のファイルを(または全てのファイルを)リストアしたりする。tar はまた
54追加ファイルを加えたりアーカイブファイル中のリストを更新したりするために
55使われる。
56
57tar はマルチボリュームサポート、自動アーカイブ圧縮/伸長、リモート
58アーカイブの取り扱う機能、そして差分バックアップとフルバックアップをする
59機能を含んでいる。
60
61もしリモートバックアップのために tar をインストールするなら、rmt パッケージ
62もまたインストールする必要がある。
63
64
65%prep
66%setup -q
67%patch0 -p1 -b .manpage
68%patch8 -p1 -b .loneZeroWarning
69%patch11 -p1 -b .vfatTruncate
70%patch12 -p1 -b .wildcards
71%patch15 -p1 -b .update_and_changedir
72
73%patch100 -p1 -b .accept-bz2
74%patch110 -p1 -b .CVE-2010-0624
75
76%build
77autoreconf
78%configure --bindir=/bin --libexecdir=/sbin
79make LIBS=-lbsd %{?_smp_mflags}
80
81
82%install
83rm -rf $RPM_BUILD_ROOT
84
85make prefix=${RPM_BUILD_ROOT}%{_prefix} \
86    localedir=${RPM_BUILD_ROOT}%{_prefix}/share/locale \
87    bindir=${RPM_BUILD_ROOT}/bin \
88    libexecdir=${RPM_BUILD_ROOT}/sbin \
89    mandir=${RPM_BUILD_ROOT}%{_mandir} \
90    infodir=${RPM_BUILD_ROOT}%{_infodir} \
91        install
92ln -s tar ${RPM_BUILD_ROOT}/bin/gtar
93
94( cd $RPM_BUILD_ROOT
95  for dir in ./bin ./sbin .%{_prefix}/bin .%{_prefix}/libexec
96  do
97    [ -d $dir ] || continue
98    strip $dir/* || :
99  done
100  gzip -9nf .%{_infodir}/tar.info*
101  rm -f .%{_infodir}/dir
102)
103
104mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
105install -c -m644 tar.1 ${RPM_BUILD_ROOT}%{_mandir}/man1
106
107rm -f ${RPM_BUILD_ROOT}/sbin/rmt
108
109%find_lang %name
110
111
112%post
113/sbin/install-info %{_infodir}/tar.info.gz %{_infodir}/dir
114
115
116%preun
117if [ $1 = 0 ]; then
118   /sbin/install-info --delete %{_infodir}/tar.info.gz %{_infodir}/dir
119fi
120
121
122%clean
123rm -rf ${RPM_BUILD_ROOT}
124
125
126%files -f %{name}.lang
127%defattr(-,root,root)
128%doc AUTHORS COPYING ChangeLog* NEWS README THANKS TODO
129/bin/tar
130/bin/gtar
131%{_mandir}/man1/tar.1*
132%{_mandir}/man8/rmt.8*
133%{_infodir}/tar.info*
134
135
136%changelog
137* Fri Jan 16 2015 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.28-1
138- new upstream release
139
140* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.27.1-1
141- new upstream release
142- remove Patch13 (tar-1.23-oldarchive.patch)
143- add Patch15 (tar-1.26-update-with-change-directory.patch) from Fedora
144
145* Wed May 18 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.26-1
146- new upstream release
147- added BuildRequires: gettext
148
149* Mon Nov 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.25-1
150- new upstream release
151- changed source archive type (gzip to bzip2)
152- modified Patch8 a little
153- added Patch11,12,13 from Fedora development
154- added BuildRequires: autoconf texinfo
155- run autoreconf on %%build
156
157* Tue Mar 16 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.22-4
158- add patch110 for fix CVE-2010-0624 (rmt) from fc11
159
160* Thu Apr 30 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.22-3
161- add missing documents
162
163* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22-2
164- spec in utf-8
165
166* Mon Mar 16 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.22-1
167- new upstream release
168- improved tar-1.20-loneZeroWarning.patch (refer to Fedora package)
169
170* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20-1
171- new upstream release
172- remove unneeded patches
173
174* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.15.1-0vl3
175- rebuilt for VineSeed
176
177* Thu Nov 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2.1
178- add patch120 for fix CVE-2006-6097
179
180* Sun Sep 17 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2
181- add patch110 for fix CVE-2006-0300
182
183* Mon May 02 2005 Satoshi MACHINO <machino@vinelinux.org> 1.15.1-0vl1
184- new upstream release
185- fixed patch6 and patch7 for new upstream release
186- some patches are imported from fedora package. and fixed
187        -- stop issuing lone zero block warnings(patch8)
188        -- fixed testsuite(patch9)
189        -- don't applyed(patch10)
190        -- fixed offset had incorrect type(patch11)
191
192* Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-0vl1
193- new upstream release
194- some patches are imported from fedora package.
195
196* Fri May  2 2003 IWAI Masaharu <iwai@alib.jp> 1.3.25-8vl4
197- rebuild with new toolchain
198  - update BuildRequire (autoconf253 -> autoconf)
199
200* Thu Oct 31 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.25-8vl3
201- add adhoc but useful patch100 for "z" option to accepts bz2 tarball.
202
203* Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl2
204- Oops the spec was in Shift-JIS. Fixed.
205
206* Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl1
207- based on 1.3.25-8 from Rawhide and built for Vine Linux
208- the previous Vine package was 1.3.18-0vl2. Vine's changelog was as follows:
209
210  - Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13.18-0vl2
211  - rebuild to remove rpmlib dependancy
212
213  - Sat May 26 2001 <sagami@vinelinux.org>
214  - 1.13.18-0vl1: based on 1.13.18-1 and added Japanese summary and description
215  - added barterly patch
216
217* Fri Aug 23 2002 Phil Knirsch <pknirsch@redhat.com> 1.13.25-8
218- Included security patch from errata release.
219
220* Mon Jul  1 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-7
221- Fix argv NULL termination (#64869)
222
223* Thu May 23 2002 Tim Powers <timp@redhat.com>
224- automated rebuild
225
226* Tue Apr  9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-4
227- Fix build with autoconf253 (LIBOBJ change; autoconf252 worked)
228
229* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
230- automated rebuild
231
232* Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-2
233- Don't include hardlinks to sockets in a tar file (#54827)
234
235* Thu Sep 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-1
236- 1.13.25
237
238* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.22-1
239- Update to 1.13.22, adapt patches
240
241* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-6
242- Fix #52084
243
244* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-5
245- Fix build with current autoconf (stricter checking on AC_DEFINE)
246- Fix segfault when tarring directories without having read permissions
247  (#40802)
248
249* Tue Mar  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
250- Don't depend on librt.
251
252* Fri Feb 23 2001 Trond Eivind Glomsr <teg@redhat.com>
253- langify
254
255* Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
256- Fix up the man page (#28915)
257
258* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
259- 1.3.19, nukes -I and fixes up -N
260- Add -I back in as an alias to -j with a nice loud warning
261
262* Mon Oct 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
263- 1.3.18
264- Update man page to reflect changes
265
266* Thu Oct  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
267- Fix the "ignore failed read" option (Bug #8330)
268
269* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
270- fix hang on tar tvzf - <something.tar.gz, introduced by
271  exit code fix (Bug #15448), Patch from Tim Waugh <twaugh@redhat.com>
272
273* Fri Aug 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
274- really fix exit code (Bug #15448)
275
276* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
277- fix exit code (Bug #15448), patch from Tim Waugh <twaugh@redhat.com>
278
279* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
280- automatic rebuild
281
282* Mon Jun 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
283- FHSify
284
285* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
286- fix for ia64
287
288* Wed Feb  9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
289- Fix the exclude bug (#9201)
290
291* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
292- man pages are compressed
293- fix description
294- fix fnmatch build problems
295
296* Sun Jan  9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
297- 1.13.17
298- remove dotbug patch (fixed in base)
299- update download URL
300
301* Fri Jan  7 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
302- Fix a severe bug (tar xf any_package_containing_. would delete the
303  current directory)
304
305* Wed Jan  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
306- 1.3.16
307- unset LINGUAS before running configure
308
309* Tue Nov  9 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
310- 1.13.14
311- Update man page to know about -I / --bzip
312- Remove dependancy on rmt - tar can be used for anything local
313  without it.
314
315* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
316- upgrade to 1.13.11.
317
318* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
319- update to 1.13.9.
320
321* Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
322- update to 1.13.6.
323- support -y --bzip2 options for bzip2 compression (#2415).
324
325* Fri Jul 23 1999 Jeff Johnson <jbj@redhat.com>
326- update to 1.13.5.
327
328* Tue Jul 13 1999 Bill Nottingham <notting@redhat.com>
329- update to 1.13
330
331* Sat Jun 26 1999 Jeff Johnson <jbj@redhat.com>
332- update to 1.12.64014.
333- pipe patch corrected for remote tars now merged in.
334
335* Sun Jun 20 1999 Jeff Johnson <jbj@redhat.com>
336- update to tar-1.12.64013.
337- subtract (and reopen #2415) bzip2 support using -y.
338- move gtar to /bin.
339
340* Tue Jun 15 1999 Jeff Johnson <jbj@redhat.com>
341- upgrade to tar-1.12.64011 to
342-   add bzip2 support (#2415)
343-   fix filename bug (#3479)
344
345* Mon Mar 29 1999 Jeff Johnson <jbj@redhat.com>
346- fix suspended tar with compression over pipe produces error (#390).
347
348* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
349- auto rebuild in the new build environment (release 8)
350
351* Mon Mar 08 1999 Michael Maher <mike@redhat.com>
352- added patch for bad name cache.
353- FIXES BUG 320
354
355* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
356- Injected new description and group.
357
358* Fri Dec 18 1998 Preston Brown <pbrown@redhat.com>
359- bumped spec number for initial rh 6.0 build
360
361* Tue Aug  4 1998 Jeff Johnson <jbj@redhat.com>
362- add /usr/bin/gtar symlink (change #421)
363
364* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
365- Fiddle bindir/libexecdir to get RH install correct.
366- Don't include /sbin/rmt -- use the rmt from dump.
367- Turn on nls.
368
369* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
370- translations modified for de, fr, tr
371
372* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
373- updated from 1.11.8 to 1.12
374- various spec file cleanups
375- /sbin/install-info support
376
377* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
378- built against glibc
379
380* Thu May 29 1997 Michael Fulbright <msf@redhat.com>
381- Fixed to include rmt
Note: See TracBrowser for help on using the repository browser.