source: projects/specs/trunk/t/tar/tar-vl.spec @ 8065

Revision 8065, 11.6 KB checked in by Takemikaduchi, 10 years ago (diff)

libdrm, libwacom, tar: new upstream release
xorg-x11-drivers: new upstream release or rebuild

Line 
1Summary: A GNU file archiving program.
2Summary(ja): GNU ファイルアーカイブプログラム
3Name: tar
4Version: 1.27.1
5Release: 1%{?_dist_release}
6License: GPLv3+
7Group: Applications/Archiving
8Source: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.xz
9Patch0: tar-1.13.18-manpage.patch
10Patch8: tar-1.20-loneZeroWarning.patch
11Patch10: tar-1.15.1-gcc4.patch
12
13#Fix extracting sparse files to a filesystem like vfat,
14#when ftruncate may fail to grow the size of a file.(#179507)
15Patch11: tar-1.15.1-vfatTruncate.patch
16#change inclusion defaults of tar to "--wildcards --anchored
17#--wildcards-match-slash" for compatibility reasons (#206841)
18Patch12: tar-1.17-wildcards.patch
19
20# Fix for bad cooperation of -C and -u options.
21# ~> #688567
22# ~> http://lists.gnu.org/archive/html/bug-tar/2012-02/msg00007.html
23# ~> still downstream
24Patch15: tar-1.26-update-with-change-directory.patch
25
26# adhoc but useful patch for z option accepts bzip2ed tarball.
27Patch100: tar-1.13.6-barterly.patch
28Patch110: tar-1.22-rtapelib-overflow.patch
29
30BuildRequires: autoconf texinfo gettext
31
32Requires(post,postun): install-info
33Buildroot: %{_tmppath}/%{name}-%{version}-root
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39The GNU tar program saves many files together in one archive and can
40restore individual files (or all of the files) from that archive. Tar
41can also be used to add supplemental files to an archive and to update
42or list files in the archive. Tar includes multivolume support,
43automatic archive compression/decompression, the ability to perform
44remote archives, and the ability to perform incremental and full
45backups.
46
47If you want to use tar for remote backups, you also need to install
48the rmt package.
49
50
51%description -l ja
52GNU tar プログラムは多くのファイルを一つのファイルにまとめたりアーカイブ
53から個々のファイルを(または全てのファイルを)リストアしたりする。tar はまた
54追加ファイルを加えたりアーカイブファイル中のリストを更新したりするために
55使われる。
56
57tar はマルチボリュームサポート、自動アーカイブ圧縮/伸長、リモート
58アーカイブの取り扱う機能、そして差分バックアップとフルバックアップをする
59機能を含んでいる。
60
61もしリモートバックアップのために tar をインストールするなら、rmt パッケージ
62もまたインストールする必要がある。
63
64
65%prep
66%setup -q
67%patch0 -p1 -b .manpage
68%patch8 -p1 -b .loneZeroWarning
69%patch11 -p1 -b .vfatTruncate
70%patch12 -p1 -b .wildcards
71%patch15 -p1 -b .update_and_changedir
72
73%patch100 -p1 -b .accept-bz2
74%patch110 -p1 -b .CVE-2010-0624
75
76%build
77autoreconf
78%configure --bindir=/bin --libexecdir=/sbin
79make LIBS=-lbsd %{?_smp_mflags}
80
81
82%install
83rm -rf $RPM_BUILD_ROOT
84
85make prefix=${RPM_BUILD_ROOT}%{_prefix} \
86    localedir=${RPM_BUILD_ROOT}%{_prefix}/share/locale \
87    bindir=${RPM_BUILD_ROOT}/bin \
88    libexecdir=${RPM_BUILD_ROOT}/sbin \
89    mandir=${RPM_BUILD_ROOT}%{_mandir} \
90    infodir=${RPM_BUILD_ROOT}%{_infodir} \
91        install
92ln -s tar ${RPM_BUILD_ROOT}/bin/gtar
93
94( cd $RPM_BUILD_ROOT
95  for dir in ./bin ./sbin .%{_prefix}/bin .%{_prefix}/libexec
96  do
97    [ -d $dir ] || continue
98    strip $dir/* || :
99  done
100  gzip -9nf .%{_infodir}/tar.info*
101  rm -f .%{_infodir}/dir
102)
103
104mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
105install -c -m644 tar.1 ${RPM_BUILD_ROOT}%{_mandir}/man1
106
107rm -f ${RPM_BUILD_ROOT}/sbin/rmt
108
109%find_lang %name
110
111
112%post
113/sbin/install-info %{_infodir}/tar.info.gz %{_infodir}/dir
114
115
116%preun
117if [ $1 = 0 ]; then
118   /sbin/install-info --delete %{_infodir}/tar.info.gz %{_infodir}/dir
119fi
120
121
122%clean
123rm -rf ${RPM_BUILD_ROOT}
124
125
126%files -f %{name}.lang
127%defattr(-,root,root)
128%doc AUTHORS COPYING ChangeLog* NEWS README THANKS TODO
129/bin/tar
130/bin/gtar
131%{_mandir}/man1/tar.1*
132%{_infodir}/tar.info*
133
134
135%changelog
136* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.27.1-1
137- new upstream release
138- remove Patch13 (tar-1.23-oldarchive.patch)
139- add Patch15 (tar-1.26-update-with-change-directory.patch) from Fedora
140
141* Wed May 18 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.26-1
142- new upstream release
143- added BuildRequires: gettext
144
145* Mon Nov 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.25-1
146- new upstream release
147- changed source archive type (gzip to bzip2)
148- modified Patch8 a little
149- added Patch11,12,13 from Fedora development
150- added BuildRequires: autoconf texinfo
151- run autoreconf on %%build
152
153* Tue Mar 16 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.22-4
154- add patch110 for fix CVE-2010-0624 (rmt) from fc11
155
156* Thu Apr 30 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.22-3
157- add missing documents
158
159* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22-2
160- spec in utf-8
161
162* Mon Mar 16 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.22-1
163- new upstream release
164- improved tar-1.20-loneZeroWarning.patch (refer to Fedora package)
165
166* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20-1
167- new upstream release
168- remove unneeded patches
169
170* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.15.1-0vl3
171- rebuilt for VineSeed
172
173* Thu Nov 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2.1
174- add patch120 for fix CVE-2006-6097
175
176* Sun Sep 17 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2
177- add patch110 for fix CVE-2006-0300
178
179* Mon May 02 2005 Satoshi MACHINO <machino@vinelinux.org> 1.15.1-0vl1
180- new upstream release
181- fixed patch6 and patch7 for new upstream release
182- some patches are imported from fedora package. and fixed
183        -- stop issuing lone zero block warnings(patch8)
184        -- fixed testsuite(patch9)
185        -- don't applyed(patch10)
186        -- fixed offset had incorrect type(patch11)
187
188* Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-0vl1
189- new upstream release
190- some patches are imported from fedora package.
191
192* Fri May  2 2003 IWAI Masaharu <iwai@alib.jp> 1.3.25-8vl4
193- rebuild with new toolchain
194  - update BuildRequire (autoconf253 -> autoconf)
195
196* Thu Oct 31 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.25-8vl3
197- add adhoc but useful patch100 for "z" option to accepts bz2 tarball.
198
199* Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl2
200- Oops the spec was in Shift-JIS. Fixed.
201
202* Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl1
203- based on 1.3.25-8 from Rawhide and built for Vine Linux
204- the previous Vine package was 1.3.18-0vl2. Vine's changelog was as follows:
205
206  - Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13.18-0vl2
207  - rebuild to remove rpmlib dependancy
208
209  - Sat May 26 2001 <sagami@vinelinux.org>
210  - 1.13.18-0vl1: based on 1.13.18-1 and added Japanese summary and description
211  - added barterly patch
212
213* Fri Aug 23 2002 Phil Knirsch <pknirsch@redhat.com> 1.13.25-8
214- Included security patch from errata release.
215
216* Mon Jul  1 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-7
217- Fix argv NULL termination (#64869)
218
219* Thu May 23 2002 Tim Powers <timp@redhat.com>
220- automated rebuild
221
222* Tue Apr  9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-4
223- Fix build with autoconf253 (LIBOBJ change; autoconf252 worked)
224
225* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
226- automated rebuild
227
228* Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-2
229- Don't include hardlinks to sockets in a tar file (#54827)
230
231* Thu Sep 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-1
232- 1.13.25
233
234* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.22-1
235- Update to 1.13.22, adapt patches
236
237* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-6
238- Fix #52084
239
240* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-5
241- Fix build with current autoconf (stricter checking on AC_DEFINE)
242- Fix segfault when tarring directories without having read permissions
243  (#40802)
244
245* Tue Mar  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
246- Don't depend on librt.
247
248* Fri Feb 23 2001 Trond Eivind Glomsr <teg@redhat.com>
249- langify
250
251* Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
252- Fix up the man page (#28915)
253
254* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
255- 1.3.19, nukes -I and fixes up -N
256- Add -I back in as an alias to -j with a nice loud warning
257
258* Mon Oct 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
259- 1.3.18
260- Update man page to reflect changes
261
262* Thu Oct  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
263- Fix the "ignore failed read" option (Bug #8330)
264
265* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
266- fix hang on tar tvzf - <something.tar.gz, introduced by
267  exit code fix (Bug #15448), Patch from Tim Waugh <twaugh@redhat.com>
268
269* Fri Aug 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
270- really fix exit code (Bug #15448)
271
272* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
273- fix exit code (Bug #15448), patch from Tim Waugh <twaugh@redhat.com>
274
275* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
276- automatic rebuild
277
278* Mon Jun 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
279- FHSify
280
281* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
282- fix for ia64
283
284* Wed Feb  9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
285- Fix the exclude bug (#9201)
286
287* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
288- man pages are compressed
289- fix description
290- fix fnmatch build problems
291
292* Sun Jan  9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
293- 1.13.17
294- remove dotbug patch (fixed in base)
295- update download URL
296
297* Fri Jan  7 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
298- Fix a severe bug (tar xf any_package_containing_. would delete the
299  current directory)
300
301* Wed Jan  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
302- 1.3.16
303- unset LINGUAS before running configure
304
305* Tue Nov  9 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
306- 1.13.14
307- Update man page to know about -I / --bzip
308- Remove dependancy on rmt - tar can be used for anything local
309  without it.
310
311* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
312- upgrade to 1.13.11.
313
314* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
315- update to 1.13.9.
316
317* Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
318- update to 1.13.6.
319- support -y --bzip2 options for bzip2 compression (#2415).
320
321* Fri Jul 23 1999 Jeff Johnson <jbj@redhat.com>
322- update to 1.13.5.
323
324* Tue Jul 13 1999 Bill Nottingham <notting@redhat.com>
325- update to 1.13
326
327* Sat Jun 26 1999 Jeff Johnson <jbj@redhat.com>
328- update to 1.12.64014.
329- pipe patch corrected for remote tars now merged in.
330
331* Sun Jun 20 1999 Jeff Johnson <jbj@redhat.com>
332- update to tar-1.12.64013.
333- subtract (and reopen #2415) bzip2 support using -y.
334- move gtar to /bin.
335
336* Tue Jun 15 1999 Jeff Johnson <jbj@redhat.com>
337- upgrade to tar-1.12.64011 to
338-   add bzip2 support (#2415)
339-   fix filename bug (#3479)
340
341* Mon Mar 29 1999 Jeff Johnson <jbj@redhat.com>
342- fix suspended tar with compression over pipe produces error (#390).
343
344* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
345- auto rebuild in the new build environment (release 8)
346
347* Mon Mar 08 1999 Michael Maher <mike@redhat.com>
348- added patch for bad name cache.
349- FIXES BUG 320
350
351* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
352- Injected new description and group.
353
354* Fri Dec 18 1998 Preston Brown <pbrown@redhat.com>
355- bumped spec number for initial rh 6.0 build
356
357* Tue Aug  4 1998 Jeff Johnson <jbj@redhat.com>
358- add /usr/bin/gtar symlink (change #421)
359
360* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
361- Fiddle bindir/libexecdir to get RH install correct.
362- Don't include /sbin/rmt -- use the rmt from dump.
363- Turn on nls.
364
365* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
366- translations modified for de, fr, tr
367
368* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
369- updated from 1.11.8 to 1.12
370- various spec file cleanups
371- /sbin/install-info support
372
373* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
374- built against glibc
375
376* Thu May 29 1997 Michael Fulbright <msf@redhat.com>
377- Fixed to include rmt
Note: See TracBrowser for help on using the repository browser.