source: projects/specs/trunk/t/tar/tar-vl.spec @ 1393

Revision 1393, 10.3 KB checked in by inagaki, 14 years ago (diff)

updated: libindi, libpng, cups, sudo, sylpheed and tar

Line 
1Summary: A GNU file archiving program.
2Summary(ja): GNU ファイルアーカイブプログラム
3Name: tar
4Version: 1.22
5Release: 4%{?_dist_release}
6License: GPLv3+
7Group: Applications/Archiving
8Source: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.gz
9Patch0: tar-1.13.18-manpage.patch
10Patch8: tar-1.20-loneZeroWarning.patch
11Patch10: tar-1.15.1-gcc4.patch
12# adhoc but useful patch for z option accepts bzip2ed tarball.
13Patch100: tar-1.13.6-barterly.patch
14Patch110: tar-1.22-rtapelib-overflow.patch
15Requires(post,postun): install-info
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17
18
19%description
20The GNU tar program saves many files together in one archive and can
21restore individual files (or all of the files) from that archive. Tar
22can also be used to add supplemental files to an archive and to update
23or list files in the archive. Tar includes multivolume support,
24automatic archive compression/decompression, the ability to perform
25remote archives, and the ability to perform incremental and full
26backups.
27
28If you want to use tar for remote backups, you also need to install
29the rmt package.
30
31
32%description -l ja
33GNU tar プログラムは多くのファイルを一つのファイルにまとめたりアーカイブ
34から個々のファイルを(または全てのファイルを)リストアしたりする。tarはまた
35追加ファイルを加えたりアーカイブファイル中のリストを更新したりするために
36使われる。
37
38tar はマルチボリュームサポート、自動アーカイブ圧縮/伸長、リモート
39アーカイブの取り扱う機能、そして差分バックアップとフルバックアップをする
40機能を含んでいる。
41
42もしリモートバックアップのために tar をインストールするなら、rmt パッケージ
43もまたインストールする必要がある。
44
45
46%prep
47%setup -q
48%patch0 -p1 -b .manpage
49%patch8 -p1 -b .loneZeroWarning
50%patch100 -p1 -b .accept-bz2
51%patch110 -p1 -b .CVE-2010-0624
52
53
54%build
55%configure --bindir=/bin --libexecdir=/sbin
56make LIBS=-lbsd %{?_smp_mflags}
57
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62make prefix=${RPM_BUILD_ROOT}%{_prefix} \
63    localedir=${RPM_BUILD_ROOT}%{_prefix}/share/locale \
64    bindir=${RPM_BUILD_ROOT}/bin \
65    libexecdir=${RPM_BUILD_ROOT}/sbin \
66    mandir=${RPM_BUILD_ROOT}%{_mandir} \
67    infodir=${RPM_BUILD_ROOT}%{_infodir} \
68        install
69ln -s tar ${RPM_BUILD_ROOT}/bin/gtar
70
71( cd $RPM_BUILD_ROOT
72  for dir in ./bin ./sbin .%{_prefix}/bin .%{_prefix}/libexec
73  do
74    [ -d $dir ] || continue
75    strip $dir/* || :
76  done
77  gzip -9nf .%{_infodir}/tar.info*
78  rm -f .%{_infodir}/dir
79)
80
81mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
82install -c -m644 tar.1 ${RPM_BUILD_ROOT}%{_mandir}/man1
83
84rm -f ${RPM_BUILD_ROOT}/sbin/rmt
85
86%find_lang %name
87
88
89%post
90/sbin/install-info %{_infodir}/tar.info.gz %{_infodir}/dir
91
92
93%preun
94if [ $1 = 0 ]; then
95   /sbin/install-info --delete %{_infodir}/tar.info.gz %{_infodir}/dir
96fi
97
98
99%clean
100rm -rf ${RPM_BUILD_ROOT}
101
102
103%files -f %{name}.lang
104%defattr(-,root,root)
105%doc AUTHORS COPYING ChangeLog* NEWS README THANKS TODO
106/bin/tar
107/bin/gtar
108%{_mandir}/man1/tar.1*
109%{_infodir}/tar.info*
110
111
112%changelog
113* Tue Mar 16 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.22-4
114- add patch110 for fix CVE-2010-0624 (rmt) from fc11
115
116* Thu Apr 30 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.22-3
117- add missing documents
118
119* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22-2
120- spec in utf-8
121
122* Mon Mar 16 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.22-1
123- new upstream release
124- improved tar-1.20-loneZeroWarning.patch (refer to Fedora package)
125
126* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20-1
127- new upstream release
128- remove unneeded patches
129
130* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.15.1-0vl3
131- rebuilt for VineSeed
132
133* Thu Nov 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2.1
134- add patch120 for fix CVE-2006-6097
135
136* Sun Sep 17 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2
137- add patch110 for fix CVE-2006-0300
138
139* Mon May 02 2005 Satoshi MACHINO <machino@vinelinux.org> 1.15.1-0vl1
140- new upstream release
141- fixed patch6 and patch7 for new upstream release
142- some patches are imported from fedora package. and fixed
143        -- stop issuing lone zero block warnings(patch8)
144        -- fixed testsuite(patch9)
145        -- don't applyed(patch10)
146        -- fixed offset had incorrect type(patch11)
147
148* Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-0vl1
149- new upstream release
150- some patches are imported from fedora package.
151
152* Fri May  2 2003 IWAI Masaharu <iwai@alib.jp> 1.3.25-8vl4
153- rebuild with new toolchain
154  - update BuildRequire (autoconf253 -> autoconf)
155
156* Thu Oct 31 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.25-8vl3
157- add adhoc but useful patch100 for "z" option to accepts bz2 tarball.
158
159* Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl2
160- Oops the spec was in Shift-JIS. Fixed.
161
162* Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl1
163- based on 1.3.25-8 from Rawhide and built for Vine Linux
164- the previous Vine package was 1.3.18-0vl2. Vine's changelog was as follows:
165
166  - Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13.18-0vl2
167  - rebuild to remove rpmlib dependancy
168
169  - Sat May 26 2001 <sagami@vinelinux.org>
170  - 1.13.18-0vl1: based on 1.13.18-1 and added Japanese summary and description
171  - added barterly patch
172
173* Fri Aug 23 2002 Phil Knirsch <pknirsch@redhat.com> 1.13.25-8
174- Included security patch from errata release.
175
176* Mon Jul  1 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-7
177- Fix argv NULL termination (#64869)
178
179* Thu May 23 2002 Tim Powers <timp@redhat.com>
180- automated rebuild
181
182* Tue Apr  9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-4
183- Fix build with autoconf253 (LIBOBJ change; autoconf252 worked)
184
185* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
186- automated rebuild
187
188* Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-2
189- Don't include hardlinks to sockets in a tar file (#54827)
190
191* Thu Sep 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-1
192- 1.13.25
193
194* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.22-1
195- Update to 1.13.22, adapt patches
196
197* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-6
198- Fix #52084
199
200* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-5
201- Fix build with current autoconf (stricter checking on AC_DEFINE)
202- Fix segfault when tarring directories without having read permissions
203  (#40802)
204
205* Tue Mar  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
206- Don't depend on librt.
207
208* Fri Feb 23 2001 Trond Eivind Glomsr <teg@redhat.com>
209- langify
210
211* Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
212- Fix up the man page (#28915)
213
214* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
215- 1.3.19, nukes -I and fixes up -N
216- Add -I back in as an alias to -j with a nice loud warning
217
218* Mon Oct 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
219- 1.3.18
220- Update man page to reflect changes
221
222* Thu Oct  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
223- Fix the "ignore failed read" option (Bug #8330)
224
225* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
226- fix hang on tar tvzf - <something.tar.gz, introduced by
227  exit code fix (Bug #15448), Patch from Tim Waugh <twaugh@redhat.com>
228
229* Fri Aug 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
230- really fix exit code (Bug #15448)
231
232* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
233- fix exit code (Bug #15448), patch from Tim Waugh <twaugh@redhat.com>
234
235* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
236- automatic rebuild
237
238* Mon Jun 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
239- FHSify
240
241* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
242- fix for ia64
243
244* Wed Feb  9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
245- Fix the exclude bug (#9201)
246
247* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
248- man pages are compressed
249- fix description
250- fix fnmatch build problems
251
252* Sun Jan  9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
253- 1.13.17
254- remove dotbug patch (fixed in base)
255- update download URL
256
257* Fri Jan  7 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
258- Fix a severe bug (tar xf any_package_containing_. would delete the
259  current directory)
260
261* Wed Jan  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
262- 1.3.16
263- unset LINGUAS before running configure
264
265* Tue Nov  9 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
266- 1.13.14
267- Update man page to know about -I / --bzip
268- Remove dependancy on rmt - tar can be used for anything local
269  without it.
270
271* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
272- upgrade to 1.13.11.
273
274* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
275- update to 1.13.9.
276
277* Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
278- update to 1.13.6.
279- support -y --bzip2 options for bzip2 compression (#2415).
280
281* Fri Jul 23 1999 Jeff Johnson <jbj@redhat.com>
282- update to 1.13.5.
283
284* Tue Jul 13 1999 Bill Nottingham <notting@redhat.com>
285- update to 1.13
286
287* Sat Jun 26 1999 Jeff Johnson <jbj@redhat.com>
288- update to 1.12.64014.
289- pipe patch corrected for remote tars now merged in.
290
291* Sun Jun 20 1999 Jeff Johnson <jbj@redhat.com>
292- update to tar-1.12.64013.
293- subtract (and reopen #2415) bzip2 support using -y.
294- move gtar to /bin.
295
296* Tue Jun 15 1999 Jeff Johnson <jbj@redhat.com>
297- upgrade to tar-1.12.64011 to
298-   add bzip2 support (#2415)
299-   fix filename bug (#3479)
300
301* Mon Mar 29 1999 Jeff Johnson <jbj@redhat.com>
302- fix suspended tar with compression over pipe produces error (#390).
303
304* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
305- auto rebuild in the new build environment (release 8)
306
307* Mon Mar 08 1999 Michael Maher <mike@redhat.com>
308- added patch for bad name cache.
309- FIXES BUG 320
310
311* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
312- Injected new description and group.
313
314* Fri Dec 18 1998 Preston Brown <pbrown@redhat.com>
315- bumped spec number for initial rh 6.0 build
316
317* Tue Aug  4 1998 Jeff Johnson <jbj@redhat.com>
318- add /usr/bin/gtar symlink (change #421)
319
320* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
321- Fiddle bindir/libexecdir to get RH install correct.
322- Don't include /sbin/rmt -- use the rmt from dump.
323- Turn on nls.
324
325* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
326- translations modified for de, fr, tr
327
328* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
329- updated from 1.11.8 to 1.12
330- various spec file cleanups
331- /sbin/install-info support
332
333* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
334- built against glibc
335
336* Thu May 29 1997 Michael Fulbright <msf@redhat.com>
337- Fixed to include rmt
Note: See TracBrowser for help on using the repository browser.