source: projects/specs/trunk/t/tar/tar-vl.spec @ 2188

Revision 2188, 11.1 KB checked in by kudoh, 13 years ago (diff)
Line 
1Summary: A GNU file archiving program.
2Summary(ja): GNU ファイルアーカイブプログラム
3Name: tar
4Version: 1.25
5Release: 1%{?_dist_release}
6License: GPLv3+
7Group: Applications/Archiving
8Source: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.bz2
9Patch0: tar-1.13.18-manpage.patch
10Patch8: tar-1.20-loneZeroWarning.patch
11Patch10: tar-1.15.1-gcc4.patch
12
13#Fix extracting sparse files to a filesystem like vfat,
14#when ftruncate may fail to grow the size of a file.(#179507)
15Patch11: tar-1.15.1-vfatTruncate.patch
16#change inclusion defaults of tar to "--wildcards --anchored
17#--wildcards-match-slash" for compatibility reasons (#206841)
18Patch12: tar-1.17-wildcards.patch
19#oldarchive option was not working(#594044)
20Patch13: tar-1.23-oldarchive.patch
21
22# adhoc but useful patch for z option accepts bzip2ed tarball.
23Patch100: tar-1.13.6-barterly.patch
24Patch110: tar-1.22-rtapelib-overflow.patch
25
26BuildRequires: autoconf texinfo
27
28Requires(post,postun): install-info
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30
31
32%description
33The GNU tar program saves many files together in one archive and can
34restore individual files (or all of the files) from that archive. Tar
35can also be used to add supplemental files to an archive and to update
36or list files in the archive. Tar includes multivolume support,
37automatic archive compression/decompression, the ability to perform
38remote archives, and the ability to perform incremental and full
39backups.
40
41If you want to use tar for remote backups, you also need to install
42the rmt package.
43
44
45%description -l ja
46GNU tar プログラムは多くのファイルを一つのファイルにまとめたりアーカイブ
47から個々のファイルを(または全てのファイルを)リストアしたりする。tar はまた
48追加ファイルを加えたりアーカイブファイル中のリストを更新したりするために
49使われる。
50
51tar はマルチボリュームサポート、自動アーカイブ圧縮/伸長、リモート
52アーカイブの取り扱う機能、そして差分バックアップとフルバックアップをする
53機能を含んでいる。
54
55もしリモートバックアップのために tar をインストールするなら、rmt パッケージ
56もまたインストールする必要がある。
57
58
59%prep
60%setup -q
61%patch0 -p1 -b .manpage
62%patch8 -p1 -b .loneZeroWarning
63%patch11 -p1 -b .vfatTruncate
64%patch12 -p1 -b .wildcards
65%patch13 -p1 -b .oldarchive
66
67%patch100 -p1 -b .accept-bz2
68%patch110 -p1 -b .CVE-2010-0624
69
70%build
71autoreconf
72%configure --bindir=/bin --libexecdir=/sbin
73make LIBS=-lbsd %{?_smp_mflags}
74
75
76%install
77rm -rf $RPM_BUILD_ROOT
78
79make prefix=${RPM_BUILD_ROOT}%{_prefix} \
80    localedir=${RPM_BUILD_ROOT}%{_prefix}/share/locale \
81    bindir=${RPM_BUILD_ROOT}/bin \
82    libexecdir=${RPM_BUILD_ROOT}/sbin \
83    mandir=${RPM_BUILD_ROOT}%{_mandir} \
84    infodir=${RPM_BUILD_ROOT}%{_infodir} \
85        install
86ln -s tar ${RPM_BUILD_ROOT}/bin/gtar
87
88( cd $RPM_BUILD_ROOT
89  for dir in ./bin ./sbin .%{_prefix}/bin .%{_prefix}/libexec
90  do
91    [ -d $dir ] || continue
92    strip $dir/* || :
93  done
94  gzip -9nf .%{_infodir}/tar.info*
95  rm -f .%{_infodir}/dir
96)
97
98mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
99install -c -m644 tar.1 ${RPM_BUILD_ROOT}%{_mandir}/man1
100
101rm -f ${RPM_BUILD_ROOT}/sbin/rmt
102
103%find_lang %name
104
105
106%post
107/sbin/install-info %{_infodir}/tar.info.gz %{_infodir}/dir
108
109
110%preun
111if [ $1 = 0 ]; then
112   /sbin/install-info --delete %{_infodir}/tar.info.gz %{_infodir}/dir
113fi
114
115
116%clean
117rm -rf ${RPM_BUILD_ROOT}
118
119
120%files -f %{name}.lang
121%defattr(-,root,root)
122%doc AUTHORS COPYING ChangeLog* NEWS README THANKS TODO
123/bin/tar
124/bin/gtar
125%{_mandir}/man1/tar.1*
126%{_infodir}/tar.info*
127
128
129%changelog
130* Mon Nov 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.25-1
131- new upstream release
132- changed source archive type (gzip to bzip2)
133- modified Patch8 a little
134- added Patch11,12,13 from Fedora development
135- added BuildRequires: autoconf texinfo
136- run autoreconf on %%build
137
138* Tue Mar 16 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.22-4
139- add patch110 for fix CVE-2010-0624 (rmt) from fc11
140
141* Thu Apr 30 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.22-3
142- add missing documents
143
144* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22-2
145- spec in utf-8
146
147* Mon Mar 16 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.22-1
148- new upstream release
149- improved tar-1.20-loneZeroWarning.patch (refer to Fedora package)
150
151* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20-1
152- new upstream release
153- remove unneeded patches
154
155* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.15.1-0vl3
156- rebuilt for VineSeed
157
158* Thu Nov 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2.1
159- add patch120 for fix CVE-2006-6097
160
161* Sun Sep 17 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2
162- add patch110 for fix CVE-2006-0300
163
164* Mon May 02 2005 Satoshi MACHINO <machino@vinelinux.org> 1.15.1-0vl1
165- new upstream release
166- fixed patch6 and patch7 for new upstream release
167- some patches are imported from fedora package. and fixed
168        -- stop issuing lone zero block warnings(patch8)
169        -- fixed testsuite(patch9)
170        -- don't applyed(patch10)
171        -- fixed offset had incorrect type(patch11)
172
173* Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-0vl1
174- new upstream release
175- some patches are imported from fedora package.
176
177* Fri May  2 2003 IWAI Masaharu <iwai@alib.jp> 1.3.25-8vl4
178- rebuild with new toolchain
179  - update BuildRequire (autoconf253 -> autoconf)
180
181* Thu Oct 31 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.25-8vl3
182- add adhoc but useful patch100 for "z" option to accepts bz2 tarball.
183
184* Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl2
185- Oops the spec was in Shift-JIS. Fixed.
186
187* Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl1
188- based on 1.3.25-8 from Rawhide and built for Vine Linux
189- the previous Vine package was 1.3.18-0vl2. Vine's changelog was as follows:
190
191  - Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13.18-0vl2
192  - rebuild to remove rpmlib dependancy
193
194  - Sat May 26 2001 <sagami@vinelinux.org>
195  - 1.13.18-0vl1: based on 1.13.18-1 and added Japanese summary and description
196  - added barterly patch
197
198* Fri Aug 23 2002 Phil Knirsch <pknirsch@redhat.com> 1.13.25-8
199- Included security patch from errata release.
200
201* Mon Jul  1 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-7
202- Fix argv NULL termination (#64869)
203
204* Thu May 23 2002 Tim Powers <timp@redhat.com>
205- automated rebuild
206
207* Tue Apr  9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-4
208- Fix build with autoconf253 (LIBOBJ change; autoconf252 worked)
209
210* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
211- automated rebuild
212
213* Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-2
214- Don't include hardlinks to sockets in a tar file (#54827)
215
216* Thu Sep 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-1
217- 1.13.25
218
219* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.22-1
220- Update to 1.13.22, adapt patches
221
222* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-6
223- Fix #52084
224
225* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-5
226- Fix build with current autoconf (stricter checking on AC_DEFINE)
227- Fix segfault when tarring directories without having read permissions
228  (#40802)
229
230* Tue Mar  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
231- Don't depend on librt.
232
233* Fri Feb 23 2001 Trond Eivind Glomsr <teg@redhat.com>
234- langify
235
236* Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
237- Fix up the man page (#28915)
238
239* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
240- 1.3.19, nukes -I and fixes up -N
241- Add -I back in as an alias to -j with a nice loud warning
242
243* Mon Oct 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
244- 1.3.18
245- Update man page to reflect changes
246
247* Thu Oct  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
248- Fix the "ignore failed read" option (Bug #8330)
249
250* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
251- fix hang on tar tvzf - <something.tar.gz, introduced by
252  exit code fix (Bug #15448), Patch from Tim Waugh <twaugh@redhat.com>
253
254* Fri Aug 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
255- really fix exit code (Bug #15448)
256
257* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
258- fix exit code (Bug #15448), patch from Tim Waugh <twaugh@redhat.com>
259
260* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
261- automatic rebuild
262
263* Mon Jun 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
264- FHSify
265
266* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
267- fix for ia64
268
269* Wed Feb  9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
270- Fix the exclude bug (#9201)
271
272* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
273- man pages are compressed
274- fix description
275- fix fnmatch build problems
276
277* Sun Jan  9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
278- 1.13.17
279- remove dotbug patch (fixed in base)
280- update download URL
281
282* Fri Jan  7 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
283- Fix a severe bug (tar xf any_package_containing_. would delete the
284  current directory)
285
286* Wed Jan  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
287- 1.3.16
288- unset LINGUAS before running configure
289
290* Tue Nov  9 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
291- 1.13.14
292- Update man page to know about -I / --bzip
293- Remove dependancy on rmt - tar can be used for anything local
294  without it.
295
296* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
297- upgrade to 1.13.11.
298
299* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
300- update to 1.13.9.
301
302* Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
303- update to 1.13.6.
304- support -y --bzip2 options for bzip2 compression (#2415).
305
306* Fri Jul 23 1999 Jeff Johnson <jbj@redhat.com>
307- update to 1.13.5.
308
309* Tue Jul 13 1999 Bill Nottingham <notting@redhat.com>
310- update to 1.13
311
312* Sat Jun 26 1999 Jeff Johnson <jbj@redhat.com>
313- update to 1.12.64014.
314- pipe patch corrected for remote tars now merged in.
315
316* Sun Jun 20 1999 Jeff Johnson <jbj@redhat.com>
317- update to tar-1.12.64013.
318- subtract (and reopen #2415) bzip2 support using -y.
319- move gtar to /bin.
320
321* Tue Jun 15 1999 Jeff Johnson <jbj@redhat.com>
322- upgrade to tar-1.12.64011 to
323-   add bzip2 support (#2415)
324-   fix filename bug (#3479)
325
326* Mon Mar 29 1999 Jeff Johnson <jbj@redhat.com>
327- fix suspended tar with compression over pipe produces error (#390).
328
329* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
330- auto rebuild in the new build environment (release 8)
331
332* Mon Mar 08 1999 Michael Maher <mike@redhat.com>
333- added patch for bad name cache.
334- FIXES BUG 320
335
336* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
337- Injected new description and group.
338
339* Fri Dec 18 1998 Preston Brown <pbrown@redhat.com>
340- bumped spec number for initial rh 6.0 build
341
342* Tue Aug  4 1998 Jeff Johnson <jbj@redhat.com>
343- add /usr/bin/gtar symlink (change #421)
344
345* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
346- Fiddle bindir/libexecdir to get RH install correct.
347- Don't include /sbin/rmt -- use the rmt from dump.
348- Turn on nls.
349
350* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
351- translations modified for de, fr, tr
352
353* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
354- updated from 1.11.8 to 1.12
355- various spec file cleanups
356- /sbin/install-info support
357
358* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
359- built against glibc
360
361* Thu May 29 1997 Michael Fulbright <msf@redhat.com>
362- Fixed to include rmt
Note: See TracBrowser for help on using the repository browser.