source: projects/specs/trunk/t/tar/tar-vl.spec @ 9283

Revision 9283, 11.9 KB checked in by inagaki, 9 years ago (diff)

2015-01-20 Ryoichi INAGAKI <ryo1@…>

  • clamtk: updated
  • tar: fixed spec


Line 
1Summary: A GNU file archiving program.
2Summary(ja): GNU ファイルアーカイブプログラム
3Name: tar
4Version: 1.28
5Release: 2%{?_dist_release}
6License: GPLv3+
7Group: Applications/Archiving
8Source: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.xz
9Patch0: tar-1.13.18-manpage.patch
10Patch8: tar-1.20-loneZeroWarning.patch
11Patch10: tar-1.15.1-gcc4.patch
12
13#Fix extracting sparse files to a filesystem like vfat,
14#when ftruncate may fail to grow the size of a file.(#179507)
15Patch11: tar-1.15.1-vfatTruncate.patch
16#change inclusion defaults of tar to "--wildcards --anchored
17#--wildcards-match-slash" for compatibility reasons (#206841)
18Patch12: tar-1.17-wildcards.patch
19
20# Fix for bad cooperation of -C and -u options.
21# ~> #688567
22# ~> http://lists.gnu.org/archive/html/bug-tar/2012-02/msg00007.html
23# ~> still downstream
24Patch15: tar-1.26-update-with-change-directory.patch
25
26# adhoc but useful patch for z option accepts bzip2ed tarball.
27Patch100: tar-1.13.6-barterly.patch
28Patch110: tar-1.22-rtapelib-overflow.patch
29
30Buildroot: %{_tmppath}/%{name}-%{version}-root
31BuildRequires: autoconf texinfo gettext
32BuildRequires: libacl-devel
33
34Requires(post,postun): install-info
35
36Vendor: Project Vine
37Distribution: Vine Linux
38
39%description
40The GNU tar program saves many files together in one archive and can
41restore individual files (or all of the files) from that archive. Tar
42can also be used to add supplemental files to an archive and to update
43or list files in the archive. Tar includes multivolume support,
44automatic archive compression/decompression, the ability to perform
45remote archives, and the ability to perform incremental and full
46backups.
47
48If you want to use tar for remote backups, you also need to install
49the rmt package.
50
51
52%description -l ja
53GNU tar プログラムは多くのファイルを一つのファイルにまとめたりアーカイブ
54から個々のファイルを(または全てのファイルを)リストアしたりします。tar は
55また、追加ファイルを加えたりアーカイブファイル中のリストを更新したりする
56ために使われます。
57
58tar はマルチボリュームサポート、自動アーカイブ圧縮/伸長、リモートアーカイ
59ブの取り扱い機能、そして差分バックアップとフルバックアップをする機能を含ん
60でいます。
61
62もしリモートバックアップのために tar をインストールするなら、rmt パッケージ
63もまたインストールする必要があります。
64
65
66%prep
67%setup -q
68%patch0 -p1 -b .manpage
69%patch8 -p1 -b .loneZeroWarning
70%patch11 -p1 -b .vfatTruncate
71%patch12 -p1 -b .wildcards
72%patch15 -p1 -b .update_and_changedir
73
74%patch100 -p1 -b .accept-bz2
75%patch110 -p1 -b .CVE-2010-0624
76
77%build
78autoreconf
79%configure --bindir=/bin --libexecdir=/sbin
80make LIBS="-lbsd -lacl" %{?_smp_mflags}
81
82
83%install
84rm -rf $RPM_BUILD_ROOT
85
86make prefix=${RPM_BUILD_ROOT}%{_prefix} \
87    localedir=${RPM_BUILD_ROOT}%{_prefix}/share/locale \
88    bindir=${RPM_BUILD_ROOT}/bin \
89    libexecdir=${RPM_BUILD_ROOT}/sbin \
90    mandir=${RPM_BUILD_ROOT}%{_mandir} \
91    infodir=${RPM_BUILD_ROOT}%{_infodir} \
92        install
93ln -s tar ${RPM_BUILD_ROOT}/bin/gtar
94
95( cd $RPM_BUILD_ROOT
96  for dir in ./bin ./sbin .%{_prefix}/bin .%{_prefix}/libexec
97  do
98    [ -d $dir ] || continue
99    strip $dir/* || :
100  done
101  gzip -9nf .%{_infodir}/tar.info*
102  rm -f .%{_infodir}/dir
103)
104
105mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
106install -c -m644 tar.1 ${RPM_BUILD_ROOT}%{_mandir}/man1
107
108rm -f ${RPM_BUILD_ROOT}/sbin/rmt
109
110%find_lang %name
111
112
113%post
114/sbin/install-info %{_infodir}/tar.info.gz %{_infodir}/dir
115
116
117%preun
118if [ $1 = 0 ]; then
119   /sbin/install-info --delete %{_infodir}/tar.info.gz %{_infodir}/dir
120fi
121
122
123%clean
124rm -rf ${RPM_BUILD_ROOT}
125
126
127%files -f %{name}.lang
128%defattr(-,root,root)
129%doc AUTHORS COPYING ChangeLog* NEWS README THANKS TODO
130/bin/tar
131/bin/gtar
132%{_mandir}/man1/tar.1*
133%{_mandir}/man8/rmt.8*
134%{_infodir}/tar.info*
135
136
137%changelog
138* Tue Jan 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.28-2
139- added LIBS="-lacl" to build on x86_64 (ad-hoc fix, maybe)
140- added BR: libacl-devel
141
142* Fri Jan 16 2015 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.28-1
143- new upstream release
144
145* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.27.1-1
146- new upstream release
147- remove Patch13 (tar-1.23-oldarchive.patch)
148- add Patch15 (tar-1.26-update-with-change-directory.patch) from Fedora
149
150* Wed May 18 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.26-1
151- new upstream release
152- added BuildRequires: gettext
153
154* Mon Nov 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.25-1
155- new upstream release
156- changed source archive type (gzip to bzip2)
157- modified Patch8 a little
158- added Patch11,12,13 from Fedora development
159- added BuildRequires: autoconf texinfo
160- run autoreconf on %%build
161
162* Tue Mar 16 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.22-4
163- add patch110 for fix CVE-2010-0624 (rmt) from fc11
164
165* Thu Apr 30 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.22-3
166- add missing documents
167
168* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22-2
169- spec in utf-8
170
171* Mon Mar 16 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.22-1
172- new upstream release
173- improved tar-1.20-loneZeroWarning.patch (refer to Fedora package)
174
175* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20-1
176- new upstream release
177- remove unneeded patches
178
179* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.15.1-0vl3
180- rebuilt for VineSeed
181
182* Thu Nov 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2.1
183- add patch120 for fix CVE-2006-6097
184
185* Sun Sep 17 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2
186- add patch110 for fix CVE-2006-0300
187
188* Mon May 02 2005 Satoshi MACHINO <machino@vinelinux.org> 1.15.1-0vl1
189- new upstream release
190- fixed patch6 and patch7 for new upstream release
191- some patches are imported from fedora package. and fixed
192        -- stop issuing lone zero block warnings(patch8)
193        -- fixed testsuite(patch9)
194        -- don't applyed(patch10)
195        -- fixed offset had incorrect type(patch11)
196
197* Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-0vl1
198- new upstream release
199- some patches are imported from fedora package.
200
201* Fri May  2 2003 IWAI Masaharu <iwai@alib.jp> 1.3.25-8vl4
202- rebuild with new toolchain
203  - update BuildRequire (autoconf253 -> autoconf)
204
205* Thu Oct 31 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.25-8vl3
206- add adhoc but useful patch100 for "z" option to accepts bz2 tarball.
207
208* Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl2
209- Oops the spec was in Shift-JIS. Fixed.
210
211* Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl1
212- based on 1.3.25-8 from Rawhide and built for Vine Linux
213- the previous Vine package was 1.3.18-0vl2. Vine's changelog was as follows:
214
215  - Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13.18-0vl2
216  - rebuild to remove rpmlib dependancy
217
218  - Sat May 26 2001 <sagami@vinelinux.org>
219  - 1.13.18-0vl1: based on 1.13.18-1 and added Japanese summary and description
220  - added barterly patch
221
222* Fri Aug 23 2002 Phil Knirsch <pknirsch@redhat.com> 1.13.25-8
223- Included security patch from errata release.
224
225* Mon Jul  1 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-7
226- Fix argv NULL termination (#64869)
227
228* Thu May 23 2002 Tim Powers <timp@redhat.com>
229- automated rebuild
230
231* Tue Apr  9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-4
232- Fix build with autoconf253 (LIBOBJ change; autoconf252 worked)
233
234* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
235- automated rebuild
236
237* Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-2
238- Don't include hardlinks to sockets in a tar file (#54827)
239
240* Thu Sep 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-1
241- 1.13.25
242
243* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.22-1
244- Update to 1.13.22, adapt patches
245
246* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-6
247- Fix #52084
248
249* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-5
250- Fix build with current autoconf (stricter checking on AC_DEFINE)
251- Fix segfault when tarring directories without having read permissions
252  (#40802)
253
254* Tue Mar  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
255- Don't depend on librt.
256
257* Fri Feb 23 2001 Trond Eivind Glomsr <teg@redhat.com>
258- langify
259
260* Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
261- Fix up the man page (#28915)
262
263* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
264- 1.3.19, nukes -I and fixes up -N
265- Add -I back in as an alias to -j with a nice loud warning
266
267* Mon Oct 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
268- 1.3.18
269- Update man page to reflect changes
270
271* Thu Oct  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
272- Fix the "ignore failed read" option (Bug #8330)
273
274* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
275- fix hang on tar tvzf - <something.tar.gz, introduced by
276  exit code fix (Bug #15448), Patch from Tim Waugh <twaugh@redhat.com>
277
278* Fri Aug 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
279- really fix exit code (Bug #15448)
280
281* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
282- fix exit code (Bug #15448), patch from Tim Waugh <twaugh@redhat.com>
283
284* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
285- automatic rebuild
286
287* Mon Jun 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
288- FHSify
289
290* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
291- fix for ia64
292
293* Wed Feb  9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
294- Fix the exclude bug (#9201)
295
296* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
297- man pages are compressed
298- fix description
299- fix fnmatch build problems
300
301* Sun Jan  9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
302- 1.13.17
303- remove dotbug patch (fixed in base)
304- update download URL
305
306* Fri Jan  7 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
307- Fix a severe bug (tar xf any_package_containing_. would delete the
308  current directory)
309
310* Wed Jan  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
311- 1.3.16
312- unset LINGUAS before running configure
313
314* Tue Nov  9 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
315- 1.13.14
316- Update man page to know about -I / --bzip
317- Remove dependancy on rmt - tar can be used for anything local
318  without it.
319
320* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
321- upgrade to 1.13.11.
322
323* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
324- update to 1.13.9.
325
326* Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
327- update to 1.13.6.
328- support -y --bzip2 options for bzip2 compression (#2415).
329
330* Fri Jul 23 1999 Jeff Johnson <jbj@redhat.com>
331- update to 1.13.5.
332
333* Tue Jul 13 1999 Bill Nottingham <notting@redhat.com>
334- update to 1.13
335
336* Sat Jun 26 1999 Jeff Johnson <jbj@redhat.com>
337- update to 1.12.64014.
338- pipe patch corrected for remote tars now merged in.
339
340* Sun Jun 20 1999 Jeff Johnson <jbj@redhat.com>
341- update to tar-1.12.64013.
342- subtract (and reopen #2415) bzip2 support using -y.
343- move gtar to /bin.
344
345* Tue Jun 15 1999 Jeff Johnson <jbj@redhat.com>
346- upgrade to tar-1.12.64011 to
347-   add bzip2 support (#2415)
348-   fix filename bug (#3479)
349
350* Mon Mar 29 1999 Jeff Johnson <jbj@redhat.com>
351- fix suspended tar with compression over pipe produces error (#390).
352
353* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
354- auto rebuild in the new build environment (release 8)
355
356* Mon Mar 08 1999 Michael Maher <mike@redhat.com>
357- added patch for bad name cache.
358- FIXES BUG 320
359
360* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
361- Injected new description and group.
362
363* Fri Dec 18 1998 Preston Brown <pbrown@redhat.com>
364- bumped spec number for initial rh 6.0 build
365
366* Tue Aug  4 1998 Jeff Johnson <jbj@redhat.com>
367- add /usr/bin/gtar symlink (change #421)
368
369* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
370- Fiddle bindir/libexecdir to get RH install correct.
371- Don't include /sbin/rmt -- use the rmt from dump.
372- Turn on nls.
373
374* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
375- translations modified for de, fr, tr
376
377* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
378- updated from 1.11.8 to 1.12
379- various spec file cleanups
380- /sbin/install-info support
381
382* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
383- built against glibc
384
385* Thu May 29 1997 Michael Fulbright <msf@redhat.com>
386- Fixed to include rmt
Note: See TracBrowser for help on using the repository browser.