source: projects/specs/trunk/t/t1lib/t1lib-vl.spec @ 521

Revision 521, 7.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name    t1lib
2%define version 5.0.2
3%define release 2%{?_dist_release}
4
5Summary:        Type 1 font rasterizer
6Name:           %{name}
7Version:        %{version}
8Release:        %{release}
9URL:            http://freshmeat.net/projects/t1lib
10Source:         ftp://sunsite.unc.edu/pub/Linux/libs/graphics/%{name}-%{version}.tar.gz
11Patch0:         %{name}-DESTDIR.patch
12Patch1:         %{name}-doc.patch.bz2
13Patch2:         %{name}-config.patch.bz2
14Group:          System Environment/Libraries
15#BuildRequires: XFree86-devel xpm-devel
16BuildRequires:  xorg-x11-devel libXpm-devel
17BuildRequires:  tetex
18BuildRequires:  tetex-latex
19License:        LGPL
20Prefix:         %{_prefix}
21BuildRoot:      %{_tmppath}/%{name}-%{version}-%(id -u -n)
22Epoch:          1
23
24%description
25T1lib is a library for generating character and string-glyphs from
26Adobe Type 1 fonts under UNIX. T1lib uses most of the code of the X11
27rasterizer donated by IBM to the X11-project. But some disadvantages
28of the rasterizer being included in X11 have been eliminated.
29T1lib also includes a support for antialiasing.
30
31%package devel
32Summary:        Header files for Type 1 font rasterizer
33Group:          Development/Libraries
34Requires:       %{name} = %{epoch}:%{version}
35Provides:       %{name}-devel = %{version}-%{release}
36
37%description devel
38Header files required for compiling packages
39needing the t1lib.
40
41%package static-devel
42Summary:        Static libraries for Type 1 font rasterizer
43Group:          Development/Libraries
44Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
45Provides:       %{name}-static-devel = %{version}-%{release}
46
47%description static-devel
48Static libraries required for staticaly compiling packages needing the t1lib.
49
50%package progs
51Summary:        Programs dor manipulating Type 1 font
52Group:          Applications/Graphics
53License:        GPL
54Requires:       %{name} = %{epoch}:%{version}
55Provides:       %{name}-progs
56
57%description progs
58The t1lib-progs contains the programs "xglyph" and "type1afm"
59It also contains the "t1libconfig" script used to configure t1lib.
60
61%prep
62rm -rf %buildroot
63
64%setup -q
65%patch0 -p1
66%patch1 -p0
67%patch2 -p0
68
69%build
70%configure
71export tagname=CC
72perl -pi -e 's,-DGLOBAL_CONFIG_DIR="\\"/usr/share/t1lib\\"",-DGLOBAL_CONFIG_DIR="\\"/etc/t1lib\\"",;' Makefile
73(cd lib
74perl -pi -e 's,$(DESTDIR)/usr/share/t1lib,$(DESTDIR)$(datedir)t1lib,;' Makefile
75)
76make without_doc LIBTOOL=/usr/bin/libtool
77(cd doc
78make clean
79make pdf)
80
81%install
82rm -rf $RPM_BUILD_ROOT
83install -d $RPM_BUILD_ROOT%{_libdir} \
84        $RPM_BUILD_ROOT%{_datadir} \
85        $RPM_BUILD_ROOT%{_bindir} \
86        $RPM_BUILD_ROOT%{_includedir}
87
88export tagname=CC
89%makeinstall DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
90
91#rm -rf %buildroot/%{_datadir}/t1lib/doc
92mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/t1lib
93mv $RPM_BUILD_ROOT%{_datadir}/t1lib/t1lib.config $RPM_BUILD_ROOT%{_sysconfdir}/t1lib
94
95%ifarch alpha
96(cd $RPM_BUILD_ROOT%{_libdir}
97ln -sf libt1.so libt1.so.0)
98%endif
99
100## remove unuse files
101rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
102
103
104%post   -n %{name} -p /sbin/ldconfig
105%postun -n %{name} -p /sbin/ldconfig
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110
111%files -n %{name}
112%defattr(-,root,root)
113%config(noreplace) %{_sysconfdir}/t1lib/t1lib.config
114%doc Changes LGPL README.t1*
115%attr(755,root,root) %{_libdir}/libt1*.so.*
116
117%files -n %{name}-devel
118%defattr(-,root,root)
119%doc LGPL doc/t1lib_doc.pdf
120%{_includedir}/*
121%{_libdir}/*.so
122
123%files -n %{name}-static-devel
124%defattr(-,root,root)
125%doc LGPL
126%{_libdir}/*.a
127#%{_libdir}/*.la
128
129%files -n %{name}-progs
130%defattr(-,root,root)
131%doc LICENSE README.t1python
132%attr(755,root,root) %{_bindir}/*
133
134%changelog
135* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 5.0.2-2vl5
136- rebuild with libXaw.so.7 (libXaw-1.0.5)
137- spec in utf-8
138
139* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 5.0.2-1vl5
140- applied new versioning policy
141- removed *.la
142- added BuildRequires: xorg-x11-devel libXpm-devel, instead of XFree86-devel xpm-devel
143
144* Sat Dec 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0.2-0vl2
145- fixed spec file to build current environment
146- added %{epoch} related t1libs
147
148* Sat Jun 19 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0.2-0vl1
149- updated to 5.0.2
150- changed Group:
151
152* Sun Mar 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0.0-0vl1
153- new upstream release 5.0.0
154
155* Fri May 31 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.3.1-5vl0
156- modified for Vine
157
158* Thu May 16 2002 Yves Duret <yduret@mandrakesoft.com> 1.3.1-5mdk
159- 9.0 lib policy: added %libname-static-devel
160
161* Wed Apr 17 2002 Yves Duret <yduret@mandrakesoft.com> 1.3.1-4mdk
162- use %%makeinstall_std
163- use %%buildroot
164- devel package provides %%version-%%release
165
166* Sat Feb 02 2002 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.3.1-3mdk
167- fixed multiple "install -d" (problem with {).
168
169* Mon Jan 21 2002 Yves Duret <yduret@mandrakesoft.com> 1.3.1-2mdk
170- use the freshmeat url
171
172* Sun Jan 13 2002 Geoffrey Lee <snailtalk@mandrakesoft.com> 1.3.1-1mdk
173- 1.3.1.
174- Remove the URL. There doesn't seem to be one for it.
175
176* Sun Oct 28 2001 Geoffrey Lee <snailtalk@mandrakesoft.com> 1.3-1mdk
177- The all new-and-shiny t1lib 1.3.
178
179* Wed Aug 15 2001 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.2-2mdk
180- removed .dvi.gz doc.
181- removed .ps docs and unneeded .eps files. All printable doc files
182  now replaced with only one PDF doc file.
183
184* Tue Aug 07 2001 Yves Duret <yduret@mandrakesoft.com> 1.2-1mdk
185- version 1.2
186- s{Serial}{Epoch} & s{Copyright}{License}
187- updated url & source
188- added Patch{0,1,2}
189- fix buildrequires
190- remove big, fussy and redundand pdf/ps doc (ghibo sux) :
191  size of devel rpm divided by more than 2 !
192
193* Wed May 23 2001 Yves Duret <yduret@mandrakesoft.com> 1.1.1-2mdk
194- more and more macros
195- s{Copyright}{License}
196
197* Sat May 05 2001 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.1.1-1mdk
198- updated to release 1.1.1 (bugfixes).
199
200* Tue Mar 13 2001 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.1.0-1mdk
201- updated to release 1.1.0.
202- gzip doc instead of bzip2.
203- removed docdir patch.
204
205* Wed Dec 27 2000 Yves Duret <yduret@mandrakesoft.com> 1.0.1-6mdk
206- added a obsoletes -devel tag.
207
208* Tue Dec 26 2000 Yves Duret <yduret@mandrakesoft.com> 1.0.1-5mdk
209- splitted into main deval and progs packages.
210- config file now in /etc as it should be
211- used bzip2 instead of gzip for doc
212- macros
213
214* Mon Aug 07 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.0.1-4mdk
215- automatically added BuildRequires
216
217* Fri Jul 28 2000 Frederic Crozat <fcrozat@mandrakesoft.com> 1.0.1-3mdk
218- BM + macroszification
219
220* Tue May 16 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.0.1-2mdk
221- Move .so from devel to package and add some links for alpha.
222
223* Sat Apr 01 2000 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.0.1-1mdk
224- updated to version 1.0.1.
225- moved .so file to devel package.
226- exchanged package group between main and -devel packages.
227
228* Thu Mar 23 2000 Daouda Lo <daouda@mandrakesoft.com> 0.9.2-3mdk
229- fix group.
230
231* Thu Jan 13 2000 Pixel <pixel@mandrakesoft.com>
232- libtoolize --force.
233
234* Sat Oct 30 1999 Giuseppe Ghibメ<ghibo@linux-mandrake.com>
235- updated to version 0.9.2.
236
237* Thu Aug 12 1999 Giuseppe Ghibメ<ghibo@linux-mandrake.com>
238- added PostScript documentation.
239- split into main and devel package.
240
241* Sun Aug 1 1999 Richard D. Jackson <richardj@1gig.net>
242- first release of t1lib-0.9.1
Note: See TracBrowser for help on using the repository browser.