source: projects/specs/trunk/t/t1lib/t1lib-vl.spec @ 3700

Revision 3700, 7.0 KB checked in by inagaki, 13 years ago (diff)

update: t1lib, t1utils

Line 
1%define name    t1lib
2%define version 5.0.2
3%define release 3%{?_dist_release}
4
5Summary:        Type 1 font rasterizer
6Name:           %{name}
7Version:        %{version}
8Release:        %{release}
9Epoch:          1
10
11Group:          System Environment/Libraries
12License:        LGPL
13URL:            http://freshmeat.net/projects/t1lib
14
15Source:         ftp://sunsite.unc.edu/pub/Linux/libs/graphics/%{name}-%{version}.tar.gz
16Patch0:         %{name}-DESTDIR.patch
17Patch1:         %{name}-doc.patch.bz2
18Patch2:         %{name}-config.patch.bz2
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  libICE-devel libX11-devel libXaw-devel libXpm-devel
22BuildRequires:  texlive
23
24%description
25T1lib is a library for generating character and string-glyphs from
26Adobe Type 1 fonts under UNIX. T1lib uses most of the code of the X11
27rasterizer donated by IBM to the X11-project. But some disadvantages
28of the rasterizer being included in X11 have been eliminated.
29T1lib also includes a support for antialiasing.
30
31%package devel
32Summary:        Header files for Type 1 font rasterizer
33Group:          Development/Libraries
34Requires:       %{name} = %{epoch}:%{version}
35Provides:       %{name}-devel = %{version}-%{release}
36
37%description devel
38Header files required for compiling packages
39needing the t1lib.
40
41%package static-devel
42Summary:        Static libraries for Type 1 font rasterizer
43Group:          Development/Libraries
44Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
45Provides:       %{name}-static-devel = %{version}-%{release}
46
47%description static-devel
48Static libraries required for staticaly compiling packages needing the t1lib.
49
50%package progs
51Summary:        Programs dor manipulating Type 1 font
52Group:          Applications/Graphics
53License:        GPL
54Requires:       %{name} = %{epoch}:%{version}
55Provides:       %{name}-progs
56
57%description progs
58The t1lib-progs contains the programs "xglyph" and "type1afm"
59It also contains the "t1libconfig" script used to configure t1lib.
60
61%prep
62rm -rf %buildroot
63
64%setup -q
65%patch0 -p1
66%patch1 -p0
67%patch2 -p0
68
69%build
70%configure
71export tagname=CC
72perl -pi -e 's,-DGLOBAL_CONFIG_DIR="\\"/usr/share/t1lib\\"",-DGLOBAL_CONFIG_DIR="\\"/etc/t1lib\\"",;' Makefile
73(cd lib
74perl -pi -e 's,$(DESTDIR)/usr/share/t1lib,$(DESTDIR)$(datedir)t1lib,;' Makefile
75)
76make without_doc LIBTOOL=/usr/bin/libtool
77(cd doc
78make clean
79make pdf)
80
81%install
82rm -rf $RPM_BUILD_ROOT
83install -d $RPM_BUILD_ROOT%{_libdir} \
84        $RPM_BUILD_ROOT%{_datadir} \
85        $RPM_BUILD_ROOT%{_bindir} \
86        $RPM_BUILD_ROOT%{_includedir}
87
88export tagname=CC
89%makeinstall DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
90
91#rm -rf %buildroot/%{_datadir}/t1lib/doc
92mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/t1lib
93mv $RPM_BUILD_ROOT%{_datadir}/t1lib/t1lib.config $RPM_BUILD_ROOT%{_sysconfdir}/t1lib
94
95%ifarch alpha
96(cd $RPM_BUILD_ROOT%{_libdir}
97ln -sf libt1.so libt1.so.0)
98%endif
99
100## remove unuse files
101rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
102
103
104%post   -n %{name} -p /sbin/ldconfig
105%postun -n %{name} -p /sbin/ldconfig
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110
111%files -n %{name}
112%defattr(-,root,root)
113%config(noreplace) %{_sysconfdir}/t1lib/t1lib.config
114%doc Changes LGPL README.t1*
115%attr(755,root,root) %{_libdir}/libt1*.so.*
116
117%files -n %{name}-devel
118%defattr(-,root,root)
119%doc LGPL doc/t1lib_doc.pdf
120%{_includedir}/*
121%{_libdir}/*.so
122
123%files -n %{name}-static-devel
124%defattr(-,root,root)
125%doc LGPL
126%{_libdir}/*.a
127#%{_libdir}/*.la
128
129%files -n %{name}-progs
130%defattr(-,root,root)
131%doc LICENSE README.t1python
132%attr(755,root,root) %{_bindir}/*
133
134%changelog
135* Mon Apr 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0.2-3
136- rebuild with current VineSeed
137- use BR: texlive instead of tetex
138
139* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 5.0.2-2vl5
140- rebuild with libXaw.so.7 (libXaw-1.0.5)
141- spec in utf-8
142
143* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 5.0.2-1vl5
144- applied new versioning policy
145- removed *.la
146- added BuildRequires: xorg-x11-devel libXpm-devel, instead of XFree86-devel xpm-devel
147
148* Sat Dec 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0.2-0vl2
149- fixed spec file to build current environment
150- added %{epoch} related t1libs
151
152* Sat Jun 19 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0.2-0vl1
153- updated to 5.0.2
154- changed Group:
155
156* Sun Mar 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0.0-0vl1
157- new upstream release 5.0.0
158
159* Fri May 31 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.3.1-5vl0
160- modified for Vine
161
162* Thu May 16 2002 Yves Duret <yduret@mandrakesoft.com> 1.3.1-5mdk
163- 9.0 lib policy: added %libname-static-devel
164
165* Wed Apr 17 2002 Yves Duret <yduret@mandrakesoft.com> 1.3.1-4mdk
166- use %%makeinstall_std
167- use %%buildroot
168- devel package provides %%version-%%release
169
170* Sat Feb 02 2002 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.3.1-3mdk
171- fixed multiple "install -d" (problem with {).
172
173* Mon Jan 21 2002 Yves Duret <yduret@mandrakesoft.com> 1.3.1-2mdk
174- use the freshmeat url
175
176* Sun Jan 13 2002 Geoffrey Lee <snailtalk@mandrakesoft.com> 1.3.1-1mdk
177- 1.3.1.
178- Remove the URL. There doesn't seem to be one for it.
179
180* Sun Oct 28 2001 Geoffrey Lee <snailtalk@mandrakesoft.com> 1.3-1mdk
181- The all new-and-shiny t1lib 1.3.
182
183* Wed Aug 15 2001 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.2-2mdk
184- removed .dvi.gz doc.
185- removed .ps docs and unneeded .eps files. All printable doc files
186  now replaced with only one PDF doc file.
187
188* Tue Aug 07 2001 Yves Duret <yduret@mandrakesoft.com> 1.2-1mdk
189- version 1.2
190- s{Serial}{Epoch} & s{Copyright}{License}
191- updated url & source
192- added Patch{0,1,2}
193- fix buildrequires
194- remove big, fussy and redundand pdf/ps doc (ghibo sux) :
195  size of devel rpm divided by more than 2 !
196
197* Wed May 23 2001 Yves Duret <yduret@mandrakesoft.com> 1.1.1-2mdk
198- more and more macros
199- s{Copyright}{License}
200
201* Sat May 05 2001 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.1.1-1mdk
202- updated to release 1.1.1 (bugfixes).
203
204* Tue Mar 13 2001 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.1.0-1mdk
205- updated to release 1.1.0.
206- gzip doc instead of bzip2.
207- removed docdir patch.
208
209* Wed Dec 27 2000 Yves Duret <yduret@mandrakesoft.com> 1.0.1-6mdk
210- added a obsoletes -devel tag.
211
212* Tue Dec 26 2000 Yves Duret <yduret@mandrakesoft.com> 1.0.1-5mdk
213- splitted into main deval and progs packages.
214- config file now in /etc as it should be
215- used bzip2 instead of gzip for doc
216- macros
217
218* Mon Aug 07 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.0.1-4mdk
219- automatically added BuildRequires
220
221* Fri Jul 28 2000 Frederic Crozat <fcrozat@mandrakesoft.com> 1.0.1-3mdk
222- BM + macroszification
223
224* Tue May 16 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.0.1-2mdk
225- Move .so from devel to package and add some links for alpha.
226
227* Sat Apr 01 2000 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.0.1-1mdk
228- updated to version 1.0.1.
229- moved .so file to devel package.
230- exchanged package group between main and -devel packages.
231
232* Thu Mar 23 2000 Daouda Lo <daouda@mandrakesoft.com> 0.9.2-3mdk
233- fix group.
234
235* Thu Jan 13 2000 Pixel <pixel@mandrakesoft.com>
236- libtoolize --force.
237
238* Sat Oct 30 1999 Giuseppe Ghibメ<ghibo@linux-mandrake.com>
239- updated to version 0.9.2.
240
241* Thu Aug 12 1999 Giuseppe Ghibメ<ghibo@linux-mandrake.com>
242- added PostScript documentation.
243- split into main and devel package.
244
245* Sun Aug 1 1999 Richard D. Jackson <richardj@1gig.net>
246- first release of t1lib-0.9.1
Note: See TracBrowser for help on using the repository browser.