source: projects/specs/trunk/s/system-config-printer/system-config-printer-vl.spec @ 8618

Revision 8618, 32.1 KB checked in by Takemikaduchi, 10 years ago (diff)

uedev: new upstream release
system-config-printer: add R:python-pycurl

Line 
1%define pycups_version 1.9.66
2%define pysmbc_version 1.0.14.1
3%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
4%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
5%{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
6
7Summary: A printer administration tool
8Summary(ja): プリンタ管理ツール
9Name: system-config-printer
10Version: 1.4.4
11Release: 2%{?_dist_release}
12License: GPLv2+
13URL: http://cyberelk.net/tim/software/system-config-printer/
14Group: System Environment/Base
15
16Source0: http://cyberelk.net/tim/data/system-config-printer/1.4/system-config-printer-%{version}.tar.xz
17Source1: http://cyberelk.net/tim/data/pycups/pycups-%{pycups_version}.tar.bz2
18Source2: http://cyberelk.net/tim/data/pysmbc/pysmbc-%{pysmbc_version}.tar.bz2
19
20Source10: %{name}-1.3.2-ja.po
21
22Patch21: %{name}-1.3.2-ppd-translation.patch
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25
26BuildRequires: cups-devel >= 1.2
27BuildRequires: glib2-devel
28BuildRequires: python-devel >= 2.5
29BuildRequires: libsmbclient-devel >= 3.2
30BuildRequires: desktop-file-utils >= 0.2.92
31BuildRequires: gettext
32BuildRequires: intltool
33BuildRequires: xmlto
34BuildRequires: python-tools
35BuildRequires: libusb1-devel
36BuildRequires: eudev-libudev-devel
37BuildRequires: eudev
38BuildRequires: epydoc
39
40Requires: pygtk2
41Requires: pygobject
42Requires: python-pycurl
43Requires: desktop-file-utils
44Requires: dbus-x11
45Requires: system-config-printer-libs = %{version}-%{release}
46Requires: gnome-icon-theme
47Requires: gnome-python
48Requires: gnome-python-gnomekeyring
49Requires: notification-daemon
50Requires: notify-python
51Requires: libxml2-python
52
53Obsoletes: system-config-printer-gui <= 0.6.152
54Provides: system-config-printer-gui = 0.6.152
55
56Obsoletes: desktop-printing <= 0.20-7.fc7
57Provides: desktop-printing = 0.20-7.fc7
58
59%description
60system-config-printer is a graphical user interface that allows
61the user to configure a CUPS print server.
62
63%package libs
64Summary: Libraries and shared code for printer administration tool
65Summary(ja): Libraries and shared code for printer administration tool
66Group: System Environment/Base
67Requires: python
68Requires: foomatic
69Provides: pycups = %{pycups_version}
70Provides: pysmbc = %{pysmbc_version}
71
72%description libs
73The common code used by both the graphical and non-graphical parts of
74the configuration tool.
75
76%package udev
77Summary: Rules for udev for automatic configuration of USB printers
78Group: System Environment/Base
79Requires: system-config-printer-libs = %{version}-%{release}
80Obsoletes: hal-cups-utils <= 0.6.20
81Provides: hal-cups-utils = 0.6.20
82
83%description udev
84The udev rules and helper programs for automatically configuring USB
85printers.
86
87%prep
88%setup -q -a 1 -a 2
89
90%patch21 -p1 -b .ppd-translation
91
92cp -f %{SOURCE10} po/ja.po
93
94%build
95export CFLAGS="$CFLAGS -Wno-implicit-function-declaration"
96%configure --with-udev-rules
97
98pushd pycups-%{pycups_version}
99make
100make doc
101popd
102
103pushd pysmbc-%{pysmbc_version}
104make
105make doc
106popd
107
108%install
109rm -rf %buildroot
110make DESTDIR=%buildroot install \
111     udevrulesdir=/lib/udev/rules.d \
112     udevhelperdir=/lib/udev
113
114pushd pycups-%{pycups_version}
115make DESTDIR=%buildroot install
116popd
117
118pushd pysmbc-%{pysmbc_version}
119make DESTDIR=%buildroot install
120popd
121
122%{__mkdir_p} %buildroot%{_localstatedir}/run/udev-configure-printer
123touch %buildroot%{_localstatedir}/run/udev-configure-printer/usb-uris
124
125%find_lang system-config-printer
126
127%clean
128rm -rf %buildroot
129
130%post
131/bin/rm -f /var/cache/foomatic/foomatic.pickle
132exit 0
133
134%files libs -f system-config-printer.lang
135%defattr(-,root,root,-)
136%doc --parents pycups-%{pycups_version}/{ChangeLog,README,NEWS,TODO,examples,html}
137%doc --parents pysmbc-%{pysmbc_version}/{ChangeLog,README,NEWS,TODO,test.py,html}
138%config(noreplace) %{_sysconfdir}/dbus-1/system.d/com.redhat.NewPrinterNotification.conf
139%config(noreplace) %{_sysconfdir}/dbus-1/system.d/com.redhat.PrinterDriversInstaller.conf
140%dir %{_sysconfdir}/cupshelpers
141%config(noreplace) %{_sysconfdir}/cupshelpers/preferreddrivers.xml
142%{python_sitearch}/cups.so
143%{python_sitearch}/_smbc.so
144%dir %{python_sitearch}/smbc
145%{python_sitearch}/smbc/*.py*
146%ifarch x86_64
147%{python_sitearch}/*.egg-info
148%endif
149%dir %{python_sitelib}/cupshelpers
150%{python_sitelib}/cupshelpers/*.py*
151%{python_sitelib}/*.egg-info
152%{_rpmconfigdir}/fileattrs/psdriver.attr
153%{_rpmconfigdir}/postscriptdriver.prov
154
155%files udev
156%defattr(-,root,root,-)
157/lib/udev/rules.d/*.rules
158/lib/udev/udev-*-printer
159%dir %{_localstatedir}/run/udev-configure-printer
160%verify(not md5 size mtime) %config(noreplace,missingok) %attr(0644,root,root) %{_localstatedir}/run/udev-configure-printer/usb-uris
161
162%files
163%defattr(-,root,root,-)
164%doc ChangeLog README
165%{_bindir}/%{name}
166%{_bindir}/%{name}-applet
167%{_bindir}/install-printerdriver
168%{_bindir}/scp-dbus-service
169%{_datadir}/dbus-1/interfaces/*.xml
170%{_datadir}/dbus-1/services/*.service
171%dir %{_datadir}/%{name}
172%{_datadir}/%{name}/*.py*
173%{_datadir}/%{name}/troubleshoot
174%{_datadir}/%{name}/icons
175%dir %{_datadir}/%{name}/xml
176%{_datadir}/%{name}/xml/*.rng
177%{_datadir}/%{name}/xml/*.py*
178%dir %{_datadir}/%{name}/ui
179%{_datadir}/%{name}/ui/*.ui
180%{_datadir}/applications/system-config-printer.desktop
181%{_sysconfdir}/xdg/autostart/print-applet.desktop
182%{_mandir}/man1/*
183
184%changelog
185* Fri Jun 27 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-2
186- add Requires: python-pycurl
187
188* Sun Jun 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
189- new upstream release
190  - system-config-printer-1.4.4
191  - pycups-1.9.66
192  - pysmbc-1.0.14.1
193- change BuildRequires: eudev-libudev-devel instead of libudev-devel
194- change BuildRequires: libusb1-devel instead of libusb-devel
195- remove Patch2 (system-config-printer-check-device-ids.patch)
196- remove Patch3 (system-config-printer-self.printers.patch)
197- remove Patch20 (system-config-printer-1.3.2-gettext.patch)
198
199* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2-4
200- rebuild with python-2.7.2
201
202* Fri Apr 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-3
203- update patch21 and ja.po
204
205* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2-2
206- add BuildRequires: glib2-devel
207
208* Sat Apr 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-1
209- new upstream release
210  - system-config-printer-1.3.2
211  - pycups-1.9.55
212  - pysmbc-1.0.10
213- drop old patches (1,2,10)
214- add Patch2,3 from fedora
215  - Patch2: Improvements for check-device-ids from upstream.
216  - Patch3: Fixed traceback in newprinter.py (bug #680683).
217- update ja.po
218- Patch21: add more ppd translation dictionary
219- add BR: epydoc
220
221* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.92-1
222- new development release (pre1.2)
223  - system-config-printer-1.1.92
224  - pycups-1.9.48
225- add Patch1,2 from fedora
226  - Patch1: build without epydoc, remove BR: epydoc
227  - Patch2: Convert MFG and MDL to lowercase before D-Bus call
228    to work around bug #566217.
229- add BR: python-tools, libudev-devel, libusb-devel
230- add R: libxml2-python
231
232* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.7-2
233- rebuilt with python-2.6.4
234
235* Sat Jun 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.7-1
236- new upstream release
237  - Updated translations.
238  - Don't abort if the jobviewer couldn't show a notification.
239  - Don't use setlocale() for locale-independent case conversion.
240  - Don't assume the notification daemon can show action buttons.
241  - Use case-insensitive matching for model names.
242  - HPLIP compatibility fixes.
243  - Fixed typo in jobviewer keyring support (Ubuntu #343156).
244  - Added support for https device URIs (bug #478677).
245  - Prevent traceback in monitor when connection failed (Ubuntu #343387).
246- add Patch10: fix infinite loop on adding printer
247- add Patch11: do not probe hplip
248
249* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
250- new upstream release
251  - system-config-printer 1.1.6
252  - pycups 1.9.45
253
254* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.9-1
255- initial build for Vine Linux
256
257* Tue Oct 21 2008 Tim Waugh <twaugh@redhat.com> 1.0.9-1
258- Updated to 1.0.9 for translations.
259- Updated pysmbc to 1.0.6.  No longer need pysmbc-git patch.
260
261* Fri Oct 17 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-7
262- Added patch for pysmbc changes in git to prevent getdents crashing
263  (bug #465975).
264
265* Thu Oct 16 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-6
266- Updated patch for 1.0.x changes:
267  - Fixed SMB authentication dialog's cancel button (bug #467127).
268  - Work around samba bug #5805 by sending debug output to stderr
269    instead of stdout.
270
271* Wed Oct 15 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-5
272- Updated patch for 1.0.x changes:
273  - Fixed SMB authentication (bug #464003).
274
275* Wed Oct 15 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-4
276- Updated patch for 1.0.x changes:
277  - Removed unneeded debugging output.
278  - Don't show the applet in KDE (bug #466945).
279  - Auth/error dialog improvements for SMB as for IPP (bug #465407).
280
281* Mon Oct 13 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-3
282- Added patch for 1.0.x changes since 1.0.8:
283  - Don't use a LinkButton for the 'Problems?' button (bug #465407).
284  - Don't use a separator for the server settings dialog (bug
285    #465407).
286  - Don't set non-zero page size for SpinButtons.
287  - Don't show an error dialog if an IPP operation's authentication
288    dialog is cancelled by the user, but show an error dialog if the
289    password was incorrect (bug #465407).
290  - Set Server Settings... menu entry sensitive depending on whether
291    we are connected to a server (Ubuntu #280736).
292  - Lots of translations updated.
293
294* Mon Sep 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-2
295- Removed patch (no longer needed).
296
297* Mon Sep 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-1
298- 1.0.8:
299  - Use modelName from custom PPD to suggest name for new printer
300    (trac #97).
301  - Avoid display problem with installable options.
302  - Better matching for Lexmark printers.
303  - Catch exceptions from advanced server settings dialog (Ubuntu
304    #267557).
305  - Added some missing OpenPrinting query fields.
306  - Jockey support added.
307  - Lots of translations updated.
308
309* Sat Aug 30 2008 Tim Waugh <twaugh@redhat.com> 1.0.7-2
310- Handle IPP_FORBIDDEN (bug #460670).
311
312* Fri Aug 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.7-1
313- 1.0.7:
314  - Efficiency improvements.
315  - Small UI improvements for the New Printer dialog.
316  - Other small fixes.
317
318* Fri Aug 29 2008 Tim Waugh <twaugh@redhat.com>
319- Updated pysmbc to 1.0.5.
320- Updated pycups to 1.9.42.
321
322* Tue Aug 26 2008 Tim Waugh <twaugh@redhat.com> 1.0.6-1
323- Requires gnome-python2-gnome (bug #460021).
324- 1.0.6:
325  - More delete-event fixes.
326  - Fixed temporary file leak.
327  - Fixed dialog leaks.
328  - Small UI improvements for the New Printer dialog.
329  - Other small fixes.
330
331* Thu Aug 14 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-3
332- Include other fixes from upstream including:
333  - OpenPrinting API change (trac #74).
334  - libnotify API change for 'closed' signal.
335  - Notification for job authentication (trac #91).
336  - Glade delete-event fixes (trac #88).
337  - Pre-fill username in job authentication dialog (trac #87).
338
339* Wed Aug 13 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-2
340- Handle HTTP_FORBIDDEN.
341
342* Mon Aug 11 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-1
343- 1.0.5.
344- Updated pycups to 1.9.41.
345
346* Thu Jul 10 2008 Tim Waugh <twaugh@redhat.com> 1.0.4-1
347- 1.0.4.
348- Applied upstream patch for pycups to fix getPrinterAttributes when
349  requested_attributes is specified.
350
351* Tue Jul  8 2008 Tim Waugh <twaugh@redhat.com> 1.0.3-2
352- Better debugging for pysmbc.
353
354* Mon Jun 30 2008 Tim Waugh <twaugh@redhat.com> 1.0.3-1
355- Updated pycups to 1.9.40.
356- 1.0.3.
357
358* Fri Jun 20 2008 Tim Waugh <twaugh@redhat.com>
359- Updated pysmbc to 1.0.4.
360
361* Tue Jun 10 2008 Tim Waugh <twaugh@redhat.com> 1.0.2-1
362- 1.0.2.
363
364* Mon Jun  9 2008 Tim Waugh <twaugh@redhat.com> 1.0.1-1
365- Updated pysmbc to 1.0.3.
366- 1.0.1 (bug #450119).
367
368* Thu Jun  5 2008 Tim Waugh <twaugh@redhat.com>
369- Requires notify-python (bug #450139).
370
371* Thu Jun  5 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-3
372- Applied patches from upstream (bug #450120).
373
374* Tue Jun  3 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-2
375- Applied patches from upstream (bug #449753).
376
377* Thu May 29 2008 Tim Waugh <twaugh@redhat.com>
378- Updated pycups to 1.9.39.
379- Updated libs summary.
380
381* Tue May 27 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-1
382- 1.0.0.
383
384* Fri May 23 2008 Tim Waugh <twaugh@redhat.com> 0.9.93-2
385- Fixed small UI problem in SMB browser.
386
387* Fri May 23 2008 Tim Waugh <twaugh@redhat.com> 0.9.93-1
388- 0.9.93.
389
390* Tue May 20 2008 Tim Waugh <twaugh@redhat.com> 0.9.92-1
391- 0.9.92.
392
393* Tue May 20 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-3
394- Sync to trunk.
395- Updated pysmbc to 1.0.2.
396
397* Sun May 18 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-2
398- Fixed icon search path.
399
400* Fri May 16 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-1
401- No longer requires system-install-packages (bug #444645).
402- Added pysmbc.  Build requires libsmbclient-devel.
403- Don't install consolehelper bits any more as they are no longer needed.
404- 0.9.91:
405  - User interface overhaul, part 2.
406
407* Thu Apr  3 2008 Tim Waugh <twaugh@redhat.com> 0.9.90-1
408- Updated pycups to 1.9.38.
409- 0.9.90:
410  - User interface overhaul, part 1.
411
412* Thu Apr  3 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.2-1
413- 0.7.82.2:
414  - Various bug fixes.
415  - Translation updates.
416
417* Mon Mar 17 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-3
418- Updated pycups to 1.9.37.
419- More fixes from upstream.
420
421* Wed Mar  5 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-2
422- Updated pycups to 1.9.36.
423- Some fixes from upstream.
424
425* Mon Mar  3 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-1
426- Requires /usr/bin/system-install-packages not pirut (bug #435622).
427- 0.7.82.1:
428  - More trouble-shooting improvements.
429  - applet: notify user about failed jobs (bug #168370).
430
431* Tue Feb 19 2008 Tim Waugh <twaugh@redhat.com> 0.7.82-1
432- Updated to pycups-1.9.35.
433- 0.7.82:
434  - More trouble-shooting improvements.
435
436* Wed Feb 13 2008 Tim Waugh <twaugh@redhat.com> 0.7.81-1
437- 0.7.81:
438  - Trouble-shooting improvements and other minor fixes.
439
440* Mon Feb 11 2008 Tim Waugh <twaugh@redhat.com> 0.7.80-2
441- Rebuild for GCC 4.3.
442
443* Mon Feb  4 2008 Tim Waugh <twaugh@redhat.com> 0.7.80-1
444- Updated to pycups-1.9.34.
445- 0.7.80:
446  - Trouble-shooting support.
447
448* Fri Jan 25 2008 Tim Waugh <twaugh@redhat.com> 0.7.79-1
449- 0.7.79.
450
451* Wed Jan 23 2008 Tim Waugh <twaugh@redhat.com> 0.7.78-5
452- Updated to pycups-1.9.33.
453
454* Wed Jan 16 2008 Tim Waugh <twaugh@redhat.com> 0.7.78-4
455- Use config-util from new usermode (bug #428406).
456
457* Thu Dec 20 2007 Tim Waugh <twaugh@redhat.com>
458- Requires notification-daemon (Ubuntu #176929).
459- Requires gnome-python2 for theme support (Ubuntu #176929).
460- Requires gnome-icon-theme for printer icon (Ubuntu #176929).
461
462* Mon Dec 17 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-3
463- Install Python egg-info file.
464- Updated pycups to 1.9.32.
465
466* Tue Nov 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-2
467- pycups: Applied patch from SVN to allow fetching printer attributes by URI.
468- Sync to SVN 1748.
469
470* Thu Nov 22 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-1
471- pycups: Fix job-sheets-default attribute.
472- Updated pycups to 1.9.31.
473- 0.7.78.
474
475* Wed Nov 21 2007 Tim Waugh <twaugh@redhat.com>
476- Applied patch to pycups to avoid reading uninitialised
477  memory (bug #390431).
478
479* Mon Nov 19 2007 Tim Waugh <twaugh@redhat.com>
480- Updated pycups to 1.9.30.
481
482* Tue Oct 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.77-1
483- 0.7.77:
484  - Tooltips for the button bar buttons (bug #335601).
485
486* Mon Oct 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.76-1
487- 0.7.76.
488
489* Thu Oct  4 2007 Tim Waugh <twaugh@redhat.com> 0.7.75-1
490- 0.7.75.
491
492* Wed Oct  3 2007 Tim Waugh <twaugh@redhat.com>
493- No need to run update-desktop-database because there are no MimeKey
494  lines in the desktop files.
495- Consistent macro style.
496
497* Tue Oct  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.4-1
498- Changed PreReq to Requires.
499- Mark console.apps file as a config file.
500- Mark pam file as a config file (not replaceable).
501- No need to ship empty NEWS file.
502- Give cupsd.py executable permissions to satisfy rpmlint.
503- Provides system-config-printer-gui.
504- Mark D-Bus configuration file as a config file.
505- Fixed libs summary.
506- Better buildroot tag.
507- Better defattr.
508- Preserve timestamps on explicitly install files.
509- Make example pycups program non-executable.
510- 0.7.74.4:
511  - Updated translations.
512  - Several small bugs fixed.
513
514* Thu Sep 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.3-1
515- 0.7.74.3:
516  - Updated translations.
517  - Other small bug fixes.
518
519* Tue Sep 25 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-3
520- Pull in SVN patch from stable branch for foomatic recommended
521  drivers (bug #292021).
522
523* Fri Sep 21 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-2
524- Pull in SVN patch from stable branch for 'Allow printing from
525  the Internet' check-box (bug #221003).
526
527* Wed Sep 19 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-1
528- Updated pycups to 1.9.27.
529- 0.7.74.2:
530  - When a class is removed on the server, remove it from the UI.
531  - When deleting a printer, select the default printer again.
532  - Select newly-copied printer.
533  - Updated translation (fi).
534  - Better --help message.
535  - Use strcoll to sort manufacturer names.
536  - Avoid duplicate 'recommended' marks.
537  - Remove duplicate device URIs.
538  - Handle IPP_TAG_NOVALUE attributes (for CUPS 1.3.x).
539
540* Wed Sep 12 2007 Tim Waugh <twaugh@redhat.com>
541- Updated pycups to 1.9.26.
542- Build requires epydoc.  Ship HTML documentation.
543
544* Fri Sep  7 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.1-1
545- 0.7.74.1:
546  - Updated Polish translation (bug #263001).
547  - Don't select the default printer after changes to another printer have
548    been made.
549  - Always construct URI from input fields when changing device (bug #281551).
550  - Avoid busy-cursor traceback when window is not yet displayed.
551
552* Thu Aug 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.74-1
553- Updated pycups to 1.9.25.
554- 0.7.74:
555  - Fixed New Class dialog.
556  - UI fixes.
557
558* Sat Aug 25 2007 Tim Waugh <twaugh@redhat.com>
559- More specific license tag.
560
561* Fri Aug 24 2007 Tim Waugh <twaugh@redhat.com> 0.7.73-1
562- 0.7.73.
563
564* Fri Aug 10 2007 Tim Waugh <twaugh@redhat.com> 0.7.72-2
565- Ship the applet's desktop file.
566
567* Wed Aug  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.72-1
568- 0.7.72:
569  - Fixed my-default-printer traceback.
570  - Improvements to New Printer wizard (Till Kamppeter).
571
572* Fri Aug  3 2007 Tim Waugh <twaugh@redhat.com> 0.7.71-1
573- 0.7.71:
574  - Don't discard make/model-matched devices when there are ID-matched
575    devices (Till Kamppeter).
576  - Fixed fallback if no text-only driver is available (Till Kamppeter).
577  - Initialise the make/model list when an ID match failed (Till Kamppeter).
578  - Better error-handling in default-print application (Ubuntu #129901).
579  - UI tweak in admin tool (Ubuntu #128263).
580  - Handle socket: URIs (Ubuntu #127074).
581
582* Mon Jul 23 2007 Tim Waugh <twaugh@redhat.com> 0.7.70-2
583- Obsoletes/provides desktop-printing.
584
585* Mon Jul  9 2007 Tim Waugh <twaugh@redhat.com> 0.7.70-1
586- Requires pirut for system-install-packages.
587- 0.7.70:
588  - Increased GetReady->NewPrinter timeout.
589  - More binary names mapped to package named.
590  - Run system-install-packages to install missing drivers (bug #246726).
591  - Less debug output.
592  - Desktop file fixes for KDE (bug #247299).
593
594* Thu Jun 28 2007 Tim Waugh <twaugh@redhat.com> 0.7.69-1
595- No longer requires PyXML (bug #233146).
596- Moved applet to main package.
597- 0.7.69:
598  - Use HardwareSettings category for my-default-printer desktop
599    file (bug #244935).
600  - Removed unused code.
601  - Filter PPDs by natural language (bug #244173).
602
603* Mon Jun 25 2007 Tim Waugh <twaugh@redhat.com>
604- The applet requires dbus-x11 (Ubuntu #119570).
605
606* Fri Jun 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.68-1
607- 0.7.68:
608  - Fixed the notification bubbles.
609  - Ship my-default-printer utility.
610
611* Fri Jun  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.67-1
612- Don't put TrayIcon or SystemSetup categories in the desktop file.
613- Updated pycups to 1.9.24.
614- 0.7.67:
615  - Fixed desktop files to have capital letters at the start of each
616    word in the Name field (bug #242859).
617  - Fixed crash when saving unapplied changes.
618  - Fixed Device ID parser to always split the CMD field at commas.
619  - New PPDs class means we no longer parse the foomatic XML database.
620
621* Wed May 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.66-1
622- 0.7.66:
623  - Allow job-hold-until to be set (bug #239776).
624  - Implement new printer notifications.
625
626* Tue May 22 2007 Tim Waugh <twaugh@redhat.com> 0.7.65-1
627- Build requires xmlto.
628- Updated to pycups-1.9.22.
629- 0.7.65:
630  - Use urllib for quoting/unquoting (Val Henson, Ubuntu #105022).
631  - Added kn translation.
632  - Better permissions on non-scripts.
633  - Added man pages.
634  - Applet: status feedback.
635  - Applet: fixed relative time descriptions.
636  - Applet: limit refresh frequency.
637
638* Mon Apr 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.63.1-1
639- 0.7.63.1:
640  - Small applet fixes.
641
642* Thu Apr  5 2007 Tim Waugh <twaugh@redhat.com> 0.7.63-1
643- 0.7.63:
644  - Translation updates.
645  - Checked in missing file.
646
647* Wed Apr  4 2007 Tim Waugh <twaugh@redhat.com>
648- Updated to pycups-1.9.20 for printer-state-reasons fix.
649
650* Mon Apr  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.62-1
651- 0.7.62:
652  - Use standard icon for admin tool desktop file.
653  - Fixed env path in Python scripts.
654  - Applet: stop running when the session ends.
655  - Prevent a traceback in the SMB browser (bug #225351).
656  - 'Manage print jobs' desktop file.
657
658* Fri Mar 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.61-1
659- 0.7.61:
660  - Fixed retrieval of SMB authentication details (bug #203539).
661
662* Tue Mar 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.60-1
663- Updated to pycups-1.9.19.
664- Avoid %%makeinstall.
665- 0.7.60:
666  - Handle reconnection failure.
667  - New applet name.
668
669* Mon Mar 26 2007 Tim Waugh <twaugh@redhat.com> 0.7.59-1
670- 0.7.59:
671  - Fixed a translatable string.
672  - Set a window icon (bug #233899).
673  - Handle failure to start the D-Bus service.
674  - Ellipsize the document and printer named (bug #233899).
675  - Removed the status bar (bug #233899).
676  - Added an icon pop-up menu for 'Hide' (bug #233899).
677
678* Wed Mar 21 2007 Tim Waugh <twaugh@redhat.com> 0.7.57-1
679- Added URL tag.
680- 0.7.57:
681  - Prevent traceback when removing temporary file (Ubuntu #92914).
682  - Added print applet.
683
684* Sun Mar 18 2007 Tim Waugh <twaugh@redhat.com> 0.7.56-2
685- Updated to pycups-1.9.18.
686
687* Fri Mar 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.56-1
688- 0.7.56:
689  - Parse Boolean strings correctly in job options.
690  - Small command-set list/string fix (bug #230665).
691  - Handle hostname look-up failures.
692  - Updated filter-to-driver map.
693  - Don't parse printers.conf (bug #231826).
694
695* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.55-1
696- 0.7.55:
697  - Use converted value for job option widgets.
698
699* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.54-1
700- 0.7.54:
701  - Removed debugging code.
702
703* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.53-1
704- No longer requires rhpl (since 0.7.53).
705- 0.7.53:
706  - Use gettext instead of rhpl.translate.
707  - Better layout for PPD options.
708  - Added scrollbars to main printer list (bug #229453).
709  - Set maximum width of default printer label (bug #229453).
710  - Handle applying changes correctly when switching to another
711    printer (bug #229378).
712  - Don't crash when failing to fetch the PPD (bug #229406).
713  - Make the text entry boxes sensitive but not editable for remote
714    printers (bug #229381).
715  - Better job options screen layout (bug #222272).
716
717* Tue Feb 13 2007 Tim Waugh <twaugh@redhat.com> 0.7.52-1
718- 0.7.52:
719  - Sort models using cups.modelSort before scanning for a close
720    match (bug #228505).
721  - Fixed matching logic (bug #228505).
722
723* Fri Feb  9 2007 Tim Waugh <twaugh@redhat.com> 0.7.51-1
724- 0.7.51:
725  - Prevent display glitch in job options list when clicking on a printer
726    repeatedly.
727  - List conflicting PPD options, and embolden the relevant tab
728    labels (bug #226368).
729  - Fixed typo in 'set default' handling that caused a traceback (bug #227936).
730  - Handle interactive search a little better (bug #227935).
731
732* Wed Feb  7 2007 Tim Waugh <twaugh@redhat.com> 0.7.50-1
733- 0.7.50:
734  - Fixed hex digits list (bug #223770).
735  - Added bs translation.
736  - Don't put the ellipsis in the real device URI (bug #227643).
737  - Don't check for existing drivers for complex command lines (bug #225104).
738  - Allow floating point job options (bug #224651).
739  - Prevent shared/published confusion (bug #225081).
740  - Fixed PPD page size setting.
741  - Avoid os.remove exception (bug #226703).
742  - Handle unknown job options (bug #225538).
743
744* Tue Jan 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.49-1
745- 0.7.49:
746  - Fixed a traceback in the driver check code.
747  - Fixed a typo in the conflicts message.
748  - Handle InputSlot/ManualFeed specially because libcups does (bug #222490).
749
750* Mon Jan 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.48-1
751- 0.7.48:
752  - Updated translations.
753
754* Fri Jan 12 2007 Tim Waugh <twaugh@redhat.com> 0.7.47-1
755- 0.7.47:
756  - Fixed minor text bugs (bug #177433).
757  - Handle shell builtins in the driver check (bug #222413).
758
759* Mon Jan  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.46-1
760- 0.7.46:
761  - Fixed page size problem (bug #221702).
762  - Added 'ro' to ALL_LINGUAS.
763
764* Wed Jan  3 2007 Tim Waugh <twaugh@redhat.com> 0.7.45-1
765- Updated to pycups-1.9.17.
766- 0.7.45:
767  - Fixed traceback in driver check.
768
769* Tue Jan  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.44-1
770- 0.7.44:
771  - Fixed traceback in error display (bug #220136).
772  - Preserve case in model string when dumping debug output.
773
774* Thu Dec 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.43-1
775- 0.7.43:
776  - Don't check against IEEE 1284 DES field at all.
777  - Merged device matching code (bug #219518).
778  - Catch non-fatal errors when auto-matching device.
779  - Fixed driver checking bug involving pipelines (bug #220347).
780  - Show PPD errors (bug #220136).
781
782* Mon Dec 11 2006 Tim Waugh <twaugh@redhat.com> 0.7.42-1
783- 0.7.42:
784  - Fixed typo in command set matching code.
785  - Case-insensitive matching when Device ID not known to database.
786
787* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0.7.41-2
788- build against python 2.5
789
790* Thu Dec  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.41-1
791- Updated pycups to 1.9.16.
792- 0.7.41:
793  - Reconnect smoothly after uploading new configuration.
794  - Update lpoptions when setting default printer if it conflicts with
795    the new setting (bug #217395).
796  - Fixed typo in show_HTTP_Error (bug #217537).
797  - Don't pre-select make and model when not discoverable for chosen
798    device (bug #217518).
799  - Set Forward button sensitive on Device screen in new-printer
800    dialog (bug #217515).
801  - Keep Server Settings selected after applying changes if it was selected
802    before.
803  - Set Connecting dialog transient for main window.
804  - Center Connecting dialog on parent.
805  - Optional 'reason' argument for cupshelpers.Printer.setEnabled.
806  - Describe devices that have no optional parameters.
807
808* Thu Nov 30 2006 Tim Waugh <twaugh@redhat.com>
809- Provide pycups feature.
810
811* Tue Nov 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.40-1
812- 0.7.40:
813  - Removed username:password from hint string because we add that in
814    afterwards.
815  - Don't set button widths in create-printer dialog (bug #217025).
816
817* Tue Nov 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.39-1
818- 0.7.39:
819  - Busy cursor while loading foomatic and PPD list (bug #215527).
820  - Make PPD NickName selectable.
821  - Added SMB hint label on device screen (bug #212759).
822
823* Tue Nov 14 2006 Tim Waugh <twaugh@redhat.com> 0.7.38-1
824- Updated pycups to 1.9.15.
825- 0.7.38:
826  - Fixed a bug in the 'ieee1284'/'ppd-device-id' parsing code.
827
828* Mon Nov 13 2006 Tim Waugh <twaugh@redhat.com> 0.7.37-1
829- 0.7.37:
830  - Allow cancellation of test pages (bug #215054).
831
832* Fri Nov 10 2006 Tim Waugh <twaugh@redhat.com> 0.7.36-1
833- 0.7.36:
834  - Match against commandset (bug #214181).
835  - Parse 'ieee1284' foomatic autodetect entries (bug #214761).
836  - Don't remove foomatic PPDs from the list (bug #197331).
837
838* Tue Nov  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.35-1
839- 0.7.35.
840
841* Thu Nov  2 2006 Tim Waugh <twaugh@redhat.com>
842- Updated to pycups-1.9.14 (bug #213136).
843
844* Tue Oct 31 2006 Tim Waugh <twaugh@redhat.com>
845- Update desktop database (bug #213249).
846
847* Tue Oct 24 2006 Tim Waugh <twaugh@redhat.com>
848- Build requires Python 2.4.
849
850* Mon Oct  2 2006 Tim Waugh <twaugh@redhat.com> 0.7.32-1
851- Updated to pycups-1.9.13 for HTTP_FORBIDDEN.
852- 0.7.32:
853  - Handle HTTP errors during connection (bug #208824).
854  - Updated translations (bug #208873).
855
856* Fri Sep 29 2006 Tim Waugh <twaugh@redhat.com> 0.7.31-1
857- 0.7.31:
858  - Select recommended driver automatically (bug #208606).
859  - Better visibility of driver list (bug #203907).
860
861* Fri Sep 29 2006 Tim Waugh <twaugh@redhat.com> 0.7.30-1
862- 0.7.30:
863  - Translations fixed properly (bug #206622).
864  - Button widths corrected (bug #208556).
865
866* Tue Sep 26 2006 Tim Waugh <twaugh@redhat.com> 0.7.28-1
867- 0.7.28.  Translations fixed (bug #206622).
868
869* Wed Aug 30 2006 Tim Waugh <twaugh@redhat.com> 0.7.27-1
870- Build requires intltool.
871- 0.7.27.
872
873* Wed Aug 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.26-1
874- 0.7.26.  Fixes bug # 203149.
875
876* Mon Aug 14 2006 Florian Festi <ffesti@redhat.com> 0.7.25-1
877- 0.7.25. (bug #202060)
878
879* Fri Aug 11 2006 Tim Waugh <twaugh@redhat.com>
880- Fixed description (bug #202189).
881
882* Thu Aug  3 2006 Tim Waugh <twaugh@redhat.com> 0.7.24-1
883- 0.7.24.
884
885* Mon Jul 24 2006 Tim Waugh <twaugh@redhat.com> 0.7.23-1
886- 0.7.23.  Fixes bug #197866.
887
888* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.22-1.1
889- rebuild
890
891* Fri Jul  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.22-1
892- 0.7.22.
893
894* Wed Jul  5 2006 Tim Waugh <twaugh@redhat.com> 0.7.21-1
895- Updated to pycups-1.9.12.
896- 0.7.21.
897
898* Mon Jul  3 2006 Tim Waugh <twaugh@redhat.com> 0.7.20-1
899- 0.7.20.
900
901* Fri Jun 30 2006 Tim Waugh <twaugh@redhat.com> 0.7.19-1
902- 0.7.19.
903- Remove foomatic pickle file post-install.
904
905* Tue Jun 27 2006 Tim Waugh <twaugh@redhat.com> 0.7.18-1
906- 0.7.18.
907- Ship translations with libs subpackage.
908
909* Fri Jun 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.17-1
910- 0.7.17.
911
912* Fri Jun 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.16-1
913- 0.7.16, now with SMB browser.
914
915* Thu Jun 22 2006 Tim Waugh <twaugh@redhat.com> 0.7.15-1
916- 0.7.15.
917- Build requires gettext-devel.
918- Ship translations.
919
920* Tue Jun 20 2006 Tim Waugh <twaugh@redhat.com> 0.7.14-1
921- 0.7.14.
922
923* Mon Jun 19 2006 Tim Waugh <twaugh@redhat.com> 0.7.13-1
924- 0.7.13.
925
926* Fri Jun  9 2006 Tim Waugh <twaugh@redhat.com> 0.7.12-1
927- 0.7.12.
928
929* Thu Jun  1 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-3
930- Fix libs dependency.
931
932* Thu Jun  1 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-2
933- Moved the gtk_html2pango module to the libs package (needed by
934  foomatic.py).
935
936* Wed May 31 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-1
937- Split out system-config-printer-libs.
938- Updated to system-config-printer-0.7.11.
939
940* Sat May 27 2006 Tim Waugh <twaugh@redhat.com> 0.7.10-2
941- Requires gobject2 (bug #192764).
942
943* Fri May 26 2006 Tim Waugh <twaugh@redhat.com> 0.7.10-1
944- Require foomatic (bug #192764).
945- Updated to system-config-printer-0.7.10.
946
947* Thu May 25 2006 Tim Waugh <twaugh@redhat.com> 0.7.9-1
948- Updated to pycups-1.9.11.
949- Updated to system-config-printer-0.7.9.
950
951* Mon May 15 2006 Tim Waugh <twaugh@redhat.com> 0.7.8-1
952- Updated to pycups-1.9.10.
953- Updated to system-config-printer-0.7.8.
954
955* Fri May  5 2006 Tim Waugh <twaugh@redhat.com>
956- Fix pycups segfault.
957
958* Fri May  5 2006 Tim Waugh <twaugh@redhat.com> 0.7.7-2
959- Ship PAM and userhelper files.
960- Requires usermode.
961- Added missing options.py file.
962- Fix getClasses() in pycups.
963
964* Thu May  4 2006 Tim Waugh <twaugh@redhat.com> 0.7.7-1
965- Updated to system-config-printer-0.7.7.
966- Updated to pycups-1.9.9.
967- Desktop file.
968- Requires PyXML.
969
970* Fri Apr 28 2006 Tim Waugh <twaugh@redhat.com>
971- Make it actually run.
972
973* Fri Apr 21 2006 Tim Waugh <twaugh@redhat.com>
974- Build requires CUPS 1.2.
975
976* Thu Apr 20 2006 Tim Waugh <twaugh@redhat.com> 0.7.5-1
977- Updated to pycups-1.9.8.  No longer need threads patch.
978- Updated to system-config-printer-0.7.5.
979
980* Sat Apr 15 2006 Tim Waugh <twaugh@redhat.com>
981- Updated to pycups-1.9.7.
982
983* Thu Apr 13 2006 Tim Waugh <twaugh@redhat.com> 0.7.4-2
984- Obsoletes: system-config-printer-gui <= 0.6.152
985
986* Wed Apr 12 2006 Tim Waugh <twaugh@redhat.com> 0.7.4-1
987- Updated to system-config-printer-0.7.4.
988
989* Fri Apr  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.3-1
990- Added threads patch from pycups CVS.
991- Updated to system-config-printer-0.7.3.
992
993* Tue Apr  4 2006 Tim Waugh <twaugh@redhat.com>
994- Updated to pycups-1.9.6.
995
996* Fri Mar 24 2006 Tim Waugh <twaugh@redhat.com>
997- Updated to pycups-1.9.5.
998
999* Fri Mar 17 2006 Tim Waugh <twaugh@redhat.com>
1000- Package the actual system-config-printer command.
1001
1002* Thu Mar 16 2006 Tim Waugh <twaugh@redhat.com> 0.7.1-1
1003- Include s-c-printer tarball.
1004- Updated to pycups-1.9.4.
1005
1006* Wed Mar 15 2006 Tim Waugh <twaugh@redhat.com> 0.7.0-1
1007- Initial spec file.
Note: See TracBrowser for help on using the repository browser.