source: projects/specs/trunk/s/system-config-printer/system-config-printer-vl.spec @ 521

Revision 521, 30.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pycups_version 1.9.48
2%define pysmbc_version 1.0.6
3%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
4%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
5%{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
6
7Summary: A printer administration tool
8Summary(ja): プリンタ管理ツール
9Name: system-config-printer
10Version: 1.1.92
11Release: 1%{?_dist_release}
12License: GPLv2+
13URL: http://cyberelk.net/tim/software/system-config-printer/
14Group: System Environment/Base
15
16Source0: http://cyberelk.net/tim/data/system-config-printer/1.2/system-config-printer-%{version}.tar.bz2
17Source1: http://cyberelk.net/tim/data/pycups/pycups-%{pycups_version}.tar.bz2
18Source2: http://cyberelk.net/tim/data/pysmbc/pysmbc-%{pysmbc_version}.tar.bz2
19
20Source10: %{name}-1.1.92-ja.po
21
22Patch1: system-config-printer-no-epydoc.patch
23Patch2: system-config-printer-lowercase-mfg-mdl.patch
24Patch10: system-config-printer-1.1.7-fix-adding-printer.patch
25
26Patch20: %{name}-1.1.92-gettext.patch
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29
30BuildRequires: cups-devel >= 1.2
31BuildRequires: python-devel >= 2.5
32BuildRequires: libsmbclient-devel >= 3.2
33BuildRequires: desktop-file-utils >= 0.2.92
34BuildRequires: gettext
35BuildRequires: intltool
36BuildRequires: xmlto
37BuildRequires: python-tools
38BuildRequires: libusb-devel, libudev-devel
39
40
41Requires: pygtk2
42Requires: pygobject
43Requires: desktop-file-utils
44Requires: dbus-x11
45Requires: system-config-printer-libs = %{version}-%{release}
46Requires: gnome-icon-theme
47Requires: gnome-python
48Requires: gnome-python-gnomekeyring
49Requires: notification-daemon
50Requires: notify-python
51Requires: libxml2-python
52
53Obsoletes: system-config-printer-gui <= 0.6.152
54Provides: system-config-printer-gui = 0.6.152
55
56Obsoletes: desktop-printing <= 0.20-7.fc7
57Provides: desktop-printing = 0.20-7.fc7
58
59%description
60system-config-printer is a graphical user interface that allows
61the user to configure a CUPS print server.
62
63%package libs
64Summary: Libraries and shared code for printer administration tool
65Summary(ja): Libraries and shared code for printer administration tool
66Group: System Environment/Base
67Requires: python
68Requires: foomatic
69Provides: pycups = %{pycups_version}
70Provides: pysmbc = %{pysmbc_version}
71
72%description libs
73The common code used by both the graphical and non-graphical parts of
74the configuration tool.
75
76%package udev
77Summary: Rules for udev for automatic configuration of USB printers
78Group: System Environment/Base
79Requires: system-config-printer-libs = %{version}-%{release}
80Obsoletes: hal-cups-utils <= 0.6.20
81Provides: hal-cups-utils = 0.6.20
82
83%description udev
84The udev rules and helper programs for automatically configuring USB
85printers.
86
87%prep
88%setup -q -a 1 -a 2
89
90%patch1 -p1 -b .no-epydoc
91%patch2 -p1 -b .lowercase-mfg-mdl
92%patch10 -p1
93%patch20 -p1
94
95
96cp -f %{SOURCE10} po/ja.po
97
98%build
99%configure --with-udev-rules
100
101pushd pycups-%{pycups_version}
102make
103make doc
104popd
105
106pushd pysmbc-%{pysmbc_version}
107make
108make doc
109popd
110
111%install
112rm -rf %buildroot
113make DESTDIR=%buildroot install
114
115pushd pycups-%{pycups_version}
116make DESTDIR=%buildroot install
117popd
118
119pushd pysmbc-%{pysmbc_version}
120make DESTDIR=%buildroot install
121popd
122
123%{__mkdir_p} %buildroot%{_localstatedir}/run/udev-configure-printer
124touch %buildroot%{_localstatedir}/run/udev-configure-printer/usb-uris
125
126%find_lang system-config-printer
127
128%clean
129rm -rf %buildroot
130
131%post
132/bin/rm -f /var/cache/foomatic/foomatic.pickle
133exit 0
134
135%files libs -f system-config-printer.lang
136%defattr(-,root,root,-)
137%doc --parents pycups-%{pycups_version}/{ChangeLog,README,NEWS,TODO,examples,html}
138%doc --parents pysmbc-%{pysmbc_version}/{ChangeLog,README,NEWS,TODO,test.py,html}
139%config(noreplace) %{_sysconfdir}/dbus-1/system.d/newprinternotification.conf
140%config(noreplace) %{_sysconfdir}/dbus-1/system.d/printerdriversinstaller.conf
141%{python_sitearch}/cups.so
142%{python_sitearch}/smbc.so
143%{python_sitearch}/*.egg-info
144%dir %{python_sitelib}/cupshelpers
145%{python_sitelib}/cupshelpers/__init__.py*
146%{python_sitelib}/cupshelpers/cupshelpers.py*
147%{python_sitelib}/cupshelpers/openprinting.py*
148%{python_sitelib}/cupshelpers/ppds.py*
149%{python_sitelib}/*.egg-info
150
151%files udev
152%defattr(-,root,root,-)
153/lib/udev/rules.d/*.rules
154/lib/udev/udev-*-printer
155%dir %{_localstatedir}/run/udev-configure-printer
156%verify(not md5 size mtime) %config(noreplace,missingok) %attr(0644,root,root) %{_localstatedir}/run/udev-configure-printer/usb-uris
157
158%files
159%defattr(-,root,root,-)
160%doc ChangeLog README
161%{_bindir}/%{name}
162%{_bindir}/%{name}-applet
163%dir %{_datadir}/%{name}
164%{_datadir}/%{name}/*.py*
165%{_datadir}/%{name}/troubleshoot
166%{_datadir}/%{name}/icons
167%{_datadir}/%{name}/ui/*.glade
168%{_datadir}/applications/system-config-printer.desktop
169%{_datadir}/applications/manage-print-jobs.desktop
170%{_sysconfdir}/xdg/autostart/print-applet.desktop
171%{_mandir}/man1/*
172
173%changelog
174* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.92-1
175- new development release (pre1.2)
176  - system-config-printer-1.1.92
177  - pycups-1.9.48
178- add Patch1,2 from fedora
179  - Patch1: build without epydoc, remove BR: epydoc
180  - Patch2: Convert MFG and MDL to lowercase before D-Bus call
181    to work around bug #566217.
182- add BR: python-tools, libudev-devel, libusb-devel
183- add R: libxml2-python
184
185* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.7-2
186- rebuilt with python-2.6.4
187
188* Sat Jun 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.7-1
189- new upstream release
190  - Updated translations.
191  - Don't abort if the jobviewer couldn't show a notification.
192  - Don't use setlocale() for locale-independent case conversion.
193  - Don't assume the notification daemon can show action buttons.
194  - Use case-insensitive matching for model names.
195  - HPLIP compatibility fixes.
196  - Fixed typo in jobviewer keyring support (Ubuntu #343156).
197  - Added support for https device URIs (bug #478677).
198  - Prevent traceback in monitor when connection failed (Ubuntu #343387).
199- add Patch10: fix infinite loop on adding printer
200- add Patch11: do not probe hplip
201
202* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
203- new upstream release
204  - system-config-printer 1.1.6
205  - pycups 1.9.45
206
207* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.9-1
208- initial build for Vine Linux
209
210* Tue Oct 21 2008 Tim Waugh <twaugh@redhat.com> 1.0.9-1
211- Updated to 1.0.9 for translations.
212- Updated pysmbc to 1.0.6.  No longer need pysmbc-git patch.
213
214* Fri Oct 17 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-7
215- Added patch for pysmbc changes in git to prevent getdents crashing
216  (bug #465975).
217
218* Thu Oct 16 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-6
219- Updated patch for 1.0.x changes:
220  - Fixed SMB authentication dialog's cancel button (bug #467127).
221  - Work around samba bug #5805 by sending debug output to stderr
222    instead of stdout.
223
224* Wed Oct 15 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-5
225- Updated patch for 1.0.x changes:
226  - Fixed SMB authentication (bug #464003).
227
228* Wed Oct 15 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-4
229- Updated patch for 1.0.x changes:
230  - Removed unneeded debugging output.
231  - Don't show the applet in KDE (bug #466945).
232  - Auth/error dialog improvements for SMB as for IPP (bug #465407).
233
234* Mon Oct 13 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-3
235- Added patch for 1.0.x changes since 1.0.8:
236  - Don't use a LinkButton for the 'Problems?' button (bug #465407).
237  - Don't use a separator for the server settings dialog (bug
238    #465407).
239  - Don't set non-zero page size for SpinButtons.
240  - Don't show an error dialog if an IPP operation's authentication
241    dialog is cancelled by the user, but show an error dialog if the
242    password was incorrect (bug #465407).
243  - Set Server Settings... menu entry sensitive depending on whether
244    we are connected to a server (Ubuntu #280736).
245  - Lots of translations updated.
246
247* Mon Sep 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-2
248- Removed patch (no longer needed).
249
250* Mon Sep 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-1
251- 1.0.8:
252  - Use modelName from custom PPD to suggest name for new printer
253    (trac #97).
254  - Avoid display problem with installable options.
255  - Better matching for Lexmark printers.
256  - Catch exceptions from advanced server settings dialog (Ubuntu
257    #267557).
258  - Added some missing OpenPrinting query fields.
259  - Jockey support added.
260  - Lots of translations updated.
261
262* Sat Aug 30 2008 Tim Waugh <twaugh@redhat.com> 1.0.7-2
263- Handle IPP_FORBIDDEN (bug #460670).
264
265* Fri Aug 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.7-1
266- 1.0.7:
267  - Efficiency improvements.
268  - Small UI improvements for the New Printer dialog.
269  - Other small fixes.
270
271* Fri Aug 29 2008 Tim Waugh <twaugh@redhat.com>
272- Updated pysmbc to 1.0.5.
273- Updated pycups to 1.9.42.
274
275* Tue Aug 26 2008 Tim Waugh <twaugh@redhat.com> 1.0.6-1
276- Requires gnome-python2-gnome (bug #460021).
277- 1.0.6:
278  - More delete-event fixes.
279  - Fixed temporary file leak.
280  - Fixed dialog leaks.
281  - Small UI improvements for the New Printer dialog.
282  - Other small fixes.
283
284* Thu Aug 14 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-3
285- Include other fixes from upstream including:
286  - OpenPrinting API change (trac #74).
287  - libnotify API change for 'closed' signal.
288  - Notification for job authentication (trac #91).
289  - Glade delete-event fixes (trac #88).
290  - Pre-fill username in job authentication dialog (trac #87).
291
292* Wed Aug 13 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-2
293- Handle HTTP_FORBIDDEN.
294
295* Mon Aug 11 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-1
296- 1.0.5.
297- Updated pycups to 1.9.41.
298
299* Thu Jul 10 2008 Tim Waugh <twaugh@redhat.com> 1.0.4-1
300- 1.0.4.
301- Applied upstream patch for pycups to fix getPrinterAttributes when
302  requested_attributes is specified.
303
304* Tue Jul  8 2008 Tim Waugh <twaugh@redhat.com> 1.0.3-2
305- Better debugging for pysmbc.
306
307* Mon Jun 30 2008 Tim Waugh <twaugh@redhat.com> 1.0.3-1
308- Updated pycups to 1.9.40.
309- 1.0.3.
310
311* Fri Jun 20 2008 Tim Waugh <twaugh@redhat.com>
312- Updated pysmbc to 1.0.4.
313
314* Tue Jun 10 2008 Tim Waugh <twaugh@redhat.com> 1.0.2-1
315- 1.0.2.
316
317* Mon Jun  9 2008 Tim Waugh <twaugh@redhat.com> 1.0.1-1
318- Updated pysmbc to 1.0.3.
319- 1.0.1 (bug #450119).
320
321* Thu Jun  5 2008 Tim Waugh <twaugh@redhat.com>
322- Requires notify-python (bug #450139).
323
324* Thu Jun  5 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-3
325- Applied patches from upstream (bug #450120).
326
327* Tue Jun  3 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-2
328- Applied patches from upstream (bug #449753).
329
330* Thu May 29 2008 Tim Waugh <twaugh@redhat.com>
331- Updated pycups to 1.9.39.
332- Updated libs summary.
333
334* Tue May 27 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-1
335- 1.0.0.
336
337* Fri May 23 2008 Tim Waugh <twaugh@redhat.com> 0.9.93-2
338- Fixed small UI problem in SMB browser.
339
340* Fri May 23 2008 Tim Waugh <twaugh@redhat.com> 0.9.93-1
341- 0.9.93.
342
343* Tue May 20 2008 Tim Waugh <twaugh@redhat.com> 0.9.92-1
344- 0.9.92.
345
346* Tue May 20 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-3
347- Sync to trunk.
348- Updated pysmbc to 1.0.2.
349
350* Sun May 18 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-2
351- Fixed icon search path.
352
353* Fri May 16 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-1
354- No longer requires system-install-packages (bug #444645).
355- Added pysmbc.  Build requires libsmbclient-devel.
356- Don't install consolehelper bits any more as they are no longer needed.
357- 0.9.91:
358  - User interface overhaul, part 2.
359
360* Thu Apr  3 2008 Tim Waugh <twaugh@redhat.com> 0.9.90-1
361- Updated pycups to 1.9.38.
362- 0.9.90:
363  - User interface overhaul, part 1.
364
365* Thu Apr  3 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.2-1
366- 0.7.82.2:
367  - Various bug fixes.
368  - Translation updates.
369
370* Mon Mar 17 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-3
371- Updated pycups to 1.9.37.
372- More fixes from upstream.
373
374* Wed Mar  5 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-2
375- Updated pycups to 1.9.36.
376- Some fixes from upstream.
377
378* Mon Mar  3 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-1
379- Requires /usr/bin/system-install-packages not pirut (bug #435622).
380- 0.7.82.1:
381  - More trouble-shooting improvements.
382  - applet: notify user about failed jobs (bug #168370).
383
384* Tue Feb 19 2008 Tim Waugh <twaugh@redhat.com> 0.7.82-1
385- Updated to pycups-1.9.35.
386- 0.7.82:
387  - More trouble-shooting improvements.
388
389* Wed Feb 13 2008 Tim Waugh <twaugh@redhat.com> 0.7.81-1
390- 0.7.81:
391  - Trouble-shooting improvements and other minor fixes.
392
393* Mon Feb 11 2008 Tim Waugh <twaugh@redhat.com> 0.7.80-2
394- Rebuild for GCC 4.3.
395
396* Mon Feb  4 2008 Tim Waugh <twaugh@redhat.com> 0.7.80-1
397- Updated to pycups-1.9.34.
398- 0.7.80:
399  - Trouble-shooting support.
400
401* Fri Jan 25 2008 Tim Waugh <twaugh@redhat.com> 0.7.79-1
402- 0.7.79.
403
404* Wed Jan 23 2008 Tim Waugh <twaugh@redhat.com> 0.7.78-5
405- Updated to pycups-1.9.33.
406
407* Wed Jan 16 2008 Tim Waugh <twaugh@redhat.com> 0.7.78-4
408- Use config-util from new usermode (bug #428406).
409
410* Thu Dec 20 2007 Tim Waugh <twaugh@redhat.com>
411- Requires notification-daemon (Ubuntu #176929).
412- Requires gnome-python2 for theme support (Ubuntu #176929).
413- Requires gnome-icon-theme for printer icon (Ubuntu #176929).
414
415* Mon Dec 17 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-3
416- Install Python egg-info file.
417- Updated pycups to 1.9.32.
418
419* Tue Nov 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-2
420- pycups: Applied patch from SVN to allow fetching printer attributes by URI.
421- Sync to SVN 1748.
422
423* Thu Nov 22 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-1
424- pycups: Fix job-sheets-default attribute.
425- Updated pycups to 1.9.31.
426- 0.7.78.
427
428* Wed Nov 21 2007 Tim Waugh <twaugh@redhat.com>
429- Applied patch to pycups to avoid reading uninitialised
430  memory (bug #390431).
431
432* Mon Nov 19 2007 Tim Waugh <twaugh@redhat.com>
433- Updated pycups to 1.9.30.
434
435* Tue Oct 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.77-1
436- 0.7.77:
437  - Tooltips for the button bar buttons (bug #335601).
438
439* Mon Oct 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.76-1
440- 0.7.76.
441
442* Thu Oct  4 2007 Tim Waugh <twaugh@redhat.com> 0.7.75-1
443- 0.7.75.
444
445* Wed Oct  3 2007 Tim Waugh <twaugh@redhat.com>
446- No need to run update-desktop-database because there are no MimeKey
447  lines in the desktop files.
448- Consistent macro style.
449
450* Tue Oct  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.4-1
451- Changed PreReq to Requires.
452- Mark console.apps file as a config file.
453- Mark pam file as a config file (not replaceable).
454- No need to ship empty NEWS file.
455- Give cupsd.py executable permissions to satisfy rpmlint.
456- Provides system-config-printer-gui.
457- Mark D-Bus configuration file as a config file.
458- Fixed libs summary.
459- Better buildroot tag.
460- Better defattr.
461- Preserve timestamps on explicitly install files.
462- Make example pycups program non-executable.
463- 0.7.74.4:
464  - Updated translations.
465  - Several small bugs fixed.
466
467* Thu Sep 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.3-1
468- 0.7.74.3:
469  - Updated translations.
470  - Other small bug fixes.
471
472* Tue Sep 25 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-3
473- Pull in SVN patch from stable branch for foomatic recommended
474  drivers (bug #292021).
475
476* Fri Sep 21 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-2
477- Pull in SVN patch from stable branch for 'Allow printing from
478  the Internet' check-box (bug #221003).
479
480* Wed Sep 19 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-1
481- Updated pycups to 1.9.27.
482- 0.7.74.2:
483  - When a class is removed on the server, remove it from the UI.
484  - When deleting a printer, select the default printer again.
485  - Select newly-copied printer.
486  - Updated translation (fi).
487  - Better --help message.
488  - Use strcoll to sort manufacturer names.
489  - Avoid duplicate 'recommended' marks.
490  - Remove duplicate device URIs.
491  - Handle IPP_TAG_NOVALUE attributes (for CUPS 1.3.x).
492
493* Wed Sep 12 2007 Tim Waugh <twaugh@redhat.com>
494- Updated pycups to 1.9.26.
495- Build requires epydoc.  Ship HTML documentation.
496
497* Fri Sep  7 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.1-1
498- 0.7.74.1:
499  - Updated Polish translation (bug #263001).
500  - Don't select the default printer after changes to another printer have
501    been made.
502  - Always construct URI from input fields when changing device (bug #281551).
503  - Avoid busy-cursor traceback when window is not yet displayed.
504
505* Thu Aug 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.74-1
506- Updated pycups to 1.9.25.
507- 0.7.74:
508  - Fixed New Class dialog.
509  - UI fixes.
510
511* Sat Aug 25 2007 Tim Waugh <twaugh@redhat.com>
512- More specific license tag.
513
514* Fri Aug 24 2007 Tim Waugh <twaugh@redhat.com> 0.7.73-1
515- 0.7.73.
516
517* Fri Aug 10 2007 Tim Waugh <twaugh@redhat.com> 0.7.72-2
518- Ship the applet's desktop file.
519
520* Wed Aug  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.72-1
521- 0.7.72:
522  - Fixed my-default-printer traceback.
523  - Improvements to New Printer wizard (Till Kamppeter).
524
525* Fri Aug  3 2007 Tim Waugh <twaugh@redhat.com> 0.7.71-1
526- 0.7.71:
527  - Don't discard make/model-matched devices when there are ID-matched
528    devices (Till Kamppeter).
529  - Fixed fallback if no text-only driver is available (Till Kamppeter).
530  - Initialise the make/model list when an ID match failed (Till Kamppeter).
531  - Better error-handling in default-print application (Ubuntu #129901).
532  - UI tweak in admin tool (Ubuntu #128263).
533  - Handle socket: URIs (Ubuntu #127074).
534
535* Mon Jul 23 2007 Tim Waugh <twaugh@redhat.com> 0.7.70-2
536- Obsoletes/provides desktop-printing.
537
538* Mon Jul  9 2007 Tim Waugh <twaugh@redhat.com> 0.7.70-1
539- Requires pirut for system-install-packages.
540- 0.7.70:
541  - Increased GetReady->NewPrinter timeout.
542  - More binary names mapped to package named.
543  - Run system-install-packages to install missing drivers (bug #246726).
544  - Less debug output.
545  - Desktop file fixes for KDE (bug #247299).
546
547* Thu Jun 28 2007 Tim Waugh <twaugh@redhat.com> 0.7.69-1
548- No longer requires PyXML (bug #233146).
549- Moved applet to main package.
550- 0.7.69:
551  - Use HardwareSettings category for my-default-printer desktop
552    file (bug #244935).
553  - Removed unused code.
554  - Filter PPDs by natural language (bug #244173).
555
556* Mon Jun 25 2007 Tim Waugh <twaugh@redhat.com>
557- The applet requires dbus-x11 (Ubuntu #119570).
558
559* Fri Jun 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.68-1
560- 0.7.68:
561  - Fixed the notification bubbles.
562  - Ship my-default-printer utility.
563
564* Fri Jun  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.67-1
565- Don't put TrayIcon or SystemSetup categories in the desktop file.
566- Updated pycups to 1.9.24.
567- 0.7.67:
568  - Fixed desktop files to have capital letters at the start of each
569    word in the Name field (bug #242859).
570  - Fixed crash when saving unapplied changes.
571  - Fixed Device ID parser to always split the CMD field at commas.
572  - New PPDs class means we no longer parse the foomatic XML database.
573
574* Wed May 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.66-1
575- 0.7.66:
576  - Allow job-hold-until to be set (bug #239776).
577  - Implement new printer notifications.
578
579* Tue May 22 2007 Tim Waugh <twaugh@redhat.com> 0.7.65-1
580- Build requires xmlto.
581- Updated to pycups-1.9.22.
582- 0.7.65:
583  - Use urllib for quoting/unquoting (Val Henson, Ubuntu #105022).
584  - Added kn translation.
585  - Better permissions on non-scripts.
586  - Added man pages.
587  - Applet: status feedback.
588  - Applet: fixed relative time descriptions.
589  - Applet: limit refresh frequency.
590
591* Mon Apr 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.63.1-1
592- 0.7.63.1:
593  - Small applet fixes.
594
595* Thu Apr  5 2007 Tim Waugh <twaugh@redhat.com> 0.7.63-1
596- 0.7.63:
597  - Translation updates.
598  - Checked in missing file.
599
600* Wed Apr  4 2007 Tim Waugh <twaugh@redhat.com>
601- Updated to pycups-1.9.20 for printer-state-reasons fix.
602
603* Mon Apr  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.62-1
604- 0.7.62:
605  - Use standard icon for admin tool desktop file.
606  - Fixed env path in Python scripts.
607  - Applet: stop running when the session ends.
608  - Prevent a traceback in the SMB browser (bug #225351).
609  - 'Manage print jobs' desktop file.
610
611* Fri Mar 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.61-1
612- 0.7.61:
613  - Fixed retrieval of SMB authentication details (bug #203539).
614
615* Tue Mar 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.60-1
616- Updated to pycups-1.9.19.
617- Avoid %%makeinstall.
618- 0.7.60:
619  - Handle reconnection failure.
620  - New applet name.
621
622* Mon Mar 26 2007 Tim Waugh <twaugh@redhat.com> 0.7.59-1
623- 0.7.59:
624  - Fixed a translatable string.
625  - Set a window icon (bug #233899).
626  - Handle failure to start the D-Bus service.
627  - Ellipsize the document and printer named (bug #233899).
628  - Removed the status bar (bug #233899).
629  - Added an icon pop-up menu for 'Hide' (bug #233899).
630
631* Wed Mar 21 2007 Tim Waugh <twaugh@redhat.com> 0.7.57-1
632- Added URL tag.
633- 0.7.57:
634  - Prevent traceback when removing temporary file (Ubuntu #92914).
635  - Added print applet.
636
637* Sun Mar 18 2007 Tim Waugh <twaugh@redhat.com> 0.7.56-2
638- Updated to pycups-1.9.18.
639
640* Fri Mar 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.56-1
641- 0.7.56:
642  - Parse Boolean strings correctly in job options.
643  - Small command-set list/string fix (bug #230665).
644  - Handle hostname look-up failures.
645  - Updated filter-to-driver map.
646  - Don't parse printers.conf (bug #231826).
647
648* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.55-1
649- 0.7.55:
650  - Use converted value for job option widgets.
651
652* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.54-1
653- 0.7.54:
654  - Removed debugging code.
655
656* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.53-1
657- No longer requires rhpl (since 0.7.53).
658- 0.7.53:
659  - Use gettext instead of rhpl.translate.
660  - Better layout for PPD options.
661  - Added scrollbars to main printer list (bug #229453).
662  - Set maximum width of default printer label (bug #229453).
663  - Handle applying changes correctly when switching to another
664    printer (bug #229378).
665  - Don't crash when failing to fetch the PPD (bug #229406).
666  - Make the text entry boxes sensitive but not editable for remote
667    printers (bug #229381).
668  - Better job options screen layout (bug #222272).
669
670* Tue Feb 13 2007 Tim Waugh <twaugh@redhat.com> 0.7.52-1
671- 0.7.52:
672  - Sort models using cups.modelSort before scanning for a close
673    match (bug #228505).
674  - Fixed matching logic (bug #228505).
675
676* Fri Feb  9 2007 Tim Waugh <twaugh@redhat.com> 0.7.51-1
677- 0.7.51:
678  - Prevent display glitch in job options list when clicking on a printer
679    repeatedly.
680  - List conflicting PPD options, and embolden the relevant tab
681    labels (bug #226368).
682  - Fixed typo in 'set default' handling that caused a traceback (bug #227936).
683  - Handle interactive search a little better (bug #227935).
684
685* Wed Feb  7 2007 Tim Waugh <twaugh@redhat.com> 0.7.50-1
686- 0.7.50:
687  - Fixed hex digits list (bug #223770).
688  - Added bs translation.
689  - Don't put the ellipsis in the real device URI (bug #227643).
690  - Don't check for existing drivers for complex command lines (bug #225104).
691  - Allow floating point job options (bug #224651).
692  - Prevent shared/published confusion (bug #225081).
693  - Fixed PPD page size setting.
694  - Avoid os.remove exception (bug #226703).
695  - Handle unknown job options (bug #225538).
696
697* Tue Jan 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.49-1
698- 0.7.49:
699  - Fixed a traceback in the driver check code.
700  - Fixed a typo in the conflicts message.
701  - Handle InputSlot/ManualFeed specially because libcups does (bug #222490).
702
703* Mon Jan 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.48-1
704- 0.7.48:
705  - Updated translations.
706
707* Fri Jan 12 2007 Tim Waugh <twaugh@redhat.com> 0.7.47-1
708- 0.7.47:
709  - Fixed minor text bugs (bug #177433).
710  - Handle shell builtins in the driver check (bug #222413).
711
712* Mon Jan  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.46-1
713- 0.7.46:
714  - Fixed page size problem (bug #221702).
715  - Added 'ro' to ALL_LINGUAS.
716
717* Wed Jan  3 2007 Tim Waugh <twaugh@redhat.com> 0.7.45-1
718- Updated to pycups-1.9.17.
719- 0.7.45:
720  - Fixed traceback in driver check.
721
722* Tue Jan  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.44-1
723- 0.7.44:
724  - Fixed traceback in error display (bug #220136).
725  - Preserve case in model string when dumping debug output.
726
727* Thu Dec 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.43-1
728- 0.7.43:
729  - Don't check against IEEE 1284 DES field at all.
730  - Merged device matching code (bug #219518).
731  - Catch non-fatal errors when auto-matching device.
732  - Fixed driver checking bug involving pipelines (bug #220347).
733  - Show PPD errors (bug #220136).
734
735* Mon Dec 11 2006 Tim Waugh <twaugh@redhat.com> 0.7.42-1
736- 0.7.42:
737  - Fixed typo in command set matching code.
738  - Case-insensitive matching when Device ID not known to database.
739
740* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0.7.41-2
741- build against python 2.5
742
743* Thu Dec  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.41-1
744- Updated pycups to 1.9.16.
745- 0.7.41:
746  - Reconnect smoothly after uploading new configuration.
747  - Update lpoptions when setting default printer if it conflicts with
748    the new setting (bug #217395).
749  - Fixed typo in show_HTTP_Error (bug #217537).
750  - Don't pre-select make and model when not discoverable for chosen
751    device (bug #217518).
752  - Set Forward button sensitive on Device screen in new-printer
753    dialog (bug #217515).
754  - Keep Server Settings selected after applying changes if it was selected
755    before.
756  - Set Connecting dialog transient for main window.
757  - Center Connecting dialog on parent.
758  - Optional 'reason' argument for cupshelpers.Printer.setEnabled.
759  - Describe devices that have no optional parameters.
760
761* Thu Nov 30 2006 Tim Waugh <twaugh@redhat.com>
762- Provide pycups feature.
763
764* Tue Nov 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.40-1
765- 0.7.40:
766  - Removed username:password from hint string because we add that in
767    afterwards.
768  - Don't set button widths in create-printer dialog (bug #217025).
769
770* Tue Nov 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.39-1
771- 0.7.39:
772  - Busy cursor while loading foomatic and PPD list (bug #215527).
773  - Make PPD NickName selectable.
774  - Added SMB hint label on device screen (bug #212759).
775
776* Tue Nov 14 2006 Tim Waugh <twaugh@redhat.com> 0.7.38-1
777- Updated pycups to 1.9.15.
778- 0.7.38:
779  - Fixed a bug in the 'ieee1284'/'ppd-device-id' parsing code.
780
781* Mon Nov 13 2006 Tim Waugh <twaugh@redhat.com> 0.7.37-1
782- 0.7.37:
783  - Allow cancellation of test pages (bug #215054).
784
785* Fri Nov 10 2006 Tim Waugh <twaugh@redhat.com> 0.7.36-1
786- 0.7.36:
787  - Match against commandset (bug #214181).
788  - Parse 'ieee1284' foomatic autodetect entries (bug #214761).
789  - Don't remove foomatic PPDs from the list (bug #197331).
790
791* Tue Nov  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.35-1
792- 0.7.35.
793
794* Thu Nov  2 2006 Tim Waugh <twaugh@redhat.com>
795- Updated to pycups-1.9.14 (bug #213136).
796
797* Tue Oct 31 2006 Tim Waugh <twaugh@redhat.com>
798- Update desktop database (bug #213249).
799
800* Tue Oct 24 2006 Tim Waugh <twaugh@redhat.com>
801- Build requires Python 2.4.
802
803* Mon Oct  2 2006 Tim Waugh <twaugh@redhat.com> 0.7.32-1
804- Updated to pycups-1.9.13 for HTTP_FORBIDDEN.
805- 0.7.32:
806  - Handle HTTP errors during connection (bug #208824).
807  - Updated translations (bug #208873).
808
809* Fri Sep 29 2006 Tim Waugh <twaugh@redhat.com> 0.7.31-1
810- 0.7.31:
811  - Select recommended driver automatically (bug #208606).
812  - Better visibility of driver list (bug #203907).
813
814* Fri Sep 29 2006 Tim Waugh <twaugh@redhat.com> 0.7.30-1
815- 0.7.30:
816  - Translations fixed properly (bug #206622).
817  - Button widths corrected (bug #208556).
818
819* Tue Sep 26 2006 Tim Waugh <twaugh@redhat.com> 0.7.28-1
820- 0.7.28.  Translations fixed (bug #206622).
821
822* Wed Aug 30 2006 Tim Waugh <twaugh@redhat.com> 0.7.27-1
823- Build requires intltool.
824- 0.7.27.
825
826* Wed Aug 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.26-1
827- 0.7.26.  Fixes bug # 203149.
828
829* Mon Aug 14 2006 Florian Festi <ffesti@redhat.com> 0.7.25-1
830- 0.7.25. (bug #202060)
831
832* Fri Aug 11 2006 Tim Waugh <twaugh@redhat.com>
833- Fixed description (bug #202189).
834
835* Thu Aug  3 2006 Tim Waugh <twaugh@redhat.com> 0.7.24-1
836- 0.7.24.
837
838* Mon Jul 24 2006 Tim Waugh <twaugh@redhat.com> 0.7.23-1
839- 0.7.23.  Fixes bug #197866.
840
841* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.22-1.1
842- rebuild
843
844* Fri Jul  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.22-1
845- 0.7.22.
846
847* Wed Jul  5 2006 Tim Waugh <twaugh@redhat.com> 0.7.21-1
848- Updated to pycups-1.9.12.
849- 0.7.21.
850
851* Mon Jul  3 2006 Tim Waugh <twaugh@redhat.com> 0.7.20-1
852- 0.7.20.
853
854* Fri Jun 30 2006 Tim Waugh <twaugh@redhat.com> 0.7.19-1
855- 0.7.19.
856- Remove foomatic pickle file post-install.
857
858* Tue Jun 27 2006 Tim Waugh <twaugh@redhat.com> 0.7.18-1
859- 0.7.18.
860- Ship translations with libs subpackage.
861
862* Fri Jun 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.17-1
863- 0.7.17.
864
865* Fri Jun 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.16-1
866- 0.7.16, now with SMB browser.
867
868* Wed Jun 22 2006 Tim Waugh <twaugh@redhat.com> 0.7.15-1
869- 0.7.15.
870- Build requires gettext-devel.
871- Ship translations.
872
873* Tue Jun 20 2006 Tim Waugh <twaugh@redhat.com> 0.7.14-1
874- 0.7.14.
875
876* Mon Jun 19 2006 Tim Waugh <twaugh@redhat.com> 0.7.13-1
877- 0.7.13.
878
879* Fri Jun  9 2006 Tim Waugh <twaugh@redhat.com> 0.7.12-1
880- 0.7.12.
881
882* Thu Jun  1 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-3
883- Fix libs dependency.
884
885* Thu Jun  1 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-2
886- Moved the gtk_html2pango module to the libs package (needed by
887  foomatic.py).
888
889* Wed May 31 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-1
890- Split out system-config-printer-libs.
891- Updated to system-config-printer-0.7.11.
892
893* Sat May 27 2006 Tim Waugh <twaugh@redhat.com> 0.7.10-2
894- Requires gobject2 (bug #192764).
895
896* Fri May 26 2006 Tim Waugh <twaugh@redhat.com> 0.7.10-1
897- Require foomatic (bug #192764).
898- Updated to system-config-printer-0.7.10.
899
900* Thu May 25 2006 Tim Waugh <twaugh@redhat.com> 0.7.9-1
901- Updated to pycups-1.9.11.
902- Updated to system-config-printer-0.7.9.
903
904* Mon May 15 2006 Tim Waugh <twaugh@redhat.com> 0.7.8-1
905- Updated to pycups-1.9.10.
906- Updated to system-config-printer-0.7.8.
907
908* Fri May  5 2006 Tim Waugh <twaugh@redhat.com>
909- Fix pycups segfault.
910
911* Fri May  5 2006 Tim Waugh <twaugh@redhat.com> 0.7.7-2
912- Ship PAM and userhelper files.
913- Requires usermode.
914- Added missing options.py file.
915- Fix getClasses() in pycups.
916
917* Thu May  4 2006 Tim Waugh <twaugh@redhat.com> 0.7.7-1
918- Updated to system-config-printer-0.7.7.
919- Updated to pycups-1.9.9.
920- Desktop file.
921- Requires PyXML.
922
923* Fri Apr 28 2006 Tim Waugh <twaugh@redhat.com>
924- Make it actually run.
925
926* Fri Apr 21 2006 Tim Waugh <twaugh@redhat.com>
927- Build requires CUPS 1.2.
928
929* Thu Apr 20 2006 Tim Waugh <twaugh@redhat.com> 0.7.5-1
930- Updated to pycups-1.9.8.  No longer need threads patch.
931- Updated to system-config-printer-0.7.5.
932
933* Sat Apr 15 2006 Tim Waugh <twaugh@redhat.com>
934- Updated to pycups-1.9.7.
935
936* Thu Apr 13 2006 Tim Waugh <twaugh@redhat.com> 0.7.4-2
937- Obsoletes: system-config-printer-gui <= 0.6.152
938
939* Wed Apr 12 2006 Tim Waugh <twaugh@redhat.com> 0.7.4-1
940- Updated to system-config-printer-0.7.4.
941
942* Fri Apr  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.3-1
943- Added threads patch from pycups CVS.
944- Updated to system-config-printer-0.7.3.
945
946* Tue Apr  4 2006 Tim Waugh <twaugh@redhat.com>
947- Updated to pycups-1.9.6.
948
949* Fri Mar 24 2006 Tim Waugh <twaugh@redhat.com>
950- Updated to pycups-1.9.5.
951
952* Fri Mar 17 2006 Tim Waugh <twaugh@redhat.com>
953- Package the actual system-config-printer command.
954
955* Thu Mar 16 2006 Tim Waugh <twaugh@redhat.com> 0.7.1-1
956- Include s-c-printer tarball.
957- Updated to pycups-1.9.4.
958
959* Wed Mar 15 2006 Tim Waugh <twaugh@redhat.com> 0.7.0-1
960- Initial spec file.
Note: See TracBrowser for help on using the repository browser.