source: projects/specs/trunk/s/system-config-network/system-config-network-vl.spec @ 521

Revision 521, 31.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# -*- RPM-SPEC -*-
2Summary: The GUI of the Network Adminstration Tool
3Summary(ja): ネットワーク管理ツール(GUI)
4Name: system-config-network
5Version: 1.5.97
6Release: 4%{?_dist_release}
7URL: http://fedoraproject.org/wiki/SystemConfig/network
8License: GPLv2+
9Group: Applications/System
10
11Source0: %{name}-%{version}.tar.bz2
12Source1: %{name}-ja-help-image.tar.bz2
13Patch0: %{name}-1.5.97-fix-crash-on-saving.patch
14Patch1: %{name}-1.5.99-modprobeconf.patch
15Patch2: %{name}-1.5.97-ja-help.patch
16
17BuildArch: noarch
18BuildRequires: python >= 0:2.2, openjade, docbook-style-dsssl, perl, gettext, desktop-file-utils, perl-XML-Parser
19Requires: %{name}-tui = %{version}-%{release}
20Requires: pygtk2-libglade, pygtk2, gnome-python, usermode, xdg-utils
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23%description
24This is the GUI of the network configuration tool,
25supporting Ethernet, Wireless, TokenRing, ADSL, ISDN and PPP.
26
27%package tui
28Summary: The Network Adminstration Tool
29Summary(ja): ネットワーク管理ツール
30Group: Applications/System
31Requires: initscripts >= 8.80.0, usermode , kudzu, python, rhpl, newt
32Requires: pciutils, dbus-python
33
34%description tui
35This is the network configuration tool,
36supporting Ethernet, Wireless, TokenRing, ADSL, ISDN and PPP.
37
38%prep
39%setup -q -a 1
40%patch0 -p1
41%patch1 -p1
42%patch2 -p1
43
44%build
45%configure
46
47%install
48rm -rf $RPM_BUILD_ROOT
49make DESTDIR=$RPM_BUILD_ROOT install
50
51mkdir $RPM_BUILD_ROOT%{_datadir}/applications
52
53for i in system-config-network.desktop system-control-network.desktop; do \
54  desktop-file-install --vendor "" --delete-original       \
55    --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
56    --add-category System                                     \
57    --add-category Settings                                   \
58    $RPM_BUILD_ROOT%{_datadir}/system-config-network/$i; \
59done;
60
61mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/networking/devices
62mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/networking/profiles/default
63
64%find_lang %name
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69
70%files
71%defattr(-,root,root,-)
72%doc COPYING
73%{_datadir}/system-config-network/pixmaps
74%{_datadir}/system-config-network/netconfpkg/gui
75%{_datadir}/system-config-network/netconf.py*
76%{_datadir}/system-config-network/netconf_control.py*
77%{_sbindir}/system-config-network-gui
78%{_bindir}/system-control-network
79%{_datadir}/applications/*
80%{_datadir}/pixmaps/*
81
82%files -f %{name}.lang tui
83%defattr(-,root,root,-)
84%doc COPYING
85%dir %{_datadir}/system-config-network
86%doc %dir %{_datadir}/system-config-network/help
87%doc %{_datadir}/system-config-network/help/*
88%{_datadir}/system-config-network/netconf_cmd.py*
89%{_datadir}/system-config-network/netconf_tui.py*
90%{_datadir}/system-config-network/version.py*
91%dir %{_datadir}/system-config-network/netconfpkg
92%{_datadir}/system-config-network/netconfpkg/conf
93%{_datadir}/system-config-network/netconfpkg/tui
94%{_datadir}/system-config-network/netconfpkg/plugins
95%{_datadir}/system-config-network/netconfpkg/*.py*
96%{_datadir}/system-config-network/module-info
97%{_datadir}/system-config-network/providerdb
98%config(noreplace) %{_sysconfdir}/pam.d/*
99%config(noreplace) %{_sysconfdir}/security/console.apps/*
100%dir %{_sysconfdir}/sysconfig/networking
101%dir %{_sysconfdir}/sysconfig/networking/profiles
102%dir %{_sysconfdir}/sysconfig/networking/profiles/default
103%dir %{_sysconfdir}/sysconfig/networking/devices
104%{_sbindir}/system-config-network
105%{_sbindir}/system-config-network-tui
106%{_sbindir}/system-config-network-cmd
107%{_bindir}/system-config-network
108%{_bindir}/system-config-network-cmd
109
110%changelog
111* Thu Oct 22 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.5.97-4
112- add source1(images of Japanese help).
113
114* Wed Oct 21 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.5.97-3
115- add patch2 to add Japanese help.
116
117* Wed Sep 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.97-2
118- add patch1 to use /etc/modprobe.d/modprobe.conf
119
120* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.97-1
121- new upstream release
122- add Patch0 to fix crash on saving data.
123
124* Tue Apr 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.95-1
125- new upstream release
126
127* Mon Aug 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
128- initial build for Vine Linux
129
130* Tue May 27 2008 Harald Hoyer <harald@redhat.com> - 1.5.10
131- fixed Makefile.am
132
133* Tue May 27 2008 Harald Hoyer <harald@redhat.com> - 1.5.9
134- fixed console perms for Fedora <= 8
135
136* Fri May 16 2008 Harald Hoyer <harald@redhat.com> - 1.5.8
137- copy info from DNS page into each ifcfg file (dcbw)
138
139* Fri Apr 25 2008 Harald Hoyer <harald@redhat.com> - 1.5.7
140- NCisdnhardware.card -> NCisdnhardware._card (harald)
141- Fixed pap-secret parsing. (#rhbz#443347) (jmoskovc)
142
143* Tue Apr 08 2008 Harald Hoyer <harald@redhat.com> - 1.5.6
144- translation update
145- check origLine for None (harald)
146
147* Mon Mar 31 2008 Harald Hoyer <harald@redhat.com> - 1.5.5
148- fixed more rhbz#439718
149
150* Mon Mar 31 2008 Harald Hoyer <harald@redhat.com> - 1.5.4
151- fixed typos in DialupDruid (harald)
152- return None is nothing is selected (harald)
153- fixed #438901: Network Device Control doesn't work unless s-c-n has been run once (harald)
154- fixed #435041 and added UnitTest (harald)
155- be case-independent in mode parsing rhbz#433748 (harald)
156- fixed rhbz#429725 (harald)
157- do not traceback on non-int Volume (harald)
158- fixed rhbz#439718 (harald)
159
160* Sat Mar 29 2008 Harald Hoyer <harald@redhat.com> - 1.5.3
161- readded DialupDruid (harald)
162
163* Sat Mar 29 2008 Harald Hoyer <harald@redhat.com> - 1.5.2
164- devices which are controlled by NM cannot be activated/deactivated (rhbz#438902)
165- use ". config-util" in console-apps config file (rhbz#428408) (harald)
166- use xdg-open instead of htemlview (rhbz#415031) (harald)
167- added sr@latin (rhbz#425845)
168- update buttons on device edit change (harald)
169- fixed some Alias handling (harald)
170- removed Init2 string (clashes with UTMS) (harald)
171- no activate/deactivate/delete NMControlled devices (harald)
172- NCPluginDevTokenRing return None if no dialog (harald)
173- BackendHal fix to use Factory classes, no kudzu hw import (harald)
174- check if hostname is not None, before checking it (harald)
175- added tui/NCPluginTokenRingInterface (harald)
176- MTU moved to base device (rhbz#439202) (harald)
177- fixed import for ParseError (harald)
178
179* Thu Feb 28 2008 Harald Hoyer <harald@redhat.com> - 1.5.1
180- removed CIPE (harald)
181- s/Devernet/Network/ (harald)
182- Auto -> auto (harald)
183- only append localhost to AliasList, if not already in (harald)
184- show error dialog, if device loading failes (harald)
185- moved MRU to Dialup only (harald)
186- recognize qeth devices in kudzu lists (rhbz#184734) (harald)
187- added MRU field (rhbz#221294) (harald)
188- added TUI for QETH (harald)
189- do not traceback, if we try to remove a device not in our active list (harald)
190- added qeth support (harald)
191- removed ctc and iucv devices (rhbz#219180) (harald)
192- do not handle ifcfg-${parent_device}-range* rhbz#221292 (harald)
193- Minor fix in hosts parser to make tui works. (jmoskovc)
194- Stupid mode doesn't go away anymore.(rhbz#177931) (jmoskovc)
195- Fixed crash when Baud=None (jmoskovc)
196- Removing PPP option should work. NETWORKMANAGER -> NM_CONTROLLED (jmoskovc)
197- Fixed problem with import rhbz#429725 (jmoskovc)
198- Changed Clist in host editor to GtkTreeView, added checkbox to show loopbacks in hosts (jmoskovc)
199- Minor fix in hosts parser - now it accepts trailing dot. (jmoskovc)
200- Improved {pap|chap}-secrets parser, added checkbox to reveal password in dialup config (jmoskovc)
201- Fixed crash when hostname is changed. (jmoskovc)
202
203* Mon Dec 03 2007 Harald Hoyer <harald@redhat.com> - 1.5.0
204- v1.5.0
205
206* Mon Dec 03 2007 Harald Hoyer <harald@redhat.com>, Jiri Moskovcak <jmoskovc@redhat.com> - 1.4.7
207- added HAL support
208- fixed /etc/hosts parser
209- added "Controlled by NetworkManager"
210- do not fall into modified state for activate/deactivate (rhbz#377261)
211
212* Mon Nov 12 2007 Harald Hoyer <harald@redhat.com> - 1.4.6
213- moved network.xpm to (pkgdatadir)/pixmaps (rhbz#377861)
214
215* Mon Nov 12 2007 Harald Hoyer <harald@redhat.com> - 1.4.5
216- changed yelp to htmlview
217
218* Wed Nov  7 2007 Stepan Kasal <skasal@redhat.com> - 1.4.4
219- s/NEtwork/Network/ in the summary of -tui, to be consistent
220  with the summary line of the main rpm (the neat acronym is no
221  longer advertised anyway)
222- Resolves: #239216
223
224* Fri Oct 26 2007 Harald Hoyer <harald@redhat.com> - 1.4.4
225- removed not yet used NCBackendHal.py (rhbz#353771)
226- fixed yelp dependency (rhbz#344981)
227- moved %%configure to %%build (rhbz#353761)
228- fixed type with getRoot (rhbz#368871)
229
230* Mon Oct 15 2007 Harald Hoyer <harald@redhat.com> - 1.4.3
231- fixed /etc/hosts problem (rhbz#331451)
232
233* Fri Oct 12 2007 Harald Hoyer <harald@redhat.com> - 1.4.3
234- added version.py.in to POTFILES.in (rhbz#244053)
235- corrected URL (rhbz#237717)
236
237* Mon Oct 08 2007 Harald Hoyer <harald@redhat.com> - 1.4.2
238- speedup genClass
239- restorecon selinux context
240
241* Mon Sep 24 2007 Harald Hoyer <harald@redhat.com> - 1.4.1-2
242- require newt-python instead of newt only
243
244* Mon Sep 24 2007 Harald Hoyer <harald@redhat.com> - 1.4.1
245- version 1.4.1
246
247* Thu Aug 16 2007 Harald Hoyer <harald@redhat.com> - 1.4.0
248- version 1.4.0
249
250* Mon Jan  8 2007 Harald Hoyer <harald@redhat.com> - 1.3.99
251- fixed #221289
252- Resolves: rhbz#221289
253
254* Fri Dec 15 2006 Harald Hoyer <harald@redhat.com> - 1.3.98
255- translation update (bug #216559)
256- Resolves: rhbz#216559
257
258* Tue Nov 28 2006 Harald Hoyer <harald@redhat.com> - 1.3.97
259- translation update
260
261* Thu Nov  2 2006 Harald Hoyer <harald@redhat.com> - 1.3.96
262- Resolves: rhbz #211980, rhbz #213181
263
264* Wed Oct  4 2006 Harald Hoyer <harald@redhat.com> - 1.3.95
265- translation update (bug #208886)
266- use rhpl.iwlib for wireless functions (bug #197954)
267- added perl-XML-Parser build requirement
268
269* Tue Aug 15 2006 Harald Hoyer <harald@redhat.com> - 1.3.94
270- translation update (bug #182650)
271
272* Tue Aug 15 2006 Harald Hoyer <harald@redhat.com> - 1.3.93
273- added tui subdir (bug #202560)
274
275* Fri Aug 11 2006 Harald Hoyer <harald@redhat.com> - 1.3.92
276- fixed #201659
277- translation update
278
279* Tue Jul 25 2006 Harald Hoyer <harald@redhat.com> - 1.3.91
280- fixed "New Device" in text-mode
281
282* Tue Jul 18 2006 Harald Hoyer <harald@redhat.com> - 1.3.90
283- fixed:
284- [135014] MTU and MRU should be confiurable for ADSL
285- [141055] system-config-network needs to be able to set MTU
286- [149780] no GATEWAY, IPADDR and NETMASK, if BOOTPROTO=dhcp
287- [150362] [Errno 2] No such file or directory: '/etc/hosts'
288- [157172] Wrong DNS for provider "ZEDAT_Berlin"
289- [160417] Bad: cannot make any changes to network settings
290- [169819] Trailing space in host name causes crash
291- [175078] String (country name) change request
292- [176145] Please enable Serbian translation in system-config-network
293- [177198] deprecation warning in system-config-network
294- [187563] localized option passed to ifcfg-wlan0 files
295- [188321] Creating an alias for a network interface breaks device
296           setup after reboots
297- [190242] Firefox instance running as root when used to read docs
298           for system-config-*
299- [197401] Don't write HWADDR for alias interfaces
300
301* Fri Jul 14 2006 Nils Philippsen <nphilipp@redhat.com>
302- enable ml, or, sr, sr@Latn translations (#176145)
303
304* Wed Nov 02 2005 Harald Hoyer <harald@redhat.com> - 1.3.30
305- removed interdruid
306- reversed Cancel/Ok button ordering
307
308* Tue Oct 25 2005 Harald Hoyer <harald@redhat.com> - 1.3.29
309- fixed profileFrame labeling
310
311* Wed Oct 10 2005 Harald Hoyer <harald@redhat.com> - 1.3.28
312- fixed picture paths in glade files
313- fixed cancel case of passphrase dialog
314
315* Wed Oct 10 2005 Harald Hoyer <harald@redhat.com> - 1.3.27
316- use new pam stack replacement
317- added OnParent for Alias Devices
318- added SPI and better key generation for ipsec
319- corrected column handling in main window
320- GUI liftup
321- added AVM Fritz!PCI v2.0 ISDN card to ISDN Hardwarelist (bug 134605)
322- remove /etc/sysconfig/isdncard, if no ISDN is configured
323
324* Wed Apr 20 2005 Harald Hoyer <harald@redhat.com> - 1.3.26
325- CBCP_MSN added (bug #125710)
326
327* Tue Mar 31 2005 Harald Hoyer <harald@redhat.com> - 1.3.25
328- more i18n languages
329
330* Wed Mar 30 2005 Harald Hoyer <harald@redhat.com> - 1.3.24
331- gtk.FALSE and gtk.TRUE cleanups
332
333* Mon Mar 21 2005 Harald Hoyer <harald@redhat.com> - 1.3.23-2
334- moved gui parts out of the tui package
335
336* Fri Mar 04 2005 Harald Hoyer <harald@redhat.com> - 1.3.23
337- update to new gnome/gtk/glade
338
339* Wed Oct 20 2004 Harald Hoyer <harald@redhat.com> - 1.3.22
340- translation updates, added nb.po (bug 136462)
341
342* Tue Oct 05 2004 Harald Hoyer <harald@redhat.com> - 1.3.21
343- fixed /etc/hosts handling
344- handle .ko module names in updateFromKudzu
345
346* Fri Sep 03 2004 Harald Hoyer <harald@redhat.com> - 1.3.20
347- dhcp cannot be selected for aliased devices (bug 129096)
348
349* Thu Aug 26 2004 Harald Hoyer <harald@redhat.com> - 1.3.19
350- hopefully fixed bug 125393
351- fixed removal of device files
352
353* Fri Jul 30 2004 Harald Hoyer <harald@redhat.com> - 1.3.18
354- changed mainloop and mainquit
355- translation updates
356 
357* Tue Jul 06 2004 Harald Hoyer <harald@redhat.com> - 1.3.17
358- bugfix release for FC2
359
360* Tue Jun 29 2004 Harald Hoyer <harald@redhat.com> - 1.3.17
361- better "make clean"
362- removed references to Red Hat Linux
363- added testsuite for data layer
364- added some module-info entries
365- added command line parsing to network-control
366- added IPsec to network-cmd
367- switched logging to syslog
368- do not touch bonding slaves
369- better alias handling
370- better handling of chroot
371- read *.ko modules also
372- handle modules parameter without "="
373- create correct SPI_ identifier for manual IPsec keying
374- better hostname handling
375- better profile handling
376- fix kernel version parsing
377- unknown-flag.xpm for unknown country flags
378- fixed TokenRing glade file (bad hash at beginning of file)
379- fix the length of IPSec shared keys
380- prevent modified status after profile switching
381- save dialog, for ipsec deactivation
382- PEERDNS defaults to yes
383- routing for wireless config dialog
384- only display CIPE for kernel < 2.6
385
386* Thu Apr  1 2004 Harald Hoyer <harald@redhat.com> - 1.3.17
387- translation updates (119610)
388
389* Thu Mar  4 2004 Harald Hoyer <harald@redhat.com> - 1.3.16
390- be more relaxed, when parsing the kernel version (115917)
391- fixed removing of Hostname (115795)
392- fixed "DevEthernet instance has no attribute 'IPv6Init'" (116375)
393- removed save dialog, when switching profiles (107399)
394- added generic Initstrings (115768)
395- added secure.png logo
396- added "-c" parameter for activate/deactivate
397- changed hotkeys to avoid double entries
398- use new pixmap loading code (only take local paths, if debugging is active)
399- moved updateNetworkScripts() to NC_functions.py
400- fallback on /etc/sysconfig/network-scripts
401- removed /usr/lib/rhs/python from sys.path
402- added -? as a command line option
403- corrected --root= option for gui
404- activate/deactivate buttons always sensitive
405- check for ipsec-tools and dynamically display ipsec tab
406- no second dialog while activating in system-control-network
407- change hosts file on hostname change
408- PEERDNS is true, if not configured
409
410* Thu Jan 29 2004 Harald Hoyer <harald@redhat.com> - 1.3.15
411- added IPv6 support per device (111377)
412
413* Wed Jan 28 2004 Harald Hoyer <harald@redhat.com> - 1.3.14
414- modules.conf -> modprobe.conf
415
416* Thu Dec 18 2003 Harald Hoyer <harald@redhat.de> 1.3.13-2
417- added mkinstalldirs to EXTRA_DIST
418- added version to provides
419
420* Wed Dec 17 2003 Harald Hoyer <harald@redhat.de> 1.3.13
421- fixed T-Online dialog #110911
422- default flow control to CTSRTS #110347
423- only clear login/pw on provider select, if provider has its own number
424- fixed cancel of dialup process #103421
425- default to "/" for chrooted configuration
426- default to "default" profile if none active
427- fixed "activate button not active" #110193
428- scn-tui requires newt #104213
429- fixed #107816, by recognizing /var/run/ppp-ppp<NICKNAME>.pid
430- fixed a bug in ISDN activate #100677
431
432* Tue Dec 16 2003 Harald Hoyer <harald@redhat.de> 1.3.12
433- renamed redhat-config-network -> system-config-network
434- added pciutils requirement
435- added utf-8 encoding comments
436- corrected some translation strings
437- added redhat-config-network provides
438
439* Tue Oct 28 2003 Harald Hoyer <harald@redhat.de> 1.3.10
440- removed restriction on t-online password entry #105970
441- failsafe changing the error image #108094
442- corrected indention #108151
443
444* Mon Oct 27 2003 Harald Hoyer <harald@redhat.de> 1.3.9
445- fixed 107501, 107387, 106751, 104213
446- fallback to no logfile, if opening the logfile fails
447- test, if /etc/{hosts,resolv.conf} exists
448- removed ipsec tab
449
450* Thu Oct 23 2003 Than Ngo <than@redhat.com> 1.3.8
451- fix a bug in ISDN activate
452
453* Wed Oct 22 2003 Than Ngo <than@redhat.com> 1.3.7-2
454- fix a bug in saving of ISDN config file
455- add support nickname for ISDN
456 
457* Wed Oct  8 2003 Harald Hoyer <harald@redhat.de> 1.3.7
458- merged in changes from Taroon
459
460* Thu Aug 14 2003 Harald Hoyer <harald@redhat.de> 1.3.6
461- fixed #100471
462
463* Wed Aug  6 2003 Harald Hoyer <harald@redhat.de> 1.3.5
464- fixed #98251
465
466* Fri Aug  1 2003 Harald Hoyer <harald@redhat.de> 1.3.4
467- fixed #101386
468- save wireless keys in keys file
469
470* Thu Jul 31 2003 Harald Hoyer <harald@redhat.de> 1.3.3
471- fixed #85365
472- fixed glade file loading
473- more ipsec stuff
474- neat can use a "chrooted" environment now (-r)
475- .rpmsave will not be loaded
476- no interrupt/io settings for PNP cards
477- HIGIfied labels
478- double click for hardware and ipsec
479
480* Wed Jul  2 2003 Than Ngo <than@redhat.com> 1.3.2-2
481- upgrade provide database
482
483* Wed Jun 18 2003 Harald Hoyer <harald@redhat.de> 1.2.12-2
484- fixed #97562
485
486* Thu Jun 17 2003 Harald Hoyer <harald@redhat.de> 1.2.12-1
487- wlan0 handling
488- splash screen bug fixed
489- improvements in HW list handling
490- isdncard handling #91607
491
492* Thu Jun 12 2003 Harald Hoyer <harald@redhat.de> 1.2.11
493- fixed #97027
494- fixed subs of -
495
496* Wed Jun 11 2003 Harald Hoyer <harald@redhat.de> 1.2.10
497- fixed #97027 #96994
498- fixed fedora bugzilla issues #326
499- update of some translations
500
501* Wed Jun  4 2003 Harald Hoyer <harald@redhat.de> 1.2.8
502- lazy file unlinking
503- fixed #91620 #91583
504- ConfEHosts -> ConfFHosts
505
506* Mon May 19 2003 Harald Hoyer <harald@redhat.de> 1.2.7
507- make PAP/CHAP work again
508- route files chmod(0644)
509- added local variables to traceback
510
511* Thu May 01 2003 Harald Hoyer <harald@redhat.de> 1.2.6
512- use unsernetctl instead of ifdown/ifup
513
514* Thu May 01 2003 Harald Hoyer <harald@redhat.de> 1.2.5
515- fixed early import of plugins
516
517* Wed Apr 30 2003 Harald Hoyer <harald@redhat.de> 1.2.4-3
518- fixed #89915 and #89916
519
520* Tue Apr 29 2003 Harald Hoyer <harald@redhat.de> 1.2.4-1
521- 1.2.4 bugfix release
522
523* Wed Apr  2 2003 Harald Hoyer <harald@redhat.de> 1.2.3-3
524- Bugfix release for 9
525- fixed #85011, #85703, #85653, #84956, #83640, #68169, #86476, #78043, #77763
526
527* Fri Feb 21 2003 Harald Hoyer <harald@redhat.de> 1.2.0-2
528- bump to 1.2.0
529- fixed #84725
530- warning for #84752
531
532* Fri Feb 12 2003 Harald Hoyer <harald@redhat.de> 1.1.97-1
533- fixed #83692
534- updated documentation
535
536* Mon Feb  3 2003 Harald Hoyer <harald@redhat.de> 1.1.94-1
537- base -> tui, gui -> base
538
539* Thu Jan 30 2003 Harald Hoyer <harald@redhat.de> 1.1.93-1
540- 1.1.93
541
542* Wed Jan 29 2003 Harald Hoyer <harald@redhat.de> 1.1.92-1
543- 1.1.92
544
545* Tue Jan 14 2003 Harald Hoyer <harald@redhat.de> 1.1.90-1
546- 1.1.90
547
548* Thu Dec 19 2002 Than Ngo <than@redhat.com>
549- import ConfDevice
550
551* Mon Dec 16 2002 Harald Hoyer <harald@redhat.de>
552- 1.1.86
553
554* Fri Dec 13 2002 Harald Hoyer <harald@redhat.de>
555- 1.1.85
556
557* Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.1.80-1
558- Remove unpackaged files
559
560* Mon Sep  2 2002 Than Ngo <than@redhat.com> 1.1.20-1
561- don't crash by selecting provider
562- Set correct HangupTimeout for ISDN connection
563
564* Sat Aug 31 2002 Preston Brown <pbrown@localhost.localdomain>
565- fix typo in error dialog function
566
567* Thu Aug 22 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.17-1
568- Make it use the gnome help system, add yelp as a dependency (#71857)
569- Traceback fix: # 72581
570- translation updates
571
572* Wed Aug 14 2002 Harald Hoyer <harald@redhat.de>
573- #71448
574- #71265
575- #70988
576
577* Tue Aug 13 2002 Harald Hoyer <harald@redhat.de> 1.1.15-1
578- many bugfixes, including  #71062 #69333 #68793 #69133
579
580* Thu Aug  1 2002 Than Ngo <than@redhat.com> 1.1.14-1
581- set correct device type for rawip ISDN connections (bug #69568)
582- add some ISPs for Austria
583
584* Tue Jul 30 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.13-1
585- Fixes to the traceback dialog (fix "save to floppy" (we don't do that),
586  add i18n.)
587- Fix traceback with malformed /etc/hosts (#69320)
588- Fix dependencies (#69990)
589- Some minor userhelper fixes
590
591* Thu Jul 25 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.12-1
592- doc loc fixes (images)
593- add pam_timestamp support (#69869)
594
595* Wed Jul 24 2002 Harald Hoyer <harald@redhat.de>
596- renamed "default" profile in GUI
597- fixed device renaming in profiles
598
599* Wed Jul 24 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.10-1
600- More bugfixes, including #69635 #69636
601- Updated docs
602
603* Tue Jul 23 2002 Harald Hoyer <harald@redhat.de> 1.1.9-1
604- lots of bugfixes again :)
605
606* Wed Jul 17 2002 Harald Hoyer <harald@redhat.de>
607- lots of bugfixes
608- reactivated profile gui
609
610* Mon Jul  8 2002 Harald Hoyer <harald@redhat.de>
611- lots of bugfixes, new .desktop stuff
612- added desktop-file-utils BuildRequires
613
614* Tue Jul  2 2002 Harald Hoyer <harald@redhat.de> 1.1.7-1
615- cleanup, usability
616
617* Mon Jul 01 2002 Than Ngo <than@redhat.com> 1.1.6-1
618- get rid of isdnup userisdnctl, both are now part of isdn4k-utils
619
620* Thu Jun 27 2002 Harald Hoyer <harald@redhat.de> 1.1.5-1
621- many bug fixes due to gtk2 conversion
622- fixed #67273 #66200 #65185 #65073 #63963
623
624* Wed Jun 26 2002 Preston Brown <pbrown@redhat.com>
625- ethtool, pcmcia, wireless improvements
626
627* Sat Jun 22 2002 Than Ngo <than@redhat.com> 1.1.4-1
628- fixed traceback bug in activate
629- some fixes in glade file
630
631* Sun Jun 16 2002 Than Ngo <than@redhat.com> 1.1.3-1
632- get_pixbuf: if no icon was not found, looks the icons
633  in standard icon directory
634- bug fixes in wireless
635
636* Wed Jun 12 2002 Harald Hoyer <harald@redhat.de> 1.1.2-1
637- lots of i18n and migration changes
638- wireless reactivated
639
640* Fri Jun 07 2002 Than Ngo <than@redhat.com> 1.1.1-1
641- set PPPOE_TIMEOUT=80 as default, it should be about 4 times
642  the LCP_INTERVAL (bug #64903)
643
644* Wed May 29 2002 Harald Hoyer <harald@redhat.de>
645- ported to python2, gtk2, gnome2
646
647* Wed Apr 17 2002 Trond Eivind Glomsrød <teg@redhat.com>
648- Turn off wireless. It doesn't work with all modes, all cards
649 and you can't edit IP settings after the initial attempt
650
651* Wed Apr 17 2002 Harald Hoyer <harald@redhat.com> 1.0.0-1
652- moved ethmodule.so to /usr/lib
653- call it 1.0.0
654
655* Tue Apr 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.30-1
656- Updated translations
657- Updated docs
658
659* Tue Apr 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.28-1
660- more fixes
661
662* Mon Apr 15 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.27-1
663- Update translations, more fixes
664
665* Mon Apr 15 2002 Harald Hoyer <harald@redhat.com> 0.9.26-1
666- The Most Fixes (tm)
667
668* Sat Apr 13 2002 Than Ngo <than@redhat.com> 0.9.25-1
669- More fixes
670
671* Thu Apr 11 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.24-1
672- More fixes (#63177,#57064,#63207)
673
674* Tue Apr 09 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.23-1
675- more fixes
676- updated translations
677
678* Thu Apr 04 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.22-1
679- more fixes, including #62697,
680
681* Sat Mar 30 2002 Than Ngo <than@redhat.com> 0.9.21-1
682- add Token Ring/Wireless/Cipe Druids
683- more fixes
684
685* Wed Mar 26 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.20-1
686- Rebuild... it should have more fixes
687
688* Wed Mar 26 2002 Than Ngo <than@redhat.com> 0.9.19-1
689- add functions for status/activate/deactivate in neat
690- more fixes
691
692* Sat Mar 16 2002 Than Ngo <than@redhat.com> 0.9.18-1
693- add userisdnctl for ISDN
694- more fixes
695
696* Thu Mar 14 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.17-1
697- Even more fixes
698
699* Thu Mar 14 2002 Than Ngo <than@redhat.com> 0.9.16-1
700- various fixes
701
702* Thu Mar 14 2002 Than Ngo <than@redhat.com> 0.9.15-1
703- add desktop file for neat-control
704- various fixes, additions
705
706* Wed Mar 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.14-1
707- Require gnome-core, buildrequire gnome-core-devel
708
709* Mon Mar 11 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.13-1
710- New build
711- No longer noarch
712
713* Thu Feb 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.12-1
714- Various fixes, additions
715
716* Tue Jan 29 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.11-1
717- build in new environment
718
719* Mon Jan 07 2002 Than Ngo <than@redhat.com> 0.9.10.1-1
720- fixed bug #57853
721
722* Tue Dec 03 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.9.10-1
723- minor fixes, more translations
724
725* Mon Nov 26 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.9.9-0.1
726- Trying again, with more fixes :)
727
728* Fri Nov 25 2001 Than Ngo <than@redhat.com> 0.9.8-0.6
729- fixed bug #56145, #56146, #56147
730
731* Tue Nov 20 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.9.8-0.5
732- prepare for errata
733
734* Fri Nov 02 2001 Than Ngo <than@redhat.com> 0.9.7-1
735- fixed 'AVM PnP'/'Sedlbauer Speed Fax+ PnP'/'ASUS Com ISDNLink ISA PnP'
736- update provider DB
737
738* Tue Oct 30 2001 Than Ngo <than@redhat.com> 0.9.7-1
739- allow setting AVM PCI (Fritz!PCI v2) if kernel supports it
740- fixed some typo bugs
741
742* Wed Oct 24 2001 Harald Hoyer <harald@redhat.com> 0.9.6-1
743- seperated gui from data layer
744- make .pyc ghost files
745- fixed profile/alias problem
746- modem probing only once
747
748* Mon Oct 22 2001 Harald Hoyer <harald@redhat.com> 0.9.5-1
749- fixed consolehelper
750- added chars [_-] ro nickname pattern
751- added traceback catching dialog
752
753* Wed Oct 17 2001 Harald Hoyer <harald@redhat.com> 0.9.4-1
754- fixed /etc/hosts
755- fixed pap/chap
756- fixed 'save changes?'
757
758* Tue Oct 16 2001 Than Ngo <than@redhat.com> 0.9.3-1
759- fix internet-druid fails (bug #54192)
760- fix dial on demand problem from some ISDN Provider in German
761- don't trace back if length of Login name is 2 (bug #54322)
762
763* Thu Sep 27 2001 Than Ngo <than@redhat.com> 0.9.2-1
764- enable TCPIP for CIPE
765- show device Tab as default if devices exist
766
767* Wed Sep 12 2001 Than Ngo <than@redhat.com> 0.9.1-1
768- add CTC and IUCV support for s390/s390x
769- disable Dialup on s390/s390x
770
771* Thu Sep  5 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.9-1
772- Add Russian
773
774* Wed Sep  4 2001 Phil Knirsch <phil@redhat.de> 0.8.4-1
775- Fixed problem with unwanted removal of entries in /etc/modules.conf (#53042)
776
777* Mon Sep  3 2001 Than Ngo <than@redhat.com> 0.8.3-1
778- fix a bug in setting Authentication
779- fix some critical typo bugs
780
781* Fri Aug 31 2001 Than Ngo <than@redhat.com> 0.8.2-1
782- fix backtrace bug in CIPE
783- fix traceback bug if self.device.Dialup is None
784- if hardware is deleted, remove all devices used this hardware
785- de.po: fix bad translation
786
787* Fri Aug 31 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.8.1-1
788- Add support for Czech
789
790* Fri Aug 31 2001 Than Ngo <than@redhat.com>
791- fix #52920, #52922, #52914, #52916, #52917
792
793* Fri Aug 31 2001 Phil Knirsch <phil@redhat.de> 0.8.0-2
794- Fixed wrong option handling in /etc/modules.conf (#52853, #52923)
795- Fixed empty search entry in /etc/resolv.conf (#52926)
796- Fixed empty domain entry in /etc/resolv.conf (#52924)
797- Fixed ethernet hardware probing traceback (#52921)
798
799* Tue Aug 28 2001 Than Ngo <than@redhat.com> 0.8.0-1
800- fix some typo bugs
801
802* Tue Aug 28 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.10-1
803- minor fixes, including bootprotocol for CIPE (don't say it will use DHCP...)
804
805* Tue Aug 28 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.9-1
806- Not everything was marked for translation (#52650)
807
808* Tue Aug 28 2001 Than Ngo <than@redhat.com> 0.7.8-1
809- fix some typo bugs
810- fix wrong Modem entry (Bug #52601)
811
812* Mon Aug 27 2001 Than Ngo <than@redhat.com> 0.7.7-1
813- fix wrong type CBHUP
814
815* Mon Aug 27 2001 Phil Knirsch <phil@redhat.de> 0.7.6-2
816- Fixed use of /etc/sysconfig/network (#52359)
817
818* Fri Aug 24 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.6-1
819- Reordered tabs, added descriptions on each of the tabs
820
821* Fri Aug 24 2001 Bill Nottingham <notting@redhat.com> 0.7.5-1
822- tokenring support
823
824* Thu Aug 23 2001 Phil Knirsch <phil@redhat.de> 0.7.4-2
825- Fixed recalculation of BROADCAST and NETWORK values if IP and netmask are
826  present (#51462)
827
828* Mon Aug 20 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.4-1
829- More bugfixes, among them #51929, #51991, #51721, #51722,
830  partial #52044, #51720.
831- Updated translations, include more languages
832
833* Thu Aug 16 2001 Phil Knirsch <phil@redhat.de> 0.7.3-2
834- Fixed major bug in device renaming (#50885)
835
836* Tue Aug 14 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.3-1
837- more bugfixes, more docs, GUI fixes
838
839* Fri Aug 10 2001 Than Ngo <than@redhat.com> 0.7.2-1
840- more bugfixes
841
842* Fri Aug 10 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.1-1
843- more bugfixes, more docs
844
845* Wed Aug  8 2001 Alexander Larsson <alexl@redhat.com> 0.7-2
846- Install desktop files in sysconfig instead of serverconf.
847
848* Wed Aug  8 2001 Phil Knirsch <phil@redhat.de> 0.7-1
849- Added a lot of documentation
850- Final changes to the Modem druid dialog and code to look just like the
851  hardware add dialog for modems.
852
853* Wed Aug  8 2001 Phil Knirsch <phil@redhat.de> 0.6.8-3
854- Added the modem detection for the ModemDruid.
855- Added kudzu as requirement as it is needed for modem detection.
856- For compatibility still check for symlinks, too. Otherwise older setups will
857  break.
858
859* Tue Aug  7 2001 Phil Knirsch <phil@redhat.de> 0.6.7-2
860- Fixed various important bugzilla bugs
861- Added and implemented the add Hardware dialog.
862- Added a working Apply button.
863- Switched to using hardlinks instead of symlinks for config files.
864
865* Tue Aug  7 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.6.7-1
866- Add online help capability (#50739)
867
868* Mon Aug  6 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.6.6-1
869- Disable profiles in GUI and as necesarry in code
870
871* Mon Aug  6 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.6.5-1
872- more bugfixes
873- add Conf.py from pythonlib, which has gone to the great bitbucket
874  in the sky
875
876* Sun Aug  5 2001 Than Ngo <than@redhat.com>
877- fix bug 50740
878- wvdial.conf readonly for root
879
880* Fri Aug  3 2001 Than Ngo <than@redhat.com>
881- fix pap/chap Login name for T-online
882- fix InitStrings
883- use gettext function in NC_functions
884- fix loading DEFROUTE/PERSIST/DEMAND/IDLETIMEOUT for Modem dialup
885- don't backtrace if 'SetVolume' and 'Dial Command' are not defined
886
887* Thu Aug 02 2001 Phil Knirsch <phil@redhat.de> 0.6.1-2
888- Fixed buggous removal of ifcfg-lo (#50478)
889- Fixed problems with modem volume in hardware dialog
890- Fixed missing /dev/modem for modem setup (#50673)
891
892* Wed Aug  2 2001 Yukihiro Nakai <ynakai@redhat.com>
893- POTFILES.in list up fix
894- Add Japanese translation
895
896* Wed Aug 02 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.6.2-1
897- More bugfixes
898
899* Tue Jul 24 2001 Than Ngo <than@redhat.com> 0.6.1-1
900- Some more bugfixes...
901
902* Tue Jul 24 2001 Phil Knirsch <phil@redhat.de> 0.6-2
903- Some more bugfixes...
904
905* Tue Jul 24 2001 Phil Knirsch <phil@redhat.de> 0.6-1
906- Bumped version to 0.6
907
908* Tue Jul 24 2001 Than Ngo <than@redhat.com>
909- add Druid for dialup connection (ISDN/ADSL/Modem)
910
911* Thu Jul 19 2001 Trond Eivind Glomsrød <teg@redhat.com>
912- Obsolete netcfg - rp3 is next, when gnome-lokkit doesn't require
913  it anymore
914- More fixes...
915
916* Tue Jul 17 2001 Trond Eivind Glomsrød <teg@redhat.com>
917- CIPE and wireless added
918
919* Mon Jul 16 2001 Trond Eivind Glomsrød <teg@redhat.com>
920- Add i18n
921- Many minor fixes...
922
923* Wed Jul 11 2001 Trond Eivind Glomsrød <teg@redhat.com>
924- Don't run autogen.sh
925- Mark files in /etc as configuration files
926- Multiple fixes to automake files
927- Add Norwegian translation to desktop files
928- install into the configuration tool desktop directory
929
930* Wed Jul 11 2001 Than Ngo <than@redhat.com> 0.3.1-1
931- obsolete isdn-config internet-config
932- requires consolehelper, alchemist
933- add icon and desktop file
934- use bzip2
935
936* Wed Jul 11 2001 Phil Knirsch <phil@redhat.de> 0.3.0-2
937- Fixed critical problem during profile saving.
938
939* Wed Jul 10 2001 Phil Knirsch <phil@redhat.de> 0.3.0-1
940- 0.3.0-1
941- Final touches for beta2. Most stuff should work now.
942
943* Thu Jul 10 2001 Phil Knirsch <phil@redhat.de> 0.2.2-2
944- Added some missing files.
945
946* Tue Jul 10 2001 Trond Eivind Glomsrød <teg@redhat.com>
947- 0.2.2
948
949* Tue Jul 10 2001 Trond Eivind Glomsrød <teg@redhat.com>
950- 0.2.1
951
952* Mon Jul  9 2001 Trond Eivind Glomsrød <teg@redhat.com>
953- 0.2
954- New name - system-config-network.
955  Shortcut: neat (NEtwork Administration Tool)
956
957* Fri Jul 06 2001 Trond Eivind Glomsrød <teg@redhat.com>
958- Require a recent version of initscripts
959- Initial build. Don't obsolete older tools just yet...
Note: See TracBrowser for help on using the repository browser.