source: projects/specs/trunk/s/system-config-network/system-config-network-vl.spec @ 3653

Revision 3653, 32.2 KB checked in by daisuke, 13 years ago (diff)

system-config-network: update to 1.6.2, update dependency

Line 
1# -*- RPM-SPEC -*-
2Summary: The GUI of the Network Adminstration Tool
3Summary(ja): ネットワーク管理ツール(GUI)
4Name: system-config-network
5Version: 1.6.2
6Release: 1%{?_dist_release}
7URL: http://fedoraproject.org/wiki/SystemConfig/network
8License: GPLv2+
9Group: Applications/System
10
11Source0: %{name}-%{version}.tar.bz2
12Source1: %{name}-ja-help-image.tar.bz2
13Patch0: %{name}-1.5.97-fix-crash-on-saving.patch
14#Patch1: %{name}-1.5.99-modprobeconf.patch
15Patch2: %{name}-1.6.2-ja-help.patch
16
17BuildArch: noarch
18BuildRequires: python >= 0:2.2, openjade, docbook-style-dsssl, perl, gettext, desktop-file-utils, perl-XML-Parser
19BuildRequires: intltool, autoconf, automake
20Requires: %{name}-tui = %{version}-%{release}
21Requires: pygtk2-libglade, pygtk2, gnome-python, usermode-gtk, xdg-utils
22BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23
24%description
25This is the GUI of the network configuration tool,
26supporting Ethernet, Wireless, TokenRing, ADSL, ISDN and PPP.
27
28%package tui
29Summary: The Network Adminstration Tool
30Summary(ja): ネットワーク管理ツール
31Group: Applications/System
32Requires: initscripts >= 8.80.0, usermode , python, rpm-python, newt
33Requires: pciutils, dbus-python
34Requires: python-ethtool, python-iwlib
35
36%description tui
37This is the network configuration tool,
38supporting Ethernet, Wireless, TokenRing, ADSL, ISDN and PPP.
39
40%prep
41%setup -q -a 1
42%patch0 -p1
43#%patch1 -p1
44%patch2 -p1
45
46%build
47autoreconf
48%configure
49
50%install
51rm -rf $RPM_BUILD_ROOT
52make DESTDIR=$RPM_BUILD_ROOT install
53
54mkdir $RPM_BUILD_ROOT%{_datadir}/applications
55
56for i in system-config-network.desktop system-control-network.desktop; do \
57  desktop-file-install --vendor "" --delete-original       \
58    --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
59    --add-category System                                     \
60    --add-category Settings                                   \
61    $RPM_BUILD_ROOT%{_datadir}/system-config-network/$i; \
62done;
63
64mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/networking/devices
65mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/networking/profiles/default
66
67%find_lang %name
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72
73%files
74%defattr(-,root,root,-)
75%doc COPYING
76%{_datadir}/system-config-network/pixmaps
77%{_datadir}/system-config-network/netconfpkg/gui
78%{_datadir}/system-config-network/netconf.py*
79%{_datadir}/system-config-network/netconf_control.py*
80%{_sbindir}/system-config-network-gui
81%{_bindir}/system-control-network
82%{_datadir}/applications/*
83%{_datadir}/pixmaps/*
84
85%files -f %{name}.lang tui
86%defattr(-,root,root,-)
87%doc COPYING
88%dir %{_datadir}/system-config-network
89%doc %dir %{_datadir}/system-config-network/help
90%doc %{_datadir}/system-config-network/help/*
91%{_datadir}/system-config-network/netconf_cmd.py*
92%{_datadir}/system-config-network/netconf_tui.py*
93%{_datadir}/system-config-network/version.py*
94%dir %{_datadir}/system-config-network/netconfpkg
95%{_datadir}/system-config-network/netconfpkg/conf
96%{_datadir}/system-config-network/netconfpkg/tui
97%{_datadir}/system-config-network/netconfpkg/plugins
98%{_datadir}/system-config-network/netconfpkg/*.py*
99%{_datadir}/system-config-network/module-info
100%{_datadir}/system-config-network/providerdb
101%config(noreplace) %{_sysconfdir}/pam.d/*
102%config(noreplace) %{_sysconfdir}/security/console.apps/*
103%dir %{_sysconfdir}/sysconfig/networking
104%dir %{_sysconfdir}/sysconfig/networking/profiles
105%dir %{_sysconfdir}/sysconfig/networking/profiles/default
106%dir %{_sysconfdir}/sysconfig/networking/devices
107%{_sbindir}/system-config-network
108%{_sbindir}/system-config-network-tui
109%{_sbindir}/system-config-network-cmd
110%{_bindir}/system-config-network
111%{_bindir}/system-config-network-cmd
112
113%changelog
114* Sat Apr 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.2-1
115- update to 1.6.2
116- remove R: rhpl, kudzu
117- add R: python-ethtool, python-iwlib to tui
118- add R: usermode-gtk instead of usermode
119- add BR: intltool, autoconf, automake
120
121* Sat Apr 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.97-5
122- rebuild for Vine 6
123
124* Thu Oct 22 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.5.97-4
125- add source1(images of Japanese help).
126
127* Wed Oct 21 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.5.97-3
128- add patch2 to add Japanese help.
129
130* Wed Sep 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.97-2
131- add patch1 to use /etc/modprobe.d/modprobe.conf
132
133* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.97-1
134- new upstream release
135- add Patch0 to fix crash on saving data.
136
137* Tue Apr 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.95-1
138- new upstream release
139
140* Mon Aug 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
141- initial build for Vine Linux
142
143* Tue May 27 2008 Harald Hoyer <harald@redhat.com> - 1.5.10
144- fixed Makefile.am
145
146* Tue May 27 2008 Harald Hoyer <harald@redhat.com> - 1.5.9
147- fixed console perms for Fedora <= 8
148
149* Fri May 16 2008 Harald Hoyer <harald@redhat.com> - 1.5.8
150- copy info from DNS page into each ifcfg file (dcbw)
151
152* Fri Apr 25 2008 Harald Hoyer <harald@redhat.com> - 1.5.7
153- NCisdnhardware.card -> NCisdnhardware._card (harald)
154- Fixed pap-secret parsing. (#rhbz#443347) (jmoskovc)
155
156* Tue Apr 08 2008 Harald Hoyer <harald@redhat.com> - 1.5.6
157- translation update
158- check origLine for None (harald)
159
160* Mon Mar 31 2008 Harald Hoyer <harald@redhat.com> - 1.5.5
161- fixed more rhbz#439718
162
163* Mon Mar 31 2008 Harald Hoyer <harald@redhat.com> - 1.5.4
164- fixed typos in DialupDruid (harald)
165- return None is nothing is selected (harald)
166- fixed #438901: Network Device Control doesn't work unless s-c-n has been run once (harald)
167- fixed #435041 and added UnitTest (harald)
168- be case-independent in mode parsing rhbz#433748 (harald)
169- fixed rhbz#429725 (harald)
170- do not traceback on non-int Volume (harald)
171- fixed rhbz#439718 (harald)
172
173* Sat Mar 29 2008 Harald Hoyer <harald@redhat.com> - 1.5.3
174- readded DialupDruid (harald)
175
176* Sat Mar 29 2008 Harald Hoyer <harald@redhat.com> - 1.5.2
177- devices which are controlled by NM cannot be activated/deactivated (rhbz#438902)
178- use ". config-util" in console-apps config file (rhbz#428408) (harald)
179- use xdg-open instead of htemlview (rhbz#415031) (harald)
180- added sr@latin (rhbz#425845)
181- update buttons on device edit change (harald)
182- fixed some Alias handling (harald)
183- removed Init2 string (clashes with UTMS) (harald)
184- no activate/deactivate/delete NMControlled devices (harald)
185- NCPluginDevTokenRing return None if no dialog (harald)
186- BackendHal fix to use Factory classes, no kudzu hw import (harald)
187- check if hostname is not None, before checking it (harald)
188- added tui/NCPluginTokenRingInterface (harald)
189- MTU moved to base device (rhbz#439202) (harald)
190- fixed import for ParseError (harald)
191
192* Thu Feb 28 2008 Harald Hoyer <harald@redhat.com> - 1.5.1
193- removed CIPE (harald)
194- s/Devernet/Network/ (harald)
195- Auto -> auto (harald)
196- only append localhost to AliasList, if not already in (harald)
197- show error dialog, if device loading failes (harald)
198- moved MRU to Dialup only (harald)
199- recognize qeth devices in kudzu lists (rhbz#184734) (harald)
200- added MRU field (rhbz#221294) (harald)
201- added TUI for QETH (harald)
202- do not traceback, if we try to remove a device not in our active list (harald)
203- added qeth support (harald)
204- removed ctc and iucv devices (rhbz#219180) (harald)
205- do not handle ifcfg-${parent_device}-range* rhbz#221292 (harald)
206- Minor fix in hosts parser to make tui works. (jmoskovc)
207- Stupid mode doesn't go away anymore.(rhbz#177931) (jmoskovc)
208- Fixed crash when Baud=None (jmoskovc)
209- Removing PPP option should work. NETWORKMANAGER -> NM_CONTROLLED (jmoskovc)
210- Fixed problem with import rhbz#429725 (jmoskovc)
211- Changed Clist in host editor to GtkTreeView, added checkbox to show loopbacks in hosts (jmoskovc)
212- Minor fix in hosts parser - now it accepts trailing dot. (jmoskovc)
213- Improved {pap|chap}-secrets parser, added checkbox to reveal password in dialup config (jmoskovc)
214- Fixed crash when hostname is changed. (jmoskovc)
215
216* Mon Dec 03 2007 Harald Hoyer <harald@redhat.com> - 1.5.0
217- v1.5.0
218
219* Mon Dec 03 2007 Harald Hoyer <harald@redhat.com>, Jiri Moskovcak <jmoskovc@redhat.com> - 1.4.7
220- added HAL support
221- fixed /etc/hosts parser
222- added "Controlled by NetworkManager"
223- do not fall into modified state for activate/deactivate (rhbz#377261)
224
225* Mon Nov 12 2007 Harald Hoyer <harald@redhat.com> - 1.4.6
226- moved network.xpm to (pkgdatadir)/pixmaps (rhbz#377861)
227
228* Mon Nov 12 2007 Harald Hoyer <harald@redhat.com> - 1.4.5
229- changed yelp to htmlview
230
231* Wed Nov  7 2007 Stepan Kasal <skasal@redhat.com> - 1.4.4
232- s/NEtwork/Network/ in the summary of -tui, to be consistent
233  with the summary line of the main rpm (the neat acronym is no
234  longer advertised anyway)
235- Resolves: #239216
236
237* Fri Oct 26 2007 Harald Hoyer <harald@redhat.com> - 1.4.4
238- removed not yet used NCBackendHal.py (rhbz#353771)
239- fixed yelp dependency (rhbz#344981)
240- moved %%configure to %%build (rhbz#353761)
241- fixed type with getRoot (rhbz#368871)
242
243* Mon Oct 15 2007 Harald Hoyer <harald@redhat.com> - 1.4.3
244- fixed /etc/hosts problem (rhbz#331451)
245
246* Fri Oct 12 2007 Harald Hoyer <harald@redhat.com> - 1.4.3
247- added version.py.in to POTFILES.in (rhbz#244053)
248- corrected URL (rhbz#237717)
249
250* Mon Oct 08 2007 Harald Hoyer <harald@redhat.com> - 1.4.2
251- speedup genClass
252- restorecon selinux context
253
254* Mon Sep 24 2007 Harald Hoyer <harald@redhat.com> - 1.4.1-2
255- require newt-python instead of newt only
256
257* Mon Sep 24 2007 Harald Hoyer <harald@redhat.com> - 1.4.1
258- version 1.4.1
259
260* Thu Aug 16 2007 Harald Hoyer <harald@redhat.com> - 1.4.0
261- version 1.4.0
262
263* Mon Jan  8 2007 Harald Hoyer <harald@redhat.com> - 1.3.99
264- fixed #221289
265- Resolves: rhbz#221289
266
267* Fri Dec 15 2006 Harald Hoyer <harald@redhat.com> - 1.3.98
268- translation update (bug #216559)
269- Resolves: rhbz#216559
270
271* Tue Nov 28 2006 Harald Hoyer <harald@redhat.com> - 1.3.97
272- translation update
273
274* Thu Nov  2 2006 Harald Hoyer <harald@redhat.com> - 1.3.96
275- Resolves: rhbz #211980, rhbz #213181
276
277* Wed Oct  4 2006 Harald Hoyer <harald@redhat.com> - 1.3.95
278- translation update (bug #208886)
279- use rhpl.iwlib for wireless functions (bug #197954)
280- added perl-XML-Parser build requirement
281
282* Tue Aug 15 2006 Harald Hoyer <harald@redhat.com> - 1.3.94
283- translation update (bug #182650)
284
285* Tue Aug 15 2006 Harald Hoyer <harald@redhat.com> - 1.3.93
286- added tui subdir (bug #202560)
287
288* Fri Aug 11 2006 Harald Hoyer <harald@redhat.com> - 1.3.92
289- fixed #201659
290- translation update
291
292* Tue Jul 25 2006 Harald Hoyer <harald@redhat.com> - 1.3.91
293- fixed "New Device" in text-mode
294
295* Tue Jul 18 2006 Harald Hoyer <harald@redhat.com> - 1.3.90
296- fixed:
297- [135014] MTU and MRU should be confiurable for ADSL
298- [141055] system-config-network needs to be able to set MTU
299- [149780] no GATEWAY, IPADDR and NETMASK, if BOOTPROTO=dhcp
300- [150362] [Errno 2] No such file or directory: '/etc/hosts'
301- [157172] Wrong DNS for provider "ZEDAT_Berlin"
302- [160417] Bad: cannot make any changes to network settings
303- [169819] Trailing space in host name causes crash
304- [175078] String (country name) change request
305- [176145] Please enable Serbian translation in system-config-network
306- [177198] deprecation warning in system-config-network
307- [187563] localized option passed to ifcfg-wlan0 files
308- [188321] Creating an alias for a network interface breaks device
309           setup after reboots
310- [190242] Firefox instance running as root when used to read docs
311           for system-config-*
312- [197401] Don't write HWADDR for alias interfaces
313
314* Fri Jul 14 2006 Nils Philippsen <nphilipp@redhat.com>
315- enable ml, or, sr, sr@Latn translations (#176145)
316
317* Wed Nov 02 2005 Harald Hoyer <harald@redhat.com> - 1.3.30
318- removed interdruid
319- reversed Cancel/Ok button ordering
320
321* Tue Oct 25 2005 Harald Hoyer <harald@redhat.com> - 1.3.29
322- fixed profileFrame labeling
323
324* Wed Oct 10 2005 Harald Hoyer <harald@redhat.com> - 1.3.28
325- fixed picture paths in glade files
326- fixed cancel case of passphrase dialog
327
328* Wed Oct 10 2005 Harald Hoyer <harald@redhat.com> - 1.3.27
329- use new pam stack replacement
330- added OnParent for Alias Devices
331- added SPI and better key generation for ipsec
332- corrected column handling in main window
333- GUI liftup
334- added AVM Fritz!PCI v2.0 ISDN card to ISDN Hardwarelist (bug 134605)
335- remove /etc/sysconfig/isdncard, if no ISDN is configured
336
337* Wed Apr 20 2005 Harald Hoyer <harald@redhat.com> - 1.3.26
338- CBCP_MSN added (bug #125710)
339
340* Tue Mar 31 2005 Harald Hoyer <harald@redhat.com> - 1.3.25
341- more i18n languages
342
343* Wed Mar 30 2005 Harald Hoyer <harald@redhat.com> - 1.3.24
344- gtk.FALSE and gtk.TRUE cleanups
345
346* Mon Mar 21 2005 Harald Hoyer <harald@redhat.com> - 1.3.23-2
347- moved gui parts out of the tui package
348
349* Fri Mar 04 2005 Harald Hoyer <harald@redhat.com> - 1.3.23
350- update to new gnome/gtk/glade
351
352* Wed Oct 20 2004 Harald Hoyer <harald@redhat.com> - 1.3.22
353- translation updates, added nb.po (bug 136462)
354
355* Tue Oct 05 2004 Harald Hoyer <harald@redhat.com> - 1.3.21
356- fixed /etc/hosts handling
357- handle .ko module names in updateFromKudzu
358
359* Fri Sep 03 2004 Harald Hoyer <harald@redhat.com> - 1.3.20
360- dhcp cannot be selected for aliased devices (bug 129096)
361
362* Thu Aug 26 2004 Harald Hoyer <harald@redhat.com> - 1.3.19
363- hopefully fixed bug 125393
364- fixed removal of device files
365
366* Fri Jul 30 2004 Harald Hoyer <harald@redhat.com> - 1.3.18
367- changed mainloop and mainquit
368- translation updates
369 
370* Tue Jul 06 2004 Harald Hoyer <harald@redhat.com> - 1.3.17
371- bugfix release for FC2
372
373* Tue Jun 29 2004 Harald Hoyer <harald@redhat.com> - 1.3.17
374- better "make clean"
375- removed references to Red Hat Linux
376- added testsuite for data layer
377- added some module-info entries
378- added command line parsing to network-control
379- added IPsec to network-cmd
380- switched logging to syslog
381- do not touch bonding slaves
382- better alias handling
383- better handling of chroot
384- read *.ko modules also
385- handle modules parameter without "="
386- create correct SPI_ identifier for manual IPsec keying
387- better hostname handling
388- better profile handling
389- fix kernel version parsing
390- unknown-flag.xpm for unknown country flags
391- fixed TokenRing glade file (bad hash at beginning of file)
392- fix the length of IPSec shared keys
393- prevent modified status after profile switching
394- save dialog, for ipsec deactivation
395- PEERDNS defaults to yes
396- routing for wireless config dialog
397- only display CIPE for kernel < 2.6
398
399* Thu Apr  1 2004 Harald Hoyer <harald@redhat.com> - 1.3.17
400- translation updates (119610)
401
402* Thu Mar  4 2004 Harald Hoyer <harald@redhat.com> - 1.3.16
403- be more relaxed, when parsing the kernel version (115917)
404- fixed removing of Hostname (115795)
405- fixed "DevEthernet instance has no attribute 'IPv6Init'" (116375)
406- removed save dialog, when switching profiles (107399)
407- added generic Initstrings (115768)
408- added secure.png logo
409- added "-c" parameter for activate/deactivate
410- changed hotkeys to avoid double entries
411- use new pixmap loading code (only take local paths, if debugging is active)
412- moved updateNetworkScripts() to NC_functions.py
413- fallback on /etc/sysconfig/network-scripts
414- removed /usr/lib/rhs/python from sys.path
415- added -? as a command line option
416- corrected --root= option for gui
417- activate/deactivate buttons always sensitive
418- check for ipsec-tools and dynamically display ipsec tab
419- no second dialog while activating in system-control-network
420- change hosts file on hostname change
421- PEERDNS is true, if not configured
422
423* Thu Jan 29 2004 Harald Hoyer <harald@redhat.com> - 1.3.15
424- added IPv6 support per device (111377)
425
426* Wed Jan 28 2004 Harald Hoyer <harald@redhat.com> - 1.3.14
427- modules.conf -> modprobe.conf
428
429* Thu Dec 18 2003 Harald Hoyer <harald@redhat.de> 1.3.13-2
430- added mkinstalldirs to EXTRA_DIST
431- added version to provides
432
433* Wed Dec 17 2003 Harald Hoyer <harald@redhat.de> 1.3.13
434- fixed T-Online dialog #110911
435- default flow control to CTSRTS #110347
436- only clear login/pw on provider select, if provider has its own number
437- fixed cancel of dialup process #103421
438- default to "/" for chrooted configuration
439- default to "default" profile if none active
440- fixed "activate button not active" #110193
441- scn-tui requires newt #104213
442- fixed #107816, by recognizing /var/run/ppp-ppp<NICKNAME>.pid
443- fixed a bug in ISDN activate #100677
444
445* Tue Dec 16 2003 Harald Hoyer <harald@redhat.de> 1.3.12
446- renamed redhat-config-network -> system-config-network
447- added pciutils requirement
448- added utf-8 encoding comments
449- corrected some translation strings
450- added redhat-config-network provides
451
452* Tue Oct 28 2003 Harald Hoyer <harald@redhat.de> 1.3.10
453- removed restriction on t-online password entry #105970
454- failsafe changing the error image #108094
455- corrected indention #108151
456
457* Mon Oct 27 2003 Harald Hoyer <harald@redhat.de> 1.3.9
458- fixed 107501, 107387, 106751, 104213
459- fallback to no logfile, if opening the logfile fails
460- test, if /etc/{hosts,resolv.conf} exists
461- removed ipsec tab
462
463* Thu Oct 23 2003 Than Ngo <than@redhat.com> 1.3.8
464- fix a bug in ISDN activate
465
466* Wed Oct 22 2003 Than Ngo <than@redhat.com> 1.3.7-2
467- fix a bug in saving of ISDN config file
468- add support nickname for ISDN
469 
470* Wed Oct  8 2003 Harald Hoyer <harald@redhat.de> 1.3.7
471- merged in changes from Taroon
472
473* Thu Aug 14 2003 Harald Hoyer <harald@redhat.de> 1.3.6
474- fixed #100471
475
476* Wed Aug  6 2003 Harald Hoyer <harald@redhat.de> 1.3.5
477- fixed #98251
478
479* Fri Aug  1 2003 Harald Hoyer <harald@redhat.de> 1.3.4
480- fixed #101386
481- save wireless keys in keys file
482
483* Thu Jul 31 2003 Harald Hoyer <harald@redhat.de> 1.3.3
484- fixed #85365
485- fixed glade file loading
486- more ipsec stuff
487- neat can use a "chrooted" environment now (-r)
488- .rpmsave will not be loaded
489- no interrupt/io settings for PNP cards
490- HIGIfied labels
491- double click for hardware and ipsec
492
493* Wed Jul  2 2003 Than Ngo <than@redhat.com> 1.3.2-2
494- upgrade provide database
495
496* Wed Jun 18 2003 Harald Hoyer <harald@redhat.de> 1.2.12-2
497- fixed #97562
498
499* Thu Jun 17 2003 Harald Hoyer <harald@redhat.de> 1.2.12-1
500- wlan0 handling
501- splash screen bug fixed
502- improvements in HW list handling
503- isdncard handling #91607
504
505* Thu Jun 12 2003 Harald Hoyer <harald@redhat.de> 1.2.11
506- fixed #97027
507- fixed subs of -
508
509* Wed Jun 11 2003 Harald Hoyer <harald@redhat.de> 1.2.10
510- fixed #97027 #96994
511- fixed fedora bugzilla issues #326
512- update of some translations
513
514* Wed Jun  4 2003 Harald Hoyer <harald@redhat.de> 1.2.8
515- lazy file unlinking
516- fixed #91620 #91583
517- ConfEHosts -> ConfFHosts
518
519* Mon May 19 2003 Harald Hoyer <harald@redhat.de> 1.2.7
520- make PAP/CHAP work again
521- route files chmod(0644)
522- added local variables to traceback
523
524* Thu May 01 2003 Harald Hoyer <harald@redhat.de> 1.2.6
525- use unsernetctl instead of ifdown/ifup
526
527* Thu May 01 2003 Harald Hoyer <harald@redhat.de> 1.2.5
528- fixed early import of plugins
529
530* Wed Apr 30 2003 Harald Hoyer <harald@redhat.de> 1.2.4-3
531- fixed #89915 and #89916
532
533* Tue Apr 29 2003 Harald Hoyer <harald@redhat.de> 1.2.4-1
534- 1.2.4 bugfix release
535
536* Wed Apr  2 2003 Harald Hoyer <harald@redhat.de> 1.2.3-3
537- Bugfix release for 9
538- fixed #85011, #85703, #85653, #84956, #83640, #68169, #86476, #78043, #77763
539
540* Fri Feb 21 2003 Harald Hoyer <harald@redhat.de> 1.2.0-2
541- bump to 1.2.0
542- fixed #84725
543- warning for #84752
544
545* Fri Feb 12 2003 Harald Hoyer <harald@redhat.de> 1.1.97-1
546- fixed #83692
547- updated documentation
548
549* Mon Feb  3 2003 Harald Hoyer <harald@redhat.de> 1.1.94-1
550- base -> tui, gui -> base
551
552* Thu Jan 30 2003 Harald Hoyer <harald@redhat.de> 1.1.93-1
553- 1.1.93
554
555* Wed Jan 29 2003 Harald Hoyer <harald@redhat.de> 1.1.92-1
556- 1.1.92
557
558* Tue Jan 14 2003 Harald Hoyer <harald@redhat.de> 1.1.90-1
559- 1.1.90
560
561* Thu Dec 19 2002 Than Ngo <than@redhat.com>
562- import ConfDevice
563
564* Mon Dec 16 2002 Harald Hoyer <harald@redhat.de>
565- 1.1.86
566
567* Fri Dec 13 2002 Harald Hoyer <harald@redhat.de>
568- 1.1.85
569
570* Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.1.80-1
571- Remove unpackaged files
572
573* Mon Sep  2 2002 Than Ngo <than@redhat.com> 1.1.20-1
574- don't crash by selecting provider
575- Set correct HangupTimeout for ISDN connection
576
577* Sat Aug 31 2002 Preston Brown <pbrown@localhost.localdomain>
578- fix typo in error dialog function
579
580* Thu Aug 22 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.17-1
581- Make it use the gnome help system, add yelp as a dependency (#71857)
582- Traceback fix: # 72581
583- translation updates
584
585* Wed Aug 14 2002 Harald Hoyer <harald@redhat.de>
586- #71448
587- #71265
588- #70988
589
590* Tue Aug 13 2002 Harald Hoyer <harald@redhat.de> 1.1.15-1
591- many bugfixes, including  #71062 #69333 #68793 #69133
592
593* Thu Aug  1 2002 Than Ngo <than@redhat.com> 1.1.14-1
594- set correct device type for rawip ISDN connections (bug #69568)
595- add some ISPs for Austria
596
597* Tue Jul 30 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.13-1
598- Fixes to the traceback dialog (fix "save to floppy" (we don't do that),
599  add i18n.)
600- Fix traceback with malformed /etc/hosts (#69320)
601- Fix dependencies (#69990)
602- Some minor userhelper fixes
603
604* Thu Jul 25 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.12-1
605- doc loc fixes (images)
606- add pam_timestamp support (#69869)
607
608* Wed Jul 24 2002 Harald Hoyer <harald@redhat.de>
609- renamed "default" profile in GUI
610- fixed device renaming in profiles
611
612* Wed Jul 24 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.10-1
613- More bugfixes, including #69635 #69636
614- Updated docs
615
616* Tue Jul 23 2002 Harald Hoyer <harald@redhat.de> 1.1.9-1
617- lots of bugfixes again :)
618
619* Wed Jul 17 2002 Harald Hoyer <harald@redhat.de>
620- lots of bugfixes
621- reactivated profile gui
622
623* Mon Jul  8 2002 Harald Hoyer <harald@redhat.de>
624- lots of bugfixes, new .desktop stuff
625- added desktop-file-utils BuildRequires
626
627* Tue Jul  2 2002 Harald Hoyer <harald@redhat.de> 1.1.7-1
628- cleanup, usability
629
630* Mon Jul 01 2002 Than Ngo <than@redhat.com> 1.1.6-1
631- get rid of isdnup userisdnctl, both are now part of isdn4k-utils
632
633* Thu Jun 27 2002 Harald Hoyer <harald@redhat.de> 1.1.5-1
634- many bug fixes due to gtk2 conversion
635- fixed #67273 #66200 #65185 #65073 #63963
636
637* Wed Jun 26 2002 Preston Brown <pbrown@redhat.com>
638- ethtool, pcmcia, wireless improvements
639
640* Sat Jun 22 2002 Than Ngo <than@redhat.com> 1.1.4-1
641- fixed traceback bug in activate
642- some fixes in glade file
643
644* Sun Jun 16 2002 Than Ngo <than@redhat.com> 1.1.3-1
645- get_pixbuf: if no icon was not found, looks the icons
646  in standard icon directory
647- bug fixes in wireless
648
649* Wed Jun 12 2002 Harald Hoyer <harald@redhat.de> 1.1.2-1
650- lots of i18n and migration changes
651- wireless reactivated
652
653* Fri Jun 07 2002 Than Ngo <than@redhat.com> 1.1.1-1
654- set PPPOE_TIMEOUT=80 as default, it should be about 4 times
655  the LCP_INTERVAL (bug #64903)
656
657* Wed May 29 2002 Harald Hoyer <harald@redhat.de>
658- ported to python2, gtk2, gnome2
659
660* Wed Apr 17 2002 Trond Eivind Glomsrød <teg@redhat.com>
661- Turn off wireless. It doesn't work with all modes, all cards
662 and you can't edit IP settings after the initial attempt
663
664* Wed Apr 17 2002 Harald Hoyer <harald@redhat.com> 1.0.0-1
665- moved ethmodule.so to /usr/lib
666- call it 1.0.0
667
668* Tue Apr 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.30-1
669- Updated translations
670- Updated docs
671
672* Tue Apr 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.28-1
673- more fixes
674
675* Mon Apr 15 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.27-1
676- Update translations, more fixes
677
678* Mon Apr 15 2002 Harald Hoyer <harald@redhat.com> 0.9.26-1
679- The Most Fixes (tm)
680
681* Sat Apr 13 2002 Than Ngo <than@redhat.com> 0.9.25-1
682- More fixes
683
684* Thu Apr 11 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.24-1
685- More fixes (#63177,#57064,#63207)
686
687* Tue Apr 09 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.23-1
688- more fixes
689- updated translations
690
691* Thu Apr 04 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.22-1
692- more fixes, including #62697,
693
694* Sat Mar 30 2002 Than Ngo <than@redhat.com> 0.9.21-1
695- add Token Ring/Wireless/Cipe Druids
696- more fixes
697
698* Wed Mar 26 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.20-1
699- Rebuild... it should have more fixes
700
701* Wed Mar 26 2002 Than Ngo <than@redhat.com> 0.9.19-1
702- add functions for status/activate/deactivate in neat
703- more fixes
704
705* Sat Mar 16 2002 Than Ngo <than@redhat.com> 0.9.18-1
706- add userisdnctl for ISDN
707- more fixes
708
709* Thu Mar 14 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.17-1
710- Even more fixes
711
712* Thu Mar 14 2002 Than Ngo <than@redhat.com> 0.9.16-1
713- various fixes
714
715* Thu Mar 14 2002 Than Ngo <than@redhat.com> 0.9.15-1
716- add desktop file for neat-control
717- various fixes, additions
718
719* Wed Mar 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.14-1
720- Require gnome-core, buildrequire gnome-core-devel
721
722* Mon Mar 11 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.13-1
723- New build
724- No longer noarch
725
726* Thu Feb 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.12-1
727- Various fixes, additions
728
729* Tue Jan 29 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.11-1
730- build in new environment
731
732* Mon Jan 07 2002 Than Ngo <than@redhat.com> 0.9.10.1-1
733- fixed bug #57853
734
735* Tue Dec 03 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.9.10-1
736- minor fixes, more translations
737
738* Mon Nov 26 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.9.9-0.1
739- Trying again, with more fixes :)
740
741* Fri Nov 25 2001 Than Ngo <than@redhat.com> 0.9.8-0.6
742- fixed bug #56145, #56146, #56147
743
744* Tue Nov 20 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.9.8-0.5
745- prepare for errata
746
747* Fri Nov 02 2001 Than Ngo <than@redhat.com> 0.9.7-1
748- fixed 'AVM PnP'/'Sedlbauer Speed Fax+ PnP'/'ASUS Com ISDNLink ISA PnP'
749- update provider DB
750
751* Tue Oct 30 2001 Than Ngo <than@redhat.com> 0.9.7-1
752- allow setting AVM PCI (Fritz!PCI v2) if kernel supports it
753- fixed some typo bugs
754
755* Wed Oct 24 2001 Harald Hoyer <harald@redhat.com> 0.9.6-1
756- seperated gui from data layer
757- make .pyc ghost files
758- fixed profile/alias problem
759- modem probing only once
760
761* Mon Oct 22 2001 Harald Hoyer <harald@redhat.com> 0.9.5-1
762- fixed consolehelper
763- added chars [_-] ro nickname pattern
764- added traceback catching dialog
765
766* Wed Oct 17 2001 Harald Hoyer <harald@redhat.com> 0.9.4-1
767- fixed /etc/hosts
768- fixed pap/chap
769- fixed 'save changes?'
770
771* Tue Oct 16 2001 Than Ngo <than@redhat.com> 0.9.3-1
772- fix internet-druid fails (bug #54192)
773- fix dial on demand problem from some ISDN Provider in German
774- don't trace back if length of Login name is 2 (bug #54322)
775
776* Thu Sep 27 2001 Than Ngo <than@redhat.com> 0.9.2-1
777- enable TCPIP for CIPE
778- show device Tab as default if devices exist
779
780* Wed Sep 12 2001 Than Ngo <than@redhat.com> 0.9.1-1
781- add CTC and IUCV support for s390/s390x
782- disable Dialup on s390/s390x
783
784* Thu Sep  5 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.9-1
785- Add Russian
786
787* Wed Sep  4 2001 Phil Knirsch <phil@redhat.de> 0.8.4-1
788- Fixed problem with unwanted removal of entries in /etc/modules.conf (#53042)
789
790* Mon Sep  3 2001 Than Ngo <than@redhat.com> 0.8.3-1
791- fix a bug in setting Authentication
792- fix some critical typo bugs
793
794* Fri Aug 31 2001 Than Ngo <than@redhat.com> 0.8.2-1
795- fix backtrace bug in CIPE
796- fix traceback bug if self.device.Dialup is None
797- if hardware is deleted, remove all devices used this hardware
798- de.po: fix bad translation
799
800* Fri Aug 31 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.8.1-1
801- Add support for Czech
802
803* Fri Aug 31 2001 Than Ngo <than@redhat.com>
804- fix #52920, #52922, #52914, #52916, #52917
805
806* Fri Aug 31 2001 Phil Knirsch <phil@redhat.de> 0.8.0-2
807- Fixed wrong option handling in /etc/modules.conf (#52853, #52923)
808- Fixed empty search entry in /etc/resolv.conf (#52926)
809- Fixed empty domain entry in /etc/resolv.conf (#52924)
810- Fixed ethernet hardware probing traceback (#52921)
811
812* Tue Aug 28 2001 Than Ngo <than@redhat.com> 0.8.0-1
813- fix some typo bugs
814
815* Tue Aug 28 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.10-1
816- minor fixes, including bootprotocol for CIPE (don't say it will use DHCP...)
817
818* Tue Aug 28 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.9-1
819- Not everything was marked for translation (#52650)
820
821* Tue Aug 28 2001 Than Ngo <than@redhat.com> 0.7.8-1
822- fix some typo bugs
823- fix wrong Modem entry (Bug #52601)
824
825* Mon Aug 27 2001 Than Ngo <than@redhat.com> 0.7.7-1
826- fix wrong type CBHUP
827
828* Mon Aug 27 2001 Phil Knirsch <phil@redhat.de> 0.7.6-2
829- Fixed use of /etc/sysconfig/network (#52359)
830
831* Fri Aug 24 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.6-1
832- Reordered tabs, added descriptions on each of the tabs
833
834* Fri Aug 24 2001 Bill Nottingham <notting@redhat.com> 0.7.5-1
835- tokenring support
836
837* Thu Aug 23 2001 Phil Knirsch <phil@redhat.de> 0.7.4-2
838- Fixed recalculation of BROADCAST and NETWORK values if IP and netmask are
839  present (#51462)
840
841* Mon Aug 20 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.4-1
842- More bugfixes, among them #51929, #51991, #51721, #51722,
843  partial #52044, #51720.
844- Updated translations, include more languages
845
846* Thu Aug 16 2001 Phil Knirsch <phil@redhat.de> 0.7.3-2
847- Fixed major bug in device renaming (#50885)
848
849* Tue Aug 14 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.3-1
850- more bugfixes, more docs, GUI fixes
851
852* Fri Aug 10 2001 Than Ngo <than@redhat.com> 0.7.2-1
853- more bugfixes
854
855* Fri Aug 10 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.1-1
856- more bugfixes, more docs
857
858* Wed Aug  8 2001 Alexander Larsson <alexl@redhat.com> 0.7-2
859- Install desktop files in sysconfig instead of serverconf.
860
861* Wed Aug  8 2001 Phil Knirsch <phil@redhat.de> 0.7-1
862- Added a lot of documentation
863- Final changes to the Modem druid dialog and code to look just like the
864  hardware add dialog for modems.
865
866* Wed Aug  8 2001 Phil Knirsch <phil@redhat.de> 0.6.8-3
867- Added the modem detection for the ModemDruid.
868- Added kudzu as requirement as it is needed for modem detection.
869- For compatibility still check for symlinks, too. Otherwise older setups will
870  break.
871
872* Tue Aug  7 2001 Phil Knirsch <phil@redhat.de> 0.6.7-2
873- Fixed various important bugzilla bugs
874- Added and implemented the add Hardware dialog.
875- Added a working Apply button.
876- Switched to using hardlinks instead of symlinks for config files.
877
878* Tue Aug  7 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.6.7-1
879- Add online help capability (#50739)
880
881* Mon Aug  6 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.6.6-1
882- Disable profiles in GUI and as necesarry in code
883
884* Mon Aug  6 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.6.5-1
885- more bugfixes
886- add Conf.py from pythonlib, which has gone to the great bitbucket
887  in the sky
888
889* Sun Aug  5 2001 Than Ngo <than@redhat.com>
890- fix bug 50740
891- wvdial.conf readonly for root
892
893* Fri Aug  3 2001 Than Ngo <than@redhat.com>
894- fix pap/chap Login name for T-online
895- fix InitStrings
896- use gettext function in NC_functions
897- fix loading DEFROUTE/PERSIST/DEMAND/IDLETIMEOUT for Modem dialup
898- don't backtrace if 'SetVolume' and 'Dial Command' are not defined
899
900* Thu Aug 02 2001 Phil Knirsch <phil@redhat.de> 0.6.1-2
901- Fixed buggous removal of ifcfg-lo (#50478)
902- Fixed problems with modem volume in hardware dialog
903- Fixed missing /dev/modem for modem setup (#50673)
904
905* Wed Aug  2 2001 Yukihiro Nakai <ynakai@redhat.com>
906- POTFILES.in list up fix
907- Add Japanese translation
908
909* Wed Aug 02 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.6.2-1
910- More bugfixes
911
912* Tue Jul 24 2001 Than Ngo <than@redhat.com> 0.6.1-1
913- Some more bugfixes...
914
915* Tue Jul 24 2001 Phil Knirsch <phil@redhat.de> 0.6-2
916- Some more bugfixes...
917
918* Tue Jul 24 2001 Phil Knirsch <phil@redhat.de> 0.6-1
919- Bumped version to 0.6
920
921* Tue Jul 24 2001 Than Ngo <than@redhat.com>
922- add Druid for dialup connection (ISDN/ADSL/Modem)
923
924* Thu Jul 19 2001 Trond Eivind Glomsrød <teg@redhat.com>
925- Obsolete netcfg - rp3 is next, when gnome-lokkit doesn't require
926  it anymore
927- More fixes...
928
929* Tue Jul 17 2001 Trond Eivind Glomsrød <teg@redhat.com>
930- CIPE and wireless added
931
932* Mon Jul 16 2001 Trond Eivind Glomsrød <teg@redhat.com>
933- Add i18n
934- Many minor fixes...
935
936* Wed Jul 11 2001 Trond Eivind Glomsrød <teg@redhat.com>
937- Don't run autogen.sh
938- Mark files in /etc as configuration files
939- Multiple fixes to automake files
940- Add Norwegian translation to desktop files
941- install into the configuration tool desktop directory
942
943* Wed Jul 11 2001 Than Ngo <than@redhat.com> 0.3.1-1
944- obsolete isdn-config internet-config
945- requires consolehelper, alchemist
946- add icon and desktop file
947- use bzip2
948
949* Wed Jul 11 2001 Phil Knirsch <phil@redhat.de> 0.3.0-2
950- Fixed critical problem during profile saving.
951
952* Wed Jul 10 2001 Phil Knirsch <phil@redhat.de> 0.3.0-1
953- 0.3.0-1
954- Final touches for beta2. Most stuff should work now.
955
956* Thu Jul 10 2001 Phil Knirsch <phil@redhat.de> 0.2.2-2
957- Added some missing files.
958
959* Tue Jul 10 2001 Trond Eivind Glomsrød <teg@redhat.com>
960- 0.2.2
961
962* Tue Jul 10 2001 Trond Eivind Glomsrød <teg@redhat.com>
963- 0.2.1
964
965* Mon Jul  9 2001 Trond Eivind Glomsrød <teg@redhat.com>
966- 0.2
967- New name - system-config-network.
968  Shortcut: neat (NEtwork Administration Tool)
969
970* Fri Jul 06 2001 Trond Eivind Glomsrød <teg@redhat.com>
971- Require a recent version of initscripts
972- Initial build. Don't obsolete older tools just yet...
Note: See TracBrowser for help on using the repository browser.