source: projects/specs/trunk/s/system-config-network/system-config-network-vl.spec @ 12477

Revision 12477, 32.3 KB checked in by tomop, 4 years ago (diff)

updated 11 packages

libxml2-2.9.10-4

newt-0.52.21-2

python-docutils-0.16-2

python-inotify-0.9.6-3

python-lxml-4.5.2-2

python-pykf-0.3.4-8

python-2.7.18-1

rhpxl-1.9-10

rrdtool-1.7.2-3

system-config-date-1.9.61-3

system-config-network-1.6.2-2

Line 
1# -*- RPM-SPEC -*-
2Summary: The GUI of the Network Adminstration Tool
3Summary(ja): ネットワーク管理ツール(GUI)
4Name: system-config-network
5Version: 1.6.2
6Release: 2%{?_dist_release}
7Group: admin-tools
8Vendor: Project Vine
9Distribution: Vine Linux
10Packager: daisuke
11
12URL: http://fedoraproject.org/wiki/SystemConfig/network
13License: GPLv2+
14Source0: %{name}-%{version}.tar.bz2
15Source1: %{name}-ja-help-image.tar.bz2
16Patch0: %{name}-1.5.97-fix-crash-on-saving.patch
17#Patch1: %{name}-1.5.99-modprobeconf.patch
18Patch2: %{name}-1.6.2-ja-help.patch
19
20BuildArch: noarch
21BuildRequires: python >= 0:2.2, openjade, docbook-style-dsssl, perl, gettext, desktop-file-utils, perl-XML-Parser
22BuildRequires: intltool, autoconf, automake
23Requires: %{name}-tui = %{version}-%{release}
24Requires: pygtk2-libglade, pygtk2, gnome-python, usermode-gtk, xdg-utils
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26
27%description
28This is the GUI of the network configuration tool,
29supporting Ethernet, Wireless, TokenRing, ADSL, ISDN and PPP.
30
31%package tui
32Summary: The Network Adminstration Tool
33Summary(ja): ネットワーク管理ツール
34Group: admin-tools
35Requires: initscripts >= 8.80.0, usermode , python, rpm-python, python-newt
36Requires: pciutils, dbus-python
37Requires: python-ethtool, python-iwlib
38
39%description tui
40This is the network configuration tool,
41supporting Ethernet, Wireless, TokenRing, ADSL, ISDN and PPP.
42
43%prep
44%setup -q -a 1
45%patch0 -p1
46#%patch1 -p1
47%patch2 -p1
48
49%build
50autoreconf -fiv
51%configure
52
53%install
54rm -rf $RPM_BUILD_ROOT
55make DESTDIR=$RPM_BUILD_ROOT install
56
57mkdir $RPM_BUILD_ROOT%{_datadir}/applications
58
59for i in system-config-network.desktop system-control-network.desktop; do \
60  desktop-file-install --vendor "" --delete-original       \
61    --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
62    --add-category System                                     \
63    --add-category Settings                                   \
64    $RPM_BUILD_ROOT%{_datadir}/system-config-network/$i; \
65done;
66
67mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/networking/devices
68mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/networking/profiles/default
69
70%find_lang %name
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75
76%files
77%defattr(-,root,root,-)
78%doc COPYING
79%{_datadir}/system-config-network/pixmaps
80%{_datadir}/system-config-network/netconfpkg/gui
81%{_datadir}/system-config-network/netconf.py*
82%{_datadir}/system-config-network/netconf_control.py*
83%{_sbindir}/system-config-network-gui
84%{_bindir}/system-control-network
85%{_datadir}/applications/*
86%{_datadir}/pixmaps/*
87
88%files -f %{name}.lang tui
89%defattr(-,root,root,-)
90%doc COPYING
91%dir %{_datadir}/system-config-network
92%doc %dir %{_datadir}/system-config-network/help
93%doc %{_datadir}/system-config-network/help/*
94%{_datadir}/system-config-network/netconf_cmd.py*
95%{_datadir}/system-config-network/netconf_tui.py*
96%{_datadir}/system-config-network/version.py*
97%dir %{_datadir}/system-config-network/netconfpkg
98%{_datadir}/system-config-network/netconfpkg/conf
99%{_datadir}/system-config-network/netconfpkg/tui
100%{_datadir}/system-config-network/netconfpkg/plugins
101%{_datadir}/system-config-network/netconfpkg/*.py*
102%{_datadir}/system-config-network/module-info
103%{_datadir}/system-config-network/providerdb
104%config(noreplace) %{_sysconfdir}/pam.d/*
105%config(noreplace) %{_sysconfdir}/security/console.apps/*
106%dir %{_sysconfdir}/sysconfig/networking
107%dir %{_sysconfdir}/sysconfig/networking/profiles
108%dir %{_sysconfdir}/sysconfig/networking/profiles/default
109%dir %{_sysconfdir}/sysconfig/networking/devices
110%{_sbindir}/system-config-network
111%{_sbindir}/system-config-network-tui
112%{_sbindir}/system-config-network-cmd
113%{_bindir}/system-config-network
114%{_bindir}/system-config-network-cmd
115
116%changelog
117* Wed Aug 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.2-2
118- changed R:newt to R:python-newt.
119
120* Sat Apr 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.2-1
121- update to 1.6.2
122- remove R: rhpl, kudzu
123- add R: python-ethtool, python-iwlib to tui
124- add R: usermode-gtk instead of usermode
125- add BR: intltool, autoconf, automake
126
127* Sat Apr 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.97-5
128- rebuild for Vine 6
129
130* Thu Oct 22 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.5.97-4
131- add source1(images of Japanese help).
132
133* Wed Oct 21 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.5.97-3
134- add patch2 to add Japanese help.
135
136* Wed Sep 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.97-2
137- add patch1 to use /etc/modprobe.d/modprobe.conf
138
139* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.97-1
140- new upstream release
141- add Patch0 to fix crash on saving data.
142
143* Tue Apr 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.95-1
144- new upstream release
145
146* Mon Aug 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
147- initial build for Vine Linux
148
149* Tue May 27 2008 Harald Hoyer <harald@redhat.com> - 1.5.10
150- fixed Makefile.am
151
152* Tue May 27 2008 Harald Hoyer <harald@redhat.com> - 1.5.9
153- fixed console perms for Fedora <= 8
154
155* Fri May 16 2008 Harald Hoyer <harald@redhat.com> - 1.5.8
156- copy info from DNS page into each ifcfg file (dcbw)
157
158* Fri Apr 25 2008 Harald Hoyer <harald@redhat.com> - 1.5.7
159- NCisdnhardware.card -> NCisdnhardware._card (harald)
160- Fixed pap-secret parsing. (#rhbz#443347) (jmoskovc)
161
162* Tue Apr 08 2008 Harald Hoyer <harald@redhat.com> - 1.5.6
163- translation update
164- check origLine for None (harald)
165
166* Mon Mar 31 2008 Harald Hoyer <harald@redhat.com> - 1.5.5
167- fixed more rhbz#439718
168
169* Mon Mar 31 2008 Harald Hoyer <harald@redhat.com> - 1.5.4
170- fixed typos in DialupDruid (harald)
171- return None is nothing is selected (harald)
172- fixed #438901: Network Device Control doesn't work unless s-c-n has been run once (harald)
173- fixed #435041 and added UnitTest (harald)
174- be case-independent in mode parsing rhbz#433748 (harald)
175- fixed rhbz#429725 (harald)
176- do not traceback on non-int Volume (harald)
177- fixed rhbz#439718 (harald)
178
179* Sat Mar 29 2008 Harald Hoyer <harald@redhat.com> - 1.5.3
180- readded DialupDruid (harald)
181
182* Sat Mar 29 2008 Harald Hoyer <harald@redhat.com> - 1.5.2
183- devices which are controlled by NM cannot be activated/deactivated (rhbz#438902)
184- use ". config-util" in console-apps config file (rhbz#428408) (harald)
185- use xdg-open instead of htemlview (rhbz#415031) (harald)
186- added sr@latin (rhbz#425845)
187- update buttons on device edit change (harald)
188- fixed some Alias handling (harald)
189- removed Init2 string (clashes with UTMS) (harald)
190- no activate/deactivate/delete NMControlled devices (harald)
191- NCPluginDevTokenRing return None if no dialog (harald)
192- BackendHal fix to use Factory classes, no kudzu hw import (harald)
193- check if hostname is not None, before checking it (harald)
194- added tui/NCPluginTokenRingInterface (harald)
195- MTU moved to base device (rhbz#439202) (harald)
196- fixed import for ParseError (harald)
197
198* Thu Feb 28 2008 Harald Hoyer <harald@redhat.com> - 1.5.1
199- removed CIPE (harald)
200- s/Devernet/Network/ (harald)
201- Auto -> auto (harald)
202- only append localhost to AliasList, if not already in (harald)
203- show error dialog, if device loading failes (harald)
204- moved MRU to Dialup only (harald)
205- recognize qeth devices in kudzu lists (rhbz#184734) (harald)
206- added MRU field (rhbz#221294) (harald)
207- added TUI for QETH (harald)
208- do not traceback, if we try to remove a device not in our active list (harald)
209- added qeth support (harald)
210- removed ctc and iucv devices (rhbz#219180) (harald)
211- do not handle ifcfg-${parent_device}-range* rhbz#221292 (harald)
212- Minor fix in hosts parser to make tui works. (jmoskovc)
213- Stupid mode doesn't go away anymore.(rhbz#177931) (jmoskovc)
214- Fixed crash when Baud=None (jmoskovc)
215- Removing PPP option should work. NETWORKMANAGER -> NM_CONTROLLED (jmoskovc)
216- Fixed problem with import rhbz#429725 (jmoskovc)
217- Changed Clist in host editor to GtkTreeView, added checkbox to show loopbacks in hosts (jmoskovc)
218- Minor fix in hosts parser - now it accepts trailing dot. (jmoskovc)
219- Improved {pap|chap}-secrets parser, added checkbox to reveal password in dialup config (jmoskovc)
220- Fixed crash when hostname is changed. (jmoskovc)
221
222* Mon Dec 03 2007 Harald Hoyer <harald@redhat.com> - 1.5.0
223- v1.5.0
224
225* Mon Dec 03 2007 Harald Hoyer <harald@redhat.com>, Jiri Moskovcak <jmoskovc@redhat.com> - 1.4.7
226- added HAL support
227- fixed /etc/hosts parser
228- added "Controlled by NetworkManager"
229- do not fall into modified state for activate/deactivate (rhbz#377261)
230
231* Mon Nov 12 2007 Harald Hoyer <harald@redhat.com> - 1.4.6
232- moved network.xpm to (pkgdatadir)/pixmaps (rhbz#377861)
233
234* Mon Nov 12 2007 Harald Hoyer <harald@redhat.com> - 1.4.5
235- changed yelp to htmlview
236
237* Wed Nov  7 2007 Stepan Kasal <skasal@redhat.com> - 1.4.4
238- s/NEtwork/Network/ in the summary of -tui, to be consistent
239  with the summary line of the main rpm (the neat acronym is no
240  longer advertised anyway)
241- Resolves: #239216
242
243* Fri Oct 26 2007 Harald Hoyer <harald@redhat.com> - 1.4.4
244- removed not yet used NCBackendHal.py (rhbz#353771)
245- fixed yelp dependency (rhbz#344981)
246- moved %%configure to %%build (rhbz#353761)
247- fixed type with getRoot (rhbz#368871)
248
249* Mon Oct 15 2007 Harald Hoyer <harald@redhat.com> - 1.4.3
250- fixed /etc/hosts problem (rhbz#331451)
251
252* Fri Oct 12 2007 Harald Hoyer <harald@redhat.com> - 1.4.3
253- added version.py.in to POTFILES.in (rhbz#244053)
254- corrected URL (rhbz#237717)
255
256* Mon Oct 08 2007 Harald Hoyer <harald@redhat.com> - 1.4.2
257- speedup genClass
258- restorecon selinux context
259
260* Mon Sep 24 2007 Harald Hoyer <harald@redhat.com> - 1.4.1-2
261- require newt-python instead of newt only
262
263* Mon Sep 24 2007 Harald Hoyer <harald@redhat.com> - 1.4.1
264- version 1.4.1
265
266* Thu Aug 16 2007 Harald Hoyer <harald@redhat.com> - 1.4.0
267- version 1.4.0
268
269* Mon Jan  8 2007 Harald Hoyer <harald@redhat.com> - 1.3.99
270- fixed #221289
271- Resolves: rhbz#221289
272
273* Fri Dec 15 2006 Harald Hoyer <harald@redhat.com> - 1.3.98
274- translation update (bug #216559)
275- Resolves: rhbz#216559
276
277* Tue Nov 28 2006 Harald Hoyer <harald@redhat.com> - 1.3.97
278- translation update
279
280* Thu Nov  2 2006 Harald Hoyer <harald@redhat.com> - 1.3.96
281- Resolves: rhbz #211980, rhbz #213181
282
283* Wed Oct  4 2006 Harald Hoyer <harald@redhat.com> - 1.3.95
284- translation update (bug #208886)
285- use rhpl.iwlib for wireless functions (bug #197954)
286- added perl-XML-Parser build requirement
287
288* Tue Aug 15 2006 Harald Hoyer <harald@redhat.com> - 1.3.94
289- translation update (bug #182650)
290
291* Tue Aug 15 2006 Harald Hoyer <harald@redhat.com> - 1.3.93
292- added tui subdir (bug #202560)
293
294* Fri Aug 11 2006 Harald Hoyer <harald@redhat.com> - 1.3.92
295- fixed #201659
296- translation update
297
298* Tue Jul 25 2006 Harald Hoyer <harald@redhat.com> - 1.3.91
299- fixed "New Device" in text-mode
300
301* Tue Jul 18 2006 Harald Hoyer <harald@redhat.com> - 1.3.90
302- fixed:
303- [135014] MTU and MRU should be confiurable for ADSL
304- [141055] system-config-network needs to be able to set MTU
305- [149780] no GATEWAY, IPADDR and NETMASK, if BOOTPROTO=dhcp
306- [150362] [Errno 2] No such file or directory: '/etc/hosts'
307- [157172] Wrong DNS for provider "ZEDAT_Berlin"
308- [160417] Bad: cannot make any changes to network settings
309- [169819] Trailing space in host name causes crash
310- [175078] String (country name) change request
311- [176145] Please enable Serbian translation in system-config-network
312- [177198] deprecation warning in system-config-network
313- [187563] localized option passed to ifcfg-wlan0 files
314- [188321] Creating an alias for a network interface breaks device
315           setup after reboots
316- [190242] Firefox instance running as root when used to read docs
317           for system-config-*
318- [197401] Don't write HWADDR for alias interfaces
319
320* Fri Jul 14 2006 Nils Philippsen <nphilipp@redhat.com>
321- enable ml, or, sr, sr@Latn translations (#176145)
322
323* Wed Nov 02 2005 Harald Hoyer <harald@redhat.com> - 1.3.30
324- removed interdruid
325- reversed Cancel/Ok button ordering
326
327* Tue Oct 25 2005 Harald Hoyer <harald@redhat.com> - 1.3.29
328- fixed profileFrame labeling
329
330* Wed Oct 10 2005 Harald Hoyer <harald@redhat.com> - 1.3.28
331- fixed picture paths in glade files
332- fixed cancel case of passphrase dialog
333
334* Wed Oct 10 2005 Harald Hoyer <harald@redhat.com> - 1.3.27
335- use new pam stack replacement
336- added OnParent for Alias Devices
337- added SPI and better key generation for ipsec
338- corrected column handling in main window
339- GUI liftup
340- added AVM Fritz!PCI v2.0 ISDN card to ISDN Hardwarelist (bug 134605)
341- remove /etc/sysconfig/isdncard, if no ISDN is configured
342
343* Wed Apr 20 2005 Harald Hoyer <harald@redhat.com> - 1.3.26
344- CBCP_MSN added (bug #125710)
345
346* Tue Mar 31 2005 Harald Hoyer <harald@redhat.com> - 1.3.25
347- more i18n languages
348
349* Wed Mar 30 2005 Harald Hoyer <harald@redhat.com> - 1.3.24
350- gtk.FALSE and gtk.TRUE cleanups
351
352* Mon Mar 21 2005 Harald Hoyer <harald@redhat.com> - 1.3.23-2
353- moved gui parts out of the tui package
354
355* Fri Mar 04 2005 Harald Hoyer <harald@redhat.com> - 1.3.23
356- update to new gnome/gtk/glade
357
358* Wed Oct 20 2004 Harald Hoyer <harald@redhat.com> - 1.3.22
359- translation updates, added nb.po (bug 136462)
360
361* Tue Oct 05 2004 Harald Hoyer <harald@redhat.com> - 1.3.21
362- fixed /etc/hosts handling
363- handle .ko module names in updateFromKudzu
364
365* Fri Sep 03 2004 Harald Hoyer <harald@redhat.com> - 1.3.20
366- dhcp cannot be selected for aliased devices (bug 129096)
367
368* Thu Aug 26 2004 Harald Hoyer <harald@redhat.com> - 1.3.19
369- hopefully fixed bug 125393
370- fixed removal of device files
371
372* Fri Jul 30 2004 Harald Hoyer <harald@redhat.com> - 1.3.18
373- changed mainloop and mainquit
374- translation updates
375 
376* Tue Jul 06 2004 Harald Hoyer <harald@redhat.com> - 1.3.17
377- bugfix release for FC2
378
379* Tue Jun 29 2004 Harald Hoyer <harald@redhat.com> - 1.3.17
380- better "make clean"
381- removed references to Red Hat Linux
382- added testsuite for data layer
383- added some module-info entries
384- added command line parsing to network-control
385- added IPsec to network-cmd
386- switched logging to syslog
387- do not touch bonding slaves
388- better alias handling
389- better handling of chroot
390- read *.ko modules also
391- handle modules parameter without "="
392- create correct SPI_ identifier for manual IPsec keying
393- better hostname handling
394- better profile handling
395- fix kernel version parsing
396- unknown-flag.xpm for unknown country flags
397- fixed TokenRing glade file (bad hash at beginning of file)
398- fix the length of IPSec shared keys
399- prevent modified status after profile switching
400- save dialog, for ipsec deactivation
401- PEERDNS defaults to yes
402- routing for wireless config dialog
403- only display CIPE for kernel < 2.6
404
405* Thu Apr  1 2004 Harald Hoyer <harald@redhat.com> - 1.3.17
406- translation updates (119610)
407
408* Thu Mar  4 2004 Harald Hoyer <harald@redhat.com> - 1.3.16
409- be more relaxed, when parsing the kernel version (115917)
410- fixed removing of Hostname (115795)
411- fixed "DevEthernet instance has no attribute 'IPv6Init'" (116375)
412- removed save dialog, when switching profiles (107399)
413- added generic Initstrings (115768)
414- added secure.png logo
415- added "-c" parameter for activate/deactivate
416- changed hotkeys to avoid double entries
417- use new pixmap loading code (only take local paths, if debugging is active)
418- moved updateNetworkScripts() to NC_functions.py
419- fallback on /etc/sysconfig/network-scripts
420- removed /usr/lib/rhs/python from sys.path
421- added -? as a command line option
422- corrected --root= option for gui
423- activate/deactivate buttons always sensitive
424- check for ipsec-tools and dynamically display ipsec tab
425- no second dialog while activating in system-control-network
426- change hosts file on hostname change
427- PEERDNS is true, if not configured
428
429* Thu Jan 29 2004 Harald Hoyer <harald@redhat.com> - 1.3.15
430- added IPv6 support per device (111377)
431
432* Wed Jan 28 2004 Harald Hoyer <harald@redhat.com> - 1.3.14
433- modules.conf -> modprobe.conf
434
435* Thu Dec 18 2003 Harald Hoyer <harald@redhat.de> 1.3.13-2
436- added mkinstalldirs to EXTRA_DIST
437- added version to provides
438
439* Wed Dec 17 2003 Harald Hoyer <harald@redhat.de> 1.3.13
440- fixed T-Online dialog #110911
441- default flow control to CTSRTS #110347
442- only clear login/pw on provider select, if provider has its own number
443- fixed cancel of dialup process #103421
444- default to "/" for chrooted configuration
445- default to "default" profile if none active
446- fixed "activate button not active" #110193
447- scn-tui requires newt #104213
448- fixed #107816, by recognizing /var/run/ppp-ppp<NICKNAME>.pid
449- fixed a bug in ISDN activate #100677
450
451* Tue Dec 16 2003 Harald Hoyer <harald@redhat.de> 1.3.12
452- renamed redhat-config-network -> system-config-network
453- added pciutils requirement
454- added utf-8 encoding comments
455- corrected some translation strings
456- added redhat-config-network provides
457
458* Tue Oct 28 2003 Harald Hoyer <harald@redhat.de> 1.3.10
459- removed restriction on t-online password entry #105970
460- failsafe changing the error image #108094
461- corrected indention #108151
462
463* Mon Oct 27 2003 Harald Hoyer <harald@redhat.de> 1.3.9
464- fixed 107501, 107387, 106751, 104213
465- fallback to no logfile, if opening the logfile fails
466- test, if /etc/{hosts,resolv.conf} exists
467- removed ipsec tab
468
469* Thu Oct 23 2003 Than Ngo <than@redhat.com> 1.3.8
470- fix a bug in ISDN activate
471
472* Wed Oct 22 2003 Than Ngo <than@redhat.com> 1.3.7-2
473- fix a bug in saving of ISDN config file
474- add support nickname for ISDN
475 
476* Wed Oct  8 2003 Harald Hoyer <harald@redhat.de> 1.3.7
477- merged in changes from Taroon
478
479* Thu Aug 14 2003 Harald Hoyer <harald@redhat.de> 1.3.6
480- fixed #100471
481
482* Wed Aug  6 2003 Harald Hoyer <harald@redhat.de> 1.3.5
483- fixed #98251
484
485* Fri Aug  1 2003 Harald Hoyer <harald@redhat.de> 1.3.4
486- fixed #101386
487- save wireless keys in keys file
488
489* Thu Jul 31 2003 Harald Hoyer <harald@redhat.de> 1.3.3
490- fixed #85365
491- fixed glade file loading
492- more ipsec stuff
493- neat can use a "chrooted" environment now (-r)
494- .rpmsave will not be loaded
495- no interrupt/io settings for PNP cards
496- HIGIfied labels
497- double click for hardware and ipsec
498
499* Wed Jul  2 2003 Than Ngo <than@redhat.com> 1.3.2-2
500- upgrade provide database
501
502* Wed Jun 18 2003 Harald Hoyer <harald@redhat.de> 1.2.12-2
503- fixed #97562
504
505* Thu Jun 17 2003 Harald Hoyer <harald@redhat.de> 1.2.12-1
506- wlan0 handling
507- splash screen bug fixed
508- improvements in HW list handling
509- isdncard handling #91607
510
511* Thu Jun 12 2003 Harald Hoyer <harald@redhat.de> 1.2.11
512- fixed #97027
513- fixed subs of -
514
515* Wed Jun 11 2003 Harald Hoyer <harald@redhat.de> 1.2.10
516- fixed #97027 #96994
517- fixed fedora bugzilla issues #326
518- update of some translations
519
520* Wed Jun  4 2003 Harald Hoyer <harald@redhat.de> 1.2.8
521- lazy file unlinking
522- fixed #91620 #91583
523- ConfEHosts -> ConfFHosts
524
525* Mon May 19 2003 Harald Hoyer <harald@redhat.de> 1.2.7
526- make PAP/CHAP work again
527- route files chmod(0644)
528- added local variables to traceback
529
530* Thu May 01 2003 Harald Hoyer <harald@redhat.de> 1.2.6
531- use unsernetctl instead of ifdown/ifup
532
533* Thu May 01 2003 Harald Hoyer <harald@redhat.de> 1.2.5
534- fixed early import of plugins
535
536* Wed Apr 30 2003 Harald Hoyer <harald@redhat.de> 1.2.4-3
537- fixed #89915 and #89916
538
539* Tue Apr 29 2003 Harald Hoyer <harald@redhat.de> 1.2.4-1
540- 1.2.4 bugfix release
541
542* Wed Apr  2 2003 Harald Hoyer <harald@redhat.de> 1.2.3-3
543- Bugfix release for 9
544- fixed #85011, #85703, #85653, #84956, #83640, #68169, #86476, #78043, #77763
545
546* Fri Feb 21 2003 Harald Hoyer <harald@redhat.de> 1.2.0-2
547- bump to 1.2.0
548- fixed #84725
549- warning for #84752
550
551* Fri Feb 12 2003 Harald Hoyer <harald@redhat.de> 1.1.97-1
552- fixed #83692
553- updated documentation
554
555* Mon Feb  3 2003 Harald Hoyer <harald@redhat.de> 1.1.94-1
556- base -> tui, gui -> base
557
558* Thu Jan 30 2003 Harald Hoyer <harald@redhat.de> 1.1.93-1
559- 1.1.93
560
561* Wed Jan 29 2003 Harald Hoyer <harald@redhat.de> 1.1.92-1
562- 1.1.92
563
564* Tue Jan 14 2003 Harald Hoyer <harald@redhat.de> 1.1.90-1
565- 1.1.90
566
567* Thu Dec 19 2002 Than Ngo <than@redhat.com>
568- import ConfDevice
569
570* Mon Dec 16 2002 Harald Hoyer <harald@redhat.de>
571- 1.1.86
572
573* Fri Dec 13 2002 Harald Hoyer <harald@redhat.de>
574- 1.1.85
575
576* Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.1.80-1
577- Remove unpackaged files
578
579* Mon Sep  2 2002 Than Ngo <than@redhat.com> 1.1.20-1
580- don't crash by selecting provider
581- Set correct HangupTimeout for ISDN connection
582
583* Sat Aug 31 2002 Preston Brown <pbrown@localhost.localdomain>
584- fix typo in error dialog function
585
586* Thu Aug 22 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.17-1
587- Make it use the gnome help system, add yelp as a dependency (#71857)
588- Traceback fix: # 72581
589- translation updates
590
591* Wed Aug 14 2002 Harald Hoyer <harald@redhat.de>
592- #71448
593- #71265
594- #70988
595
596* Tue Aug 13 2002 Harald Hoyer <harald@redhat.de> 1.1.15-1
597- many bugfixes, including  #71062 #69333 #68793 #69133
598
599* Thu Aug  1 2002 Than Ngo <than@redhat.com> 1.1.14-1
600- set correct device type for rawip ISDN connections (bug #69568)
601- add some ISPs for Austria
602
603* Tue Jul 30 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.13-1
604- Fixes to the traceback dialog (fix "save to floppy" (we don't do that),
605  add i18n.)
606- Fix traceback with malformed /etc/hosts (#69320)
607- Fix dependencies (#69990)
608- Some minor userhelper fixes
609
610* Thu Jul 25 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.12-1
611- doc loc fixes (images)
612- add pam_timestamp support (#69869)
613
614* Wed Jul 24 2002 Harald Hoyer <harald@redhat.de>
615- renamed "default" profile in GUI
616- fixed device renaming in profiles
617
618* Wed Jul 24 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.10-1
619- More bugfixes, including #69635 #69636
620- Updated docs
621
622* Tue Jul 23 2002 Harald Hoyer <harald@redhat.de> 1.1.9-1
623- lots of bugfixes again :)
624
625* Wed Jul 17 2002 Harald Hoyer <harald@redhat.de>
626- lots of bugfixes
627- reactivated profile gui
628
629* Mon Jul  8 2002 Harald Hoyer <harald@redhat.de>
630- lots of bugfixes, new .desktop stuff
631- added desktop-file-utils BuildRequires
632
633* Tue Jul  2 2002 Harald Hoyer <harald@redhat.de> 1.1.7-1
634- cleanup, usability
635
636* Mon Jul 01 2002 Than Ngo <than@redhat.com> 1.1.6-1
637- get rid of isdnup userisdnctl, both are now part of isdn4k-utils
638
639* Thu Jun 27 2002 Harald Hoyer <harald@redhat.de> 1.1.5-1
640- many bug fixes due to gtk2 conversion
641- fixed #67273 #66200 #65185 #65073 #63963
642
643* Wed Jun 26 2002 Preston Brown <pbrown@redhat.com>
644- ethtool, pcmcia, wireless improvements
645
646* Sat Jun 22 2002 Than Ngo <than@redhat.com> 1.1.4-1
647- fixed traceback bug in activate
648- some fixes in glade file
649
650* Sun Jun 16 2002 Than Ngo <than@redhat.com> 1.1.3-1
651- get_pixbuf: if no icon was not found, looks the icons
652  in standard icon directory
653- bug fixes in wireless
654
655* Wed Jun 12 2002 Harald Hoyer <harald@redhat.de> 1.1.2-1
656- lots of i18n and migration changes
657- wireless reactivated
658
659* Fri Jun 07 2002 Than Ngo <than@redhat.com> 1.1.1-1
660- set PPPOE_TIMEOUT=80 as default, it should be about 4 times
661  the LCP_INTERVAL (bug #64903)
662
663* Wed May 29 2002 Harald Hoyer <harald@redhat.de>
664- ported to python2, gtk2, gnome2
665
666* Wed Apr 17 2002 Trond Eivind Glomsrød <teg@redhat.com>
667- Turn off wireless. It doesn't work with all modes, all cards
668 and you can't edit IP settings after the initial attempt
669
670* Wed Apr 17 2002 Harald Hoyer <harald@redhat.com> 1.0.0-1
671- moved ethmodule.so to /usr/lib
672- call it 1.0.0
673
674* Tue Apr 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.30-1
675- Updated translations
676- Updated docs
677
678* Tue Apr 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.28-1
679- more fixes
680
681* Mon Apr 15 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.27-1
682- Update translations, more fixes
683
684* Mon Apr 15 2002 Harald Hoyer <harald@redhat.com> 0.9.26-1
685- The Most Fixes (tm)
686
687* Sat Apr 13 2002 Than Ngo <than@redhat.com> 0.9.25-1
688- More fixes
689
690* Thu Apr 11 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.24-1
691- More fixes (#63177,#57064,#63207)
692
693* Tue Apr 09 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.23-1
694- more fixes
695- updated translations
696
697* Thu Apr 04 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.22-1
698- more fixes, including #62697,
699
700* Sat Mar 30 2002 Than Ngo <than@redhat.com> 0.9.21-1
701- add Token Ring/Wireless/Cipe Druids
702- more fixes
703
704* Wed Mar 26 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.20-1
705- Rebuild... it should have more fixes
706
707* Wed Mar 26 2002 Than Ngo <than@redhat.com> 0.9.19-1
708- add functions for status/activate/deactivate in neat
709- more fixes
710
711* Sat Mar 16 2002 Than Ngo <than@redhat.com> 0.9.18-1
712- add userisdnctl for ISDN
713- more fixes
714
715* Thu Mar 14 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.17-1
716- Even more fixes
717
718* Thu Mar 14 2002 Than Ngo <than@redhat.com> 0.9.16-1
719- various fixes
720
721* Thu Mar 14 2002 Than Ngo <than@redhat.com> 0.9.15-1
722- add desktop file for neat-control
723- various fixes, additions
724
725* Wed Mar 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.14-1
726- Require gnome-core, buildrequire gnome-core-devel
727
728* Mon Mar 11 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.13-1
729- New build
730- No longer noarch
731
732* Thu Feb 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.12-1
733- Various fixes, additions
734
735* Tue Jan 29 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.11-1
736- build in new environment
737
738* Mon Jan 07 2002 Than Ngo <than@redhat.com> 0.9.10.1-1
739- fixed bug #57853
740
741* Tue Dec 03 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.9.10-1
742- minor fixes, more translations
743
744* Mon Nov 26 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.9.9-0.1
745- Trying again, with more fixes :)
746
747* Fri Nov 25 2001 Than Ngo <than@redhat.com> 0.9.8-0.6
748- fixed bug #56145, #56146, #56147
749
750* Tue Nov 20 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.9.8-0.5
751- prepare for errata
752
753* Fri Nov 02 2001 Than Ngo <than@redhat.com> 0.9.7-1
754- fixed 'AVM PnP'/'Sedlbauer Speed Fax+ PnP'/'ASUS Com ISDNLink ISA PnP'
755- update provider DB
756
757* Tue Oct 30 2001 Than Ngo <than@redhat.com> 0.9.7-1
758- allow setting AVM PCI (Fritz!PCI v2) if kernel supports it
759- fixed some typo bugs
760
761* Wed Oct 24 2001 Harald Hoyer <harald@redhat.com> 0.9.6-1
762- seperated gui from data layer
763- make .pyc ghost files
764- fixed profile/alias problem
765- modem probing only once
766
767* Mon Oct 22 2001 Harald Hoyer <harald@redhat.com> 0.9.5-1
768- fixed consolehelper
769- added chars [_-] ro nickname pattern
770- added traceback catching dialog
771
772* Wed Oct 17 2001 Harald Hoyer <harald@redhat.com> 0.9.4-1
773- fixed /etc/hosts
774- fixed pap/chap
775- fixed 'save changes?'
776
777* Tue Oct 16 2001 Than Ngo <than@redhat.com> 0.9.3-1
778- fix internet-druid fails (bug #54192)
779- fix dial on demand problem from some ISDN Provider in German
780- don't trace back if length of Login name is 2 (bug #54322)
781
782* Thu Sep 27 2001 Than Ngo <than@redhat.com> 0.9.2-1
783- enable TCPIP for CIPE
784- show device Tab as default if devices exist
785
786* Wed Sep 12 2001 Than Ngo <than@redhat.com> 0.9.1-1
787- add CTC and IUCV support for s390/s390x
788- disable Dialup on s390/s390x
789
790* Thu Sep  5 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.9-1
791- Add Russian
792
793* Wed Sep  4 2001 Phil Knirsch <phil@redhat.de> 0.8.4-1
794- Fixed problem with unwanted removal of entries in /etc/modules.conf (#53042)
795
796* Mon Sep  3 2001 Than Ngo <than@redhat.com> 0.8.3-1
797- fix a bug in setting Authentication
798- fix some critical typo bugs
799
800* Fri Aug 31 2001 Than Ngo <than@redhat.com> 0.8.2-1
801- fix backtrace bug in CIPE
802- fix traceback bug if self.device.Dialup is None
803- if hardware is deleted, remove all devices used this hardware
804- de.po: fix bad translation
805
806* Fri Aug 31 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.8.1-1
807- Add support for Czech
808
809* Fri Aug 31 2001 Than Ngo <than@redhat.com>
810- fix #52920, #52922, #52914, #52916, #52917
811
812* Fri Aug 31 2001 Phil Knirsch <phil@redhat.de> 0.8.0-2
813- Fixed wrong option handling in /etc/modules.conf (#52853, #52923)
814- Fixed empty search entry in /etc/resolv.conf (#52926)
815- Fixed empty domain entry in /etc/resolv.conf (#52924)
816- Fixed ethernet hardware probing traceback (#52921)
817
818* Tue Aug 28 2001 Than Ngo <than@redhat.com> 0.8.0-1
819- fix some typo bugs
820
821* Tue Aug 28 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.10-1
822- minor fixes, including bootprotocol for CIPE (don't say it will use DHCP...)
823
824* Tue Aug 28 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.9-1
825- Not everything was marked for translation (#52650)
826
827* Tue Aug 28 2001 Than Ngo <than@redhat.com> 0.7.8-1
828- fix some typo bugs
829- fix wrong Modem entry (Bug #52601)
830
831* Mon Aug 27 2001 Than Ngo <than@redhat.com> 0.7.7-1
832- fix wrong type CBHUP
833
834* Mon Aug 27 2001 Phil Knirsch <phil@redhat.de> 0.7.6-2
835- Fixed use of /etc/sysconfig/network (#52359)
836
837* Fri Aug 24 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.6-1
838- Reordered tabs, added descriptions on each of the tabs
839
840* Fri Aug 24 2001 Bill Nottingham <notting@redhat.com> 0.7.5-1
841- tokenring support
842
843* Thu Aug 23 2001 Phil Knirsch <phil@redhat.de> 0.7.4-2
844- Fixed recalculation of BROADCAST and NETWORK values if IP and netmask are
845  present (#51462)
846
847* Mon Aug 20 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.4-1
848- More bugfixes, among them #51929, #51991, #51721, #51722,
849  partial #52044, #51720.
850- Updated translations, include more languages
851
852* Thu Aug 16 2001 Phil Knirsch <phil@redhat.de> 0.7.3-2
853- Fixed major bug in device renaming (#50885)
854
855* Tue Aug 14 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.3-1
856- more bugfixes, more docs, GUI fixes
857
858* Fri Aug 10 2001 Than Ngo <than@redhat.com> 0.7.2-1
859- more bugfixes
860
861* Fri Aug 10 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.1-1
862- more bugfixes, more docs
863
864* Wed Aug  8 2001 Alexander Larsson <alexl@redhat.com> 0.7-2
865- Install desktop files in sysconfig instead of serverconf.
866
867* Wed Aug  8 2001 Phil Knirsch <phil@redhat.de> 0.7-1
868- Added a lot of documentation
869- Final changes to the Modem druid dialog and code to look just like the
870  hardware add dialog for modems.
871
872* Wed Aug  8 2001 Phil Knirsch <phil@redhat.de> 0.6.8-3
873- Added the modem detection for the ModemDruid.
874- Added kudzu as requirement as it is needed for modem detection.
875- For compatibility still check for symlinks, too. Otherwise older setups will
876  break.
877
878* Tue Aug  7 2001 Phil Knirsch <phil@redhat.de> 0.6.7-2
879- Fixed various important bugzilla bugs
880- Added and implemented the add Hardware dialog.
881- Added a working Apply button.
882- Switched to using hardlinks instead of symlinks for config files.
883
884* Tue Aug  7 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.6.7-1
885- Add online help capability (#50739)
886
887* Mon Aug  6 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.6.6-1
888- Disable profiles in GUI and as necesarry in code
889
890* Mon Aug  6 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.6.5-1
891- more bugfixes
892- add Conf.py from pythonlib, which has gone to the great bitbucket
893  in the sky
894
895* Sun Aug  5 2001 Than Ngo <than@redhat.com>
896- fix bug 50740
897- wvdial.conf readonly for root
898
899* Fri Aug  3 2001 Than Ngo <than@redhat.com>
900- fix pap/chap Login name for T-online
901- fix InitStrings
902- use gettext function in NC_functions
903- fix loading DEFROUTE/PERSIST/DEMAND/IDLETIMEOUT for Modem dialup
904- don't backtrace if 'SetVolume' and 'Dial Command' are not defined
905
906* Thu Aug 02 2001 Phil Knirsch <phil@redhat.de> 0.6.1-2
907- Fixed buggous removal of ifcfg-lo (#50478)
908- Fixed problems with modem volume in hardware dialog
909- Fixed missing /dev/modem for modem setup (#50673)
910
911* Wed Aug  2 2001 Yukihiro Nakai <ynakai@redhat.com>
912- POTFILES.in list up fix
913- Add Japanese translation
914
915* Wed Aug 02 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.6.2-1
916- More bugfixes
917
918* Tue Jul 24 2001 Than Ngo <than@redhat.com> 0.6.1-1
919- Some more bugfixes...
920
921* Tue Jul 24 2001 Phil Knirsch <phil@redhat.de> 0.6-2
922- Some more bugfixes...
923
924* Tue Jul 24 2001 Phil Knirsch <phil@redhat.de> 0.6-1
925- Bumped version to 0.6
926
927* Tue Jul 24 2001 Than Ngo <than@redhat.com>
928- add Druid for dialup connection (ISDN/ADSL/Modem)
929
930* Thu Jul 19 2001 Trond Eivind Glomsrød <teg@redhat.com>
931- Obsolete netcfg - rp3 is next, when gnome-lokkit doesn't require
932  it anymore
933- More fixes...
934
935* Tue Jul 17 2001 Trond Eivind Glomsrød <teg@redhat.com>
936- CIPE and wireless added
937
938* Mon Jul 16 2001 Trond Eivind Glomsrød <teg@redhat.com>
939- Add i18n
940- Many minor fixes...
941
942* Wed Jul 11 2001 Trond Eivind Glomsrød <teg@redhat.com>
943- Don't run autogen.sh
944- Mark files in /etc as configuration files
945- Multiple fixes to automake files
946- Add Norwegian translation to desktop files
947- install into the configuration tool desktop directory
948
949* Wed Jul 11 2001 Than Ngo <than@redhat.com> 0.3.1-1
950- obsolete isdn-config internet-config
951- requires consolehelper, alchemist
952- add icon and desktop file
953- use bzip2
954
955* Wed Jul 11 2001 Phil Knirsch <phil@redhat.de> 0.3.0-2
956- Fixed critical problem during profile saving.
957
958* Wed Jul 10 2001 Phil Knirsch <phil@redhat.de> 0.3.0-1
959- 0.3.0-1
960- Final touches for beta2. Most stuff should work now.
961
962* Thu Jul 10 2001 Phil Knirsch <phil@redhat.de> 0.2.2-2
963- Added some missing files.
964
965* Tue Jul 10 2001 Trond Eivind Glomsrød <teg@redhat.com>
966- 0.2.2
967
968* Tue Jul 10 2001 Trond Eivind Glomsrød <teg@redhat.com>
969- 0.2.1
970
971* Mon Jul  9 2001 Trond Eivind Glomsrød <teg@redhat.com>
972- 0.2
973- New name - system-config-network.
974  Shortcut: neat (NEtwork Administration Tool)
975
976* Fri Jul 06 2001 Trond Eivind Glomsrød <teg@redhat.com>
977- Require a recent version of initscripts
978- Initial build. Don't obsolete older tools just yet...
Note: See TracBrowser for help on using the repository browser.