source: projects/specs/trunk/s/system-config-display/system-config-display-vl.spec @ 521

Revision 521, 17.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A graphical interface for configuring the X Window System display
2Summary(ja): X ウィンドウシステムのディスプレイを設定するためのグラフィカルインタフェース
3Name: system-config-display
4Version: 1.1.3
5Release: 2%{?_dist_release}
6URL: http://fedoraproject.org/wiki/SystemConfig/Tools
7License: GPL
8ExclusiveOS: Linux
9Group: System Environment/Base
10BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11BuildArch: noarch
12
13Source0: http://fedorahosted.org/releases/s/y/%{name}/%{name}-%{version}.tar.bz2
14Patch10: system-config-display-1.1.3-check-DISPLAY.patch
15
16ExcludeArch: s390 s390x
17BuildRequires: desktop-file-utils
18BuildRequires: intltool, gettext
19Requires: pygtk2 >= 1.99.11
20Requires: pygtk2-libglade
21Requires: python
22Requires: usermode >= 1.98
23Requires: usermode-gtk
24Requires: hwdata
25Requires: dbus-python
26Requires: pyxf86config >= 0.3.16
27Requires: rhpl >= 0.170-1
28Requires: rhpxl >= 0.34-1
29Requires: /usr/bin/Xorg
30Requires: metacity
31Requires: gtk2 >= 2.6
32Requires: hicolor-icon-theme
33
34%description
35system-config-display is a graphical application for configuring an
36X Window System X server display.
37
38%prep
39%setup -q
40%patch10 -p1
41
42for i in src/* ;do
43  perl -pi -e 's|python2|python|g' $i
44done
45
46%build
47make
48
49%install
50rm -rf $RPM_BUILD_ROOT
51make INSTROOT=$RPM_BUILD_ROOT install
52desktop-file-install --vendor "" --delete-original      \
53  --dir $RPM_BUILD_ROOT%{_datadir}/applications         \
54  --remove-category Application                         \
55  --remove-category SystemSetup                         \
56  --add-category Settings                               \
57  $RPM_BUILD_ROOT%{_datadir}/applications/system-config-display.desktop
58chmod a-x $RPM_BUILD_ROOT%{_datadir}/system-config-display/pixmaps/*
59
60%find_lang %name
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%postun
66touch --no-create %{_datadir}/icons/hicolor
67if [ -x /usr/bin/gtk-update-icon-cache -a -e %{_datadir}/icons/hicolor ]; then
68  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
69fi
70
71%post
72touch --no-create %{_datadir}/icons/hicolor
73if [ -x /usr/bin/gtk-update-icon-cache -a -e %{_datadir}/icons/hicolor ]; then
74  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
75fi
76
77
78%files -f %{name}.lang
79%defattr(-,root,root)
80%{_bindir}/system-config-display
81%{_datadir}/system-config-display
82%{_datadir}/applications/*
83%attr(0644,root,root) %config /etc/security/console.apps/system-config-display
84%attr(0644,root,root) %config /etc/pam.d/system-config-display
85%attr(0644,root,root) %{_datadir}/icons/hicolor/48x48/apps/system-config-display.png
86
87%changelog
88* Mon Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-2
89- add Patch10 to run on no-X environment. (<BTS:760>)
90
91* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-1
92- new upstream release
93- remove obsolete patches
94
95* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.51-2
96- require usermode >= 1.98
97
98* Tue Aug 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.51-1
99- initial build for Vine Linux
100
101* Sun Apr 06 2008 Adam Jackson <ajax@redhat.com> 1.0.51-9
102- scd-1.0.51-backtick.patch: Fix unicode hilarity. (#441060)
103
104* Thu Mar 27 2008 Bill Nottingham <notting@redhat.com> 1.0.51-8
105- don't use rhpxl.mouse any more
106
107* Mon Feb 25 2008 Adam Jackson <ajax@redhat.com> 1.0.51-7
108- scd-1.0.51-unkudzify.patch: Replace kudzu dependency with dbus dependency.
109- Fix the chmod fix from -6 to, you know, work.
110
111* Tue Feb 12 2008 Adam Jackson <ajax@redhat.com> 1.0.51-6
112- Clear executable bit from the icons. (#429875)
113
114* Tue Jan 22 2008 Adam Jackson <ajax@redhat.com> 1.0.51-5
115- scd-1.0.51-config-util.patch: Update for new usermode. (#428397)
116
117* Mon Oct 01 2007 Adam Jackson <ajax@redhat.com> 1.0.51-4
118- Un-Require: redhat-artwork, we don't actually require it. (#314001)
119
120* Tue Jul 24 2007 Adam Jackson <ajax@redhat.com> 1.0.51-3
121- Remove ppc64 from ExcludeArch.
122
123* Wed Jun 27 2007 Matthias Clasen <mclasen@redhat.com> 1.0.51-2
124- Fix up categories in desktop file
125
126* Wed Apr 11 2007 Adam Jackson <ajax@redhat.com> 1.0.51-1
127- Load the mouse and keyboard configs from the config file, so as not to
128  clobber them. (#145316)
129
130* Wed Mar 28 2007 Jeremy Katz <katzj@redhat.com> - 1.0.50-1
131- start X server with a black background; we don't need xsri anymore
132
133* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.0.49-1
134- Package review cleanups.
135
136* Mon Jan 29 2007 Adam Jackson <ajax@redhat.com>
137- Copy instead of rename when doing backup of xorg.conf, in case the user has
138  it as a symlink. (#181965)
139
140* Fri Dec 15 2006 Adam Jackson <ajax@redhat.com> 1.0.48-2
141- Rebuild for translations.
142
143* Fri Dec 8 2006 Adam Jackson <ajax@redhat.com>
144- Add dist tag to Release.
145
146* Thu Dec 7 2006 Adam Jackson <ajax@redhat.com> 1.0.48-1
147- Import old driver list code from rhpxl. (#218241)
148
149* Wed Dec 6 2006 Adam Jackson <ajax@redhat.com> 1.0.47-1
150- Fail gracefully on machines with no video.
151
152* Tue Nov 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.0.46-1
153- Fix mnemonic for the color depth combo on the last tab (#216391)
154
155* Wed Sep 13 2006 Adam Jackson <ajackson@redhat.com> 1.0.45-1
156- Refresh the mode state before first paint, to give rhpxl a chance to ask
157  RANDR for the current mode.
158
159* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.0.44-1
160- Unpack properly when given a refresh rate instead of a refresh range.
161
162* Fri Aug 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.43-1
163- Drop 8bpp support.
164- Simplify monitor selection view.
165- Fix initial window sizing to be large enough for all fields.
166
167* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.0.42-1
168- Align lists correctly in RTL locales.  (#202754)
169
170* Thu Aug  3 2006 Bill Nottingham <notting@redhat.com> 1.0.41-1
171- adjust to new rhpxl (<clumens@redhat.com>)
172- work with newer, sparser, config files
173- when dealing with autoprobed monitors, pull current resolution from randr
174
175* Wed Jul 26 2006 Chris Lumens <clumens@redhat.com> 1.0.38-1
176- Fix CHARSET in te and kn translations (#200203).
177- Add gettext to buildrequires.
178
179* Thu Mar 09 2006 Chris Lumens <clumens@redhat.com> 1.0.37-2
180- Add back spec file parts that got lost on last rebuild.
181
182* Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 1.0.37-1
183- Initialize monitor name label to something other than unknown if we
184  really know what it is.
185
186* Fri Mar 03 2006 Martin Stransky <stransky@redhat.com> 1.0.36-3
187- added pam fix (#170625)
188- fix prereq (#182861, #182862)
189
190* Wed Feb 22 2006 Chris Lumens <clumens@redhat.com> 1.0.36-2
191- Add rhpxl to requires
192
193* Fri Jan 27 2006 Paul Nasrat <pnasrat@redhat.com> - 1.0.36-1
194- Rebuild for translations
195- Fix reconfig mode
196
197* Thu Jan 12 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.35-1
198- Rebuild
199
200* Tue Jan 10 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.34-1
201- Some s/rhpl/rhpxl/ type changes
202
203* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> - 1.0.33-1
204- minor changes needed for modular X
205
206* Wed Sep 21 2005 Bill Nottingham <notting@redhat.com> 1.0.32-1
207- Fix up some leftover code that still needed migration (#168932)
208
209* Fri Sep  9 2005 Bill Nottingham <notting@redhat.com> 1.0.31-1
210- Adapt to new kudzu video driver probing, and new rhpl
211
212* Mon Jun 27 2005 Soren Sandmann <sandmann@redhat.com> 1.0.30-1
213- Add ppc64 to ExcludeArchs
214
215* Mon May 23 2005 Jeremy Katz <katzj@redhat.com> - 1.0.29-1
216- put scriptlets from distcvs in this specfile
217
218* Mon May 23 2005 Jeremy Katz <katzj@redhat.com> - 1.0.28-1
219- fix typo in cleanup leading to traceback (#157423)
220
221* Thu Apr 28 2005 Soren Sandmann <sandmann@redhat.com> 1.0.26-1
222- Clean up deprecation warnings (#153937)
223
224* Tue Jan 04 2005 Paul Nasrat <pnasrat@redhat.com> 1.0.25-1
225- Only merge hardware_state if defined (#143944)
226- Only print card if verbose (#143271)
227
228* Mon Nov 15 2004 Paul Nasrat <pnasrat@redhat.com> 1.0.24-1
229- Dual Head patch for testing thanks to Marc Andre Morissette (#136916)
230
231* Tue Oct 19 2004 Paul Nasrat <pnasrat@redhat.com> 1.0.23-1
232- Firstboot - re-read config so both kbd and display changes persist (#135361)
233
234* Thu Oct 14 2004 Paul Nasrat <pnasrat@redhat.com> 1.0.22-1
235- Depth callback patch from twaugh (#128650)
236
237* Fri Oct 01 2004 Paul Nasrat <pnasrat@redhat.com> 1.0.21-1
238- fix mouse traceback
239
240* Tue Sep 07 2004 Paul Nasrat <pnasrat@redhat.com> - 1.0.20-1
241- Refactor some stuff into rhpl
242- Don't override driver changes unless in reconfig (#127779)
243 
244* Tue Sep 07 2004 Paul Nasrat <pnasrat@redhat.com> - 1.0.19-1
245- Translatable desktop
246- Layout changes for firstboot screen
247
248* Thu Aug 19 2004 Paul Nasrat <pnasrat@redhat.com> - 1.0.18-2
249- Ensure selection string translatable
250
251* Thu Aug 19 2004 Paul Nasrat <pnasrat@redhat.com> - 1.0.18-1
252- Monitor selection for first boot
253
254* Fri Jun 25 2004 Brent Fox <bfox@redhat.com> - 1.0.17-1
255- initialize self.probed_path in videocardDialog.py (bug #113695)
256
257* Wed Jun 23 2004 Brent Fox <bfox@redhat.com> - 1.0.16-1
258- reduce size of monitor-off.png and monitor-on.png to fit in 640x480 (bug #122142)
259
260* Mon Jun 14 2004 Brent Fox <bfox@redhat.com> - 1.0.15-2
261- set the text domain for xconf.py and xConfigDialog.py (bug #123494)
262
263* Wed Jun  2 2004 Alex Larsson <alexl@redhat.com> 1.0.15-1
264- fix --reconfig and catch some exceptions for readonly root
265
266* Tue May 25 2004 Brent Fox <bfox@redhat.com> 1.0.14-2
267- add BuildRequires for desktop-file-utils (bug# 124181)
268
269* Fri Apr 30 2004 Brent Fox <bfox@redhat.com> 1.0.14-1
270- do not write out extra XF86Config file during firstboot (bug #121729)
271
272* Tue Apr 20 2004 Brent Fox <bfox@redhat.com> 1.0.13-3
273- Do not write out XkbRules line to config file, as it is unnecessary to hard
274  code the rules file, which has a built in default which should always
275  work. (#120858)
276
277* Wed Apr 14 2004 Brent Fox <bfox@redhat.com> 1.0.13-2
278- update requires for new pyxf86config
279
280* Tue Apr 13 2004 Brent Fox <bfox@redhat.com> 1.0.13-1
281- make changes for XFree86 -> Xorg conversion
282
283* Thu Apr  8 2004 Brent Fox <bfox@redhat.com> 1.0.12-2
284- fix icon path (bug #120174)
285
286* Tue Mar 23 2004 Brent Fox <bfox@redhat.com> 1.0.12-1
287- filter out duplicate monitor entries (bug #118976)
288
289* Wed Mar 17 2004 Mike A. Harris <mharris@redhat.com> 1.0.11-1
290- Change Requires: XFree86 to Requires: /usr/X11R6/bin/XFree86, which is
291  what it appears from the sources is being called.  That will need to change
292  when the server gets renamed, so it should be implemented IMHO in a way
293  that is not hard coded.  This should suffice for now however.
294- Changed package description to remove "XFree86" name and replace it with
295  generic "X Window System X server" term.
296- Added the "via", and "voodoo" drivers that were missing to internal driver
297  list in videocardDialog.py.  The list is still missing stuff though, but
298  those sprung to mind.
299- Added force-tag target to Makefile with tag -cF
300- Added tag target without -F to Makefile
301- Removed -F from archive target as that can potentially blow away an already
302  tagged and released version from the repository if someone accidentally
303  does a "make archive" without updating the spec file Version: field like
304  I just about did.  ;o)
305
306* Mon Mar  1 2004 Brent Fox <bfox@redhat.com> 1.0.10-1
307- sanity check the monitor selection (bug #112314)
308
309* Mon Mar  1 2004 Brent Fox <bfox@redhat.com> 1.0.9-3
310- remove Requires on system-config-mouse
311
312* Fri Feb 27 2004 Brent Fox <bfox@redhat.com> 1.0.9-2
313- another stab at the dual-head code
314
315* Thu Feb 26 2004 Brent Fox <bfox@redhat.com> 1.0.9-1
316- write out "Screen" entry for dual-head cards
317
318* Tue Feb 24 2004 Brent Fox <bfox@redhat.com> 1.0.8-1
319- start up metacity to make the windows look nice (bug #108206)
320
321* Thu Feb 19 2004 Brent Fox <bfox@redhat.com> 1.0.7-1
322- don't import rhpl.mouse in xconf.py
323
324* Tue Feb 17 2004 Brent Fox <bfox@redhat.com> 1.0.6-1
325- write XF86Config to the correct path (bug #115501)
326
327* Fri Jan 30 2004 Brent Fox <bfox@redhat.com> 1.0.5-1
328- correct naming in the spec file description
329
330* Thu Dec  4 2003 Brent Fox <bfox@redhat.com> 1.0.4-1
331- add code to apply changes made in the firstboot display screen
332
333* Tue Dec  2 2003 Brent Fox <bfox@redhat.com> 1.0.3-1
334- add code to pull display notebook page into firstboot
335
336* Thu Nov 20 2003 Brent Fox <bfox@redhat.com> 1.0.2-1
337- fix path problem
338
339* Wed Nov 19 2003 Brent Fox <bfox@redhat.com> 1.0.1-1
340- rename from redhat-config-xfree86 to system-config-display
341- add Obsoletes for redhat-config-xfree86
342- make changes for Python2
343
344* Thu Oct 23 2003 Brent Fox <bfox@redhat.com> 0.9.15-1
345- work around cards with no driver entries (bug #106501)
346
347* Thu Oct 23 2003 Brent Fox <bfox@redhat.com> 0.9.14-1
348- check length of list before removing items (bug #107790)
349
350* Thu Oct 16 2003 Brent Fox <bfox@redhat.com> 0.9.13-1
351- allow dualhead to be disabled (bug #107261)
352
353* Wed Oct 15 2003 Brent Fox <bfox@redhat.com> 0.9.12-1
354- fix bug #106884 for real this time
355
356* Tue Oct 14 2003 Brent Fox <bfox@redhat.com> 0.9.11-1
357- package lightrays.png inside redhat-config-xfree86
358
359* Mon Oct 13 2003 Brent Fox <bfox@redhat.com> 0.9.10-1
360- make sure current is initialized (bug #106884)
361
362* Mon Oct  6 2003 Brent Fox <bfox@redhat.com> 0.9.9-3
363- add a Requires for XFree86 (bug #105992)
364
365* Mon Oct  6 2003 Brent Fox <bfox@redhat.com> 0.9.9-2
366- finish up the dual-head code
367- catch case of having no layout options
368
369* Thu Oct  2 2003 Brent Fox <bfox@redhat.com> 0.9.9-1
370- first stab at multihead code
371- commit some additional monitor icons
372
373* Thu Aug 14 2003 Brent Fox <bfox@redhat.com> 0.9.8-1
374- tag on every build
375
376* Thu Jun  5 2003 Brent Fox <bfox@redhat.com> 0.9.7-1
377- see if we have the name for an unprobed monitor
378
379* Tue Jun  3 2003 Brent Fox <bfox@redhat.com> 0.9.6-1
380- only offer the resolutions that we know to be reasonable for the selected monitor (bug #88269)
381
382* Fri May 30 2003 Brent Fox <bfox@redhat.com> 0.9.5-1
383- big UI changes
384- make room in the UI for multihead stuff
385
386* Wed May 28 2003 Brent Fox <bfox@redhat.com> 0.7.6-1
387- add an ExcludeArch for s390 and s390x (bug #91811)
388
389* Fri May 23 2003 Brent Fox <bfox@redhat.com> 0.7.5-1
390- turn on horizontal scrolling in videocard window
391- initialize dpi measurement option menu correctly (bug #90190)
392
393* Wed May 21 2003 Michael Fulbright <msf@redhat.com> 0.7.4-1
394- converted to use new way of representing Generic monitors in MonitorsDB
395
396* Tue Feb  4 2003 Brent Fox <bfox@redhat.com> 0.7.3-2
397- paint the background with lightrays.png
398
399* Thu Jan 30 2003 Brent Fox <bfox@redhat.com> 0.7.3-1
400- bump and build
401
402* Tue Jan 21 2003 Brent Fox <bfox@redhat.com> 0.7.2-3
403- add closing parenthesis (bug #80398)
404
405* Mon Jan 20 2003 Brent Fox <bfox@redhat.com> 0.7.2-2
406- iterate through available video cards until one works
407- clean up the output
408
409* Fri Jan 17 2003 Brent Fox <bfox@redhat.com> 0.7.1-6
410- make monitor dialog a little larger and allow horz. scrolling (bug #82112)
411
412* Tue Jan 14 2003 Brent Fox <bfox@redhat.com> 0.7.1-5
413- fixed desktop file icon
414
415* Thu Jan  9 2003 Jeremy Katz <katzj@redhat.com> 0.7.1-4
416- import rhpl.monitor
417
418* Mon Jan  6 2003 Brent Fox <bfox@redhat.com> 0.7.1-3
419- try to read the XMOUSETYPE from /etc/sysconfig/mouse (bug #74992)
420
421* Sun Jan  5 2003 Brent Fox <bfox@redhat.com> 0.7.1-2
422- fix the dialog centering code
423- connect the resolution menu to update_ui so the screenshot gets refreshed
424
425* Sun Jan  5 2003 Brent Fox <bfox@redhat.com> 0.7.1-1
426- change radio buttons to OptionMenus
427
428* Fri Jan  3 2003 Brent Fox <bfox@redhat.com> 0.7.0-6
429- default to us keyboard if /etc/sysconfig/keyboard contains a keyboard unknown to rhpl (bug #80993)
430
431* Sun Dec 22 2002 Brent Fox <bfox@redhat.com> 0.7.0-5
432- change xconfig.comment to reflect that redhat-config-xfree86 made the change
433
434* Fri Dec 20 2002 Brent Fox <bfox@redhat.com> 0.7.0-4
435- call mouse.read() if probing didn't return a valid DEVICE info (bug #80115)
436- import string in videocardDialog.py
437- pass hardware_state into VideocardDialog
438
439* Thu Dec 19 2002 Brent Fox <bfox@redhat.com> 0.7.0-2
440- made some ui cleanups that keeps the dialog from resizing while changing resolutions
441- removed all the autoconf stuff and replaced it with simpler Makefile and spec file
442- rebuild for completeness
443
444* Fri Dec 13 2002 Brent Fox <bfox@redhat.com> 0.7.0-1
445- pulled the classes out into their own files to make it more understandable
446
447* Tue Nov 12 2002 Michael Fulbright <msf@redhat.com> 0.6.9-1
448- migrated to new rhpl based backend
449
450* Tue Nov  5 2002 Alexander Larsson <alexl@redhat.com>
451- Fixed some small bugs
452
453* Thu Sep  5 2002 Alexander Larsson <alexl@redhat.com>
454- Require pygtk2-libglade
455
456* Fri Aug 30 2002 Jeremy Katz <katzj@redhat.com> 0.6.6-1
457- create /etc/X11/X symlink (#73108)
458
459* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 0.6.5-1
460- Fix DRI state changes. (#72255)
461
462* Tue Aug 27 2002 Alexander Larsson <alexl@redhat.com> 0.6.4-1
463- Fix XF86Option typo (#72243)
464
465* Mon Aug 26 2002 Alexander Larsson <alexl@redhat.com> 0.6.3-1
466- Fixes bug #72456
467
468* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 0.6.2-1
469- Fixed part of Bug #72275, the rest is in Gtk+.
470
471* Wed Aug 21 2002 Preston Brown <pbrown@redhat.com> 0.6.1-1
472- fixed starting tool when XF86Config is corrupt (#71461)
473
474* Fri Aug  9 2002 Alexander Larsson <alexl@redhat.com> 0.6.0-1
475- Add 640x480 to list of resolutions
476- Kluge around treeview horizontal scroll bug in videocard dialog
477- set textdomain everywhere it is needed to make i18n work
478- Try --reconfig if starting an xserver with the current config file doesn't work.
479- Tell gdm to restart server on logout after we write the config file.
480
481* Tue Aug  6 2002 Preston Brown <pbrown@redhat.com> 0.5.2-1
482- output to XF86Config (not XF86Config-4) when using --reconfig
483
484* Fri Jul 19 2002 Alexander Larsson <alexl@redhat.com>
485- Obsolete Xconfigurator
486
487* Wed Jun 26 2002 Alexander Larsson <alexl@redhat.com> 0.3.1-1
488- Updated to use configure
489
490* Mon Jun 17 2002 Alexander Larsson <alexl@redhat.com>
491- Bumped version to 0.3.0
492
493* Thu May 30 2002 Alex Larsson <alexl@redhat.com>
494- Bumped to 0.2.2
495
496* Tue May 28 2002 Alex Larsson <alexl@redhat.com>
497- Update to version 0.2.0
498
499* Thu Apr 11 2002 Alex Larsson <alexl@redhat.com> 0.1.0-1
500- Initial release
501
502* Tue Apr  9 2002 Alex Larsson <alexl@redhat.com>
503- Initial specfile
504
505
Note: See TracBrowser for help on using the repository browser.