source: projects/specs/trunk/s/system-config-display/system-config-display-vl.spec @ 5701

Revision 5701, 17.8 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1Summary: A graphical interface for configuring the X Window System display
2Summary(ja): X ウィンドウシステムのディスプレイを設定するためのグラフィカルインタフェース
3Name: system-config-display
4Version: 1.1.3
5Release: 5%{?_dist_release}
6URL: http://fedoraproject.org/wiki/SystemConfig/Tools
7License: GPL
8ExclusiveOS: Linux
9Group: System Environment/Base
10BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11BuildArch: noarch
12
13Source0: http://fedorahosted.org/releases/s/y/%{name}/%{name}-%{version}.tar.bz2
14Patch10: system-config-display-1.1.3-check-DISPLAY.patch
15
16ExcludeArch: s390 s390x
17BuildRequires: desktop-file-utils
18BuildRequires: intltool, gettext
19Requires: pygtk2 >= 1.99.11
20Requires: pygtk2-libglade
21Requires: python
22Requires: usermode >= 1.98
23Requires: usermode-gtk
24Requires: hwdata
25Requires: dbus-python
26Requires: pyxf86config >= 0.3.16
27Requires: rhpl >= 0.170-1
28Requires: rhpxl >= 0.34-1
29Requires: xorg-x11-server-Xorg
30Requires: metacity
31Requires: gtk2 >= 2.6
32Requires: hicolor-icon-theme
33
34%description
35system-config-display is a graphical application for configuring an
36X Window System X server display.
37
38%prep
39%setup -q
40%patch10 -p1
41
42for i in src/* ;do
43  perl -pi -e 's|python2|python|g' $i
44done
45
46%build
47make
48
49%install
50rm -rf $RPM_BUILD_ROOT
51make INSTROOT=$RPM_BUILD_ROOT install
52desktop-file-install --vendor "" --delete-original      \
53  --dir $RPM_BUILD_ROOT%{_datadir}/applications         \
54  --remove-category Application                         \
55  --remove-category SystemSetup                         \
56  --add-category Settings                               \
57  $RPM_BUILD_ROOT%{_datadir}/applications/system-config-display.desktop
58chmod a-x $RPM_BUILD_ROOT%{_datadir}/system-config-display/pixmaps/*
59
60%find_lang %name
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%postun
66touch --no-create %{_datadir}/icons/hicolor
67if [ -x /usr/bin/gtk-update-icon-cache -a -e %{_datadir}/icons/hicolor ]; then
68  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
69fi
70
71%post
72touch --no-create %{_datadir}/icons/hicolor
73if [ -x /usr/bin/gtk-update-icon-cache -a -e %{_datadir}/icons/hicolor ]; then
74  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
75fi
76
77
78%files -f %{name}.lang
79%defattr(-,root,root)
80%{_bindir}/system-config-display
81%{_datadir}/system-config-display
82%{_datadir}/applications/*
83%attr(0644,root,root) %config /etc/security/console.apps/system-config-display
84%attr(0644,root,root) %config /etc/pam.d/system-config-display
85%attr(0644,root,root) %{_datadir}/icons/hicolor/48x48/apps/system-config-display.png
86
87%changelog
88* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.3-5
89- rebuild with python-2.7.2
90
91* Sun May 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.3-4
92- change Requires: xorg-x11-server-Xorg instead of /usr/bin/Xorg
93
94* Sat Apr 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-3
95- rebuild for Vine 6
96
97* Mon Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-2
98- add Patch10 to run on no-X environment. (<BTS:760>)
99
100* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-1
101- new upstream release
102- remove obsolete patches
103
104* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.51-2
105- require usermode >= 1.98
106
107* Tue Aug 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.51-1
108- initial build for Vine Linux
109
110* Sun Apr 06 2008 Adam Jackson <ajax@redhat.com> 1.0.51-9
111- scd-1.0.51-backtick.patch: Fix unicode hilarity. (#441060)
112
113* Thu Mar 27 2008 Bill Nottingham <notting@redhat.com> 1.0.51-8
114- don't use rhpxl.mouse any more
115
116* Mon Feb 25 2008 Adam Jackson <ajax@redhat.com> 1.0.51-7
117- scd-1.0.51-unkudzify.patch: Replace kudzu dependency with dbus dependency.
118- Fix the chmod fix from -6 to, you know, work.
119
120* Tue Feb 12 2008 Adam Jackson <ajax@redhat.com> 1.0.51-6
121- Clear executable bit from the icons. (#429875)
122
123* Tue Jan 22 2008 Adam Jackson <ajax@redhat.com> 1.0.51-5
124- scd-1.0.51-config-util.patch: Update for new usermode. (#428397)
125
126* Mon Oct 01 2007 Adam Jackson <ajax@redhat.com> 1.0.51-4
127- Un-Require: redhat-artwork, we don't actually require it. (#314001)
128
129* Tue Jul 24 2007 Adam Jackson <ajax@redhat.com> 1.0.51-3
130- Remove ppc64 from ExcludeArch.
131
132* Wed Jun 27 2007 Matthias Clasen <mclasen@redhat.com> 1.0.51-2
133- Fix up categories in desktop file
134
135* Wed Apr 11 2007 Adam Jackson <ajax@redhat.com> 1.0.51-1
136- Load the mouse and keyboard configs from the config file, so as not to
137  clobber them. (#145316)
138
139* Wed Mar 28 2007 Jeremy Katz <katzj@redhat.com> - 1.0.50-1
140- start X server with a black background; we don't need xsri anymore
141
142* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.0.49-1
143- Package review cleanups.
144
145* Mon Jan 29 2007 Adam Jackson <ajax@redhat.com>
146- Copy instead of rename when doing backup of xorg.conf, in case the user has
147  it as a symlink. (#181965)
148
149* Fri Dec 15 2006 Adam Jackson <ajax@redhat.com> 1.0.48-2
150- Rebuild for translations.
151
152* Fri Dec 8 2006 Adam Jackson <ajax@redhat.com>
153- Add dist tag to Release.
154
155* Thu Dec 7 2006 Adam Jackson <ajax@redhat.com> 1.0.48-1
156- Import old driver list code from rhpxl. (#218241)
157
158* Wed Dec 6 2006 Adam Jackson <ajax@redhat.com> 1.0.47-1
159- Fail gracefully on machines with no video.
160
161* Tue Nov 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.0.46-1
162- Fix mnemonic for the color depth combo on the last tab (#216391)
163
164* Wed Sep 13 2006 Adam Jackson <ajackson@redhat.com> 1.0.45-1
165- Refresh the mode state before first paint, to give rhpxl a chance to ask
166  RANDR for the current mode.
167
168* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.0.44-1
169- Unpack properly when given a refresh rate instead of a refresh range.
170
171* Fri Aug 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.43-1
172- Drop 8bpp support.
173- Simplify monitor selection view.
174- Fix initial window sizing to be large enough for all fields.
175
176* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.0.42-1
177- Align lists correctly in RTL locales.  (#202754)
178
179* Thu Aug  3 2006 Bill Nottingham <notting@redhat.com> 1.0.41-1
180- adjust to new rhpxl (<clumens@redhat.com>)
181- work with newer, sparser, config files
182- when dealing with autoprobed monitors, pull current resolution from randr
183
184* Wed Jul 26 2006 Chris Lumens <clumens@redhat.com> 1.0.38-1
185- Fix CHARSET in te and kn translations (#200203).
186- Add gettext to buildrequires.
187
188* Thu Mar 09 2006 Chris Lumens <clumens@redhat.com> 1.0.37-2
189- Add back spec file parts that got lost on last rebuild.
190
191* Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 1.0.37-1
192- Initialize monitor name label to something other than unknown if we
193  really know what it is.
194
195* Fri Mar 03 2006 Martin Stransky <stransky@redhat.com> 1.0.36-3
196- added pam fix (#170625)
197- fix prereq (#182861, #182862)
198
199* Wed Feb 22 2006 Chris Lumens <clumens@redhat.com> 1.0.36-2
200- Add rhpxl to requires
201
202* Fri Jan 27 2006 Paul Nasrat <pnasrat@redhat.com> - 1.0.36-1
203- Rebuild for translations
204- Fix reconfig mode
205
206* Thu Jan 12 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.35-1
207- Rebuild
208
209* Tue Jan 10 2006 Soren Sandmann <sandmann@redhat.com> - 1.0.34-1
210- Some s/rhpl/rhpxl/ type changes
211
212* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> - 1.0.33-1
213- minor changes needed for modular X
214
215* Wed Sep 21 2005 Bill Nottingham <notting@redhat.com> 1.0.32-1
216- Fix up some leftover code that still needed migration (#168932)
217
218* Fri Sep  9 2005 Bill Nottingham <notting@redhat.com> 1.0.31-1
219- Adapt to new kudzu video driver probing, and new rhpl
220
221* Mon Jun 27 2005 Soren Sandmann <sandmann@redhat.com> 1.0.30-1
222- Add ppc64 to ExcludeArchs
223
224* Mon May 23 2005 Jeremy Katz <katzj@redhat.com> - 1.0.29-1
225- put scriptlets from distcvs in this specfile
226
227* Mon May 23 2005 Jeremy Katz <katzj@redhat.com> - 1.0.28-1
228- fix typo in cleanup leading to traceback (#157423)
229
230* Thu Apr 28 2005 Soren Sandmann <sandmann@redhat.com> 1.0.26-1
231- Clean up deprecation warnings (#153937)
232
233* Tue Jan 04 2005 Paul Nasrat <pnasrat@redhat.com> 1.0.25-1
234- Only merge hardware_state if defined (#143944)
235- Only print card if verbose (#143271)
236
237* Mon Nov 15 2004 Paul Nasrat <pnasrat@redhat.com> 1.0.24-1
238- Dual Head patch for testing thanks to Marc Andre Morissette (#136916)
239
240* Tue Oct 19 2004 Paul Nasrat <pnasrat@redhat.com> 1.0.23-1
241- Firstboot - re-read config so both kbd and display changes persist (#135361)
242
243* Thu Oct 14 2004 Paul Nasrat <pnasrat@redhat.com> 1.0.22-1
244- Depth callback patch from twaugh (#128650)
245
246* Fri Oct 01 2004 Paul Nasrat <pnasrat@redhat.com> 1.0.21-1
247- fix mouse traceback
248
249* Tue Sep 07 2004 Paul Nasrat <pnasrat@redhat.com> - 1.0.20-1
250- Refactor some stuff into rhpl
251- Don't override driver changes unless in reconfig (#127779)
252 
253* Tue Sep 07 2004 Paul Nasrat <pnasrat@redhat.com> - 1.0.19-1
254- Translatable desktop
255- Layout changes for firstboot screen
256
257* Thu Aug 19 2004 Paul Nasrat <pnasrat@redhat.com> - 1.0.18-2
258- Ensure selection string translatable
259
260* Thu Aug 19 2004 Paul Nasrat <pnasrat@redhat.com> - 1.0.18-1
261- Monitor selection for first boot
262
263* Fri Jun 25 2004 Brent Fox <bfox@redhat.com> - 1.0.17-1
264- initialize self.probed_path in videocardDialog.py (bug #113695)
265
266* Wed Jun 23 2004 Brent Fox <bfox@redhat.com> - 1.0.16-1
267- reduce size of monitor-off.png and monitor-on.png to fit in 640x480 (bug #122142)
268
269* Mon Jun 14 2004 Brent Fox <bfox@redhat.com> - 1.0.15-2
270- set the text domain for xconf.py and xConfigDialog.py (bug #123494)
271
272* Wed Jun  2 2004 Alex Larsson <alexl@redhat.com> 1.0.15-1
273- fix --reconfig and catch some exceptions for readonly root
274
275* Tue May 25 2004 Brent Fox <bfox@redhat.com> 1.0.14-2
276- add BuildRequires for desktop-file-utils (bug# 124181)
277
278* Fri Apr 30 2004 Brent Fox <bfox@redhat.com> 1.0.14-1
279- do not write out extra XF86Config file during firstboot (bug #121729)
280
281* Tue Apr 20 2004 Brent Fox <bfox@redhat.com> 1.0.13-3
282- Do not write out XkbRules line to config file, as it is unnecessary to hard
283  code the rules file, which has a built in default which should always
284  work. (#120858)
285
286* Wed Apr 14 2004 Brent Fox <bfox@redhat.com> 1.0.13-2
287- update requires for new pyxf86config
288
289* Tue Apr 13 2004 Brent Fox <bfox@redhat.com> 1.0.13-1
290- make changes for XFree86 -> Xorg conversion
291
292* Thu Apr  8 2004 Brent Fox <bfox@redhat.com> 1.0.12-2
293- fix icon path (bug #120174)
294
295* Tue Mar 23 2004 Brent Fox <bfox@redhat.com> 1.0.12-1
296- filter out duplicate monitor entries (bug #118976)
297
298* Wed Mar 17 2004 Mike A. Harris <mharris@redhat.com> 1.0.11-1
299- Change Requires: XFree86 to Requires: /usr/X11R6/bin/XFree86, which is
300  what it appears from the sources is being called.  That will need to change
301  when the server gets renamed, so it should be implemented IMHO in a way
302  that is not hard coded.  This should suffice for now however.
303- Changed package description to remove "XFree86" name and replace it with
304  generic "X Window System X server" term.
305- Added the "via", and "voodoo" drivers that were missing to internal driver
306  list in videocardDialog.py.  The list is still missing stuff though, but
307  those sprung to mind.
308- Added force-tag target to Makefile with tag -cF
309- Added tag target without -F to Makefile
310- Removed -F from archive target as that can potentially blow away an already
311  tagged and released version from the repository if someone accidentally
312  does a "make archive" without updating the spec file Version: field like
313  I just about did.  ;o)
314
315* Mon Mar  1 2004 Brent Fox <bfox@redhat.com> 1.0.10-1
316- sanity check the monitor selection (bug #112314)
317
318* Mon Mar  1 2004 Brent Fox <bfox@redhat.com> 1.0.9-3
319- remove Requires on system-config-mouse
320
321* Fri Feb 27 2004 Brent Fox <bfox@redhat.com> 1.0.9-2
322- another stab at the dual-head code
323
324* Thu Feb 26 2004 Brent Fox <bfox@redhat.com> 1.0.9-1
325- write out "Screen" entry for dual-head cards
326
327* Tue Feb 24 2004 Brent Fox <bfox@redhat.com> 1.0.8-1
328- start up metacity to make the windows look nice (bug #108206)
329
330* Thu Feb 19 2004 Brent Fox <bfox@redhat.com> 1.0.7-1
331- don't import rhpl.mouse in xconf.py
332
333* Tue Feb 17 2004 Brent Fox <bfox@redhat.com> 1.0.6-1
334- write XF86Config to the correct path (bug #115501)
335
336* Fri Jan 30 2004 Brent Fox <bfox@redhat.com> 1.0.5-1
337- correct naming in the spec file description
338
339* Thu Dec  4 2003 Brent Fox <bfox@redhat.com> 1.0.4-1
340- add code to apply changes made in the firstboot display screen
341
342* Tue Dec  2 2003 Brent Fox <bfox@redhat.com> 1.0.3-1
343- add code to pull display notebook page into firstboot
344
345* Thu Nov 20 2003 Brent Fox <bfox@redhat.com> 1.0.2-1
346- fix path problem
347
348* Wed Nov 19 2003 Brent Fox <bfox@redhat.com> 1.0.1-1
349- rename from redhat-config-xfree86 to system-config-display
350- add Obsoletes for redhat-config-xfree86
351- make changes for Python2
352
353* Thu Oct 23 2003 Brent Fox <bfox@redhat.com> 0.9.15-1
354- work around cards with no driver entries (bug #106501)
355
356* Thu Oct 23 2003 Brent Fox <bfox@redhat.com> 0.9.14-1
357- check length of list before removing items (bug #107790)
358
359* Thu Oct 16 2003 Brent Fox <bfox@redhat.com> 0.9.13-1
360- allow dualhead to be disabled (bug #107261)
361
362* Wed Oct 15 2003 Brent Fox <bfox@redhat.com> 0.9.12-1
363- fix bug #106884 for real this time
364
365* Tue Oct 14 2003 Brent Fox <bfox@redhat.com> 0.9.11-1
366- package lightrays.png inside redhat-config-xfree86
367
368* Mon Oct 13 2003 Brent Fox <bfox@redhat.com> 0.9.10-1
369- make sure current is initialized (bug #106884)
370
371* Mon Oct  6 2003 Brent Fox <bfox@redhat.com> 0.9.9-3
372- add a Requires for XFree86 (bug #105992)
373
374* Mon Oct  6 2003 Brent Fox <bfox@redhat.com> 0.9.9-2
375- finish up the dual-head code
376- catch case of having no layout options
377
378* Thu Oct  2 2003 Brent Fox <bfox@redhat.com> 0.9.9-1
379- first stab at multihead code
380- commit some additional monitor icons
381
382* Thu Aug 14 2003 Brent Fox <bfox@redhat.com> 0.9.8-1
383- tag on every build
384
385* Thu Jun  5 2003 Brent Fox <bfox@redhat.com> 0.9.7-1
386- see if we have the name for an unprobed monitor
387
388* Tue Jun  3 2003 Brent Fox <bfox@redhat.com> 0.9.6-1
389- only offer the resolutions that we know to be reasonable for the selected monitor (bug #88269)
390
391* Fri May 30 2003 Brent Fox <bfox@redhat.com> 0.9.5-1
392- big UI changes
393- make room in the UI for multihead stuff
394
395* Wed May 28 2003 Brent Fox <bfox@redhat.com> 0.7.6-1
396- add an ExcludeArch for s390 and s390x (bug #91811)
397
398* Fri May 23 2003 Brent Fox <bfox@redhat.com> 0.7.5-1
399- turn on horizontal scrolling in videocard window
400- initialize dpi measurement option menu correctly (bug #90190)
401
402* Wed May 21 2003 Michael Fulbright <msf@redhat.com> 0.7.4-1
403- converted to use new way of representing Generic monitors in MonitorsDB
404
405* Tue Feb  4 2003 Brent Fox <bfox@redhat.com> 0.7.3-2
406- paint the background with lightrays.png
407
408* Thu Jan 30 2003 Brent Fox <bfox@redhat.com> 0.7.3-1
409- bump and build
410
411* Tue Jan 21 2003 Brent Fox <bfox@redhat.com> 0.7.2-3
412- add closing parenthesis (bug #80398)
413
414* Mon Jan 20 2003 Brent Fox <bfox@redhat.com> 0.7.2-2
415- iterate through available video cards until one works
416- clean up the output
417
418* Fri Jan 17 2003 Brent Fox <bfox@redhat.com> 0.7.1-6
419- make monitor dialog a little larger and allow horz. scrolling (bug #82112)
420
421* Tue Jan 14 2003 Brent Fox <bfox@redhat.com> 0.7.1-5
422- fixed desktop file icon
423
424* Thu Jan  9 2003 Jeremy Katz <katzj@redhat.com> 0.7.1-4
425- import rhpl.monitor
426
427* Mon Jan  6 2003 Brent Fox <bfox@redhat.com> 0.7.1-3
428- try to read the XMOUSETYPE from /etc/sysconfig/mouse (bug #74992)
429
430* Sun Jan  5 2003 Brent Fox <bfox@redhat.com> 0.7.1-2
431- fix the dialog centering code
432- connect the resolution menu to update_ui so the screenshot gets refreshed
433
434* Sun Jan  5 2003 Brent Fox <bfox@redhat.com> 0.7.1-1
435- change radio buttons to OptionMenus
436
437* Fri Jan  3 2003 Brent Fox <bfox@redhat.com> 0.7.0-6
438- default to us keyboard if /etc/sysconfig/keyboard contains a keyboard unknown to rhpl (bug #80993)
439
440* Sun Dec 22 2002 Brent Fox <bfox@redhat.com> 0.7.0-5
441- change xconfig.comment to reflect that redhat-config-xfree86 made the change
442
443* Fri Dec 20 2002 Brent Fox <bfox@redhat.com> 0.7.0-4
444- call mouse.read() if probing didn't return a valid DEVICE info (bug #80115)
445- import string in videocardDialog.py
446- pass hardware_state into VideocardDialog
447
448* Thu Dec 19 2002 Brent Fox <bfox@redhat.com> 0.7.0-2
449- made some ui cleanups that keeps the dialog from resizing while changing resolutions
450- removed all the autoconf stuff and replaced it with simpler Makefile and spec file
451- rebuild for completeness
452
453* Fri Dec 13 2002 Brent Fox <bfox@redhat.com> 0.7.0-1
454- pulled the classes out into their own files to make it more understandable
455
456* Tue Nov 12 2002 Michael Fulbright <msf@redhat.com> 0.6.9-1
457- migrated to new rhpl based backend
458
459* Tue Nov  5 2002 Alexander Larsson <alexl@redhat.com>
460- Fixed some small bugs
461
462* Thu Sep  5 2002 Alexander Larsson <alexl@redhat.com>
463- Require pygtk2-libglade
464
465* Fri Aug 30 2002 Jeremy Katz <katzj@redhat.com> 0.6.6-1
466- create /etc/X11/X symlink (#73108)
467
468* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 0.6.5-1
469- Fix DRI state changes. (#72255)
470
471* Tue Aug 27 2002 Alexander Larsson <alexl@redhat.com> 0.6.4-1
472- Fix XF86Option typo (#72243)
473
474* Mon Aug 26 2002 Alexander Larsson <alexl@redhat.com> 0.6.3-1
475- Fixes bug #72456
476
477* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 0.6.2-1
478- Fixed part of Bug #72275, the rest is in Gtk+.
479
480* Wed Aug 21 2002 Preston Brown <pbrown@redhat.com> 0.6.1-1
481- fixed starting tool when XF86Config is corrupt (#71461)
482
483* Fri Aug  9 2002 Alexander Larsson <alexl@redhat.com> 0.6.0-1
484- Add 640x480 to list of resolutions
485- Kluge around treeview horizontal scroll bug in videocard dialog
486- set textdomain everywhere it is needed to make i18n work
487- Try --reconfig if starting an xserver with the current config file doesn't work.
488- Tell gdm to restart server on logout after we write the config file.
489
490* Tue Aug  6 2002 Preston Brown <pbrown@redhat.com> 0.5.2-1
491- output to XF86Config (not XF86Config-4) when using --reconfig
492
493* Fri Jul 19 2002 Alexander Larsson <alexl@redhat.com>
494- Obsolete Xconfigurator
495
496* Wed Jun 26 2002 Alexander Larsson <alexl@redhat.com> 0.3.1-1
497- Updated to use configure
498
499* Mon Jun 17 2002 Alexander Larsson <alexl@redhat.com>
500- Bumped version to 0.3.0
501
502* Thu May 30 2002 Alex Larsson <alexl@redhat.com>
503- Bumped to 0.2.2
504
505* Tue May 28 2002 Alex Larsson <alexl@redhat.com>
506- Update to version 0.2.0
507
508* Thu Apr 11 2002 Alex Larsson <alexl@redhat.com> 0.1.0-1
509- Initial release
510
511* Tue Apr  9 2002 Alex Larsson <alexl@redhat.com>
512- Initial specfile
513
514
Note: See TracBrowser for help on using the repository browser.