source: projects/specs/trunk/s/syslinux/syslinux-vl.spec @ 5805

Revision 5805, 7.3 KB checked in by daisuke, 12 years ago (diff)

update to 4.05

Line 
1Summary: Simple kernel loader which uses a FAT ot iso9660 filesystem ot a PXE network
2Summary(ja): FAT/iso9660 ファイルシステムまたは PXE ネットワークを利用するシンプルなカーネルローダー
3Name: syslinux
4Version: 4.05
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: Applications/System
8Source0: ftp://ftp.kernel.org/pub/linux/utils/boot/syslinux/%{name}-%{version}.tar.xz
9URL: http://syslinux.zytor.com/
10ExclusiveArch: %{ix86} x86_64
11Buildroot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: nasm, perl, netpbm-progs
13BuildRequires: libuuid-devel
14Requires: mtools
15
16Vendor: Project Vine
17Distribution: Vine Linux
18Packager: daisuke, shaolin
19
20
21%description
22SYSLINUX is a suite of bootloaders, currently supporting DOS FAT filesystems,
23Linux ext2/ext3 filesystems (EXTLINUX), PXE network boots
24(PXELINUX), or ISO 9660 CD-ROMs (ISOLINUX).  It also includes a tool,
25MEMDISK, which loads legacy operating systems from these media.
26
27%description -l ja
28SYSLINUX はカーネルローダー集です。現在は FAT ファイルシステム、Linux の
29ext2/ext3 ファイルシステム(EXTLINUX)、PXE ネットワークブート (PXELINUX) および
30ISO 9660 CDROM (ISOLINUX) に対応しています。
31
32
33%package perl
34Summary: Syslinux tools written in perl
35Summary(ja): Syslinux の perl ツール集
36Group: Applications/System
37
38%description perl
39Syslinux tools written in perl
40
41
42%package devel
43Summary: Headers and libraries for syslinux development.
44Summary(ja): Syslinux 開発用ヘッダとライブラリ
45Group: Development/Libraries
46
47%description devel
48Headers and libraries for syslinux development.
49
50
51%package extlinux
52Summary: The EXTLINUX bootloader, for booting the local system.
53Summary(ja): EXTLINUX ブートローダ
54Group: System/Boot
55Requires: syslinux
56
57%description extlinux
58The EXTLINUX bootloader, for booting the local system, as well as all
59the SYSLINUX/PXELINUX modules in /boot.
60
61
62%package tftpboot
63Summary: SYSLINUX modules in /tftpboot, available for network booting
64Summary(ja): ネットワークブート用 SYSLINUX モジュール
65Group: Applications/Internet
66Requires: syslinux
67
68%description tftpboot
69All the SYSLINUX/PXELINUX modules directly available for network
70booting in the /tftpboot directory.
71
72
73%prep
74%setup -q -n syslinux-%{version}
75
76
77%build
78make clean
79make installer
80make -C sample tidy
81
82
83%install
84rm -rf %{buildroot}
85
86mkdir -p %{buildroot}%{_bindir}
87mkdir -p %{buildroot}%{_sbindir}
88mkdir -p %{buildroot}%{_syssbindir}
89mkdir -p %{buildroot}%{_libdir}/syslinux
90mkdir -p %{buildroot}%{_includedir}
91make install-all \
92        INSTALLROOT=%{buildroot} BINDIR=%{_bindir} SBINDIR=%{_syssbindir} \
93        LIBDIR=%{_prefix}/lib DATADIR=%{_datadir} \
94        MANDIR=%{_mandir} INCDIR=%{_includedir} \
95        TFTPBOOT=/tftpboot EXTLINUXDIR=/boot/extlinux
96
97install -m 755 linux/syslinux-nomtools %{buildroot}%{_datadir}/syslinux
98install -m 755 linux/syslinux %{buildroot}%{_datadir}/syslinux
99
100mkdir -p %{buildroot}/%{_docdir}/%{name}-%{version}/sample
101install -m 644 sample/sample.* %{buildroot}/%{_docdir}/%{name}-%{version}/sample/
102mkdir -p %{buildroot}/etc
103( cd %{buildroot}/etc && ln -s ../boot/extlinux/extlinux.conf . )
104
105# don't ship libsyslinux, at least, not for now
106rm -f %{buildroot}%{_prefix}/lib/libsyslinux*
107rm -f %{buildroot}%{_includedir}/syslinux.h
108
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113
114%files
115%defattr(-,root,root)
116%doc NEWS README* COPYING
117%doc doc/*
118%doc sample
119%{_mandir}/man1/gethostip*
120%{_mandir}/man1/syslinux*
121%{_mandir}/man1/extlinux*
122%{_bindir}/gethostip
123%{_bindir}/isohybrid
124%{_bindir}/memdiskfind
125%{_bindir}/syslinux
126%dir %{_datadir}/syslinux
127%{_datadir}/syslinux/*.com
128%{_datadir}/syslinux/*.exe
129%{_datadir}/syslinux/*.c32
130%{_datadir}/syslinux/*.bin
131%{_datadir}/syslinux/*.0
132%{_datadir}/syslinux/memdisk
133%dir %{_datadir}/syslinux/dosutil
134%{_datadir}/syslinux/dosutil/*
135%{_datadir}/syslinux/syslinux
136%{_datadir}/syslinux/syslinux-nomtools
137%dir %{_datadir}/syslinux/diag
138%{_datadir}/syslinux/diag/*
139
140%files perl
141%defattr(-,root,root)
142%{_mandir}/man1/lss16toppm*
143%{_mandir}/man1/ppmtolss16*
144%{_mandir}/man1/syslinux2ansi*
145%{_bindir}/keytab-lilo
146%{_bindir}/lss16toppm
147%{_bindir}/md5pass
148%{_bindir}/mkdiskimage
149%{_bindir}/ppmtolss16
150%{_bindir}/pxelinux-options
151%{_bindir}/sha1pass
152%{_bindir}/syslinux2ansi
153%{_bindir}/isohybrid.pl
154
155
156%files devel
157%defattr(-,root,root)
158%dir %{_datadir}/syslinux/com32
159%{_datadir}/syslinux/com32/*
160
161
162%files extlinux
163%{_syssbindir}/extlinux
164/boot/extlinux
165%config /etc/extlinux.conf
166
167
168%files tftpboot
169/tftpboot
170
171
172%post extlinux
173# If we have a /boot/extlinux.conf file, assume extlinux is our bootloader
174# and update it.
175if [ -f /boot/extlinux/extlinux.conf ]; then \
176        extlinux --update /boot/extlinux ; \
177elif [ -f /boot/extlinux.conf ]; then \
178        mkdir -p /boot/extlinux && \
179        mv /boot/extlinux.conf /boot/extlinux/extlinux.conf && \
180        extlinux --update /boot/extlinux ; \
181fi
182
183
184%changelog
185* Mon Feb 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.05-1
186- update to 4.05
187- add BR: libuuid-devel
188
189* Mon Jun 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.04-1
190- update to 4.04
191
192* Tue Jan 11 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.03-1
193- new upstream release
194
195* Sun Sep 26 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.02-2
196- remove Obsoletes: syslinux-devel
197
198* Sat Sep 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.02-1
199- new upstream release
200- split out -devel/perl/extlinux/tftpboot subpackages
201
202* Sat Nov 28 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.83-1
203- new upstream release
204
205* Fri Jun 12 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.82-1
206- new upstream release w/ bugfixes
207
208* Thu May 14 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.80-1
209- new upstream release 3.80 w/ dozens of bugfixes and new features :)
210
211* Thu Dec 11 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.63-3
212- add missing files to the filelist
213
214* Fri May 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.63-2
215- spec in UTF-8
216
217* Mon May 19 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.63-1
218- updated to new upstream release
219
220* Wed Nov 21 2007 Shu KONNO <owa@bg.wakwak.com> 3.53-0vl1
221- new upstream source
222
223* Wed May 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.07-0vl1
224- new upstream source
225- add extlinux
226- remove and obsolete syslinux-devel
227
228* Fri Dec 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13-0vl1
229- new upstream release
230
231* Fri Jun 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10-0vl1
232- new upstream release
233
234* Wed Mar 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.52-2vl1
235- rebuild for Vine Linux
236
237* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
238- Bump release + rebuild.
239
240* Sat Feb 10 2001 Matt Wilson <msw@redhat.com>
241- 1.52
242
243* Wed Jan 24 2001 Matt Wilson <msw@redhat.com>
244- 1.51pre7
245
246* Mon Jan 22 2001 Matt Wilson <msw@redhat.com>
247- 1.51pre5
248
249* Fri Jan 19 2001 Matt Wilson <msw@redhat.com>
250- 1.51pre3, with e820 detection
251
252* Tue Dec 12 2000 Than Ngo <than@redhat.com>
253- rebuilt with fixed fileutils
254
255* Thu Nov 9 2000 Than Ngo <than@redhat.com>
256- update to 1.49
257- update ftp site
258- clean up specfile
259- add some useful documents
260
261* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
262- add %%defattr (release 4)
263
264* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
265- automatic rebuild
266
267* Thu Jul 06 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
268- use %%{_tmppath}
269- change application group (Applications/Internet doesn't seem
270  right to me)
271- added BuildRequires
272
273* Tue Apr 04 2000 Erik Troan <ewt@redhat.com>
274- initial packaging
Note: See TracBrowser for help on using the repository browser.