source: projects/specs/trunk/s/syslinux/syslinux-vl.spec @ 9006

Revision 9006, 7.5 KB checked in by inagaki, 10 years ago (diff)

2014-10-12 Ryoichi INAGAKI <ryo1@…>

  • libcgroup, libwebp, libyaml: fixed Group
  • syslinux: updated


Line 
1Summary: Simple kernel loader which uses a FAT ot iso9660 filesystem ot a PXE network
2Summary(ja): FAT/iso9660 ファイルシステムまたは PXE ネットワークを利用するシンプルなカーネルローダー
3Name: syslinux
4Version: 4.07
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: Applications/System
8Source0: ftp://ftp.kernel.org/pub/linux/utils/boot/syslinux/%{name}-%{version}.tar.xz
9URL: http://syslinux.zytor.com/
10ExclusiveArch: %{ix86} x86_64
11Buildroot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: nasm, perl, netpbm-progs
13BuildRequires: libuuid-devel
14Requires: mtools
15
16Vendor: Project Vine
17Distribution: Vine Linux
18Packager: daisuke, shaolin
19
20%description
21SYSLINUX is a suite of bootloaders, currently supporting DOS FAT filesystems,
22Linux ext2/ext3 filesystems (EXTLINUX), PXE network boots
23(PXELINUX), or ISO 9660 CD-ROMs (ISOLINUX).  It also includes a tool,
24MEMDISK, which loads legacy operating systems from these media.
25
26%description -l ja
27SYSLINUX はカーネルローダー集です。現在は FAT ファイルシステム、Linux の
28ext2/ext3 ファイルシステム(EXTLINUX)、PXE ネットワークブート (PXELINUX) および
29ISO 9660 CDROM (ISOLINUX) に対応しています。
30
31
32%package perl
33Summary: Syslinux tools written in perl
34Summary(ja): Syslinux の perl ツール集
35Group: Applications/System
36
37%description perl
38Syslinux tools written in perl
39
40
41%package devel
42Summary: Headers and libraries for syslinux development.
43Summary(ja): Syslinux 開発用ヘッダとライブラリ
44Group: Development/Libraries
45
46%description devel
47Headers and libraries for syslinux development.
48
49
50%package extlinux
51Summary: The EXTLINUX bootloader, for booting the local system.
52Summary(ja): EXTLINUX ブートローダ
53Group: Applications/System
54Requires: syslinux
55
56%description extlinux
57The EXTLINUX bootloader, for booting the local system, as well as all
58the SYSLINUX/PXELINUX modules in /boot.
59
60
61%package tftpboot
62Summary: SYSLINUX modules in /tftpboot, available for network booting
63Summary(ja): ネットワークブート用 SYSLINUX モジュール
64Group: Applications/Internet
65Requires: syslinux
66
67%description tftpboot
68All the SYSLINUX/PXELINUX modules directly available for network
69booting in the /tftpboot directory.
70
71
72%prep
73%setup -q -n syslinux-%{version}
74
75
76%build
77make clean
78make installer
79make -C sample tidy
80
81
82%install
83rm -rf %{buildroot}
84
85mkdir -p %{buildroot}%{_bindir}
86mkdir -p %{buildroot}%{_sbindir}
87mkdir -p %{buildroot}%{_syssbindir}
88mkdir -p %{buildroot}%{_libdir}/syslinux
89mkdir -p %{buildroot}%{_includedir}
90make install-all \
91        INSTALLROOT=%{buildroot} BINDIR=%{_bindir} SBINDIR=%{_syssbindir} \
92        LIBDIR=%{_prefix}/lib DATADIR=%{_datadir} \
93        MANDIR=%{_mandir} INCDIR=%{_includedir} \
94        TFTPBOOT=/tftpboot EXTLINUXDIR=/boot/extlinux
95
96install -m 755 linux/syslinux-nomtools %{buildroot}%{_datadir}/syslinux
97install -m 755 linux/syslinux %{buildroot}%{_datadir}/syslinux
98
99mkdir -p %{buildroot}/%{_docdir}/%{name}-%{version}/sample
100install -m 644 sample/sample.* %{buildroot}/%{_docdir}/%{name}-%{version}/sample/
101mkdir -p %{buildroot}/etc
102( cd %{buildroot}/etc && ln -s ../boot/extlinux/extlinux.conf . )
103
104# don't ship libsyslinux, at least, not for now
105rm -f %{buildroot}%{_prefix}/lib/libsyslinux*
106rm -f %{buildroot}%{_includedir}/syslinux.h
107
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112
113%files
114%defattr(-,root,root)
115%doc NEWS README* COPYING
116%doc doc/*
117%doc sample
118%{_mandir}/man1/gethostip*
119%{_mandir}/man1/syslinux*
120%{_mandir}/man1/extlinux*
121%{_bindir}/gethostip
122%{_bindir}/isohybrid
123%{_bindir}/memdiskfind
124%{_bindir}/syslinux
125%dir %{_datadir}/syslinux
126%{_datadir}/syslinux/*.com
127%{_datadir}/syslinux/*.exe
128%{_datadir}/syslinux/*.c32
129%{_datadir}/syslinux/*.bin
130%{_datadir}/syslinux/*.0
131%{_datadir}/syslinux/memdisk
132%dir %{_datadir}/syslinux/dosutil
133%{_datadir}/syslinux/dosutil/*
134%{_datadir}/syslinux/syslinux
135%{_datadir}/syslinux/syslinux-nomtools
136%dir %{_datadir}/syslinux/diag
137%{_datadir}/syslinux/diag/*
138
139%files perl
140%defattr(-,root,root)
141%{_mandir}/man1/lss16toppm*
142%{_mandir}/man1/ppmtolss16*
143%{_mandir}/man1/syslinux2ansi*
144%{_bindir}/keytab-lilo
145%{_bindir}/lss16toppm
146%{_bindir}/md5pass
147%{_bindir}/mkdiskimage
148%{_bindir}/ppmtolss16
149%{_bindir}/pxelinux-options
150%{_bindir}/sha1pass
151%{_bindir}/syslinux2ansi
152%{_bindir}/isohybrid.pl
153
154
155%files devel
156%defattr(-,root,root)
157%dir %{_datadir}/syslinux/com32
158%{_datadir}/syslinux/com32/*
159
160
161%files extlinux
162%{_syssbindir}/extlinux
163/boot/extlinux
164%config /etc/extlinux.conf
165
166
167%files tftpboot
168/tftpboot
169
170
171%post extlinux
172# If we have a /boot/extlinux.conf file, assume extlinux is our bootloader
173# and update it.
174if [ -f /boot/extlinux/extlinux.conf ]; then \
175        extlinux --update /boot/extlinux ; \
176elif [ -f /boot/extlinux.conf ]; then \
177        mkdir -p /boot/extlinux && \
178        mv /boot/extlinux.conf /boot/extlinux/extlinux.conf && \
179        extlinux --update /boot/extlinux ; \
180fi
181
182
183%changelog
184* Sun Oct 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.07-1
185- updated to 4.07
186- moved extlinux subpackage to Applications/System Group
187
188* Mon Feb 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.05-1
189- update to 4.05
190- add BR: libuuid-devel
191
192* Mon Jun 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.04-1
193- update to 4.04
194
195* Tue Jan 11 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.03-1
196- new upstream release
197
198* Sun Sep 26 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.02-2
199- remove Obsoletes: syslinux-devel
200
201* Sat Sep 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.02-1
202- new upstream release
203- split out -devel/perl/extlinux/tftpboot subpackages
204
205* Sat Nov 28 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.83-1
206- new upstream release
207
208* Fri Jun 12 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.82-1
209- new upstream release w/ bugfixes
210
211* Thu May 14 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.80-1
212- new upstream release 3.80 w/ dozens of bugfixes and new features :)
213
214* Thu Dec 11 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.63-3
215- add missing files to the filelist
216
217* Fri May 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.63-2
218- spec in UTF-8
219
220* Mon May 19 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.63-1
221- updated to new upstream release
222
223* Wed Nov 21 2007 Shu KONNO <owa@bg.wakwak.com> 3.53-0vl1
224- new upstream source
225
226* Wed May 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.07-0vl1
227- new upstream source
228- add extlinux
229- remove and obsolete syslinux-devel
230
231* Fri Dec 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13-0vl1
232- new upstream release
233
234* Fri Jun 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10-0vl1
235- new upstream release
236
237* Wed Mar 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.52-2vl1
238- rebuild for Vine Linux
239
240* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
241- Bump release + rebuild.
242
243* Sat Feb 10 2001 Matt Wilson <msw@redhat.com>
244- 1.52
245
246* Wed Jan 24 2001 Matt Wilson <msw@redhat.com>
247- 1.51pre7
248
249* Mon Jan 22 2001 Matt Wilson <msw@redhat.com>
250- 1.51pre5
251
252* Fri Jan 19 2001 Matt Wilson <msw@redhat.com>
253- 1.51pre3, with e820 detection
254
255* Tue Dec 12 2000 Than Ngo <than@redhat.com>
256- rebuilt with fixed fileutils
257
258* Thu Nov 9 2000 Than Ngo <than@redhat.com>
259- update to 1.49
260- update ftp site
261- clean up specfile
262- add some useful documents
263
264* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
265- add %%defattr (release 4)
266
267* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
268- automatic rebuild
269
270* Thu Jul 06 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
271- use %%{_tmppath}
272- change application group (Applications/Internet doesn't seem
273  right to me)
274- added BuildRequires
275
276* Tue Apr 04 2000 Erik Troan <ewt@redhat.com>
277- initial packaging
Note: See TracBrowser for help on using the repository browser.