source: projects/specs/trunk/s/syslinux/syslinux-vl.spec @ 1907

Revision 1907, 7.0 KB checked in by shaolin, 14 years ago (diff)
  • syslinux: remove Obsoletes: syslinux-devel
Line 
1Summary: Simple kernel loader which uses a FAT ot iso9660 filesystem ot a PXE network
2Summary(ja): FAT/iso9660 ファイルシステムまたは PXE ネットワークを利用するシンプルなカーネルローダー
3Name: syslinux
4Version: 4.02
5Release: 2%{?_dist_release}
6License: GPLv2+
7Group: Applications/System
8Source0: ftp://ftp.kernel.org/pub/linux/utils/boot/syslinux/%{name}-%{version}.tar.bz2
9URL: http://syslinux.zytor.com/
10ExclusiveArch: %{ix86} x86_64
11Buildroot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: nasm, perl, netpbm-progs
13Requires: mtools
14
15Vendor: Project Vine
16Distribution: Vine Linux
17Packager: daisuke, shaolin
18
19
20%description
21SYSLINUX is a suite of bootloaders, currently supporting DOS FAT filesystems,
22Linux ext2/ext3 filesystems (EXTLINUX), PXE network boots
23(PXELINUX), or ISO 9660 CD-ROMs (ISOLINUX).  It also includes a tool,
24MEMDISK, which loads legacy operating systems from these media.
25
26%description -l ja
27SYSLINUX はカーネルローダー集です。現在は FAT ファイルシステム、Linux の
28ext2/ext3 ファイルシステム(EXTLINUX)、PXE ネットワークブート (PXELINUX) および
29ISO 9660 CDROM (ISOLINUX) に対応しています。
30
31
32%package perl
33Summary: Syslinux tools written in perl
34Summary(ja): Syslinux の perl ツール集
35Group: Applications/System
36
37%description perl
38Syslinux tools written in perl
39
40
41%package devel
42Summary: Headers and libraries for syslinux development.
43Summary(ja): Syslinux 開発用ヘッダとライブラリ
44Group: Development/Libraries
45
46%description devel
47Headers and libraries for syslinux development.
48
49
50%package extlinux
51Summary: The EXTLINUX bootloader, for booting the local system.
52Summary(ja): EXTLINUX ブートローダ
53Group: System/Boot
54Requires: syslinux
55
56%description extlinux
57The EXTLINUX bootloader, for booting the local system, as well as all
58the SYSLINUX/PXELINUX modules in /boot.
59
60
61%package tftpboot
62Summary: SYSLINUX modules in /tftpboot, available for network booting
63Summary(ja): ネットワークブート用 SYSLINUX モジュール
64Group: Applications/Internet
65Requires: syslinux
66
67%description tftpboot
68All the SYSLINUX/PXELINUX modules directly available for network
69booting in the /tftpboot directory.
70
71
72%prep
73%setup -q -n syslinux-%{version}
74
75
76%build
77make clean
78make installer
79make -C sample tidy
80
81
82%install
83rm -rf %{buildroot}
84
85mkdir -p %{buildroot}%{_bindir}
86mkdir -p %{buildroot}%{_sbindir}
87mkdir -p %{buildroot}%{_syssbindir}
88mkdir -p %{buildroot}%{_libdir}/syslinux
89mkdir -p %{buildroot}%{_includedir}
90make install-all \
91        INSTALLROOT=%{buildroot} BINDIR=%{_bindir} SBINDIR=%{_syssbindir} \
92        LIBDIR=%{_prefix}/lib DATADIR=%{_datadir} \
93        MANDIR=%{_mandir} INCDIR=%{_includedir} \
94        TFTPBOOT=/tftpboot EXTLINUXDIR=/boot/extlinux
95
96install -m 755 linux/syslinux-nomtools %{buildroot}%{_datadir}/syslinux
97install -m 755 linux/syslinux %{buildroot}%{_datadir}/syslinux
98
99mkdir -p %{buildroot}/%{_docdir}/%{name}-%{version}/sample
100install -m 644 sample/sample.* %{buildroot}/%{_docdir}/%{name}-%{version}/sample/
101mkdir -p %{buildroot}/etc
102( cd %{buildroot}/etc && ln -s ../boot/extlinux/extlinux.conf . )
103
104# don't ship libsyslinux, at least, not for now
105rm -f %{buildroot}%{_prefix}/lib/libsyslinux*
106rm -f %{buildroot}%{_includedir}/syslinux.h
107
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112
113%files
114%defattr(-,root,root)
115%doc NEWS README* COPYING
116%doc doc/*
117%doc sample
118%{_mandir}/man1/gethostip*
119%{_mandir}/man1/syslinux*
120%{_mandir}/man1/extlinux*
121%{_bindir}/gethostip
122%{_bindir}/isohybrid
123%{_bindir}/memdiskfind
124%{_bindir}/syslinux
125%dir %{_datadir}/syslinux
126%{_datadir}/syslinux/*.com
127%{_datadir}/syslinux/*.exe
128%{_datadir}/syslinux/*.c32
129%{_datadir}/syslinux/*.bin
130%{_datadir}/syslinux/*.0
131%{_datadir}/syslinux/memdisk
132%dir %{_datadir}/syslinux/dosutil
133%{_datadir}/syslinux/dosutil/*
134%{_datadir}/syslinux/syslinux
135%{_datadir}/syslinux/syslinux-nomtools
136
137
138%files perl
139%defattr(-,root,root)
140%{_mandir}/man1/lss16toppm*
141%{_mandir}/man1/ppmtolss16*
142%{_mandir}/man1/syslinux2ansi*
143%{_bindir}/keytab-lilo
144%{_bindir}/lss16toppm
145%{_bindir}/md5pass
146%{_bindir}/mkdiskimage
147%{_bindir}/ppmtolss16
148%{_bindir}/pxelinux-options
149%{_bindir}/sha1pass
150%{_bindir}/syslinux2ansi
151%{_bindir}/isohybrid.pl
152
153
154%files devel
155%defattr(-,root,root)
156%dir %{_datadir}/syslinux/com32
157%{_datadir}/syslinux/com32/*
158
159
160%files extlinux
161%{_syssbindir}/extlinux
162/boot/extlinux
163%config /etc/extlinux.conf
164
165
166%files tftpboot
167/tftpboot
168
169
170%post extlinux
171# If we have a /boot/extlinux.conf file, assume extlinux is our bootloader
172# and update it.
173if [ -f /boot/extlinux/extlinux.conf ]; then \
174        extlinux --update /boot/extlinux ; \
175elif [ -f /boot/extlinux.conf ]; then \
176        mkdir -p /boot/extlinux && \
177        mv /boot/extlinux.conf /boot/extlinux/extlinux.conf && \
178        extlinux --update /boot/extlinux ; \
179fi
180
181
182%changelog
183* Sun Sep 26 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.02-2
184- remove Obsoletes: syslinux-devel
185
186* Sat Sep 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.02-1
187- new upstream release
188- split out -devel/perl/extlinux/tftpboot subpackages
189
190* Sat Nov 28 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.83-1
191- new upstream release
192
193* Fri Jun 12 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.82-1
194- new upstream release w/ bugfixes
195
196* Thu May 14 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.80-1
197- new upstream release 3.80 w/ dozens of bugfixes and new features :)
198
199* Thu Dec 11 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.63-3
200- add missing files to the filelist
201
202* Fri May 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.63-2
203- spec in UTF-8
204
205* Mon May 19 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.63-1
206- updated to new upstream release
207
208* Wed Nov 21 2007 Shu KONNO <owa@bg.wakwak.com> 3.53-0vl1
209- new upstream source
210
211* Wed May 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.07-0vl1
212- new upstream source
213- add extlinux
214- remove and obsolete syslinux-devel
215
216* Fri Dec 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13-0vl1
217- new upstream release
218
219* Fri Jun 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10-0vl1
220- new upstream release
221
222* Wed Mar 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.52-2vl1
223- rebuild for Vine Linux
224
225* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
226- Bump release + rebuild.
227
228* Sat Feb 10 2001 Matt Wilson <msw@redhat.com>
229- 1.52
230
231* Wed Jan 24 2001 Matt Wilson <msw@redhat.com>
232- 1.51pre7
233
234* Mon Jan 22 2001 Matt Wilson <msw@redhat.com>
235- 1.51pre5
236
237* Fri Jan 19 2001 Matt Wilson <msw@redhat.com>
238- 1.51pre3, with e820 detection
239
240* Tue Dec 12 2000 Than Ngo <than@redhat.com>
241- rebuilt with fixed fileutils
242
243* Thu Nov 9 2000 Than Ngo <than@redhat.com>
244- update to 1.49
245- update ftp site
246- clean up specfile
247- add some useful documents
248
249* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
250- add %%defattr (release 4)
251
252* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
253- automatic rebuild
254
255* Thu Jul 06 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
256- use %%{_tmppath}
257- change application group (Applications/Internet doesn't seem
258  right to me)
259- added BuildRequires
260
261* Tue Apr 04 2000 Erik Troan <ewt@redhat.com>
262- initial packaging
Note: See TracBrowser for help on using the repository browser.