source: projects/specs/trunk/s/syslinux/syslinux-vl.spec @ 1905

Revision 1905, 6.9 KB checked in by shaolin, 14 years ago (diff)
  • syslinux: new upstream release; split out subpackages
Line 
1Summary: Simple kernel loader which uses a FAT ot iso9660 filesystem ot a PXE network
2Summary(ja): FAT/iso9660 ファイルシステムまたは PXE ネットワークを利用するシンプルなカーネルローダー
3Name: syslinux
4Version: 4.02
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: Applications/System
8Source0: ftp://ftp.kernel.org/pub/linux/utils/boot/syslinux/%{name}-%{version}.tar.bz2
9URL: http://syslinux.zytor.com/
10ExclusiveArch: %{ix86} x86_64
11Buildroot: %{_tmppath}/%{name}-%{version}-root
12BuildPrereq: nasm, perl, netpbm-progs
13Requires: mtools
14Obsoletes: %{name}-devel
15
16Vendor: Project Vine
17Distribution: Vine Linux
18Packager: daisuke, shaolin
19
20
21%description
22SYSLINUX is a suite of bootloaders, currently supporting DOS FAT filesystems,
23Linux ext2/ext3 filesystems (EXTLINUX), PXE network boots
24(PXELINUX), or ISO 9660 CD-ROMs (ISOLINUX).  It also includes a tool,
25MEMDISK, which loads legacy operating systems from these media.
26
27%description -l ja
28SYSLINUX はカーネルローダー集です。現在は FAT ファイルシステム、Linux の
29ext2/ext3 ファイルシステム(EXTLINUX)、PXE ネットワークブート (PXELINUX) および
30ISO 9660 CDROM (ISOLINUX) に対応しています。
31
32
33%package perl
34Summary: Syslinux tools written in perl
35Summary(ja): Syslinux の perl ツール集
36Group: Applications/System
37
38%description perl
39Syslinux tools written in perl
40
41
42%package devel
43Summary: Headers and libraries for syslinux development.
44Summary(ja): Syslinux 開発用ヘッダとライブラリ
45Group: Development/Libraries
46
47%description devel
48Headers and libraries for syslinux development.
49
50
51%package extlinux
52Summary: The EXTLINUX bootloader, for booting the local system.
53Summary(ja): EXTLINUX ブートローダ
54Group: System/Boot
55Requires: syslinux
56
57%description extlinux
58The EXTLINUX bootloader, for booting the local system, as well as all
59the SYSLINUX/PXELINUX modules in /boot.
60
61
62%package tftpboot
63Summary: SYSLINUX modules in /tftpboot, available for network booting
64Summary(ja): ネットワークブート用 SYSLINUX モジュール
65Group: Applications/Internet
66Requires: syslinux
67
68%description tftpboot
69All the SYSLINUX/PXELINUX modules directly available for network
70booting in the /tftpboot directory.
71
72
73%prep
74%setup -q -n syslinux-%{version}
75
76
77%build
78make clean
79make installer
80make -C sample tidy
81
82
83%install
84rm -rf %{buildroot}
85
86mkdir -p %{buildroot}%{_bindir}
87mkdir -p %{buildroot}%{_sbindir}
88mkdir -p %{buildroot}%{_syssbindir}
89mkdir -p %{buildroot}%{_libdir}/syslinux
90mkdir -p %{buildroot}%{_includedir}
91make install-all \
92        INSTALLROOT=%{buildroot} BINDIR=%{_bindir} SBINDIR=%{_syssbindir} \
93        LIBDIR=%{_prefix}/lib DATADIR=%{_datadir} \
94        MANDIR=%{_mandir} INCDIR=%{_includedir} \
95        TFTPBOOT=/tftpboot EXTLINUXDIR=/boot/extlinux
96
97install -m 755 linux/syslinux-nomtools %{buildroot}%{_datadir}/syslinux
98install -m 755 linux/syslinux %{buildroot}%{_datadir}/syslinux
99
100mkdir -p %{buildroot}/%{_docdir}/%{name}-%{version}/sample
101install -m 644 sample/sample.* %{buildroot}/%{_docdir}/%{name}-%{version}/sample/
102mkdir -p %{buildroot}/etc
103( cd %{buildroot}/etc && ln -s ../boot/extlinux/extlinux.conf . )
104
105# don't ship libsyslinux, at least, not for now
106rm -f %{buildroot}%{_prefix}/lib/libsyslinux*
107rm -f %{buildroot}%{_includedir}/syslinux.h
108
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113
114%files
115%defattr(-,root,root)
116%doc NEWS README* COPYING
117%doc doc/*
118%doc sample
119%{_mandir}/man1/gethostip*
120%{_mandir}/man1/syslinux*
121%{_mandir}/man1/extlinux*
122%{_bindir}/gethostip
123%{_bindir}/isohybrid
124%{_bindir}/memdiskfind
125%{_bindir}/syslinux
126%dir %{_datadir}/syslinux
127%{_datadir}/syslinux/*.com
128%{_datadir}/syslinux/*.exe
129%{_datadir}/syslinux/*.c32
130%{_datadir}/syslinux/*.bin
131%{_datadir}/syslinux/*.0
132%{_datadir}/syslinux/memdisk
133%dir %{_datadir}/syslinux/dosutil
134%{_datadir}/syslinux/dosutil/*
135%{_datadir}/syslinux/syslinux
136%{_datadir}/syslinux/syslinux-nomtools
137
138
139%files perl
140%defattr(-,root,root)
141%{_mandir}/man1/lss16toppm*
142%{_mandir}/man1/ppmtolss16*
143%{_mandir}/man1/syslinux2ansi*
144%{_bindir}/keytab-lilo
145%{_bindir}/lss16toppm
146%{_bindir}/md5pass
147%{_bindir}/mkdiskimage
148%{_bindir}/ppmtolss16
149%{_bindir}/pxelinux-options
150%{_bindir}/sha1pass
151%{_bindir}/syslinux2ansi
152%{_bindir}/isohybrid.pl
153
154
155%files devel
156%defattr(-,root,root)
157%dir %{_datadir}/syslinux/com32
158%{_datadir}/syslinux/com32/*
159
160
161%files extlinux
162%{_syssbindir}/extlinux
163/boot/extlinux
164%config /etc/extlinux.conf
165
166
167%files tftpboot
168/tftpboot
169
170
171%post extlinux
172# If we have a /boot/extlinux.conf file, assume extlinux is our bootloader
173# and update it.
174if [ -f /boot/extlinux/extlinux.conf ]; then \
175        extlinux --update /boot/extlinux ; \
176elif [ -f /boot/extlinux.conf ]; then \
177        mkdir -p /boot/extlinux && \
178        mv /boot/extlinux.conf /boot/extlinux/extlinux.conf && \
179        extlinux --update /boot/extlinux ; \
180fi
181
182
183%changelog
184* Sat Sep 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.02-1
185- new upstream release
186- split out -devel/perl/extlinux/tftpboot subpackages
187
188* Sat Nov 28 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.83-1
189- new upstream release
190
191* Fri Jun 12 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.82-1
192- new upstream release w/ bugfixes
193
194* Thu May 14 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.80-1
195- new upstream release 3.80 w/ dozens of bugfixes and new features :)
196
197* Thu Dec 11 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.63-3
198- add missing files to the filelist
199
200* Fri May 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.63-2
201- spec in UTF-8
202
203* Mon May 19 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.63-1
204- updated to new upstream release
205
206* Wed Nov 21 2007 Shu KONNO <owa@bg.wakwak.com> 3.53-0vl1
207- new upstream source
208
209* Wed May 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.07-0vl1
210- new upstream source
211- add extlinux
212- remove and obsolete syslinux-devel
213
214* Fri Dec 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13-0vl1
215- new upstream release
216
217* Fri Jun 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10-0vl1
218- new upstream release
219
220* Wed Mar 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.52-2vl1
221- rebuild for Vine Linux
222
223* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
224- Bump release + rebuild.
225
226* Sat Feb 10 2001 Matt Wilson <msw@redhat.com>
227- 1.52
228
229* Wed Jan 24 2001 Matt Wilson <msw@redhat.com>
230- 1.51pre7
231
232* Mon Jan 22 2001 Matt Wilson <msw@redhat.com>
233- 1.51pre5
234
235* Fri Jan 19 2001 Matt Wilson <msw@redhat.com>
236- 1.51pre3, with e820 detection
237
238* Tue Dec 12 2000 Than Ngo <than@redhat.com>
239- rebuilt with fixed fileutils
240
241* Thu Nov 9 2000 Than Ngo <than@redhat.com>
242- update to 1.49
243- update ftp site
244- clean up specfile
245- add some useful documents
246
247* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
248- add %%defattr (release 4)
249
250* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
251- automatic rebuild
252
253* Thu Jul 06 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
254- use %%{_tmppath}
255- change application group (Applications/Internet doesn't seem
256  right to me)
257- added BuildRequires
258
259* Tue Apr 04 2000 Erik Troan <ewt@redhat.com>
260- initial packaging
Note: See TracBrowser for help on using the repository browser.