source: projects/specs/trunk/s/swig/swig-vl.spec @ 11305

Revision 11305, 5.7 KB checked in by tomop, 6 years ago (diff)

swig-3.0.12-1

Line 
1%define tcl 1
2%define guile 0
3
4Summary: Connects C/C++/Objective C to some high-level programming languages
5Summary(ja): C/C++/Objective C を高級プログラミング言語に接続するためのツール
6Name: swig
7Version: 3.0.12
8Release: 1%{?_dist_release}
9License: GPLv3+ and BSD
10Group: Development/Tools
11URL: http://swig.sourceforge.net/
12Vendor: Project Vine
13Distribution: Vine Linux
14
15Source: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: lua-devel
19BuildRequires: pcre-devel
20BuildRequires: perl
21BuildRequires: python-devel
22BuildRequires: ruby-devel
23%if %{tcl}
24BuildRequires: tcl-devel
25%endif
26%if %{guile}
27BuildRequires: guile-devel
28%endif
29BuildRequires: autoconf, automake, gawk, nkf
30Obsoletes: swig-runtime
31
32%description
33Simplified Wrapper and Interface Generator (SWIG) is a software
34development tool for connecting C, C++ and Objective C programs with a
35variety of high-level programming languages.  SWIG is primarily used
36with Perl, Python and Tcl/TK, but it has also been extended to Java,
37Eiffel and Guile.  SWIG is normally used to create high-level
38interpreted programming environments, systems integration, and as a
39tool for building user interfaces
40
41%package doc
42Summary: Documentation files for SWIG
43Summary(ja): SWIG のドキュメント
44License: BSD
45Group: Documentation
46BuildArch: noarch
47
48%description doc
49This package contains documentation for SWIG and useful examples
50
51%prep
52%setup -q -n swig-%{version}
53
54# as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
55# (specific req/prov filtering). Before you remove this hack make sure you don't
56# reintroduce https://bugzilla.redhat.com/show_bug.cgi?id=489421
57cat << \EOF > %{name}-prov
58#!/bin/sh
59%{__perl_provides} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
60EOF
61
62%global __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
63chmod +x %{__perl_provides}
64
65cat << \EOF > %{name}-req
66#!/bin/sh
67%{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
68EOF
69
70%global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
71chmod +x %{__perl_requires}
72
73for all in CHANGES README; do
74        iconv -f ISO88591 -t UTF8 < $all > $all.new
75        touch -r $all $all.new
76        mv -f $all.new $all
77done
78
79%build
80./autogen.sh
81%configure
82make %{?_smp_mflags}
83
84# Test suite is currently broken
85#make check
86
87%install
88rm -rf %{buildroot}
89
90make clean-examples
91
92pushd Examples/
93# Remove all arch dependent files in Examples/
94find -type f -name 'Makefile.in' | xargs rm -f --
95
96# We don't want to ship files below.
97rm -rf test-suite
98find -type f -name '*.dsp' | xargs rm -f --
99find -type f -name '*.dsw' | xargs rm -f --
100
101# Convert files to UNIX format
102for all in `find -type f`; do
103        nkf --unix $all
104        chmod -x $all
105done
106popd
107
108make DESTDIR=%{buildroot} install
109
110%clean
111rm -rf %{buildroot}
112
113%files
114%defattr(-,root,root,-)
115%{_bindir}/*
116%{_datadir}/swig
117%doc ANNOUNCE CHANGES CHANGES.current INSTALL
118%doc README TODO
119%license LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
120
121%files doc
122%defattr(-,root,root,-)
123%doc Doc Examples
124%license LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
125
126%changelog
127* Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.12-1
128- new upstream release.
129
130* Fri Jul  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.10-1
131- new upstream release.
132
133* Wed Feb  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.0.5-1
134- new upstream release
135- moved doc subpackage to Documentation Group
136
137* Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.2-1
138- update to 3.0.2
139
140* Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
141- update to 3.0.0
142- add BR: ruby-devel, lua-devel
143
144* Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
145- update to 2.0.8
146- build with pcre-8.31
147
148* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-2
149- rebuild with python-2.7.2
150
151* Sat Oct 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.4-1
152- update to 2.0.4
153
154* Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.40-2
155- add missing man file(s) to the filelist
156
157* Mon Mar 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.40-1
158- new upstream release
159- rebuild with new toolchain
160
161* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.35-1
162- new upstream release
163
164* Wed Mar 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.31-0vl1
165- new upstream release
166- removed php-devel and ruby-devel from BuildPreReq:.
167
168* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl1
169- new upstream release
170- use %%configure
171- remove runtime subpackage
172
173* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
174- 1.3.21-0vl2
175- un-libtoolize (tarball have already been libtoolized).
176- fix %%clean.
177- add guile-devel, php-devel, python-devel and ruby-devel to BuildPreReq:.
178
179* Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
180- 1.3.21-0vl1
181- update version
182
183* Sat Dec 27 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
184- 1.3.20-0vl1
185- update version
186
187* Tue Jun 03 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
188- update version
189
190* Sun Mar 03 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
191- update version
192
193* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org>
194- import to Vine Linux
195
196* Wed Jul 19 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.3a3-1mdk
197- BM.
198- Clean up specs.
199- 1.3a3.
200
201* Tue Jun 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.1p5-5mdk
202- Use makeinstall macros.
203
204* Mon Apr 10 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-4mdk
205
206- Provides: swig
207
208* Mon Apr  3 2000 Pixel <pixel@mandrakesoft.com> 1.1p5-3mdk
209- rebuild with new perl
210- cleanup
211
212* Wed Mar 22 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-2mdk
213
214- Rebuilt on kenobi
215- Don't use prefix
216
217* Fri Mar 10 2000 Francis Galiegue <francis@mandrakesoft.com> 1.1p5-1mdk
218
219- First RPM for Mandrake
220
Note: See TracBrowser for help on using the repository browser.