source: projects/specs/trunk/s/swig/swig-vl.spec @ 10472

Revision 10472, 5.6 KB checked in by tomop, 8 years ago (diff)

swig-3.0.10-1

Line 
1%define tcl 1
2%define guile 0
3
4Summary: Connects C/C++/Objective C to some high-level programming languages
5Summary(ja): C/C++/Objective C を高級プログラミング言語に接続するためのツール
6Name: swig
7Version: 3.0.10
8Release: 1%{?_dist_release}
9License: GPLv3+ and BSD
10Group: Development/Tools
11URL: http://swig.sourceforge.net/
12Vendor: Project Vine
13Distribution: Vine Linux
14
15Source: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: lua-devel
19BuildRequires: pcre-devel
20BuildRequires: perl
21BuildRequires: python-devel
22BuildRequires: ruby-devel
23%if %{tcl}
24BuildRequires: tcl-devel
25%endif
26%if %{guile}
27BuildRequires: guile-devel
28%endif
29BuildRequires: autoconf, automake, gawk, nkf
30Obsoletes: swig-runtime
31
32%description
33Simplified Wrapper and Interface Generator (SWIG) is a software
34development tool for connecting C, C++ and Objective C programs with a
35variety of high-level programming languages.  SWIG is primarily used
36with Perl, Python and Tcl/TK, but it has also been extended to Java,
37Eiffel and Guile.  SWIG is normally used to create high-level
38interpreted programming environments, systems integration, and as a
39tool for building user interfaces
40
41%package doc
42Summary: Documentation files for SWIG
43Summary(ja): SWIG のドキュメント
44License: BSD
45Group: Documentation
46BuildArch: noarch
47
48%description doc
49This package contains documentation for SWIG and useful examples
50
51%prep
52%setup -q -n swig-%{version}
53
54# as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
55# (specific req/prov filtering). Before you remove this hack make sure you don't
56# reintroduce https://bugzilla.redhat.com/show_bug.cgi?id=489421
57cat << \EOF > %{name}-prov
58#!/bin/sh
59%{__perl_provides} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
60EOF
61
62%global __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
63chmod +x %{__perl_provides}
64
65cat << \EOF > %{name}-req
66#!/bin/sh
67%{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
68EOF
69
70%global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
71chmod +x %{__perl_requires}
72
73for all in CHANGES README; do
74        iconv -f ISO88591 -t UTF8 < $all > $all.new
75        touch -r $all $all.new
76        mv -f $all.new $all
77done
78
79%build
80./autogen.sh
81%configure
82make %{?_smp_mflags}
83
84# Test suite is currently broken
85#make check
86
87%install
88rm -rf %{buildroot}
89
90make clean-examples
91
92pushd Examples/
93# Remove all arch dependent files in Examples/
94find -type f -name 'Makefile.in' | xargs rm -f --
95
96# We don't want to ship files below.
97rm -rf test-suite
98find -type f -name '*.dsp' | xargs rm -f --
99find -type f -name '*.dsw' | xargs rm -f --
100
101# Convert files to UNIX format
102for all in `find -type f`; do
103        nkf --unix $all
104        chmod -x $all
105done
106popd
107
108make DESTDIR=%{buildroot} install
109
110%clean
111rm -rf %{buildroot}
112
113%files
114%defattr(-,root,root,-)
115%{_bindir}/*
116%{_datadir}/swig
117%doc ANNOUNCE CHANGES CHANGES.current INSTALL
118%doc README TODO
119%license LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
120
121%files doc
122%defattr(-,root,root,-)
123%doc Doc Examples
124%license LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
125
126%changelog
127* Fri Jul  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.10-1
128- new upstream release.
129
130* Wed Feb  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.0.5-1
131- new upstream release
132- moved doc subpackage to Documentation Group
133
134* Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.2-1
135- update to 3.0.2
136
137* Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
138- update to 3.0.0
139- add BR: ruby-devel, lua-devel
140
141* Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
142- update to 2.0.8
143- build with pcre-8.31
144
145* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-2
146- rebuild with python-2.7.2
147
148* Sat Oct 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.4-1
149- update to 2.0.4
150
151* Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.40-2
152- add missing man file(s) to the filelist
153
154* Mon Mar 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.40-1
155- new upstream release
156- rebuild with new toolchain
157
158* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.35-1
159- new upstream release
160
161* Wed Mar 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.31-0vl1
162- new upstream release
163- removed php-devel and ruby-devel from BuildPreReq:.
164
165* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl1
166- new upstream release
167- use %%configure
168- remove runtime subpackage
169
170* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
171- 1.3.21-0vl2
172- un-libtoolize (tarball have already been libtoolized).
173- fix %%clean.
174- add guile-devel, php-devel, python-devel and ruby-devel to BuildPreReq:.
175
176* Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
177- 1.3.21-0vl1
178- update version
179
180* Sat Dec 27 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
181- 1.3.20-0vl1
182- update version
183
184* Tue Jun 03 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
185- update version
186
187* Sun Mar 03 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
188- update version
189
190* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org>
191- import to Vine Linux
192
193* Wed Jul 19 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.3a3-1mdk
194- BM.
195- Clean up specs.
196- 1.3a3.
197
198* Tue Jun 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.1p5-5mdk
199- Use makeinstall macros.
200
201* Mon Apr 10 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-4mdk
202
203- Provides: swig
204
205* Mon Apr  3 2000 Pixel <pixel@mandrakesoft.com> 1.1p5-3mdk
206- rebuild with new perl
207- cleanup
208
209* Wed Mar 22 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-2mdk
210
211- Rebuilt on kenobi
212- Don't use prefix
213
214* Fri Mar 10 2000 Francis Galiegue <francis@mandrakesoft.com> 1.1p5-1mdk
215
216- First RPM for Mandrake
217
Note: See TracBrowser for help on using the repository browser.