source: projects/specs/trunk/s/swig/swig-vl.spec @ 9329

Revision 9329, 5.5 KB checked in by inagaki, 9 years ago (diff)

2015-02-05 Ryoichi INAGAKI <ryo1@…>

  • Cython, swig: updated
  • emacsen-common, gtkparasite, perl-Mail-{DKIM,Sendmail}: moved Group


Line 
1%define tcl 1
2%define guile 0
3
4Summary: Connects C/C++/Objective C to some high-level programming languages
5Summary(ja): C/C++/Objective C を高級プログラミング言語に接続するためのツール
6Name: swig
7Version: 3.0.5
8Release: 1%{?_dist_release}
9License: GPLv3+ and BSD
10Group: Development/Tools
11URL: http://swig.sourceforge.net/
12Source: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: lua-devel
16BuildRequires: pcre-devel
17BuildRequires: perl
18BuildRequires: python-devel
19BuildRequires: ruby-devel
20%if %{tcl}
21BuildRequires: tcl-devel
22%endif
23%if %{guile}
24BuildRequires: guile-devel
25%endif
26BuildRequires: autoconf, automake, gawk, nkf
27Obsoletes: swig-runtime
28
29%description
30Simplified Wrapper and Interface Generator (SWIG) is a software
31development tool for connecting C, C++ and Objective C programs with a
32variety of high-level programming languages.  SWIG is primarily used
33with Perl, Python and Tcl/TK, but it has also been extended to Java,
34Eiffel and Guile.  SWIG is normally used to create high-level
35interpreted programming environments, systems integration, and as a
36tool for building user interfaces
37
38%package doc
39Summary: Documentation files for SWIG
40Summary(ja): SWIG のドキュメント
41License: BSD
42Group: Documentation
43BuildArch: noarch
44
45%description doc
46This package contains documentation for SWIG and useful examples
47
48%prep
49%setup -q -n swig-%{version}
50
51# as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
52# (specific req/prov filtering). Before you remove this hack make sure you don't
53# reintroduce https://bugzilla.redhat.com/show_bug.cgi?id=489421
54cat << \EOF > %{name}-prov
55#!/bin/sh
56%{__perl_provides} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
57EOF
58
59%global __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
60chmod +x %{__perl_provides}
61
62cat << \EOF > %{name}-req
63#!/bin/sh
64%{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
65EOF
66
67%global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
68chmod +x %{__perl_requires}
69
70for all in CHANGES README; do
71        iconv -f ISO88591 -t UTF8 < $all > $all.new
72        touch -r $all $all.new
73        mv -f $all.new $all
74done
75
76%build
77./autogen.sh
78%configure
79make %{?_smp_mflags}
80
81# Test suite is currently broken
82#make check
83
84%install
85rm -rf %{buildroot}
86
87make clean-examples
88
89pushd Examples/
90# Remove all arch dependent files in Examples/
91find -type f -name 'Makefile.in' | xargs rm -f --
92
93# We don't want to ship files below.
94rm -rf test-suite
95find -type f -name '*.dsp' | xargs rm -f --
96find -type f -name '*.dsw' | xargs rm -f --
97
98# Convert files to UNIX format
99for all in `find -type f`; do
100        nkf --unix $all
101        chmod -x $all
102done
103popd
104
105make DESTDIR=%{buildroot} install
106
107%clean
108rm -rf %{buildroot}
109
110%files
111%defattr(-,root,root,-)
112%{_bindir}/*
113%{_datadir}/swig
114%{_mandir}/man1/ccache-swig.1*
115%doc ANNOUNCE CHANGES CHANGES.current INSTALL LICENSE LICENSE-GPL
116%doc LICENSE-UNIVERSITIES COPYRIGHT README TODO
117
118%files doc
119%defattr(-,root,root,-)
120%doc Doc Examples LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
121
122%changelog
123* Wed Feb  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.0.5-1
124- new upstream release
125- moved doc subpackage to Documentation Group
126
127* Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.2-1
128- update to 3.0.2
129
130* Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
131- update to 3.0.0
132- add BR: ruby-devel, lua-devel
133
134* Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
135- update to 2.0.8
136- build with pcre-8.31
137
138* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-2
139- rebuild with python-2.7.2
140
141* Sat Oct 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.4-1
142- update to 2.0.4
143
144* Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.40-2
145- add missing man file(s) to the filelist
146
147* Mon Mar 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.40-1
148- new upstream release
149- rebuild with new toolchain
150
151* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.35-1
152- new upstream release
153
154* Wed Mar 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.31-0vl1
155- new upstream release
156- removed php-devel and ruby-devel from BuildPreReq:.
157
158* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl1
159- new upstream release
160- use %%configure
161- remove runtime subpackage
162
163* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
164- 1.3.21-0vl2
165- un-libtoolize (tarball have already been libtoolized).
166- fix %%clean.
167- add guile-devel, php-devel, python-devel and ruby-devel to BuildPreReq:.
168
169* Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
170- 1.3.21-0vl1
171- update version
172
173* Sat Dec 27 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
174- 1.3.20-0vl1
175- update version
176
177* Mon Jun 03 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
178- update version
179
180* Mon Mar 03 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
181- update version
182
183* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org>
184- import to Vine Linux
185
186* Wed Jul 19 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.3a3-1mdk
187- BM.
188- Clean up specs.
189- 1.3a3.
190
191* Tue Jun 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.1p5-5mdk
192- Use makeinstall macros.
193
194* Mon Apr 10 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-4mdk
195
196- Provides: swig
197
198* Mon Apr  3 2000 Pixel <pixel@mandrakesoft.com> 1.1p5-3mdk
199- rebuild with new perl
200- cleanup
201
202* Wed Mar 22 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-2mdk
203
204- Rebuilt on kenobi
205- Don't use prefix
206
207* Fri Mar 10 2000 Francis Galiegue <francis@mandrakesoft.com> 1.1p5-1mdk
208
209- First RPM for Mandrake
210
Note: See TracBrowser for help on using the repository browser.