source: projects/specs/trunk/s/swig/swig-vl.spec @ 12309

Revision 12309, 5.9 KB checked in by tomop, 4 years ago (diff)

updated 10 packages

PyYAML-5.1.2-1

lz4-1.9.2-1

libnet-1.1.6-2

libyaml-0.2.2-1

mecab-naist-jdic-0.6.3b.20111013-2

mecab-0.996-3

perl-HTTP-Cookies-6.04-8

perl-LWP-Protocol-https-6.07-10

perl-Mozilla-CA-20180117-7

swig-4.0.1-1

Line 
1%define tcl 1
2%define guile 0
3
4Summary: Connects C/C++/Objective C to some high-level programming languages
5Summary(ja): C/C++/Objective C を高級プログラミング言語に接続するためのツール
6Name: swig
7Version: 4.0.1
8Release: 1%{?_dist_release}
9License: GPLv3+ and BSD
10Group: Development/Tools
11URL: http://swig.sourceforge.net/
12Vendor: Project Vine
13Distribution: Vine Linux
14
15Source: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: lua-devel
19BuildRequires: pcre-devel
20BuildRequires: perl
21BuildRequires: python-devel
22BuildRequires: python3-devel
23BuildRequires: ruby-devel
24%if %{tcl}
25BuildRequires: tcl-devel
26%endif
27%if %{guile}
28BuildRequires: guile-devel
29%endif
30BuildRequires: autoconf, automake, gawk, nkf
31Obsoletes: swig-runtime
32
33%description
34Simplified Wrapper and Interface Generator (SWIG) is a software
35development tool for connecting C, C++ and Objective C programs with a
36variety of high-level programming languages.  SWIG is primarily used
37with Perl, Python and Tcl/TK, but it has also been extended to Java,
38Eiffel and Guile.  SWIG is normally used to create high-level
39interpreted programming environments, systems integration, and as a
40tool for building user interfaces
41
42%package doc
43Summary: Documentation files for SWIG
44Summary(ja): SWIG のドキュメント
45License: BSD
46Group: Documentation
47BuildArch: noarch
48
49%description doc
50This package contains documentation for SWIG and useful examples
51
52%prep
53%setup -q -n swig-%{version}
54
55# as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
56# (specific req/prov filtering). Before you remove this hack make sure you don't
57# reintroduce https://bugzilla.redhat.com/show_bug.cgi?id=489421
58cat << \EOF > %{name}-prov
59#!/bin/sh
60%{__perl_provides} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
61EOF
62
63%global __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
64chmod +x %{__perl_provides}
65
66cat << \EOF > %{name}-req
67#!/bin/sh
68%{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
69EOF
70
71%global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
72chmod +x %{__perl_requires}
73
74for all in CHANGES README; do
75        iconv -f ISO88591 -t UTF8 < $all > $all.new
76        touch -r $all $all.new
77        mv -f $all.new $all
78done
79
80%build
81./autogen.sh
82%configure
83make %{?_smp_mflags}
84
85# Test suite is currently broken
86#make check
87
88%install
89rm -rf %{buildroot}
90
91make clean-examples
92
93pushd Examples/
94# Remove all arch dependent files in Examples/
95find -type f -name 'Makefile.in' | xargs rm -f --
96
97# We don't want to ship files below.
98rm -rf test-suite
99find -type f -name '*.dsp' | xargs rm -f --
100find -type f -name '*.dsw' | xargs rm -f --
101
102# Convert files to UNIX format
103for all in `find -type f`; do
104        nkf --unix $all
105        chmod -x $all
106done
107popd
108
109make DESTDIR=%{buildroot} install
110
111%clean
112rm -rf %{buildroot}
113
114%files
115%defattr(-,root,root,-)
116%{_bindir}/*
117%{_datadir}/swig
118%doc ANNOUNCE CHANGES CHANGES.current INSTALL
119%doc README TODO
120%license LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
121
122%files doc
123%defattr(-,root,root,-)
124%doc Doc Examples
125%license LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
126
127%changelog
128* Wed Oct 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.1-1
129- new upstream release.
130
131* Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.12-1
132- new upstream release.
133
134* Fri Jul  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.10-1
135- new upstream release.
136
137* Wed Feb  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.0.5-1
138- new upstream release
139- moved doc subpackage to Documentation Group
140
141* Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.2-1
142- update to 3.0.2
143
144* Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
145- update to 3.0.0
146- add BR: ruby-devel, lua-devel
147
148* Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
149- update to 2.0.8
150- build with pcre-8.31
151
152* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-2
153- rebuild with python-2.7.2
154
155* Sat Oct 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.4-1
156- update to 2.0.4
157
158* Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.40-2
159- add missing man file(s) to the filelist
160
161* Mon Mar 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.40-1
162- new upstream release
163- rebuild with new toolchain
164
165* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.35-1
166- new upstream release
167
168* Wed Mar 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.31-0vl1
169- new upstream release
170- removed php-devel and ruby-devel from BuildPreReq:.
171
172* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl1
173- new upstream release
174- use %%configure
175- remove runtime subpackage
176
177* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
178- 1.3.21-0vl2
179- un-libtoolize (tarball have already been libtoolized).
180- fix %%clean.
181- add guile-devel, php-devel, python-devel and ruby-devel to BuildPreReq:.
182
183* Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
184- 1.3.21-0vl1
185- update version
186
187* Sat Dec 27 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
188- 1.3.20-0vl1
189- update version
190
191* Tue Jun 03 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
192- update version
193
194* Sun Mar 03 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
195- update version
196
197* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org>
198- import to Vine Linux
199
200* Wed Jul 19 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.3a3-1mdk
201- BM.
202- Clean up specs.
203- 1.3a3.
204
205* Tue Jun 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.1p5-5mdk
206- Use makeinstall macros.
207
208* Mon Apr 10 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-4mdk
209
210- Provides: swig
211
212* Mon Apr  3 2000 Pixel <pixel@mandrakesoft.com> 1.1p5-3mdk
213- rebuild with new perl
214- cleanup
215
216* Wed Mar 22 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-2mdk
217
218- Rebuilt on kenobi
219- Don't use prefix
220
221* Fri Mar 10 2000 Francis Galiegue <francis@mandrakesoft.com> 1.1p5-1mdk
222
223- First RPM for Mandrake
224
Note: See TracBrowser for help on using the repository browser.