source: projects/specs/trunk/s/suricata/suricata-vl.spec @ 12532

Revision 12532, 18.0 KB checked in by tomop, 3 years ago (diff)

updated 3 packages

libnetfilter_queue-1.0.5-1

libyaml-0.2.5-1

suricata-6.0.1-1

Line 
1%bcond_with systemd
2%bcond_with libprelude
3
4Summary:        Intrusion Detection System
5Name:           suricata
6Version:        6.0.1
7Release:        1%{?_dist_release}%{?with_systemd:.systemd}
8Group:          network
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        GPLv2
13URL:            https://suricata-ids.org/
14Source0:        https://www.openinfosecfoundation.org/download/%{name}-%{version}.tar.gz
15Source1:        suricata.sysconfig
16Source2:        fedora.notes
17Source3:        suricata-tmpfiles.conf
18
19Source1000:     suricata.init
20Source1001:     suricata.logrotate
21Source1002:     pre_start
22Source1003:     post_stop
23
24# Irrelevant docs are getting installed, drop them
25Patch1: suricata-2.0.9-docs.patch
26# Suricata service file needs some options supplied
27Patch2: suricata-4.1.1-service.patch
28# Linux 5.2 headers moved SIOCGSTAMP to linux/sockios.h. Glibc will
29# include it via sys/socket.h in a future release. This is temporary
30# and should not be needed on other kernel/glibc combos.
31Patch3: suricata-4.1.4-socket.patch
32
33BuildRequires: gcc gcc-c++
34BuildRequires: rust cargo
35BuildRequires: libyaml-devel python3-pyyaml
36BuildRequires: libnfnetlink-devel libnetfilter_queue-devel libnet-devel
37BuildRequires: zlib-devel pcre-devel libcap-ng-devel
38BuildRequires: lz4-devel libpcap-devel
39BuildRequires: nspr-devel nss-devel file-devel
40BuildRequires: jansson-devel libmaxminddb-devel python3-devel lua-devel
41BuildRequires: python3-rpm-macros
42# Next line is for eBPF support
43%ifarch x86_64
44BuildRequires: clang llvm libbpf-devel
45%endif
46BuildRequires: autoconf automake libtool
47%if %{with systemd}
48BuildRequires: systemd
49%endif
50BuildRequires: hiredis-devel
51BuildRequires: libevent-devel
52%if %{with libprelude}
53BuildRequires: libprelude-devel
54%endif
55BuildRequires: gnutls-devel
56
57%ifarch x86_64
58BuildRequires: hyperscan-devel
59%endif
60
61Requires:       python3-pyyaml
62
63Requires(pre): /usr/sbin/useradd
64%if %{with systemd}
65Requires(post): systemd
66Requires(preun): systemd
67Requires(postun): systemd
68%endif
69
70%description
71The Suricata Engine is an Open Source Next Generation Intrusion
72Detection and Prevention Engine. This engine is not intended to
73just replace or emulate the existing tools in the industry, but
74will bring new ideas and technologies to the field. This new Engine
75supports Multi-threading, Automatic Protocol Detection (IP, TCP,
76UDP, ICMP, HTTP, TLS, FTP and SMB! ), Gzip Decompression, Fast IP
77Matching, and GeoIP identification.
78
79
80%debug_package
81
82
83%prep
84%setup -q
85install -m 644 %{SOURCE2} doc/
86%patch1 -p1
87%patch2 -p1
88%patch3 -p1
89sed -i 's/(datadir)/(sysconfdir)/' etc/Makefile.am
90%ifarch x86_64
91sed -i 's/-D__KERNEL__/-D__KERNEL__ -D__x86_64__/' ebpf/Makefile.am
92%endif
93autoreconf -fv --install
94
95
96%build
97%configure --enable-gccprotect --enable-pie --disable-gccmarch-native \
98        --disable-coccinelle --enable-nfqueue --enable-af-packet \
99        --with-libnspr-includes=/usr/include/nspr4 \
100        --with-libnss-includes=/usr/include/nss3 \
101        --enable-jansson --enable-geoip --enable-lua --enable-hiredis \
102%if %{with libprelude}
103        --enable-prelude \
104%endif
105        --enable-rust  \
106%ifarch x86_64
107        --enable-ebpf-build --enable-ebpf \
108%endif
109        --enable-python
110
111%make_build
112
113
114%install
115make DESTDIR="%{buildroot}" "bindir=%{_sbindir}" install
116
117# Setup etc directory
118mkdir -p %{buildroot}%{_sysconfdir}/%{name}/rules
119#install -m 640 rules/*.rules %{buildroot}%{_sysconfdir}/%{name}/rules
120for f in rules/*.rules; do
121    touch %{buildroot}%{_sysconfdir}/%{name}/$f
122done
123install -m 600 *.config %{buildroot}%{_sysconfdir}/%{name}
124install -m 600 suricata.yaml %{buildroot}%{_sysconfdir}/%{name}/
125install -m 755 %{SOURCE1002} %{buildroot}%{_sysconfdir}/%{name}/
126install -m 755 %{SOURCE1003} %{buildroot}%{_sysconfdir}/%{name}/
127
128%if %{with systemd}
129mkdir -p %{buildroot}%{_unitdir}
130install -m 0644 etc/%{name}.service %{buildroot}%{_unitdir}/
131sed -i \
132        -e 's|/var/run/|/run/|' \
133        -e '/ExecStart=/i ExecStartPre=%{_sysconfdir}/%{name}/pre_start' \
134        -e '/ExecStart=/i ExecStopPost=%{_sysconfdir}/%{name}/post_stop' \
135        %{buildroot}%{_unitdir}/%{name}.service
136%else
137mkdir -p %{buildroot}%{_initdir}
138install -m 0644 %{SOURCE1000} %{buildroot}%{_initdir}/%{name}
139%endif
140mkdir -p %{buildroot}%{_sysconfdir}/sysconfig
141install -m 0755 %{SOURCE1} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
142
143# Set up logging
144mkdir -p %{buildroot}/%{_var}/log/%{name}
145mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
146#install -m 644 etc/%{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
147#sed -i -e 's|/var/run/%{name}\.pid|/var/run/%{name}/%{name}.pid|' %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
148install -m 644 %{SOURCE1001} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
149
150# Remove a couple things so they don't get picked up
151rm -rf %{buildroot}%{_includedir}
152rm -f %{buildroot}%{_libdir}/libhtp.la
153rm -f %{buildroot}%{_libdir}/libhtp.a
154rm -f %{buildroot}%{_libdir}/libhtp.so
155rm -rf %{buildroot}%{_libdir}/pkgconfig
156
157# Setup suricata-update data directory
158mkdir -p %{buildroot}/%{_var}/lib/%{name}
159
160# Setup tmpdirs
161%if %{with systemd}
162mkdir -p %{buildroot}%{_tmpfilesdir}
163install -m 0644 %{SOURCE3} %{buildroot}%{_tmpfilesdir}/%{name}.conf
164%endif
165mkdir -p %{buildroot}/run
166install -d -m 0755 %{buildroot}/run/%{name}/
167
168cp suricata-update/README.rst doc/suricata-update-README.rst
169
170
171%check
172make check
173
174
175%pre
176getent passwd suricata >/dev/null || useradd -r -M -s /sbin/nologin suricata
177
178%post
179%if %{with systemd}
180%systemd_post suricata.service
181%else
182if [ $1 -gt 0 ]; then
183  /sbin/chkconfig --add suricata
184fi
185%endif
186
187%preun
188%if %{with systemd}
189%systemd_preun suricata.service
190%else
191if [ $1 -eq 0 -o -x /bin/systemctl ]; then
192  /sbin/service suricata stop
193  /sbin/chkconfig suricata off ||:
194  /sbin/chkconfig --del suricata
195fi
196%endif
197
198%postun
199%if %{with systemd}
200%systemd_postun_with_restart suricata.service
201%else
202if [ $1 -gt 0 -a -f /var/run/suricata/suricata.pid -a ! -x /bin/systemctl ]; then
203  /sbin/service suricata restart
204fi
205%endif
206
207
208%files
209%doc doc/Basic_Setup.txt doc/suricata-update-README.rst
210%doc doc/Setting_up_IPSinline_for_Linux.txt doc/fedora.notes
211%{!?_licensedir:%global license %%doc}
212%license COPYING
213%attr(644,root,root) %{_mandir}/man1/*
214%{_sbindir}/suricata
215%{_bindir}/suricatasc
216%{_bindir}/suricatactl
217%{_bindir}/suricata-update
218%{_libdir}/libhtp*
219%{python3_sitelib}/suricatasc/*
220%{python3_sitelib}/suricata/*
221%{python3_sitelib}/*egg-info
222%config(noreplace) %attr(0755,root,root) %{_sysconfdir}/%{name}/pre_start
223%config(noreplace) %attr(0755,root,root) %{_sysconfdir}/%{name}/post_stop
224%config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/suricata.yaml
225%config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/*.config
226%ghost %config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/rules/*.rules
227%config(noreplace) %attr(0600,suricata,root) %{_sysconfdir}/sysconfig/%{name}
228%config(noreplace) %attr(644,root,root) %{_sysconfdir}/logrotate.d/%{name}
229%attr(750,suricata,suricata) %dir %{_var}/log/%{name}
230%attr(750,suricata,suricata) %dir %{_sysconfdir}/%{name}
231%attr(750,suricata,suricata) %dir %{_sysconfdir}/%{name}/rules
232%attr(2770,suricata,suricata) %dir %{_var}/lib/%{name}
233%attr(2770,suricata,suricata) %dir /run/%{name}/
234%if %{with systemd}
235%attr(644,root,root) %{_unitdir}/suricata.service
236%{_tmpfilesdir}/%{name}.conf
237%else
238%attr(0755,root,root) %{_initdir}/%{name}
239%endif
240%{_datadir}/%{name}/rules
241
242
243%changelog
244* Wed Feb 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.1-1
245- new upstream release.
246
247* Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.3-2
248- rebuilt with python-3.8.
249
250* Tue May 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.3-1
251- new upstream release.
252
253* Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-2
254- rebuilt with libevent-2.1.11.
255
256* Sat Mar 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-1
257- new upstream release.
258
259* Wed Oct 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.0-3
260- initial build for Vine Linux.
261
262* Fri Oct 18 2019 Steve Grubb <sgrubb@redhat.com> 5.0.0-2
263- New feature release (which also fixes a security issue)
264- Enable ebpf on x86_64 only
265- Disable building on ppc64le due to rust problems
266
267* Thu Aug 01 2019 Steve Grubb <sgrubb@redhat.com> 4.1.4-4
268- Fix FTBFS bz 1736727
269
270* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.1.4-3
271- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
272
273* Mon Jul 22 2019 Steve Grubb <sgrubb@redhat.com> 4.1.4-2
274- Rebuild for libprelude so bump
275
276* Tue Apr 30 2019 Jason Taylor <jtfas90@gmail.com> 4.1.4-1
277- Upstream bugfix release
278
279* Thu Mar 07 2019 Steve Grubb <sgrubb@redhat.com> 4.1.3-1
280- Upstream bugfix release
281
282* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.1.2-2
283- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
284
285* Fri Dec 21 2018 Jason Taylor <jtfas90@gmail.com> 4.1.2-1
286- Upstream bugfix release
287- Updated source to use official download site
288
289* Thu Dec 20 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-4
290- Adjust permissions on /run/suricata and /var/lib/suricata to group writable
291
292* Mon Dec 17 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-2
293- Remove ragel requirement
294
295* Mon Dec 17 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-1
296- Make log directory group readable
297- Allow users of the suricata group to run suricata-update
298- Add lz4-devel BuildRequires to support pcap compression
299- Update service file for systemd security protections
300- Upstream bugfix update
301
302* Tue Nov 20 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-3
303- Use the upstream service and logrote files (#1330331)
304- Make the log directory readable by members of the suricata group (#1651394)
305
306* Wed Nov 07 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-2
307- Add cargo BuildRequires
308
309* Tue Nov 06 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-1
310- Latest upstream major release
311- Fixes CVE-2018-18956 Segmentation fault in the ProcessMimeEntity function
312
313* Mon Aug 13 2018 Steve Grubb <sgrubb@redhat.com> - 4.0.5-3
314- Consolidate branches so that everything is in sync (#1614935)
315
316* Fri Aug 10 2018 Jason Taylor <jtfas90@gmail.com> 4.0.5-2
317- fixes bz#1614935
318
319* Wed Jul 18 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.5-1
320- upstream security fix release
321- addresses CVE-2018-10242, CVE-2018-10243, CVE-2018-10244
322
323* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.4-3
324- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
325
326* Mon Jul 09 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-2
327- bumped release for build against hyperscan 5.0.0
328
329* Mon Jul 09 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-1
330- added gcc-c++ buildrequires
331
332* Thu Feb 15 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-1
333- fixes bz#1543250 and bz#1543251
334- multiple upstream bugfixes
335
336* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.3-3
337- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
338
339* Mon Dec 11 2017 Jason Taylor <jtfas90@gmail.com> 4.0.3-2
340- Added prelude support
341
342* Fri Dec 08 2017 Jason Taylor <jtfas90@gmail.com> 4.0.3-1
343- Upstream bugfix release
344
345* Wed Oct 18 2017 Steve Grubb <sgrubb@redhat.com> 4.0.1-1
346- Upstream bugfix update
347
348* Tue Sep 26 2017 Steve Grubb <sgrubb@redhat.com> 4.0.0-2
349- Make suricata user own /run/suricata (#1396150)
350
351* Mon Jul 31 2017 Jason Taylor <jtfas90@gmail.com> 4.0.0-1
352- Latest upstream major release
353- Build now has hyperscan and redis support
354
355* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.3-2
356- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
357
358* Thu Jul 13 2017 Jason Taylor <jtfas90@gmail.com> 3.2.3-1
359- Upstream bugfix update
360
361* Wed Jun 07 2017 Steve Grubb <sgrubb@redhat.com> 3.2.2-1
362- Upstream bugfix update
363
364* Wed Feb 15 2017 Steve Grubb <sgrubb@redhat.com> 3.2.1-1
365- Upstream security update
366
367* Mon Feb 13 2017 Steve Grubb <sgrubb@redhat.com> 3.2-1
368- New upstream feature release
369- Rotate /var/log/suricata/eve.json (#1396151)
370- Fix ownership of /run/suricata (#1396150)
371
372* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.3-2
373- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
374
375* Tue Nov 01 2016 Steve Grubb <sgrubb@redhat.com> 3.1.3-1
376- New upstream bug fix release
377
378* Wed Sep 07 2016 Steve Grubb <sgrubb@redhat.com> 3.1.2-1
379- New upstream bug fix release
380
381* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.1-2
382- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
383
384* Wed Jul 13 2016 Steve Grubb <sgrubb@redhat.com> 3.1.1-1
385- New upstream bug fix release
386
387* Wed Jun 22 2016 Steve Grubb <sgrubb@redhat.com> 3.1-1
388- New upstream bug fix release
389
390* Mon Apr 04 2016 Steve Grubb <sgrubb@redhat.com> 3.0.1-1
391- New upstream bug fix release
392
393* Wed Mar 16 2016 Steve Grubb <sgrubb@redhat.com> 3.0-2
394- Fixed Bug 1227085 - Have Suricata start after the network is online
395
396* Mon Mar 07 2016 Steve Grubb <sgrubb@redhat.com> 3.0-1
397- New upstream bug fix release
398
399* Wed Feb 10 2016 Peter Schiffer <pschiffe@redhat.com> 2.0.11-3
400- Run suricata under suricata user
401
402* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.11-2
403- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
404
405* Mon Dec 28 2015 Steve Grubb <sgrubb@redhat.com> 2.0.11-1
406- New upstream bug fix release
407
408* Wed Nov 25 2015 Steve Grubb <sgrubb@redhat.com> 2.0.10-1
409- New upstream bug fix release
410
411* Sat Oct 03 2015 Steve Grubb <sgrubb@redhat.com> 2.0.9-1
412- New upstream bug fix release
413
414* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.8-2
415- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
416
417* Wed May 06 2015 Steve Grubb <sgrubb@redhat.com> 2.0.8-1
418- New upstream security bug fix release
419
420* Thu Feb 26 2015 Steve Grubb <sgrubb@redhat.com> 2.0.7-1
421- New upstream security bug fix release for CVE-2015-0928
422
423* Thu Jan 15 2015 Steve Grubb <sgrubb@redhat.com> 2.0.6-1
424- New upstream bug fix release
425- Don't use the system libhtp library
426
427* Fri Dec 12 2014 Steve Grubb <sgrubb@redhat.com> 2.0.5-1
428- New upstream bug fix release
429- Use the system libhtp library
430
431* Wed Sep 24 2014 Steve Grubb <sgrubb@redhat.com> 2.0.4-1
432- New upstream bug fix release
433- Fixes CVE-2014-6603 out-of-bounds access in SSH parser
434
435* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3-2
436- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
437
438* Fri Aug 08 2014 Steve Grubb <sgrubb@redhat.com> 2.0.3-1
439- New upstream bug fix release
440
441* Sat Jun 28 2014 Steve Grubb <sgrubb@redhat.com> 2.0.2-2
442- Specfile cleanups (#1113413)
443
444* Wed Jun 25 2014 Steve Grubb <sgrubb@redhat.com> 2.0.2-1
445- New upstream bug fix release
446- Enable liblua support
447
448* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.1-2
449- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
450
451* Wed May 21 2014 Steve Grubb <sgrubb@redhat.com> 2.0.1-1
452- New upstream bug fix release
453
454* Wed Mar 26 2014 Steve Grubb <sgrubb@redhat.com> 2.0-1
455- Major new upstream release with new features
456
457* Tue Jan 21 2014 Dan Horák <dan[at]danny.cz> 1.4.7-3
458- luajit available only on selected arches
459
460* Sat Jan 11 2014 Steve Grubb <sgrubb@redhat.com> 1.4.7-2
461- Enable luajit support
462
463* Wed Dec 18 2013 Steve Grubb <sgrubb@redhat.com> 1.4.7-1
464- New upstream bug fix release
465
466* Fri Oct 04 2013 Steve Grubb <sgrubb@redhat.com> 1.4.6-1
467- New upstream bug fix release
468
469* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3-3
470- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
471
472* Fri Jun 21 2013 Steve Grubb <sgrubb@redhat.com> 1.4.3-2
473- Drop prelude support
474
475* Fri Jun 21 2013 Steve Grubb <sgrubb@redhat.com> 1.4.3-1
476- New upstream bug fix release
477
478* Mon Jun 03 2013 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
479- New upstream bug fix release
480
481* Sun Mar 10 2013 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
482- New upstream bugfix release
483- Enable libgeoip support
484- Switch to stack-protector-all
485
486* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-2
487- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
488
489* Thu Dec 20 2012 Steve Grubb <sgrubb@redhat.com> 1.4-1
490- New upstream feature enhancement release
491
492* Thu Dec 06 2012 Steve Grubb <sgrubb@redhat.com> 1.3.5-1
493- New upstream bugfix release
494
495* Tue Nov 27 2012 Steve Grubb <sgrubb@redhat.com> 1.3.4-1
496- New upstream release
497
498* Mon Nov 05 2012 Steve Grubb <sgrubb@redhat.com> 1.3.3-1
499- New upstream release
500
501* Tue Oct 09 2012 Steve Grubb <sgrubb@redhat.com> 1.3.2-2
502- Add nss-devel build require and systemd macros
503
504* Mon Oct 08 2012 Steve Grubb <sgrubb@redhat.com> 1.3.2-1
505- New upstream release
506
507* Sat Aug 25 2012 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
508- New upstream release
509- Switch startup to use systemd
510
511* Fri Jul 06 2012 Steve Grubb <sgrubb@redhat.com> 1.3-1
512- New upstream release
513
514* Fri Mar 30 2012 Jon Ciesla <limburgher@gmail.com> - 1.2.1-3
515- Rebuild for updated libnet.
516
517* Fri Feb 10 2012 Petr Pisar <ppisar@redhat.com> - 1.2.1-2
518- Rebuild against PCRE 8.30
519
520* Thu Feb 02 2012 Steve Grubb <sgrubb@redhat.com> 1.2.1-1
521- New upstream release
522
523* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-3
524- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
525
526* Thu Dec 22 2011 Steve Grubb <sgrubb@redhat.com> 1.1.1-2
527- Enable AF_PACKET support
528
529* Wed Dec 07 2011 Steve Grubb <sgrubb@redhat.com> 1.1.1-1
530- New upstream release
531
532* Mon Jul 25 2011 Steve Grubb <sgrubb@redhat.com> 1.0.5-1
533- New upstream release
534
535* Fri Jun 24 2011 Steve Grubb <sgrubb@redhat.com> 1.0.4-1
536- New upstream release
537
538* Thu Apr 28 2011 Dan Horák <dan[at]danny.cz> 1.0.3-2
539- don't override -march set by the buildsystem (fixes build on non-x86)
540
541* Sat Apr 23 2011 Steve Grubb <sgrubb@redhat.com> 1.0.3-1
542- New upstream release
543
544* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
545- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
546
547* Wed Nov 10 2010 Steve Grubb <sgrubb@redhat.com> 1.0.2-1
548- New upstream release (#651978)
549
550* Thu Jul 01 2010 Steve Grubb <sgrubb@redhat.com> 1.0.0-1
551- New upstream release
552
553* Fri May 07 2010 Steve Grubb <sgrubb@redhat.com> 0.9.0-1
554- New upstream release
555
556* Tue Apr 20 2010 Steve Grubb <sgrubb@redhat.com> 0.8.2-1
557- New upstream release
558
559* Sat Feb 27 2010 Steve Grubb <sgrubb@redhat.com> 0.8.1-1
560- Initial packaging
561
Note: See TracBrowser for help on using the repository browser.