source: projects/specs/trunk/s/sudo/sudo-vl.spec @ 12320

Revision 12320, 10.7 KB checked in by tomop, 4 years ago (diff)

updated 18 packages

clamav-0.102.2-1

dhcpcd-8.1.1-1

dovecot-2.3.9.3-1

golang-1.13.5-1

llvm-9.0.1-1

libjpeg-turbo-2.0.4-1

libserf-1.3.9-2

libxml2-2.9.10-2

mariadb-10.4.12-1

nodejs-12.16.0-1

php-ext-clearsilver-0.4-15

php73-7.3.14-1

python-pillow-6.2.2-1

rust-1.40.0-1

spamassassin-3.4.4-1

sqlite3-3.31.1-1

squid-4.10-1

sudo-1.8.31-1

Line 
1Summary: Allows command execution as root for specified users
2Summary(ja): スーパーユーザ権限でのコマンドの実行
3Name: sudo
4Version: 1.8.31
5Release: 1%{?_dist_release}
6License: ISC-style
7Group: Applications/System
8URL: http://www.sudo.ws/sudo/
9
10# master is toooooooooooooooo slow.
11Source0: http://www.sudo.ws/sudo/dist/sudo-%{version}.tar.gz
12#Source0: http://core.ring.gr.jp/archives/misc/sudo/sudo-%{version}.tar.gz
13Source1: sudo-sudoers-vine
14
15# don't strip
16Patch1: sudo-1.6.7p5-strip.patch
17
18Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: pam-devel
20BuildRequires: groff
21BuildRequires: flex
22BuildRequires: bison
23BuildRequires: openldap-devel
24BuildRequires: automake autoconf libtool
25BuildRequires: libcap-devel
26BuildRequires: zlib-devel
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31%description
32Sudo (superuser do) allows a system administrator to give certain users
33(or groups of users) the ability to run some (or all) commands as root while
34logging all commands and arguments. Sudo operates on a per-command basis,
35it is not a replacement for the shell.
36
37%description -l ja
38sudo は、特定のユーザや特定のグループに所属するユーザが、スーパーユーザ権限で
39いくつかのコマンド操作を行うことを許可するためのプログラムです。
40
41%prep
42%setup -q
43%patch1 -p1 -b .strip
44
45rm -rf zlib/
46
47%build
48autoreconf -I m4 -fv --install
49
50F_PIE=-fpie
51export CFLAGS="$RPM_OPT_FLAGS $F_PIE" LDFLAGS="-pie -Wl,-z,relro -Wl,-z,now"
52
53%configure \
54  --prefix=%{_prefix} \
55  --sbindir=%{_sbindir} \
56  --libdir=%{_libdir} \
57  --sysconfdir=%{_sysconfdir} \
58  --docdir=%{_datadir}/doc/%{name}-%{version} \
59  --with-iologdir=/var/log/sudo-io \
60  --with-pam \
61  --with-pam-login \
62  --with-logging=syslog \
63  --with-logfac=authpriv \
64  --with-tty-tickets \
65  --with-ignore-dot \
66  --with-editor=/bin/vi \
67  --with-env-editor \
68  --with-ldap \
69  --with-passprompt="[sudo] password for %p: " \
70  --with-secure-path="/sbin:/bin:/usr/sbin:/usr/bin" \
71  --without-interfaces \
72  --without-selinux
73make %{?_smp_mflags}
74
75%install
76rm -rf %{buildroot}
77mkdir %{buildroot}
78make install DESTDIR="%{buildroot}" install_uid=`id -u` install_gid=`id -g` sudoers_uid=`id -u` sudoers_gid=`id -g`
79
80chmod 755 %{buildroot}%{_bindir}/* %{buildroot}%{_sbindir}/*
81install -p -d -m 700 %{buildroot}/var/run/sudo
82install -p -d -m 700 %{buildroot}/var/db/sudo/lectured
83install -p -d -m 700 %{buildroot}/var/log/sudo-io
84install -p -d -m 750 %{buildroot}/etc/sudoers.d
85install -p -c -m 0440 %{SOURCE1} %{buildroot}/etc/sudoers
86
87chmod +x %{buildroot}%{_libexecdir}/sudo/*.so # for stripping, reset in %%files
88
89mv -f %{buildroot}%{_docdir}/sudo-%{version} docdir
90mv -f %{buildroot}%{_sysconfdir}/sudoers.dist docdir/
91rm -f docdir/LICENSE
92
93#Remove all .la files
94find %{buildroot} -name '*.la' -exec rm -f {} ';'
95
96%find_lang sudo
97%find_lang sudoers
98
99cat sudo.lang sudoers.lang > sudo_all.lang
100rm sudo.lang sudoers.lang
101
102mkdir -p %{buildroot}/etc/pam.d
103cat > %{buildroot}/etc/pam.d/sudo << EOF
104#%PAM-1.0
105auth       include      system-auth
106account    include      system-auth
107password   include      system-auth
108session    optional     pam_keyinit.so revoke
109session    required     pam_limits.so
110session    include      system-auth
111EOF
112
113cat > %{buildroot}/etc/pam.d/sudo-i << EOF
114#%PAM-1.0
115auth       include      sudo
116account    include      sudo
117password   include      sudo
118session    optional     pam_keyinit.so force revoke
119session    include      sudo
120EOF
121
122
123%clean
124rm -rf %{buildroot}
125
126%files -f sudo_all.lang
127%defattr(-,root,root)
128%license doc/LICENSE
129%doc docdir/*
130%doc plugins/sample/sample_plugin.c
131%attr(0440,root,root) %config(noreplace) /etc/sudoers
132%attr(0750,root,root) %dir /etc/sudoers.d/
133%config(noreplace) /etc/pam.d/sudo
134%config(noreplace) /etc/pam.d/sudo-i
135%dir /var/run/sudo
136%dir /var/db/sudo
137%dir /var/db/sudo/lectured
138%attr(0750,root,root) %dir /var/log/sudo-io
139%{_bindir}/cvtsudoers
140%attr(4111,root,root) %{_bindir}/sudo
141%{_bindir}/sudoedit
142%attr(0111,root,root) %{_bindir}/sudoreplay
143%attr(0755,root,root) %{_sbindir}/visudo
144%dir %{_libexecdir}/sudo
145%attr(0644,root,root) %{_libexecdir}/sudo/sudo_noexec.so
146%attr(0644,root,root) %{_libexecdir}/sudo/sudoers.so
147%attr(0644,root,root) %{_libexecdir}/sudo/group_file.so
148%attr(0644,root,root) %{_libexecdir}/sudo/system_group.so
149%attr(0644,root,root) %{_libexecdir}/sudo/libsudo_util.so.?.?.?
150%{_libexecdir}/sudo/libsudo_util.so.?
151%{_libexecdir}/sudo/libsudo_util.so
152%{_mandir}/man1/cvtsudoers.1*
153%{_mandir}/man5/sudoers*.5*
154%{_mandir}/man5/sudo.conf.5*
155%{_mandir}/man8/sudo.8*
156%{_mandir}/man8/sudoedit.8*
157%{_mandir}/man8/sudoreplay.8*
158%{_mandir}/man8/visudo.8*
159# should be splitted to -devel?
160%{_includedir}/sudo_plugin.h
161%{_mandir}/man8/sudo_plugin.8*
162
163
164%post
165/bin/chmod 0440 /etc/sudoers || :
166
167%changelog
168* Tue Feb 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.31-1
169- updated to 1.8.31.
170
171* Wed Jan 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.30-1
172- updated to 1.8.30.
173
174* Tue Oct 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.28-1
175- updated to 1.8.28.
176- dropped Patch2.
177
178* Sat Jul 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.17p1-1
179- updated to 1.8.17p1.
180- added Patch2.
181- dropped Patch4.
182
183* Mon Feb  3 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.8.6p8-1
184- update to 1.8.6p8
185
186* Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-3
187- fix permission of sudoreplay
188
189* Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-2
190- add /var/log/sudo-io
191- add some comments to default sudoers
192
193* Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-1
194- update to 1.8.6p7
195- drop unneeded patches.
196
197* Sat May 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-5
198- add patch120 for fix CVE-2012-2337 (netmask match)
199
200* Fri Jun 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2p7-4
201- update sudoers
202  - enable "%wheel ALL=(ALL) ALL" by default.
203
204* Thu Feb 10 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-3
205- add patch110,111 for fix CVE-2011-0010 ("-g" option)
206
207* Wed Sep  8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-2
208- add Patch100 for fix CVE-2010-2956 (sudo Runas)
209- add _smp_mflags flag into make section
210- fix doc filelist (no longer exist BUGS, CHANGSE)
211
212* Sun Jun 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-1
213- new upstream release with security fix (CVE-2010-1646)
214- change specfile name (-vl)
215
216* Sun Apr 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p6-1
217- new upstream release with security fix (CVE-2010-1163)
218- add sudoers.ldap.5 into files section
219
220* Wed Feb 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p4-1
221- new upstream release with security fix (CVE-2010-0426)
222- update Patch3
223
224* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2-1
225- new upstream release
226
227* Wed Jun 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.1-1
228- new upstream release
229- update patches
230- disable "Defaults requiretty"
231
232* Fri Feb 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.9p20-2
233- rebuilt with openldap-2.4.11
234
235* Thu Feb 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.9p20-1
236- new upstream release with security fix (CVE 2009-0034)
237
238* Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.9p17-1
239- new upstream release
240- merge some changes from fedoraproject
241  - include [sudo] in password prompt
242  - compiled with secure path
243  - also use getgrouplist() to determine group membership
244  - add sudoers file
245    - add command aliases, default environment config
246- build with openldap
247
248* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.8p12-1vl5
249- applied new versioning policy, spec in utf-8
250
251* Fri May 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p12-0vl2
252- change PAM configuration to use system-auth
253- add --with-ignore-dot, --with-editor and --with-env-editor to
254  configure option.
255
256* Mon Jan 23 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.8p12-0vl1
257- new upstream release (included security fix)
258- add patch1 for fix CVE-2006-0151
259
260* Mon May 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p8-0vl1
261- new upstream release
262- use macros
263- build with pam
264
265* Wed Jan 19 2005 IWAI, Masaharu <iwai@alib.jp> 1.6.8p6-0vl1
266- new upstream release
267
268* Sun Oct 10 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8p1-0vl1
269- SECURITY FIX: new upstream release
270- update rpmnonroot.patch ( Patch0 )
271- add new man page: sudoedit(8)
272
273* Wed Sep  1 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8-0vl1
274- new upstream release
275- update rpmnonroot.patch ( Patch0 )
276- change Copyrigh tag to License tag
277- update License
278- update URL and Source0: official web site moved.
279- new files: %%{_bindir}/sudoedit and %%{_libexecdir}/sudo_noexec.*
280
281* Mon Apr 14 2003 IWAI Masaharu <iwai@alib.jp> 1.6.7p3-0vl1
282- upstream release
283
284* Wed May 08 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl3
285- fixed changelog
286        -- don't expand macros in changelog ;P
287               
288* Wed May 01 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl2
289- changed to use configure in build section
290        (can't build on sparc)
291
292* Fri Apr 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.6-0vl1
293- upstream release
294- fix security hole : buffer over flow
295
296* Thu Jan 24 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p2-0vl1
297- upstream release
298- updated sudo.rpmnonroot.diff
299
300* Fri Jan 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p1-0vl1
301- upstream release
302- added configure script option '--disable-root-mailer'
303
304* Tue Jan 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4p1-0vl1
305- upstream release
306- eliminated FAQ from %doc
307
308* Mon Jan 14 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4-0vl1
309- upstream release
310- added noreplace flag (%{_sysconfdir}/sudoers file is not replaced)
311- updated sudo.rpmnonroot.diff
312
313* Wed May 09 2001 <sagami@vinelinux.org>
314- 1.6.3p7-0vl2: follow up 1.6.2p6-0.6vl1
315
316* Fri Mar 02 2001 sagami@vinelinux.org
317- 1.6.3p7-0vl1
318- use better macros
319
320* Thu Mar 1 2001 Kunio Murasawa <murasawa@marineroad.com>
321- 1.6.3p6-0vl1
322- changed sudo.rpmnonroot.diff for 1.6.3p6
323
324* Tue Sep 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
325- 1.6.1-2vl5
326- patch -p1 -> patch -p0
327
328* Mon Sep 18 2000 MATSUMOTO Shoji <shom@vinelinux.org>
329- 1.6.1-2vl4
330- fix uid/gid to root.root
331- add sudo.rpmnonroot.diff to built by non-root users
332
333* Tue Sep 12 2000 Jun Nishii <jun@vinelinux.org>
334- 1.6.1-2vl3
335- fix attr
336
337* Sun Sep 10 2000 Jun Nishii <jun@vinelinux.org>
338- 1.6.1-2vl2
339- enable to build by non-root useres
340
341* Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
342- 1.6.1-2vl1
343- modified %files section to handle compressed man page(s)
344
345* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
346- change group
347
348* Thu Dec 30 1999 Jun Nishii <jun@vinelinux.org>
349- version 1.6.1
350- build for Vine Linux 2.0
351
352* Fri May 14  1999 Takeda Eiji <keda@flatout.org>
353- sudo reads $BuildRoot%{_sysconfdir}/sudoers. Make change to read /etc/sudoers.
354
355* Wed Apr 21 1999 Hiroto Watanabe <watanabe@cij.co.jp>
356- Initial Release
357
Note: See TracBrowser for help on using the repository browser.