source: projects/specs/trunk/s/sudo/sudo-vl.spec @ 12277

Revision 12277, 10.5 KB checked in by tomop, 5 years ago (diff)

updated 22 packages

Cython-0.29.13-1

alsa-lib-1.1.9-1

alsa-plugins-1.1.9-1

alsa-tools-1.1.7-1

alsa-utils-1.1.9-1

cairo-1.16.0-1

evince-3.30.3-1

expat-2.2.9-1

file-roller-3.30.1-1

gtk-doc-1.32-2

libplist-2.0.0-1

libsndfile-1.0.28-1

ncurses-6.1-2

openssh-8.1p1-1

python-2.7.16-5

python3-3.5.7-4

rsync-3.1.3-1

samba-4.10.9-1

sudo-1.8.28-1

sysstat-12.1.7-1

tix-8.4.3-5

zabbix-4.0.13-1

Line 
1Summary: Allows command execution as root for specified users
2Summary(ja): スーパーユーザ権限でのコマンドの実行
3Name: sudo
4Version: 1.8.28
5Release: 1%{?_dist_release}
6License: ISC-style
7Group: Applications/System
8URL: http://www.sudo.ws/sudo/
9
10# master is toooooooooooooooo slow.
11# Source0: http://www.sudo.ws/sudo/dist/sudo-%{version}.tar.gz
12Source0: http://core.ring.gr.jp/archives/misc/sudo/sudo-%{version}.tar.gz
13Source1: sudo-sudoers-vine
14
15# don't strip
16Patch1: sudo-1.6.7p5-strip.patch
17
18Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: pam-devel
20BuildRequires: groff
21BuildRequires: flex
22BuildRequires: bison
23BuildRequires: openldap-devel
24BuildRequires: automake autoconf libtool
25BuildRequires: libcap-devel
26BuildRequires: zlib-devel
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31%description
32Sudo (superuser do) allows a system administrator to give certain users
33(or groups of users) the ability to run some (or all) commands as root while
34logging all commands and arguments. Sudo operates on a per-command basis,
35it is not a replacement for the shell.
36
37%description -l ja
38sudo は、特定のユーザや特定のグループに所属するユーザが、スーパーユーザ権限で
39いくつかのコマンド操作を行うことを許可するためのプログラムです。
40
41%prep
42%setup -q
43%patch1 -p1 -b .strip
44
45rm -rf zlib/
46
47%build
48autoreconf -I m4 -fv --install
49
50F_PIE=-fpie
51export CFLAGS="$RPM_OPT_FLAGS $F_PIE" LDFLAGS="-pie -Wl,-z,relro -Wl,-z,now"
52
53%configure \
54  --prefix=%{_prefix} \
55  --sbindir=%{_sbindir} \
56  --libdir=%{_libdir} \
57  --sysconfdir=%{_sysconfdir} \
58  --docdir=%{_datadir}/doc/%{name}-%{version} \
59  --with-iologdir=/var/log/sudo-io \
60  --with-pam \
61  --with-pam-login \
62  --with-logging=syslog \
63  --with-logfac=authpriv \
64  --with-tty-tickets \
65  --with-ignore-dot \
66  --with-editor=/bin/vi \
67  --with-env-editor \
68  --with-ldap \
69  --with-passprompt="[sudo] password for %p: " \
70  --with-secure-path="/sbin:/bin:/usr/sbin:/usr/bin" \
71  --without-interfaces \
72  --without-selinux
73make %{?_smp_mflags}
74
75%install
76rm -rf %{buildroot}
77mkdir %{buildroot}
78make install DESTDIR="%{buildroot}" install_uid=`id -u` install_gid=`id -g` sudoers_uid=`id -u` sudoers_gid=`id -g`
79
80chmod 755 %{buildroot}%{_bindir}/* %{buildroot}%{_sbindir}/*
81install -p -d -m 700 %{buildroot}/var/run/sudo
82install -p -d -m 700 %{buildroot}/var/db/sudo/lectured
83install -p -d -m 700 %{buildroot}/var/log/sudo-io
84install -p -d -m 750 %{buildroot}/etc/sudoers.d
85install -p -c -m 0440 %{SOURCE1} %{buildroot}/etc/sudoers
86
87chmod +x %{buildroot}%{_libexecdir}/sudo/*.so # for stripping, reset in %%files
88
89mv -f %{buildroot}%{_docdir}/sudo-%{version} docdir
90mv -f %{buildroot}%{_sysconfdir}/sudoers.dist docdir/
91rm -f docdir/LICENSE
92
93#Remove all .la files
94find %{buildroot} -name '*.la' -exec rm -f {} ';'
95
96%find_lang sudo
97%find_lang sudoers
98
99cat sudo.lang sudoers.lang > sudo_all.lang
100rm sudo.lang sudoers.lang
101
102mkdir -p %{buildroot}/etc/pam.d
103cat > %{buildroot}/etc/pam.d/sudo << EOF
104#%PAM-1.0
105auth       include      system-auth
106account    include      system-auth
107password   include      system-auth
108session    optional     pam_keyinit.so revoke
109session    required     pam_limits.so
110session    include      system-auth
111EOF
112
113cat > %{buildroot}/etc/pam.d/sudo-i << EOF
114#%PAM-1.0
115auth       include      sudo
116account    include      sudo
117password   include      sudo
118session    optional     pam_keyinit.so force revoke
119session    include      sudo
120EOF
121
122
123%clean
124rm -rf %{buildroot}
125
126%files -f sudo_all.lang
127%defattr(-,root,root)
128%license doc/LICENSE
129%doc docdir/*
130%doc plugins/sample/sample_plugin.c
131%attr(0440,root,root) %config(noreplace) /etc/sudoers
132%attr(0750,root,root) %dir /etc/sudoers.d/
133%config(noreplace) /etc/pam.d/sudo
134%config(noreplace) /etc/pam.d/sudo-i
135%dir /var/run/sudo
136%dir /var/db/sudo
137%dir /var/db/sudo/lectured
138%attr(0750,root,root) %dir /var/log/sudo-io
139%{_bindir}/cvtsudoers
140%attr(4111,root,root) %{_bindir}/sudo
141%{_bindir}/sudoedit
142%attr(0111,root,root) %{_bindir}/sudoreplay
143%attr(0755,root,root) %{_sbindir}/visudo
144%dir %{_libexecdir}/sudo
145%attr(0644,root,root) %{_libexecdir}/sudo/sudo_noexec.so
146%attr(0644,root,root) %{_libexecdir}/sudo/sudoers.so
147%attr(0644,root,root) %{_libexecdir}/sudo/group_file.so
148%attr(0644,root,root) %{_libexecdir}/sudo/system_group.so
149%attr(0644,root,root) %{_libexecdir}/sudo/libsudo_util.so.?.?.?
150%{_libexecdir}/sudo/libsudo_util.so.?
151%{_libexecdir}/sudo/libsudo_util.so
152%{_mandir}/man1/cvtsudoers.1*
153%{_mandir}/man5/sudoers*.5*
154%{_mandir}/man5/sudo.conf.5*
155%{_mandir}/man8/sudo.8*
156%{_mandir}/man8/sudoedit.8*
157%{_mandir}/man8/sudoreplay.8*
158%{_mandir}/man8/visudo.8*
159# should be splitted to -devel?
160%{_includedir}/sudo_plugin.h
161%{_mandir}/man8/sudo_plugin.8*
162
163
164%post
165/bin/chmod 0440 /etc/sudoers || :
166
167%changelog
168* Tue Oct 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.28-1
169- updated to 1.8.28.
170- dropped Patch2.
171
172* Sat Jul 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.17p1-1
173- updated to 1.8.17p1.
174- added Patch2.
175- dropped Patch4.
176
177* Mon Feb  3 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.8.6p8-1
178- update to 1.8.6p8
179
180* Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-3
181- fix permission of sudoreplay
182
183* Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-2
184- add /var/log/sudo-io
185- add some comments to default sudoers
186
187* Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-1
188- update to 1.8.6p7
189- drop unneeded patches.
190
191* Sat May 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-5
192- add patch120 for fix CVE-2012-2337 (netmask match)
193
194* Fri Jun 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2p7-4
195- update sudoers
196  - enable "%wheel ALL=(ALL) ALL" by default.
197
198* Thu Feb 10 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-3
199- add patch110,111 for fix CVE-2011-0010 ("-g" option)
200
201* Wed Sep  8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-2
202- add Patch100 for fix CVE-2010-2956 (sudo Runas)
203- add _smp_mflags flag into make section
204- fix doc filelist (no longer exist BUGS, CHANGSE)
205
206* Sun Jun 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-1
207- new upstream release with security fix (CVE-2010-1646)
208- change specfile name (-vl)
209
210* Sun Apr 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p6-1
211- new upstream release with security fix (CVE-2010-1163)
212- add sudoers.ldap.5 into files section
213
214* Wed Feb 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p4-1
215- new upstream release with security fix (CVE-2010-0426)
216- update Patch3
217
218* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2-1
219- new upstream release
220
221* Wed Jun 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.1-1
222- new upstream release
223- update patches
224- disable "Defaults requiretty"
225
226* Fri Feb 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.9p20-2
227- rebuilt with openldap-2.4.11
228
229* Thu Feb 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.9p20-1
230- new upstream release with security fix (CVE 2009-0034)
231
232* Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.9p17-1
233- new upstream release
234- merge some changes from fedoraproject
235  - include [sudo] in password prompt
236  - compiled with secure path
237  - also use getgrouplist() to determine group membership
238  - add sudoers file
239    - add command aliases, default environment config
240- build with openldap
241
242* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.8p12-1vl5
243- applied new versioning policy, spec in utf-8
244
245* Fri May 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p12-0vl2
246- change PAM configuration to use system-auth
247- add --with-ignore-dot, --with-editor and --with-env-editor to
248  configure option.
249
250* Mon Jan 23 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.8p12-0vl1
251- new upstream release (included security fix)
252- add patch1 for fix CVE-2006-0151
253
254* Mon May 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p8-0vl1
255- new upstream release
256- use macros
257- build with pam
258
259* Wed Jan 19 2005 IWAI, Masaharu <iwai@alib.jp> 1.6.8p6-0vl1
260- new upstream release
261
262* Sun Oct 10 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8p1-0vl1
263- SECURITY FIX: new upstream release
264- update rpmnonroot.patch ( Patch0 )
265- add new man page: sudoedit(8)
266
267* Wed Sep  1 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8-0vl1
268- new upstream release
269- update rpmnonroot.patch ( Patch0 )
270- change Copyrigh tag to License tag
271- update License
272- update URL and Source0: official web site moved.
273- new files: %%{_bindir}/sudoedit and %%{_libexecdir}/sudo_noexec.*
274
275* Mon Apr 14 2003 IWAI Masaharu <iwai@alib.jp> 1.6.7p3-0vl1
276- upstream release
277
278* Wed May 08 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl3
279- fixed changelog
280        -- don't expand macros in changelog ;P
281               
282* Wed May 01 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl2
283- changed to use configure in build section
284        (can't build on sparc)
285
286* Fri Apr 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.6-0vl1
287- upstream release
288- fix security hole : buffer over flow
289
290* Thu Jan 24 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p2-0vl1
291- upstream release
292- updated sudo.rpmnonroot.diff
293
294* Fri Jan 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p1-0vl1
295- upstream release
296- added configure script option '--disable-root-mailer'
297
298* Tue Jan 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4p1-0vl1
299- upstream release
300- eliminated FAQ from %doc
301
302* Mon Jan 14 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4-0vl1
303- upstream release
304- added noreplace flag (%{_sysconfdir}/sudoers file is not replaced)
305- updated sudo.rpmnonroot.diff
306
307* Wed May 09 2001 <sagami@vinelinux.org>
308- 1.6.3p7-0vl2: follow up 1.6.2p6-0.6vl1
309
310* Fri Mar 02 2001 sagami@vinelinux.org
311- 1.6.3p7-0vl1
312- use better macros
313
314* Thu Mar 1 2001 Kunio Murasawa <murasawa@marineroad.com>
315- 1.6.3p6-0vl1
316- changed sudo.rpmnonroot.diff for 1.6.3p6
317
318* Tue Sep 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
319- 1.6.1-2vl5
320- patch -p1 -> patch -p0
321
322* Mon Sep 18 2000 MATSUMOTO Shoji <shom@vinelinux.org>
323- 1.6.1-2vl4
324- fix uid/gid to root.root
325- add sudo.rpmnonroot.diff to built by non-root users
326
327* Tue Sep 12 2000 Jun Nishii <jun@vinelinux.org>
328- 1.6.1-2vl3
329- fix attr
330
331* Sun Sep 10 2000 Jun Nishii <jun@vinelinux.org>
332- 1.6.1-2vl2
333- enable to build by non-root useres
334
335* Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
336- 1.6.1-2vl1
337- modified %files section to handle compressed man page(s)
338
339* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
340- change group
341
342* Thu Dec 30 1999 Jun Nishii <jun@vinelinux.org>
343- version 1.6.1
344- build for Vine Linux 2.0
345
346* Fri May 14  1999 Takeda Eiji <keda@flatout.org>
347- sudo reads $BuildRoot%{_sysconfdir}/sudoers. Make change to read /etc/sudoers.
348
349* Wed Apr 21 1999 Hiroto Watanabe <watanabe@cij.co.jp>
350- Initial Release
351
Note: See TracBrowser for help on using the repository browser.