source: projects/specs/trunk/s/subversion/subversion-vl.spec @ 3130

Revision 3130, 15.6 KB checked in by iwaim, 13 years ago (diff)

subversion-1.6.16-2

Line 
1%define neon_version 0.25.5
2%define swig_version 1.3.29
3%define apache_dir /usr
4
5%define db_version 4.3.29
6
7%define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
8
9# set to zero to avoid running test suite
10%define make_check 0
11
12Summary: Modern Version Control System
13Summary(ja): モダンなバージョン管理システム
14Name: subversion
15Version: 1.6.16
16Release: 2%{?_dist_release}
17License: ASL 1.1
18Group: Development/Tools
19URL: http://subversion.apache.org/
20
21Packager: iwai
22Vendor: Project Vine
23Distribution: Vine Linux
24
25SOURCE0: subversion-%{version}.tar.bz2
26SOURCE1: subversion.conf
27SOURCE2: httpd.davcheck.conf
28SOURCE3: filter-requires.sh
29Patch1: subversion-1.6.0-deplibs.patch
30Patch3: subversion-1.6.1-rpath.patch
31Patch6: subversion-1.5.0-pie.patch
32Patch10: subversion-1.5.7-update-neon-m4.patch
33
34Requires: db4 >= %{db_version}
35Requires: expat
36Requires: neon >= %{neon_version}
37BuildRequires: apache2-devel
38BuildRequires: apr-devel, apr-util-devel
39BuildRequires: autoconf >= 2.53
40BuildRequires: db4-devel >= %{db_version}
41BuildRequires: expat-devel
42BuildRequires: gdbm-devel
43BuildRequires: libtool >= 1.4.2
44BuildRequires: neon-devel >= %{neon_version}
45BuildRequires: openssl-devel
46BuildRequires: python
47BuildRequires: python-devel
48BuildRequires: swig >= %{swig_version}
49BuildRequires: texinfo
50BuildRequires: zlib-devel
51BuildRequires: openldap-devel
52BuildRequires: ruby >= 1.8.2
53BuildRequires: ruby-devel >= 1.8.2
54BuildRequires: perl >= 5.8.0
55BuildRequires: sqlite3-devel
56BuildRequires: krb5-devel
57BuildRoot: %{_tmppath}/%{name}-%{version}-root
58
59%define __perl_requires %{SOURCE3}
60
61%description
62Subversion is a concurrent version control system which enables one
63or more users to collaborate in developing and maintaining a
64hierarchy of files and directories while keeping a history of all
65changes.  Subversion only stores the differences between versions,
66instead of every complete file.  Subversion is intended to be a
67compelling replacement for CVS.
68
69%package devel
70Group: Development/Libraries
71Summary: Development package for Subversion developers.
72Requires: subversion = %{version}-%{release}
73Requires: apr-devel, apr-util-devel
74%description devel
75The subversion-devel package includes the static libraries and include files
76for developers interacting with the subversion package.
77
78%package mod_dav_svn
79Group: System Environment/Daemons
80Summary: Apache server module for Subversion server.
81Requires: httpd >= %{apache_version}
82Requires: subversion = %{version}-%{release}
83%description mod_dav_svn
84The subversion-mod_dav_svn package adds the Subversion server Apache module to
85the Apache directories and configuration.
86
87%package tools
88Group: Development/Tools
89Summary: Tools for Subversion
90BuildRequires: perl >= 5.8.0
91Requires: perl >= 5.8.0
92Requires: subversion = %{version}-%{release}
93
94%description tools
95Tools for Subversion.
96
97%package perl
98Group: Development/Libraries
99Summary: Perl bindings to the Subversion libraries
100Requires: subversion = %{version}-%{release}
101Requires: perl >= 5.8.0
102Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
103
104%description perl
105This package includes the Perl bindings to the Subversion libraries.
106
107%package ruby
108Group: Development/Libraries
109Summary: Ruby bindings to the Subversion libraries
110Requires: subversion = %{version}-%{release}
111Requires: ruby >= 1.8.2
112
113%description ruby
114This package includes the Ruby bindings to the Subversion libraries.
115
116%package python
117Group: Development/Libraries
118Summary: Python bindings to the Subversion libraries
119Requires: subversion = %{version}-%{release}, python
120
121%description python
122This package includes the Python bindings to the Subversion libraries.
123
124%prep
125%setup -q
126%patch1 -p1 -b .deplibs
127%patch3 -p1 -b .rpath
128## comment out: 1.6.9-1
129#%patch6 -p1 -b .pie
130## comment out: 1.6.9-1
131#%patch10 -p1 -b .nola
132
133rm -rf neon apr apr-util db4
134
135%build
136./autogen.sh
137
138# fix shebang lines, #111498
139perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
140
141# override weird -shrext from ruby
142export svn_cv_ruby_link="%{__cc} -shared"
143export svn_cv_ruby_sitedir_libsuffix=""
144export svn_cv_ruby_sitedir_archsuffix=""
145
146export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path}
147export CPPFLAGS="-DSVN_NEON_0_26 -DSVN_NEON_0_25"
148%configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
149        --with-swig --with-neon=%{_prefix} \
150        --with-ruby-sitedir=%{rarchdir} \
151        --with-apxs=%{_bindir}/apxs \
152        --disable-mod-activation --disable-static --disable-neon-version-check
153# 1.3.0 tarball ships with generated swig sources
154make extraclean-swig-headers
155make %{?_smp_mflags} all
156make swig-py swig-py-lib %{swigdirs}
157make swig-pl swig-pl-lib swig-rb swig-rb-lib
158
159
160%install
161echo %{rarchdir}
162rm -rf $RPM_BUILD_ROOT
163make install \
164        install-swig-py \
165        install-swig-pl-lib \
166        install-swig-rb \
167        DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
168
169make pure_vendor_install -C subversion/bindings/swig/perl/native \
170        PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
171install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
172
173# Add subversion.conf configuration file into httpd/conf.d directory.
174install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
175install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
176
177# Set up tools package files.
178mkdir -p $RPM_BUILD_ROOT/usr/lib/subversion
179cp -r tools $RPM_BUILD_ROOT/usr/lib/subversion
180
181# Remove unpackaged files
182rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
183       $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
184       $RPM_BUILD_ROOT%{_libdir}/*.la
185       
186# remove stuff produced with Perl modules
187find $RPM_BUILD_ROOT -type f \
188     -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
189     -print0 | xargs -0 rm -f
190
191# make Perl modules writable so they get stripped
192find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
193     xargs -0 chmod 755
194
195# unnecessary libraries for swig bindings
196rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
197
198# Remove unnecessary ruby libraries
199rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
200
201# Trim what goes in docdir
202rm -rf tools/*/*.in tools/test-scripts
203                       
204# Rename authz_svn INSTALL doc for docdir
205ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
206
207%clean
208rm -rf $RPM_BUILD_ROOT
209
210%post -p /sbin/ldconfig
211
212%postun -p /sbin/ldconfig
213
214%post tools -p /sbin/ldconfig
215
216%postun tools -p /sbin/ldconfig
217
218
219%files
220%defattr(-,root,root)
221%doc BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README
222%doc subversion/LICENSE
223%{_bindir}/*
224%{_libdir}/libsvn_*.so.*
225%{_localedir}/*/*/subversion.mo
226%{_mandir}/man*/*
227%dir %{_sysconfdir}/subversion
228%exclude %{_mandir}/man*/*::*
229%exclude %{_libdir}/libsvn_swig_perl*.so.*
230%exclude %{_libdir}/libsvn_swig_py*.so.*
231%exclude %{_libdir}/libsvn_swig_ruby*.so.*
232
233%files devel
234%defattr(-,root,root)
235%{_includedir}/subversion-1
236%{_libdir}/libsvn*.so
237%exclude %{_libdir}/libsvn_swig_perl*.so.*
238%exclude %{_libdir}/libsvn_swig_py*.so.*
239%exclude %{_libdir}/libsvn_swig_ruby*.so.*
240
241%files mod_dav_svn
242%defattr(-,root,root)
243%config(noreplace) /etc/apache2/conf.d/subversion.conf
244%{apache_dir}/%{_lib}/apache2/modules/mod_*.*
245
246%files tools
247%defattr(-,root,root)
248%{_prefix}/lib/subversion/tools
249
250%files perl
251%defattr(-,root,root,-)
252%{perl_vendorarch}/auto/SVN
253%{perl_vendorarch}/SVN
254%{_libdir}/libsvn_swig_perl*
255%{_mandir}/man*/*::*
256
257%files ruby
258%defattr(-,root,root,-)
259%{_libdir}/libsvn_swig_ruby*
260%{rarchdir}/svn
261
262%files python
263%defattr(-,root,root,-)
264%{_libdir}/libsvn_swig_py*
265%{python_sitearch}/libsvn
266%{python_sitearch}/svn
267
268
269%changelog
270* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
271- build with perl 5.12.3
272- add Requires: perl(:MODULE_COMPAT_...)
273
274* Sat Mar  5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
275- new upstream release with security fix
276- add Vendor/Distri tags
277
278* Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
279- new upstream release
280
281* Tue Mar  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
282- fix <BTS:VineLinux:941>
283  - using rpm macro: rarchdir
284  - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
285- using rpm macros: perl_vendorarch and python_sitearch
286- add BuildRequires: sqlite3-devel krb5-devel
287
288* Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
289- new upstream release
290- update URL
291- update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
292- update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
293- stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
294- stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
295
296* Wed Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
297- new upstream release
298
299* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
300- new upstream release
301
302* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
303- rebuilt with python-2.5.2
304
305* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
306- new upstream release
307- rebuild with neon-0.28.2
308- dropped old-Patch10 by adding --disable-neon-version-check to %%configure
309- added Patch6, 8, 9, 10 from Fedora Core
310  * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
311  - Correct install location of java stuff (#433295)
312  * Wed Aug  8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
313  - fix build with new glibc open()-as-macro
314  - build all swig code in %%build, not %%install
315  * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
316  - build /usr/bin/* as PIEs
317
318* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
319- rebuild with expat-2.0.1
320
321* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
322- new upstream release
323- add Patch10 to build with neon.
324  1.3.2-0vl5 does not support neon..
325
326* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
327- rebuild with new neon
328
329* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
330- rebuilt with new toolchain and db4-4.3.x
331
332* Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
333- modified %%files section for lib64 architecture
334
335* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
336- new upstream release
337- rebuild with new openldap-2.3.24
338
339* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
340- new upstream release
341- change Group to Develoment/Tools
342- build with apr-1.2.7/apr-util-1.2.7
343  - require apr/apr-util instead of apache2-apr
344- build with swig-1.3.29
345- split {perl,python,ruby} related files to subpackage.
346
347* Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
348- new upstream release
349- add noreplace option for config file
350
351* Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
352- fix Requires and BuildPreReq.
353
354* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
355- new upstream release.
356- add swig-runtime to 'BuildPreReq:'.
357- fix %%files.
358
359* Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
360- require neon version 0.24.7 for ra_dav
361- add BuildPreReq: openldap-devel
362- replace BuildPreReq: httpd to BuildPreReq: apache2
363- replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
364
365* Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
366- new upstream release
367
368* Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
369- new upstream release
370
371* Fri Jun  4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
372- new upstream release
373- clean up specfile.
374
375* Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
376- new upstream release
377- build with apache2-2.0.47
378
379* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
380- build Vine Linux
381
382* Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
383- Enabled RA_DAV checking.
384  Now requires httpd package to build because of RA_DAV tests.
385
386* Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
387- Created tools package to hold the tools.
388
389* Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
390- Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
391  version of APR/APR-UTILS as of 2003.01.15.
392- Added svnversion command.
393
394* Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
395- Create a svnadmin.static which is copied to svnadmin-version-release
396  when the package is erased, so users can still dump/load their repositories
397  even after they have upgraded the RPM package.
398
399* Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
400- SWIG now builds so we can use cvs2svn.
401
402* Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
403- Made cvs2svn conditional (at least until we can get it to build consistently
404  and work).
405
406* Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
407- Added SWIG dependencies to add cvs2svn capabilities.
408
409* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
410- Now requires neon-0.22.0.
411
412* Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
413- Took out loading mod_dav_svn from subversion.spec file and put it in
414  subversion.conf file which goes into the apache conf directory.
415- Simplify what gets put into httpd.conf to only the include for the
416  subversion.conf file.
417  (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
418  me to do this).
419
420* Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
421- Updated to APR/APR-UTIL 2002-08-08.
422
423* Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
424- Updated to APACHE/APR/APR-UTIL 2002-06-25.
425- Previous version had a few problems because of missing apache error/ files.
426
427* Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
428- Updated to apache-2.0.40-0.3.
429- Updated to subversion-0.13.1-2318.
430
431* Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
432- Updated for RedHat 7.3 (autoconf253).
433- Added a bunch of pre-requisites I didn't know were needed because I built a
434  new machine that didn't have them already installed.
435- Fixed installation of man and info documentation pages.
436
437* Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
438- Back to apache-libapr* stuff, hopefully to stay.
439
440* Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
441- Fixed expat.patch to not have to make so many changes by writing a small
442  shell script that changes libexpat to -lexpat.
443
444* Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
445- Updated to neon-0.19.2.
446
447* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
448- Back to using apr and apr-util separately from apache.
449
450* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
451- Updated to APR and APR-UTIL 2002.02.11.
452- Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
453- Took out a (now non-existant) documentation file.
454- Moved SPEC file changelog to after all package definitions.
455 
456* Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
457- Updated to neon-0.18.5.
458- Broke up apache and apache-devel into apache-apr, apache-apr-devel,
459  apache-apr-utils, and apache-apr-utils-devel.
460- Updated apache to APR and APR-UTILS to 2002.02.03 version.
461
462* Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
463- Now builds without the separate APR package as it is built into and
464  "exported" from apache-2.0.31-0.3.
465
466* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
467- Took out patches to install procedure now not required because of fixes
468  in rev 1130.
469
470* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
471- Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
472  program was added.
473
474* Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
475- Release M5-r340: Added the subversion-server package.
476
477* Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
478- Release M5-r327: No longer need expat-lite. We can use the normal expat.
479
480* Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
481- Release M3-r117: Initial Version.
482
Note: See TracBrowser for help on using the repository browser.