source: projects/specs/trunk/s/subversion/subversion-vl.spec @ 2923

Revision 2923, 15.4 KB checked in by iwamoto, 13 years ago (diff)

subversion: new upstream release with security fix

Line 
1%define neon_version 0.25.5
2%define swig_version 1.3.29
3%define apache_dir /usr
4
5%define db_version 4.3.29
6
7%define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
8
9# set to zero to avoid running test suite
10%define make_check 0
11
12Summary: Modern Version Control System
13Summary(ja): モダンなバージョン管理システム
14Name: subversion
15Version: 1.6.16
16Release: 1%{?_dist_release}
17License: ASL 1.1
18Group: Development/Tools
19URL: http://subversion.apache.org/
20
21Packager: iwai
22Vendor: Project Vine
23Distribution: Vine Linux
24
25SOURCE0: subversion-%{version}.tar.bz2
26SOURCE1: subversion.conf
27SOURCE2: httpd.davcheck.conf
28SOURCE3: filter-requires.sh
29Patch1: subversion-1.6.0-deplibs.patch
30Patch3: subversion-1.6.1-rpath.patch
31Patch6: subversion-1.5.0-pie.patch
32Patch10: subversion-1.5.7-update-neon-m4.patch
33
34Requires: db4 >= %{db_version}
35Requires: expat
36Requires: neon >= %{neon_version}
37BuildRequires: apache2-devel
38BuildRequires: apr-devel, apr-util-devel
39BuildRequires: autoconf >= 2.53
40BuildRequires: db4-devel >= %{db_version}
41BuildRequires: expat-devel
42BuildRequires: gdbm-devel
43BuildRequires: libtool >= 1.4.2
44BuildRequires: neon-devel >= %{neon_version}
45BuildRequires: openssl-devel
46BuildRequires: python
47BuildRequires: python-devel
48BuildRequires: swig >= %{swig_version}
49BuildRequires: texinfo
50BuildRequires: zlib-devel
51BuildRequires: openldap-devel
52BuildRequires: ruby >= 1.8.2
53BuildRequires: ruby-devel >= 1.8.2
54BuildRequires: perl >= 5.8.0
55BuildRequires: sqlite3-devel
56BuildRequires: krb5-devel
57BuildRoot: %{_tmppath}/%{name}-%{version}-root
58
59%define __perl_requires %{SOURCE3}
60
61%description
62Subversion is a concurrent version control system which enables one
63or more users to collaborate in developing and maintaining a
64hierarchy of files and directories while keeping a history of all
65changes.  Subversion only stores the differences between versions,
66instead of every complete file.  Subversion is intended to be a
67compelling replacement for CVS.
68
69%package devel
70Group: Development/Libraries
71Summary: Development package for Subversion developers.
72Requires: subversion = %{version}-%{release}
73Requires: apr-devel, apr-util-devel
74%description devel
75The subversion-devel package includes the static libraries and include files
76for developers interacting with the subversion package.
77
78%package mod_dav_svn
79Group: System Environment/Daemons
80Summary: Apache server module for Subversion server.
81Requires: httpd >= %{apache_version}
82Requires: subversion = %{version}-%{release}
83%description mod_dav_svn
84The subversion-mod_dav_svn package adds the Subversion server Apache module to
85the Apache directories and configuration.
86
87%package tools
88Group: Development/Tools
89Summary: Tools for Subversion
90BuildRequires: perl >= 5.8.0
91Requires: perl >= 5.8.0
92Requires: subversion = %{version}-%{release}
93
94%description tools
95Tools for Subversion.
96
97%package perl
98Group: Development/Libraries
99Summary: Perl bindings to the Subversion libraries
100Requires: subversion = %{version}-%{release}
101Requires: perl >= 5.8.0
102
103%description perl
104This package includes the Perl bindings to the Subversion libraries.
105
106%package ruby
107Group: Development/Libraries
108Summary: Ruby bindings to the Subversion libraries
109Requires: subversion = %{version}-%{release}
110Requires: ruby >= 1.8.2
111
112%description ruby
113This package includes the Ruby bindings to the Subversion libraries.
114
115%package python
116Group: Development/Libraries
117Summary: Python bindings to the Subversion libraries
118Requires: subversion = %{version}-%{release}, python
119
120%description python
121This package includes the Python bindings to the Subversion libraries.
122
123%prep
124%setup -q
125%patch1 -p1 -b .deplibs
126%patch3 -p1 -b .rpath
127## comment out: 1.6.9-1
128#%patch6 -p1 -b .pie
129## comment out: 1.6.9-1
130#%patch10 -p1 -b .nola
131
132rm -rf neon apr apr-util db4
133
134%build
135./autogen.sh
136
137# fix shebang lines, #111498
138perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
139
140# override weird -shrext from ruby
141export svn_cv_ruby_link="%{__cc} -shared"
142export svn_cv_ruby_sitedir_libsuffix=""
143export svn_cv_ruby_sitedir_archsuffix=""
144
145export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path}
146export CPPFLAGS="-DSVN_NEON_0_26 -DSVN_NEON_0_25"
147%configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
148        --with-swig --with-neon=%{_prefix} \
149        --with-ruby-sitedir=%{rarchdir} \
150        --with-apxs=%{_bindir}/apxs \
151        --disable-mod-activation --disable-static --disable-neon-version-check
152# 1.3.0 tarball ships with generated swig sources
153make extraclean-swig-headers
154make %{?_smp_mflags} all
155make swig-py swig-py-lib %{swigdirs}
156make swig-pl swig-pl-lib swig-rb swig-rb-lib
157
158
159%install
160echo %{rarchdir}
161rm -rf $RPM_BUILD_ROOT
162make install \
163        install-swig-py \
164        install-swig-pl-lib \
165        install-swig-rb \
166        DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
167
168make pure_vendor_install -C subversion/bindings/swig/perl/native \
169        PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
170install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
171
172# Add subversion.conf configuration file into httpd/conf.d directory.
173install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
174install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
175
176# Set up tools package files.
177mkdir -p $RPM_BUILD_ROOT/usr/lib/subversion
178cp -r tools $RPM_BUILD_ROOT/usr/lib/subversion
179
180# Remove unpackaged files
181rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
182       $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
183       $RPM_BUILD_ROOT%{_libdir}/*.la
184       
185# remove stuff produced with Perl modules
186find $RPM_BUILD_ROOT -type f \
187     -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
188     -print0 | xargs -0 rm -f
189
190# make Perl modules writable so they get stripped
191find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
192     xargs -0 chmod 755
193
194# unnecessary libraries for swig bindings
195rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
196
197# Remove unnecessary ruby libraries
198rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
199
200# Trim what goes in docdir
201rm -rf tools/*/*.in tools/test-scripts
202                       
203# Rename authz_svn INSTALL doc for docdir
204ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
205
206%clean
207rm -rf $RPM_BUILD_ROOT
208
209%post -p /sbin/ldconfig
210
211%postun -p /sbin/ldconfig
212
213%post tools -p /sbin/ldconfig
214
215%postun tools -p /sbin/ldconfig
216
217
218%files
219%defattr(-,root,root)
220%doc BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README
221%doc subversion/LICENSE
222%{_bindir}/*
223%{_libdir}/libsvn_*.so.*
224%{_localedir}/*/*/subversion.mo
225%{_mandir}/man*/*
226%dir %{_sysconfdir}/subversion
227%exclude %{_mandir}/man*/*::*
228%exclude %{_libdir}/libsvn_swig_perl*.so.*
229%exclude %{_libdir}/libsvn_swig_py*.so.*
230%exclude %{_libdir}/libsvn_swig_ruby*.so.*
231
232%files devel
233%defattr(-,root,root)
234%{_includedir}/subversion-1
235%{_libdir}/libsvn*.so
236%exclude %{_libdir}/libsvn_swig_perl*.so.*
237%exclude %{_libdir}/libsvn_swig_py*.so.*
238%exclude %{_libdir}/libsvn_swig_ruby*.so.*
239
240%files mod_dav_svn
241%defattr(-,root,root)
242%config(noreplace) /etc/apache2/conf.d/subversion.conf
243%{apache_dir}/%{_lib}/apache2/modules/mod_*.*
244
245%files tools
246%defattr(-,root,root)
247%{_prefix}/lib/subversion/tools
248
249%files perl
250%defattr(-,root,root,-)
251%{perl_vendorarch}/auto/SVN
252%{perl_vendorarch}/SVN
253%{_libdir}/libsvn_swig_perl*
254%{_mandir}/man*/*::*
255
256%files ruby
257%defattr(-,root,root,-)
258%{_libdir}/libsvn_swig_ruby*
259%{rarchdir}/svn
260
261%files python
262%defattr(-,root,root,-)
263%{_libdir}/libsvn_swig_py*
264%{python_sitearch}/libsvn
265%{python_sitearch}/svn
266
267
268%changelog
269* Sat Mar  5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
270- new upstream release with security fix
271- add Vendor/Distri tags
272
273* Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
274- new upstream release
275
276* Tue Mar  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
277- fix <BTS:VineLinux:941>
278  - using rpm macro: rarchdir
279  - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
280- using rpm macros: perl_vendorarch and python_sitearch
281- add BuildRequires: sqlite3-devel krb5-devel
282
283* Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
284- new upstream release
285- update URL
286- update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
287- update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
288- stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
289- stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
290
291* Wed Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
292- new upstream release
293
294* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
295- new upstream release
296
297* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
298- rebuilt with python-2.5.2
299
300* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
301- new upstream release
302- rebuild with neon-0.28.2
303- dropped old-Patch10 by adding --disable-neon-version-check to %%configure
304- added Patch6, 8, 9, 10 from Fedora Core
305  * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
306  - Correct install location of java stuff (#433295)
307  * Wed Aug  8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
308  - fix build with new glibc open()-as-macro
309  - build all swig code in %%build, not %%install
310  * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
311  - build /usr/bin/* as PIEs
312
313* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
314- rebuild with expat-2.0.1
315
316* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
317- new upstream release
318- add Patch10 to build with neon.
319  1.3.2-0vl5 does not support neon..
320
321* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
322- rebuild with new neon
323
324* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
325- rebuilt with new toolchain and db4-4.3.x
326
327* Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
328- modified %%files section for lib64 architecture
329
330* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
331- new upstream release
332- rebuild with new openldap-2.3.24
333
334* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
335- new upstream release
336- change Group to Develoment/Tools
337- build with apr-1.2.7/apr-util-1.2.7
338  - require apr/apr-util instead of apache2-apr
339- build with swig-1.3.29
340- split {perl,python,ruby} related files to subpackage.
341
342* Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
343- new upstream release
344- add noreplace option for config file
345
346* Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
347- fix Requires and BuildPreReq.
348
349* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
350- new upstream release.
351- add swig-runtime to 'BuildPreReq:'.
352- fix %%files.
353
354* Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
355- require neon version 0.24.7 for ra_dav
356- add BuildPreReq: openldap-devel
357- replace BuildPreReq: httpd to BuildPreReq: apache2
358- replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
359
360* Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
361- new upstream release
362
363* Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
364- new upstream release
365
366* Fri Jun  4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
367- new upstream release
368- clean up specfile.
369
370* Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
371- new upstream release
372- build with apache2-2.0.47
373
374* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
375- build Vine Linux
376
377* Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
378- Enabled RA_DAV checking.
379  Now requires httpd package to build because of RA_DAV tests.
380
381* Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
382- Created tools package to hold the tools.
383
384* Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
385- Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
386  version of APR/APR-UTILS as of 2003.01.15.
387- Added svnversion command.
388
389* Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
390- Create a svnadmin.static which is copied to svnadmin-version-release
391  when the package is erased, so users can still dump/load their repositories
392  even after they have upgraded the RPM package.
393
394* Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
395- SWIG now builds so we can use cvs2svn.
396
397* Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
398- Made cvs2svn conditional (at least until we can get it to build consistently
399  and work).
400
401* Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
402- Added SWIG dependencies to add cvs2svn capabilities.
403
404* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
405- Now requires neon-0.22.0.
406
407* Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
408- Took out loading mod_dav_svn from subversion.spec file and put it in
409  subversion.conf file which goes into the apache conf directory.
410- Simplify what gets put into httpd.conf to only the include for the
411  subversion.conf file.
412  (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
413  me to do this).
414
415* Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
416- Updated to APR/APR-UTIL 2002-08-08.
417
418* Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
419- Updated to APACHE/APR/APR-UTIL 2002-06-25.
420- Previous version had a few problems because of missing apache error/ files.
421
422* Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
423- Updated to apache-2.0.40-0.3.
424- Updated to subversion-0.13.1-2318.
425
426* Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
427- Updated for RedHat 7.3 (autoconf253).
428- Added a bunch of pre-requisites I didn't know were needed because I built a
429  new machine that didn't have them already installed.
430- Fixed installation of man and info documentation pages.
431
432* Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
433- Back to apache-libapr* stuff, hopefully to stay.
434
435* Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
436- Fixed expat.patch to not have to make so many changes by writing a small
437  shell script that changes libexpat to -lexpat.
438
439* Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
440- Updated to neon-0.19.2.
441
442* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
443- Back to using apr and apr-util separately from apache.
444
445* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
446- Updated to APR and APR-UTIL 2002.02.11.
447- Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
448- Took out a (now non-existant) documentation file.
449- Moved SPEC file changelog to after all package definitions.
450 
451* Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
452- Updated to neon-0.18.5.
453- Broke up apache and apache-devel into apache-apr, apache-apr-devel,
454  apache-apr-utils, and apache-apr-utils-devel.
455- Updated apache to APR and APR-UTILS to 2002.02.03 version.
456
457* Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
458- Now builds without the separate APR package as it is built into and
459  "exported" from apache-2.0.31-0.3.
460
461* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
462- Took out patches to install procedure now not required because of fixes
463  in rev 1130.
464
465* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
466- Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
467  program was added.
468
469* Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
470- Release M5-r340: Added the subversion-server package.
471
472* Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
473- Release M5-r327: No longer need expat-lite. We can use the normal expat.
474
475* Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
476- Release M3-r117: Initial Version.
477
Note: See TracBrowser for help on using the repository browser.