source: projects/specs/trunk/s/subversion/subversion-vl.spec @ 2306

Revision 2306, 15.2 KB checked in by iwaim, 13 years ago (diff)

subversion 1.6.15-1

Line 
1%define neon_version 0.25.5
2%define swig_version 1.3.29
3%define apache_dir /usr
4
5%define db_version 4.3.29
6
7%define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
8
9# set to zero to avoid running test suite
10%define make_check 0
11
12Summary: Modern Version Control System
13Summary(ja): モダンなバージョン管理システム
14Name: subversion
15Version: 1.6.15
16Release: 1%{?_dist_release}
17License: ASL 1.1
18Group: Development/Tools
19URL: http://subversion.apache.org/
20
21SOURCE0: subversion-%{version}.tar.bz2
22SOURCE1: subversion.conf
23SOURCE2: httpd.davcheck.conf
24SOURCE3: filter-requires.sh
25Patch1: subversion-1.6.0-deplibs.patch
26Patch3: subversion-1.6.1-rpath.patch
27Patch6: subversion-1.5.0-pie.patch
28Patch10: subversion-1.5.7-update-neon-m4.patch
29
30Requires: db4 >= %{db_version}
31Requires: expat
32Requires: neon >= %{neon_version}
33BuildRequires: apache2-devel
34BuildRequires: apr-devel, apr-util-devel
35BuildRequires: autoconf >= 2.53
36BuildRequires: db4-devel >= %{db_version}
37BuildRequires: expat-devel
38BuildRequires: gdbm-devel
39BuildRequires: libtool >= 1.4.2
40BuildRequires: neon-devel >= %{neon_version}
41BuildRequires: openssl-devel
42BuildRequires: python
43BuildRequires: python-devel
44BuildRequires: swig >= %{swig_version}
45BuildRequires: texinfo
46BuildRequires: zlib-devel
47BuildRequires: openldap-devel
48BuildRequires: ruby >= 1.8.2
49BuildRequires: ruby-devel >= 1.8.2
50BuildRequires: perl >= 5.8.0
51BuildRequires: sqlite3-devel
52BuildRequires: krb5-devel
53BuildRoot: %{_tmppath}/%{name}-%{version}-root
54
55%define __perl_requires %{SOURCE3}
56
57%description
58Subversion is a concurrent version control system which enables one
59or more users to collaborate in developing and maintaining a
60hierarchy of files and directories while keeping a history of all
61changes.  Subversion only stores the differences between versions,
62instead of every complete file.  Subversion is intended to be a
63compelling replacement for CVS.
64
65%package devel
66Group: Development/Libraries
67Summary: Development package for Subversion developers.
68Requires: subversion = %{version}-%{release}
69Requires: apr-devel, apr-util-devel
70%description devel
71The subversion-devel package includes the static libraries and include files
72for developers interacting with the subversion package.
73
74%package mod_dav_svn
75Group: System Environment/Daemons
76Summary: Apache server module for Subversion server.
77Requires: httpd >= %{apache_version}
78Requires: subversion = %{version}-%{release}
79%description mod_dav_svn
80The subversion-mod_dav_svn package adds the Subversion server Apache module to
81the Apache directories and configuration.
82
83%package tools
84Group: Development/Tools
85Summary: Tools for Subversion
86BuildRequires: perl >= 5.8.0
87Requires: perl >= 5.8.0
88Requires: subversion = %{version}-%{release}
89
90%description tools
91Tools for Subversion.
92
93%package perl
94Group: Development/Libraries
95Summary: Perl bindings to the Subversion libraries
96Requires: subversion = %{version}-%{release}
97Requires: perl >= 5.8.0
98
99%description perl
100This package includes the Perl bindings to the Subversion libraries.
101
102%package ruby
103Group: Development/Libraries
104Summary: Ruby bindings to the Subversion libraries
105Requires: subversion = %{version}-%{release}
106Requires: ruby >= 1.8.2
107
108%description ruby
109This package includes the Ruby bindings to the Subversion libraries.
110
111%package python
112Group: Development/Libraries
113Summary: Python bindings to the Subversion libraries
114Requires: subversion = %{version}-%{release}, python
115
116%description python
117This package includes the Python bindings to the Subversion libraries.
118
119%prep
120%setup -q
121%patch1 -p1 -b .deplibs
122%patch3 -p1 -b .rpath
123## comment out: 1.6.9-1
124#%patch6 -p1 -b .pie
125## comment out: 1.6.9-1
126#%patch10 -p1 -b .nola
127
128rm -rf neon apr apr-util db4
129
130%build
131./autogen.sh
132
133# fix shebang lines, #111498
134perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
135
136# override weird -shrext from ruby
137export svn_cv_ruby_link="%{__cc} -shared"
138export svn_cv_ruby_sitedir_libsuffix=""
139export svn_cv_ruby_sitedir_archsuffix=""
140
141export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path}
142export CPPFLAGS="-DSVN_NEON_0_26 -DSVN_NEON_0_25"
143%configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
144        --with-swig --with-neon=%{_prefix} \
145        --with-ruby-sitedir=%{rarchdir} \
146        --with-apxs=%{_bindir}/apxs \
147        --disable-mod-activation --disable-static --disable-neon-version-check
148# 1.3.0 tarball ships with generated swig sources
149make extraclean-swig-headers
150make %{?_smp_mflags} all
151make swig-py swig-py-lib %{swigdirs}
152make swig-pl swig-pl-lib swig-rb swig-rb-lib
153
154
155%install
156echo %{rarchdir}
157rm -rf $RPM_BUILD_ROOT
158make install \
159        install-swig-py \
160        install-swig-pl-lib \
161        install-swig-rb \
162        DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
163
164make pure_vendor_install -C subversion/bindings/swig/perl/native \
165        PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
166install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
167
168# Add subversion.conf configuration file into httpd/conf.d directory.
169install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
170install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
171
172# Set up tools package files.
173mkdir -p $RPM_BUILD_ROOT/usr/lib/subversion
174cp -r tools $RPM_BUILD_ROOT/usr/lib/subversion
175
176# Remove unpackaged files
177rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
178       $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
179       $RPM_BUILD_ROOT%{_libdir}/*.la
180       
181# remove stuff produced with Perl modules
182find $RPM_BUILD_ROOT -type f \
183     -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
184     -print0 | xargs -0 rm -f
185
186# make Perl modules writable so they get stripped
187find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
188     xargs -0 chmod 755
189
190# unnecessary libraries for swig bindings
191rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
192
193# Remove unnecessary ruby libraries
194rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
195
196# Trim what goes in docdir
197rm -rf tools/*/*.in tools/test-scripts
198                       
199# Rename authz_svn INSTALL doc for docdir
200ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
201
202%clean
203rm -rf $RPM_BUILD_ROOT
204
205%post -p /sbin/ldconfig
206
207%postun -p /sbin/ldconfig
208
209%post tools -p /sbin/ldconfig
210
211%postun tools -p /sbin/ldconfig
212
213
214%files
215%defattr(-,root,root)
216%doc BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README
217%doc subversion/LICENSE
218%{_bindir}/*
219%{_libdir}/libsvn_*.so.*
220%{_localedir}/*/*/subversion.mo
221%{_mandir}/man*/*
222%dir %{_sysconfdir}/subversion
223%exclude %{_mandir}/man*/*::*
224%exclude %{_libdir}/libsvn_swig_perl*.so.*
225%exclude %{_libdir}/libsvn_swig_py*.so.*
226%exclude %{_libdir}/libsvn_swig_ruby*.so.*
227
228%files devel
229%defattr(-,root,root)
230%{_includedir}/subversion-1
231%{_libdir}/libsvn*.so
232%exclude %{_libdir}/libsvn_swig_perl*.so.*
233%exclude %{_libdir}/libsvn_swig_py*.so.*
234%exclude %{_libdir}/libsvn_swig_ruby*.so.*
235
236%files mod_dav_svn
237%defattr(-,root,root)
238%config(noreplace) /etc/apache2/conf.d/subversion.conf
239%{apache_dir}/%{_lib}/apache2/modules/mod_*.*
240
241%files tools
242%defattr(-,root,root)
243%{_prefix}/lib/subversion/tools
244
245%files perl
246%defattr(-,root,root,-)
247%{perl_vendorarch}/auto/SVN
248%{perl_vendorarch}/SVN
249%{_libdir}/libsvn_swig_perl*
250%{_mandir}/man*/*::*
251
252%files ruby
253%defattr(-,root,root,-)
254%{_libdir}/libsvn_swig_ruby*
255%{rarchdir}/svn
256
257%files python
258%defattr(-,root,root,-)
259%{_libdir}/libsvn_swig_py*
260%{python_sitearch}/libsvn
261%{python_sitearch}/svn
262
263
264%changelog
265* Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
266- new upstream release
267
268* Tue Mar  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
269- fix <BTS:VineLinux:941>
270  - using rpm macro: rarchdir
271  - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
272- using rpm macros: perl_vendorarch and python_sitearch
273- add BuildRequires: sqlite3-devel krb5-devel
274
275* Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
276- new upstream release
277- update URL
278- update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
279- update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
280- stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
281- stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
282
283* Wed Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
284- new upstream release
285
286* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
287- new upstream release
288
289* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
290- rebuilt with python-2.5.2
291
292* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
293- new upstream release
294- rebuild with neon-0.28.2
295- dropped old-Patch10 by adding --disable-neon-version-check to %%configure
296- added Patch6, 8, 9, 10 from Fedora Core
297  * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
298  - Correct install location of java stuff (#433295)
299  * Wed Aug  8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
300  - fix build with new glibc open()-as-macro
301  - build all swig code in %%build, not %%install
302  * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
303  - build /usr/bin/* as PIEs
304
305* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
306- rebuild with expat-2.0.1
307
308* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
309- new upstream release
310- add Patch10 to build with neon.
311  1.3.2-0vl5 does not support neon..
312
313* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
314- rebuild with new neon
315
316* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
317- rebuilt with new toolchain and db4-4.3.x
318
319* Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
320- modified %%files section for lib64 architecture
321
322* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
323- new upstream release
324- rebuild with new openldap-2.3.24
325
326* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
327- new upstream release
328- change Group to Develoment/Tools
329- build with apr-1.2.7/apr-util-1.2.7
330  - require apr/apr-util instead of apache2-apr
331- build with swig-1.3.29
332- split {perl,python,ruby} related files to subpackage.
333
334* Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
335- new upstream release
336- add noreplace option for config file
337
338* Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
339- fix Requires and BuildPreReq.
340
341* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
342- new upstream release.
343- add swig-runtime to 'BuildPreReq:'.
344- fix %%files.
345
346* Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
347- require neon version 0.24.7 for ra_dav
348- add BuildPreReq: openldap-devel
349- replace BuildPreReq: httpd to BuildPreReq: apache2
350- replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
351
352* Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
353- new upstream release
354
355* Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
356- new upstream release
357
358* Fri Jun  4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
359- new upstream release
360- clean up specfile.
361
362* Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
363- new upstream release
364- build with apache2-2.0.47
365
366* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
367- build Vine Linux
368
369* Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
370- Enabled RA_DAV checking.
371  Now requires httpd package to build because of RA_DAV tests.
372
373* Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
374- Created tools package to hold the tools.
375
376* Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
377- Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
378  version of APR/APR-UTILS as of 2003.01.15.
379- Added svnversion command.
380
381* Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
382- Create a svnadmin.static which is copied to svnadmin-version-release
383  when the package is erased, so users can still dump/load their repositories
384  even after they have upgraded the RPM package.
385
386* Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
387- SWIG now builds so we can use cvs2svn.
388
389* Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
390- Made cvs2svn conditional (at least until we can get it to build consistently
391  and work).
392
393* Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
394- Added SWIG dependencies to add cvs2svn capabilities.
395
396* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
397- Now requires neon-0.22.0.
398
399* Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
400- Took out loading mod_dav_svn from subversion.spec file and put it in
401  subversion.conf file which goes into the apache conf directory.
402- Simplify what gets put into httpd.conf to only the include for the
403  subversion.conf file.
404  (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
405  me to do this).
406
407* Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
408- Updated to APR/APR-UTIL 2002-08-08.
409
410* Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
411- Updated to APACHE/APR/APR-UTIL 2002-06-25.
412- Previous version had a few problems because of missing apache error/ files.
413
414* Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
415- Updated to apache-2.0.40-0.3.
416- Updated to subversion-0.13.1-2318.
417
418* Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
419- Updated for RedHat 7.3 (autoconf253).
420- Added a bunch of pre-requisites I didn't know were needed because I built a
421  new machine that didn't have them already installed.
422- Fixed installation of man and info documentation pages.
423
424* Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
425- Back to apache-libapr* stuff, hopefully to stay.
426
427* Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
428- Fixed expat.patch to not have to make so many changes by writing a small
429  shell script that changes libexpat to -lexpat.
430
431* Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
432- Updated to neon-0.19.2.
433
434* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
435- Back to using apr and apr-util separately from apache.
436
437* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
438- Updated to APR and APR-UTIL 2002.02.11.
439- Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
440- Took out a (now non-existant) documentation file.
441- Moved SPEC file changelog to after all package definitions.
442 
443* Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
444- Updated to neon-0.18.5.
445- Broke up apache and apache-devel into apache-apr, apache-apr-devel,
446  apache-apr-utils, and apache-apr-utils-devel.
447- Updated apache to APR and APR-UTILS to 2002.02.03 version.
448
449* Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
450- Now builds without the separate APR package as it is built into and
451  "exported" from apache-2.0.31-0.3.
452
453* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
454- Took out patches to install procedure now not required because of fixes
455  in rev 1130.
456
457* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
458- Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
459  program was added.
460
461* Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
462- Release M5-r340: Added the subversion-server package.
463
464* Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
465- Release M5-r327: No longer need expat-lite. We can use the normal expat.
466
467* Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
468- Release M3-r117: Initial Version.
469
Note: See TracBrowser for help on using the repository browser.