source: projects/specs/trunk/s/stunnel/stunnel-vl.spec @ 7406

Revision 7406, 14.3 KB checked in by iwaim, 11 years ago (diff)

new: stunnel stunnel-4.54-1

Line 
1%define ver 4.54
2%define rel 1
3
4Summary: An SSL-encrypting socket wrapper
5Name: stunnel
6Version: %{ver}
7Release: %{rel}%{?_dist_release}
8License: GPLv2
9Group: Applications/Internet
10URL: https://www.stunnel.org/
11Source0: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz
12Source1: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz.asc
13Source2: Certificate-Creation
14Source3: sfinger.xinetd
15Source4: stunnel-sfinger.conf
16Source5: pop3-redirect.xinetd
17Source6: stunnel-pop3s-client.conf
18Patch0: stunnel-4-authpriv.patch
19Patch1: stunnel-4-sample.patch
20Buildroot: %{_tmppath}/stunnel-root
21# util-linux is needed for rename
22BuildRequires: openssl-devel
23BuildRequires: pkgconfig
24BuildRequires: tcp_wrappers
25BuildRequires: util-linux
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: iwaim
30
31%description
32Stunnel is a socket wrapper which can provide SSL (Secure Sockets
33Layer) support to ordinary applications. For example, it can be used
34in conjunction with imapd to create an SSL secure IMAP server.
35
36%prep
37%setup -q
38%patch0 -p1 -b .authpriv
39%patch1 -p1 -b .sample
40
41iconv -f iso-8859-1 -t utf-8 < doc/stunnel.fr.8 > doc/stunnel.fr.8_
42mv doc/stunnel.fr.8_ doc/stunnel.fr.8
43
44%build
45CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
46if pkg-config openssl ; then
47        CFLAGS="$CFLAGS `pkg-config --cflags openssl`";
48        LDFLAGS="`pkg-config --libs-only-L openssl`"; export LDFLAGS
49fi
50%configure --disable-fips --enable-ipv6 \
51        CPPFLAGS="-UPIDFILE -DPIDFILE='\"%{_localstatedir}/run/stunnel.pid\"'"
52make LDADD="-pie -Wl,-z,defs,-z,relro,-z,now"
53
54%install
55rm -rf $RPM_BUILD_ROOT
56mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stunnel
57touch $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.pem
58make install DESTDIR=$RPM_BUILD_ROOT
59# Move the translated man pages to the right subdirectories, and strip off the
60# language suffixes.
61for lang in fr pl ; do
62        mkdir -p $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8
63        mv $RPM_BUILD_ROOT/%{_mandir}/man8/*.${lang}.8* $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/
64        rename ".${lang}" "" $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/*
65done
66
67mkdir srpm-docs
68cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} srpm-docs
69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73%files
74%defattr(-,root,root)
75%doc AUTHORS BUGS ChangeLog COPY* CREDITS PORTS README TODO
76%doc tools/stunnel.conf-sample
77%doc srpm-docs/*
78%lang(en) %doc doc/en/*
79%lang(po) %doc doc/pl/*
80%{_bindir}/stunnel
81%exclude %{_bindir}/stunnel3
82%exclude %{_datadir}/doc/stunnel
83%{_libdir}/stunnel
84%exclude %{_libdir}/stunnel/libstunnel.la
85%{_mandir}/man8/stunnel.8*
86%lang(fr) %{_mandir}/fr/man8/stunnel.8*
87%lang(pl) %{_mandir}/pl/man8/stunnel.8*
88%dir %{_sysconfdir}/%{name}
89%exclude %{_sysconfdir}/stunnel/*
90
91%changelog
92* Tue Jan 15 2013 IWAI, Masaharu <iwai@alib.jp> 4.54-1
93- initial build for Vine Linux
94
95*Mon Dec 10 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-2
96- 884183: support for full relro.
97
98*Tue Oct 16 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-1
99- New upstream realease 4.54
100- Updated local patches
101
102* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.53-2
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
104
105* Mon May 14 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.53-1
106- New upstream realease 4.53
107- Updated local patches
108
109* Tue Mar 6 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.52-1
110- New upstream realease 4.52
111- Updated local patches
112
113* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.50-2
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
115
116* Tue Jan 3 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.50-1
117- New upstream realease 4.50
118- Updated local patches
119
120* Tue Sep 20 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.44-1
121- New upstream realease 4.44
122- Updated local patches
123
124* Fri Aug 19 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.42-1
125- New upstream realease 4.42
126- Updated local patches
127- Fixes #732069
128
129* Mon Aug 1 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.41-1
130- New upstream realease 4.41
131- Updated local patches to match the new release
132
133* Tue Jun 28 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.37-1
134- New upstream realease 4.37
135- Updated local patches to match the new release
136
137* Mon Apr 4 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.35-1
138- New upstream realease 4.35
139- Updated authpriv and sample patches to match the new release
140
141* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.34-2
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
143
144* Mon Oct 4 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.34-1
145- New upstream realease 4.34
146- Updated authpriv and sample patches to match the new release
147
148* Wed Apr 7 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.33-1
149- New upstream realease 4.33
150- Updated authpriv and sample patches to match the new release
151- Addresses bz 580117 (inted mode support issue)
152
153* Mon Mar 29 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.32-1
154- New upstream realease 4.32
155- Updated authpriv and sample patches to match the new release
156
157* Tue Feb 16 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.31-1
158- New upstream realease 4.31
159- Updated authpriv and sample patches to match the new release
160
161* Tue Jan 26 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.30-1
162- New upstream realease 4.30
163- Updated authpriv and sample patches for the new release
164
165* Tue Dec 09 2009 Avesh Agarwal <avagarwa@redhat.com> - 4.29-1
166- New upstream realease 4.29
167- Updated authpriv and sample patches for the new release
168- Modified spec file to include dist tag
169
170* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 4.27-5
171- rebuilt with new openssl
172
173* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.27-4
174- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
175
176* Sun May  3 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-3
177- Fix the previous patch.
178
179* Wed Apr 29 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-2
180- Avoid aliasing undefined by ISO C
181
182* Thu Apr 16 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-1
183- Update to stunnel-4.27.
184
185* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.26-3
186- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
187
188* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 4.26-2
189- disable openssl upstream fips mode
190
191* Mon Sep 22 2008 Miloslav Trmač <mitr@redhat.com> - 4.26-1
192- Update to stunnel-4.26.
193
194* Sun Jun  8 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-2
195- Use a clearer error message if the service name is unknown in "accept"
196  Resolves: #450344
197
198* Mon Jun  2 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-1
199- Update to stunnel-4.25
200
201* Tue May 20 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-2
202- Drop stunnel3
203  Resolves: #442842
204
205* Mon May 19 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-1
206- Update to stunnel-4.24
207
208* Fri Mar 28 2008 Miloslav Trmač <mitr@redhat.com> - 4.22-1
209- Update to stunnel-4.22
210
211* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.20-6
212- Autorebuild for GCC 4.3
213
214* Tue Dec  4 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-5
215- Rebuild with openssl-0.9.8g
216
217* Tue Oct 16 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-4
218- Revert the port to NSS, wait for NSS-based stunnel 5.x instead
219  Resolves: #301971
220- Mark localized man pages with %%lang (patch by Ville Skyttä)
221  Resolves: #322281
222
223* Tue Aug 28 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-3.nss
224- Port to NSS
225
226* Mon Dec  4 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-2
227- Update BuildRequires for the separate tcp_wrappers-devel package
228
229* Thu Nov 30 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-1
230- Update to stunnel-4.20
231
232* Sat Nov 11 2006 Miloslav Trmac <mitr@redhat.com> - 4.19-1
233- Update to stunnel-4.19
234
235* Wed Oct 25 2006 Miloslav Trmac <mitr@redhat.com> - 4.18-1
236- Update to stunnel-4.18
237- Remove unused stunnel.cnf from the src.rpm
238- Fix some rpmlint warnings
239
240* Fri Aug 18 2006 Jesse Keating <jkeating@redhat.com> - 4.15-2
241- rebuilt with latest binutils to pick up 64K -z commonpagesize on ppc*
242  (#203001)
243
244* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.15-1.1
245- rebuild
246
247* Sat Mar 18 2006 Miloslav Trmac <mitr@redhat.com> - 4.15-1
248- Update to stunnel-4.15
249
250* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.2
251- bump again for double-long bug on ppc(64)
252
253* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.1
254- rebuilt for new gcc4.1 snapshot and glibc changes
255
256* Tue Jan 31 2006 Miloslav Trmac <mitr@redhat.com> - 4.14-3
257- Use pthread threading to fix crash on x86_64 (#179236)
258
259* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
260- rebuilt
261
262* Wed Nov  9 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-2
263- Rebuild with newer openssl
264
265* Thu Nov  3 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-1
266- Update to stunnel-4.14
267- Override changed default pid file location, keep it in %%{_localstatedir}/run
268
269* Sat Oct 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.13-1
270- Update to stunnel-4.13
271
272* Fri Sep 30 2005 Miloslav Trmac <mitr@redhat.com> - 4.12-1
273- Update to stunnel-4.12
274
275* Thu Sep 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-2
276- Enable IPv6 (#169050, patch by Peter Bieringer)
277- Don't ship another copy of man pages in HTML
278
279* Tue Jul 12 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-1
280- Update to stunnel-4.11
281- Fix int/size_t mismatches in stack_info ()
282- Update Certificate-Creation for /etc/pki
283
284* Wed Jun  1 2005 Miloslav Trmac <mitr@redhat.com> - 4.10-2
285- Fix inetd mode
286- Remove unnecessary Requires: and BuildRequires:
287- Clean up the spec file
288
289* Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.10-1
290- update to 4.10
291
292* Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-2
293- add buildprereqs on libtool, util-linux; change textutils/fileutils dep to
294  coreutils (#133961)
295
296* Wed Mar 16 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-1
297- update to 4.08
298- build stunnel as a PIE binary
299
300* Mon Nov 22 2004 Miloslav Trmac <mitr@redhat.com> - 4.05-4
301- Convert man pages to UTF-8
302
303* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
304- rebuilt
305
306* Thu May 27 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-2
307- move the sample configuration to %%doc, it shouldn't be used as-is (#124373)
308
309* Thu Mar 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-1
310- update to 4.05
311
312* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
313- rebuilt
314
315* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
316- rebuilt
317
318* Thu Aug  7 2003 Elliot Lee <sopwith@redhat.com> 4.04-6
319- Fix libtool
320
321* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
322- rebuilt
323
324* Fri Mar 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-4
325- fix xinetd configuration samples
326
327* Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-3
328- rebuild
329
330* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
331- rebuilt
332
333* Wed Jan 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-1
334- update to 4.04
335
336* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.03-1
337- use pkgconfig for information about openssl, if available
338
339* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
340- update to 4.03
341
342* Mon Oct 21 2002 Nalin Dahyabhai <nalin@redhat.com> 4.02-1
343- update to 4.02
344
345* Fri Oct  4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.00-1
346- don't create a dummy cert
347
348* Wed Sep 25 2002 Nalin Dahyabhai <nalin@redhat.com>
349- update to 4.00
350- remove textutils and fileutils as buildreqs, add automake/autoconf
351
352* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
353- automated rebuild
354
355* Sun May 26 2002 Tim Powers <timp@redhat.com>
356- automated rebuild
357
358* Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-2
359- rebuild in new environment
360
361* Wed Jan  2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-1
362- update to 3.22, correcting a format-string vulnerability
363
364* Wed Oct 31 2001 Nalin Dahyabhai <nalin@redhat.com> 3.21a-1
365- update to 3.21a
366
367* Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 3.20-1
368- log using LOG_AUTHPRIV facility by default (#47289)
369- make permissions on stunnel binary 0755
370- implicitly trust certificates in %%{_datadir}/ssl/trusted (#24034)
371
372* Fri Aug 10 2001 Nalin Dahyabhai <nalin@redhat.com> 3.19-1
373- update to 3.19 to avoid problems with stunnel being multithreaded, but
374  tcp wrappers not being thrad-safe
375
376* Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com>
377- update to 3.17
378
379* Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com>
380- update to 3.16
381
382* Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
383- update to 3.15
384- enable tcp-wrappers support
385
386* Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
387- remove explicit requirement on openssl (specific version isn't enough,
388  we have to depend on shared library version anyway)
389
390* Fri Apr 27 2001 Nalin Dahyabhai <nalin@redhat.com>
391- update to 3.14
392
393* Mon Mar 26 2001 Preston Brown <pbrown@redhat.com>
394- depend on make (#33148)
395
396* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
397- rebuild in new environment
398
399* Tue Feb  6 2001 Nalin Dahyabhai <nalin@redhat.com>
400- update to 3.13 to get pthread, OOB, 64-bit fixes
401- don't need sdf any more
402
403* Thu Dec 28 2000 Nalin Dahyabhai <nalin@redhat.com>
404- pull in sdf to build the man page (#22892)
405
406* Fri Dec 22 2000 Nalin Dahyabhai <nalin@redhat.com>
407- update to 3.11
408- chuck the SIGHUP patch (went upstream)
409- chuck parts of the 64-bit clean patch (went upstream)
410
411* Thu Dec 21 2000 Nalin Dahyabhai <nalin@redhat.com>
412- update to 3.10
413- more 64-bit clean changes, hopefully the last bunch
414
415* Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
416- change piddir from the default /var/stunnel to /var/run
417- clean out pid file on SIGHUP
418
419* Fri Dec 15 2000 Nalin Dahyabhai <nalin@redhat.com>
420- update to 3.9 to get a security fix
421
422* Wed Oct 25 2000 Matt Wilson <msw@redhat.com>
423- change all unsigned longs to u_int32_t when dealing with network
424  addresses
425
426* Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com>
427- make stunnel.pem also be (missingok)
428
429* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
430- move to Applications/Internet group
431- clean up %%post script
432- make stunnel.pem %%ghost %%config(noreplace)
433- provide a sample file for use with xinetd
434
435* Thu Jun  8 2000 Nalin Dahyabhai <nalin@redhat.com>
436- FHS compliance fixes
437- modify defaults
438
439* Tue Mar 14 2000 Florian La Roche <Florian.LaRoche@redhat.com>
440- update to 3.8
441- do not create certificate if one already exists
442
443* Mon Feb 21 2000 Florian La Roche <Florian.LaRoche@redhat.com>
444- update to 3.7
445- add patch to find /usr/share/ssl
446- change some perms
447
448* Sat Oct 30 1999 Bernhard Rosenkraenzer <bero@redhat.com>
449- Modify spec file to match Red Hat standards
450
451* Fri Aug 12 1999 Damien Miller <damien@ibs.com.au>
452- Updated to 3.4a
453- Patched for OpenSSL 0.9.4
454- Cleaned up files section
455
456* Sun Jul 11 1999 Damien Miller <dmiller@ilogic.com.au>
457- Updated to 3.3
458
459* Sat Nov 28 1998 Damien Miller <dmiller@ilogic.com.au>
460- Initial RPMification
Note: See TracBrowser for help on using the repository browser.